[PATCH] gnu: Add r-phyloseq

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Vallet
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Nicolas Vallet
Severity
normal
N
N
Nicolas Vallet wrote on 26 Oct 2021 23:27
(address . guix-patches@gnu.org)(name . Nicolas Vallet)(address . nicolas.vallet@inserm.fr)
20211026212752.21242-1-nls.vallet@gmail.com
From: Nicolas Vallet <nicolas.vallet@inserm.fr>

* gnu/packages/cran.scm (r-phyloseq): New variable
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..8dc875de69 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2021 Nicolas Vallet <nls.vallet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -14813,3 +14814,42 @@ and other associated metadata. De novo transcriptomes can be linked to the
appropriate sources with linkedTxomes and shared for computational
reproducibility.")
(license license:gpl2)))
+
+
+(define-public r-phyloseq
+ (package
+ (name "r-phyloseq")
+ (version "1.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "phyloseq" version))
+ (sha256
+ (base32 "192gv00xfnv9ljkgb0iw8sqzsay4f3vllyyc1slzsn15713fc4pi"))))
+ (properties `((upstream-name . "phyloseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ade4" ,r-ade4)
+ ("r-ape" ,r-ape)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biomformat" ,r-biomformat)
+ ("r-biostrings" ,r-biostrings)
+ ("r-cluster" ,r-cluster)
+ ("r-data-table" ,r-data-table)
+ ("r-foreach" ,r-foreach)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-igraph" ,r-igraph)
+ ("r-multtest" ,r-multtest)
+ ("r-plyr" ,r-plyr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-scales" ,r-scales)
+ ("r-vegan" ,r-vegan)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/joey711/phyloseq")
+ (synopsis "Handling and analysis of high-throughput microbiome census data")
+ (description
+ "Phyloseq provides a set of classes and
+tools to facilitate the import, storage, analysis,
+and graphical display of microbiome census data.")
+ (license license:agpl3+)))

base-commit: c6adc0947396daa6d85ab08837f9cbc86f4d8722
--
2.25.1
R
R
Ricardo Wurmus wrote on 1 Dec 2021 09:34
(address . 51422-done@debbugs.gnu.org)
87wnkosoy4.fsf@elephly.net
Hi,

thank you for the patch! I applied it to the “master” branch with
trivial changes. I also upgraded it to 1.38.0.

My apologies for the delay!

--
Ricardo
Closed
?