(address . guix-patches@gnu.org)
Hi Guix!
This patch series fixes pplacer. I noticed ocaml4.07-re was failing to
build, and others also failed, so this series fixes them, and pplacer.
From 5a85894ee405d2fbe909b61fb3817aa44d6a08df Mon Sep 17 00:00:00 2001
Message-Id: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:22:11 +0200
Subject: [PATCH 1/6] gnu: Add ocaml4.07-re.
* gnu/packages/ocaml.scm (ocaml4.07-re): New variable.
---
gnu/packages/ocaml.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 660bc44bc7..412e9e339d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3353,6 +3353,7 @@ (define-public ocaml-re
`(("ocaml-seq" ,ocaml-seq)))
(native-inputs
`(("ounit" ,ocaml-ounit)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-re))))
(home-page "https://github.com/ocaml/ocaml-re/")
(synopsis "Regular expression library for OCaml")
(description "Pure OCaml regular expressions with:
@@ -3365,6 +3366,19 @@ (define-public ocaml-re
@end enumerate")
(license license:expat)))
+(define-public ocaml4.07-re
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-re)
+ (arguments
+ `(#:test-target "."
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dune-version
+ (lambda _
+ (delete-file "dune-project"))))))
+ (properties '()))))
+
(define-public ocaml-ocplib-endian
(package
(name "ocaml-ocplib-endian")
--
2.33.0
From b77fb136a6f1e4ecceb0ddbd2a0318af80721d50 Mon Sep 17 00:00:00 2001
Message-Id: <b77fb136a6f1e4ecceb0ddbd2a0318af80721d50.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:26:54 +0200
Subject: [PATCH 2/6] gnu: Add ocaml4.07-alcotest.
* gnu/packages/ocaml.scm (ocaml4.07-alcotest): New variable.
---
gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 412e9e339d..a8f5faaf1d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2268,6 +2268,7 @@ (define-public ocaml-alcotest
("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
("ocaml-uuidm" ,ocaml-uuidm)
("ocaml-uutf" ,ocaml-uutf)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-alcotest))))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It
@@ -2278,6 +2279,30 @@ (define-public ocaml-alcotest
simple (yet expressive) query language to select the tests to run.")
(license license:isc)))
+(define-public ocaml4.07-alcotest
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-alcotest)
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/alcotest")
+ (commit version)))
+ (file-name (git-file-name "ocaml-alcotest" version))
+ (sha256
+ (base32
+ "1frwi185z4aadmaf0vp8xk5227nyg7nmh28ijj5l7ncjr5slvhz8"))))
+ (arguments
+ `(#:test-target "."
+ #:package "alcotest"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dune-version
+ (lambda _
+ (delete-file "dune-project"))))))
+ (properties '()))))
+
(define-public ocaml-ppx-tools
(package
(name "ocaml-ppx-tools")
--
2.33.0
From 7b0144518fa422088477d764233c1278ce48573e Mon Sep 17 00:00:00 2001
Message-Id: <7b0144518fa422088477d764233c1278ce48573e.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 16:07:46 +0200
Subject: [PATCH 3/6] gnu: ocaml-lwt: Remove unneeded input.
* gnu/packages/ocaml.scm (ocaml-lwt)[native-inputs]: Remove
ocaml-bisect-ppx.
---
gnu/packages/ocaml.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
Toggle diff (16 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a8f5faaf1d..43011a0aab 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2427,8 +2427,7 @@ (define-public ocaml-lwt
(arguments
`(#:package "lwt"))
(native-inputs
- `(("ocaml-bisect-ppx" ,ocaml-bisect-ppx)
- ("ocaml-cppo" ,ocaml-cppo)
+ `(("ocaml-cppo" ,ocaml-cppo)
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)))
--
2.33.0
From e7413cc1b1759ad7049b044d3e6743f572ced836 Mon Sep 17 00:00:00 2001
Message-Id: <e7413cc1b1759ad7049b044d3e6743f572ced836.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:27:56 +0200
Subject: [PATCH 4/6] gnu: Add ocaml4.07-bisect-ppx.
* gnu/packages/ocaml.scm (ocaml4.07-bisect-ppx): New variable.
---
gnu/packages/ocaml.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)
Toggle diff (50 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 43011a0aab..87429b92ac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6625,7 +6625,8 @@ (define-public ocaml-bisect-ppx
(arguments
;; Tests require ocamlformat which would lead to circular dependencies
'(#:tests? #f))
- (properties '((upstream-name . "bisect_ppx")))
+ (properties `((upstream-name . "bisect_ppx")
+ (ocaml4.07-variant . ,(delay ocaml4.07-bisect-ppx))))
(home-page "https://github.com/aantron/bisect_ppx")
(synopsis "Code coverage for OCaml")
(description "Bisect_ppx helps you test thoroughly. It is a small
@@ -6637,6 +6638,33 @@ (define-public ocaml-bisect-ppx
then run the Bisect_ppx report tool on the generated visitation files.")
(license license:mpl2.0)))
+(define-public ocaml4.07-bisect-ppx
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-bisect-ppx)
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aantron/bisect_ppx")
+ (commit version)))
+ (file-name (git-file-name "ocaml-bisect-ppx" version))
+ (sha256
+ (base32
+ "1njs8xc108rrpx5am5zhhcn6vjva7rsphm8034qp5lgyvnhfgh7q"))))
+ (propagated-inputs
+ `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
+ ,@(package-propagated-inputs ocaml-bisect-ppx)))
+ (native-inputs
+ `(("ocaml-ounit2" ,ocaml-ounit2)))
+ (arguments
+ `(#:test-target "."
+ ;; tests require git and network
+ #:tests? #f))
+ (properties '()))))
+
(define-public ocaml-odoc
(package
(name "ocaml-odoc")
--
2.33.0
From 04a94967f5816b42277b099aa2b386b68d13cdee Mon Sep 17 00:00:00 2001
Message-Id: <04a94967f5816b42277b099aa2b386b68d13cdee.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:28:54 +0200
Subject: [PATCH 5/6] gnu: ocaml4.07-odoc: Fix inputs.
* gnu/packages/ocaml.scm (ocaml4.07-odoc): Fix inputs.
---
gnu/packages/ocaml.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (19 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 87429b92ac..f0c46a9b4b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6751,6 +6751,12 @@ (define-public ocaml4.07-odoc
(file-name (git-file-name name version))
(sha256
(base32 "0z2nisg1vb5xlk41hqw8drvj90v52wli7zvnih6a844cg6xsvvj2"))))
+ (inputs
+ `(("ocaml-alcotest" ,ocaml-alcotest)
+ ("ocaml-markup" ,ocaml-markup)
+ ("ocaml-sexplib" ,ocaml-sexplib)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-uutf" ,ocaml-uutf)))
(properties '()))))
(define-public ocaml4.07-fftw3
--
2.33.0
From 9a5d8c50f30a25b5246d321d5331b72a88f587f9 Mon Sep 17 00:00:00 2001
Message-Id: <9a5d8c50f30a25b5246d321d5331b72a88f587f9.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:30:04 +0200
Subject: [PATCH 6/6] gnu: pplacer: Fix build.
* gnu/packages/bioinformatics.scm (pplacer): Add missing input.
---
gnu/packages/bioinformatics.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 63b391683c..41a2e52ac8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -141,6 +141,7 @@ (define-module (gnu packages bioinformatics)
#:use-module (gnu packages serialization)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages tbb)
@@ -13501,7 +13502,8 @@ (define-public pplacer
("ocaml-sqlite3" ,(package-with-ocaml4.07 ocaml-sqlite3))
("ocaml-xmlm" ,(package-with-ocaml4.07 ocaml-xmlm))
("ocaml-mcl" ,(package-with-ocaml4.07 ocaml-mcl))
- ("ocaml-gsl" ,ocaml4.07-gsl-1)))
+ ("ocaml-gsl" ,ocaml4.07-gsl-1)
+ ("sqlite:static" ,sqlite "static")))
(native-inputs
`(("cddlib-src" ,(package-source cddlib))
("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))
--
2.33.0