[PATCH 0/2] R packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 13 Sep 2021 16:18
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210913141812.521898-1-zimon.toutoune@gmail.com
Hi,

Trivial addition. The package r-presto does not have a tag version, hence the
commit; they say in README about CRAN but the archive does not contain it, or
I miss it.

All the best,
simon


zimoun (2):
gnu: Add r-simplifyenrichment.
gnu: Add r-presto.

gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++
gnu/packages/bioinformatics.scm | 34 ++++++++++++++++++++++++++++
2 files changed, 74 insertions(+)


base-commit: 53f54d4aa252fed425180641f27094600522c4f1
--
2.32.0
Z
Z
zimoun wrote on 13 Sep 2021 16:20
[PATCH 1/2] gnu: Add r-simplifyenrichment.
(address . 50570@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210913142028.522087-1-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-simplifyenrichment): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 25202410e5..e59ba07d23 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4236,6 +4236,46 @@ purposes. The package also contains legacy support for early single-end,
ungapped alignment formats.")
(license license:artistic2.0)))
+(define-public r-simplifyenrichment
+ (package
+ (name "r-simplifyenrichment")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "simplifyEnrichment" version))
+ (sha256
+ (base32
+ "0rqa414kvyjjmj4932zk39rqa14z13b57rkrxdrf16jmq2r437vh"))))
+ (properties
+ `((upstream-name . "simplifyEnrichment")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-circlize" ,r-circlize)
+ ("r-clue" ,r-clue)
+ ("r-cluster" ,r-cluster)
+ ("r-complexheatmap" ,r-complexheatmap)
+ ("r-digest" ,r-digest)
+ ("r-getoptlong" ,r-getoptlong)
+ ("r-go-db" ,r-go-db)
+ ("r-gosemsim" ,r-gosemsim)
+ ("r-matrix" ,r-matrix)
+ ("r-org-hs-eg-db" ,r-org-hs-eg-db)
+ ("r-proxyc" ,r-proxyc)
+ ("r-slam" ,r-slam)
+ ("r-tm" ,r-tm)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/jokergoo/simplifyEnrichment")
+ (synopsis "Simplify Functional Enrichment Results")
+ (description "This package provides a new clustering algorithm, binary
+cut, for clustering similarity matrices of functional terms is implemeted in
+this package. It also provideds functionalities for visualizing, summarizing
+and comparing the clusterings.")
+ (license license:expat)))
+
+
(define-public r-trajectoryutils
(package
(name "r-trajectoryutils")
--
2.32.0
Z
Z
zimoun wrote on 13 Sep 2021 16:20
[PATCH 2/2] gnu: Add r-presto.
(address . 50570@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210913142028.522087-2-zimon.toutoune@gmail.com
* gnu/packages/bioinformatics.scm (r-presto): New variable.
---
gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c3ab0ce354..647feff9ec 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7417,6 +7418,39 @@ sequence.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))
+(define-public r-presto
+ (let ((commit "052085db9c88aa70a28d11cc58ebc807999bf0ad")
+ (revision "0"))
+ (package
+ (name "r-presto")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/immunogenomics/presto")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c3fmag4r4p2lvbvxlxyck9dvfw1prbwcl9665mmlx4a35750hk8"))))
+ (properties `((upstream . "presto")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dplyr" ,r-dplyr)
+ ("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rlang" ,r-rlang)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/immunogenomics/presto")
+ (synopsis "Fast Functions for Differential Expression using Wilcox and AUC")
+ (description "This package performs a fast Wilcoxon rank sum test and
+auROC analysis.")
+ (license license:gpl3))))
+
(define-public r-snapatac
(package
(name "r-snapatac")
--
2.32.0
R
R
Ricardo Wurmus wrote on 20 Sep 2021 22:13
Re: [bug#50570] [PATCH 0/2] R packages
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 50570-done@debbugs.gnu.org)
87y27rf1ja.fsf@elephly.net
Thank you for the patches. Pushed to the “master” branch with
commit f80824fe0997f3e5d73ef16b8d42d248ce31cc69.

--
Ricardo
Closed
?