[PATCH] gnu: Add emacs-consult-notmuch.

  • Done
  • quality assurance status badge
Details
4 participants
  • Andrew Tropin
  • Kyle Meyer
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 7 Jul 2021 15:59
(address . guix-patches@gnu.org)
87tul6w7g2.fsf@trop.in
From eba48a1058bc4ae7486e74ac30cf851a78ce7272 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 7 Jul 2021 16:55:41 +0300
Subject: [PATCH] gnu: Add emacs-consult-notmuch.

* gnu/packages/emacs-xyz.scm (emacs-consult-notmuch): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9591a4e6e7..788a25a8e8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8084,6 +8084,36 @@ Emacs completion function completing-read, which allows quickly selecting from a
list of candidates.")
(license license:gpl3+)))
+(define-public emacs-consult-notmuch
+ (package
+ (name "emacs-consult-notmuch")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/jao/consult-notmuch.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19flyh3v1xm2zswzjkvjbijvpbq5r8isafza4fd0yicvqbjyklhx"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("emacs-consult" ,emacs-consult)
+ ("notmuch" ,notmuch)))
+ (license license:gpl3+)
+ (home-page "https://codeberg.org/jao/consult-notmuch")
+ (synopsis "Search and preview notmuch emails using consult")
+ (description "\
+This package provides two commands using consult to query notmuch
+emails and present results either as single emails @code{consult-notmuch}
+or full trees @code{consult-notmuch-tree}.
+
+The package also defines a narrowing source for @code{consult-buffer}, which
+can be activated with @code{(add-to-list 'consult-buffer-sources
+'consult-notmuch-buffer-source)}.")))
+
(define-public emacs-marginalia
(package
(name "emacs-marginalia")
--
2.32.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDls00PHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wUYYP/3I28M73++esACnNjmSwLHSvS/4Z15NYbI9b
gnzU4ydAT91WSvCuB/qj2/IvZ9KFzD9mcrRRGuqAF4Ya9OqcyxlYK1U+hmBQE5Qk
jlkKsWnR3Zzac25J4KtrOeg5a5ywZ5H8aszx3YnDX+RCcVuE9gBbE49OyHSHrnRm
i8upg7TT+crA3RKLEjEca/5yTXWCqjcm8oM3VGdJUaMQox56PRN9Qtzcq3LptmSN
YW8UmORqGe24aUkHws9nwtByFbsum2H8n1mK8SDSZ6auSM402TzTWOAoWbZ0ZdQ3
JrNqqGfLLhWht54b6F1O5PzxK0gFJfiiAfY5zilDn7airgdAZcE8EaWELHZEA7hi
GwUPzxXauIB9QAZbtLqrstExuCiLMEm6e6K+15VMsR/j58X7P12yFAcvlO1EX72u
Y7BZRYznV3xhQNHallJcz/o9w/Ar1SPsoTni42mVx22Ns6LYySzeKqQ6vfml/l/g
3dbJpckc3rA3n3DhRGAA/OCNnoPs9HJ22qH2Sv4I6vCZPWbuiSF2qI1dhUhDClZo
Oa9O+Q3XIr8Ty7d5TX9CQ4ZMiorYf89KJTIa5cSEmArPsUnpndjX+JOxCSsbcaHj
JzqgzrDhiMH9Dp3d1wHTSmkZlvf30maS7N9qFNdEaK+Em32h3s/UMdpnk/79JwkB
OZjVHMI2
=igtW
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 7 Jul 2021 16:12
[PATCH v2] gnu: Add emacs-consult-notmuch.
(address . guix-patches@gnu.org)
87r1gaw6u8.fsf@trop.in
v2 uses propagated-inputs instead of inputs, because using
consult-notmuch without consult and notmuch doesn't make much sense.
From 7ba18d68face76d8858ad67a6113f5773fa45cec Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 7 Jul 2021 16:55:41 +0300
Subject: [PATCH v2] gnu: Add emacs-consult-notmuch.

* gnu/packages/emacs-xyz.scm (emacs-consult-notmuch): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9591a4e6e7..492572322c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8084,6 +8084,36 @@ Emacs completion function completing-read, which allows quickly selecting from a
list of candidates.")
(license license:gpl3+)))
+(define-public emacs-consult-notmuch
+ (package
+ (name "emacs-consult-notmuch")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/jao/consult-notmuch.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19flyh3v1xm2zswzjkvjbijvpbq5r8isafza4fd0yicvqbjyklhx"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-consult" ,emacs-consult)
+ ("notmuch" ,notmuch)))
+ (license license:gpl3+)
+ (home-page "https://codeberg.org/jao/consult-notmuch")
+ (synopsis "Search and preview notmuch emails using consult")
+ (description "\
+This package provides two commands using consult to query notmuch
+emails and present results either as single emails @code{consult-notmuch}
+or full trees @code{consult-notmuch-tree}.
+
+The package also defines a narrowing source for @code{consult-buffer}, which
+can be activated with @code{(add-to-list 'consult-buffer-sources
+'consult-notmuch-buffer-source)}.")))
+
(define-public emacs-marginalia
(package
(name "emacs-marginalia")
--
2.32.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDltl8PHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6weIIP/i54f54VyVru8V3bqGpBPCyPLkFlSO8Ypo8F
cxrjgTz9wDQHq3D3lxKluE3hnb4nomTsn9YPE8Re6K3YOKci/dpaceMLnJqW7mBk
yK6A8xLJCXPrwRNOuuj6UJ8YhW4gPZOW0WjvcIPVNS/zIinP1Ure/XCjxEtFcHPr
BL5rpyQjaV4vFjKAvChjgMs7jZ6gm2MznGeedZGA2tL3knxYsyN83a6Cd48IG1KS
4EGINsZkgJrOEi0llR0QgGxCU6+Ol4BwF9DF2akCn6nDVEOyYCFM34eYueuXkag1
9OIMrnGtqyR6JpHkkhwczod2d0u3wGYuwOHIdkkzLhY+ep5FwB31YnYLoFKg4rTx
q/rgtB/FWNyKE1vnRFsZaNDg2ZJUb4tcvl+/0LHmZkPH9auxK9HMfSFDrDKtesj9
J/r2a6E2wgcVrypzdY6UR9m2VwS9UWQSbUKd9e0HqSEyirzWOH/ntPtWIiCAL7l2
D/kgFjtjTGIYKEifOX4DXeP9Iz3VHgvTsgKo3KXyjKo4JbitSA3w7h0MW/rlORjs
5Goktz6iH0zWYWgpGhgvTEfJ/8aj3inAV0R/rXl/mHhblEiptW4+D5rLcdNMUHrF
5g7AboKswG9dtxztA63RD+Ot7ZANUG84fIMrD9PDw5OIVgwC1avR4WPGw2leZzw3
dwrvxgS0
=/H0J
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 7 Jul 2021 16:18
(name . Andrew Tropin)(address . andrew@trop.in)(address . 49457@debbugs.gnu.org)
87czrutdf9.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (3 lines)
> v2 uses propagated-inputs instead of inputs, because using
> consult-notmuch without consult and notmuch doesn't make much sense.

Thank you. However, notmuch should be an input, there's no reason to
propagate it into user's profile.

Regards,
--
Nicolas Goaziou
A
A
Andrew Tropin wrote on 7 Jul 2021 16:33
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 49457@debbugs.gnu.org)
87eecaqjlu.fsf@trop.in
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (10 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> v2 uses propagated-inputs instead of inputs, because using
>> consult-notmuch without consult and notmuch doesn't make much sense.
>
> Thank you. However, notmuch should be an input, there's no reason to
> propagate it into user's profile.

There is a (require 'notmuch) in consult-notmuch code, so we need
notmuch.el on the load-path, sadly, but we don't have a separate
emacs-notmuch package for it and therefore we have to propagate the
whole notmuch package here :(
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDluz0PHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wPRIP/2m+h10PRoj+GSQn+YITRzlLOK0JGKjhsQ+V
NgWtZVOQD+apsnyEszkKUoKKw0tWzfXzFz+aundsbJArBeVSC1eY1bqLKcSD7dS+
S6qIxPHjX6qovhFqH6tgaNbYA/YdZTUgnJ0GRCu9D6U2pK4Dhh9vTbkfy5S3qpnx
Gap/YhHPwMNJNG1psoMoySbrNFJkpknDvaol0nk0Rw23I9FwguBuJHITteGTcXa4
1cAJ0HBw2mlHRbpYqmyMbqjAFxcJH+RGnm8KHr6tU5TClDAHR78zCVtHTNVBnkAf
mMrvIbFrzS9HCZqKQo1pug8kKkYpD0lMJ6BSWGoQbxnxm88JuvbYLamOuX2ZWcDt
AI6AUlMoMWrmi35L9qYU/ZocHY2zDjhOx98/X8GkYVJ1g/Ce4usyVCvfRLw93FGJ
Syhse1t1lQ7zvXiAXP5R5X3i/fHCoffAXt0uJuKEsA/5G81t6u4mIKdQqn7jZP82
VnAmTd9dv4bxhPvJ2xJwZTz8gLNyXR+vcvjt0oANdOAzcQTI9uwVtOZ/GcBNkUPY
bm/8ClChJtlJubT5Nnhge5iQf0Eelxc8tHjbMN08z82c5vQ2UKoFgj+vQnZ5/A1G
Mgr7yJ4RCGYQjZ1azpyM99PBC69tcqcZSkbxXa2/Jl9ZEbfulFy08ZGn8JwHYCE8
a7A/syCp
=H6hp
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 8 Jul 2021 09:40
(name . Andrew Tropin)(address . andrew@trop.in)(address . 49457-done@debbugs.gnu.org)
87czrtqmn6.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (3 lines)
> v2 uses propagated-inputs instead of inputs, because using
> consult-notmuch without consult and notmuch doesn't make much sense.

I applied this patch with the following changes:

Toggle quote (3 lines)
> + (uri (git-reference
> + (url "https://codeberg.org/jao/consult-notmuch.git")

I removed the ".git" suffix.

Toggle quote (4 lines)
> + (license license:gpl3+)
> + (home-page "https://codeberg.org/jao/consult-notmuch")
> + (synopsis "Search and preview notmuch emails using consult")

I properly capitalized synopsis (Notmuch, Consult).

Toggle quote (9 lines)
> + (description "\
> +This package provides two commands using consult to query notmuch
> +emails and present results either as single emails @code{consult-notmuch}
> +or full trees @code{consult-notmuch-tree}.
> +
> +The package also defines a narrowing source for @code{consult-buffer}, which
> +can be activated with @code{(add-to-list 'consult-buffer-sources
> +'consult-notmuch-buffer-source)}.")))

I shortened the description as it looked like an introduction part of
the manual instead.

I also reordered licence, home-page, synopsis and description parts.

Thank you!

Regards,
--
Nicolas Goaziou
Closed
N
N
Nicolas Goaziou wrote on 8 Jul 2021 09:41
(name . Andrew Tropin)(address . andrew@trop.in)(address . 49457@debbugs.gnu.org)
878s2hqmlp.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (10 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> Thank you. However, notmuch should be an input, there's no reason to
>> propagate it into user's profile.
>
> There is a (require 'notmuch) in consult-notmuch code, so we need
> notmuch.el on the load-path, sadly, but we don't have a separate
> emacs-notmuch package for it and therefore we have to propagate the
> whole notmuch package here :(

Duh! You're right, of course.

Applied, as detailed in another message.

Regards,
--
Nicolas Goaziou
Z
Z
zimoun wrote on 8 Jul 2021 11:13
(address . 49457@debbugs.gnu.org)
86bl7d2mny.fsf@gmail.com
Hi,

(Sorry for this naive question.)

On Thu, 08 Jul 2021 at 09:41, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (13 lines)
> Andrew Tropin <andrew@trop.in> writes:
>> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>>> Thank you. However, notmuch should be an input, there's no reason to
>>> propagate it into user's profile.
>>
>> There is a (require 'notmuch) in consult-notmuch code, so we need
>> notmuch.el on the load-path, sadly, but we don't have a separate
>> emacs-notmuch package for it and therefore we have to propagate the
>> whole notmuch package here :(
>
> Duh! You're right, of course.

For my personal understanding because I am not familiar with Emacs
packages and package propagation. The package ’emacs-magit’ has ’git’
as inputs and AFAIK it does not work without Git installed in the
profile. Why is it different?

Cheers,
simon
N
N
Nicolas Goaziou wrote on 8 Jul 2021 11:41
(name . zimoun)(address . zimon.toutoune@gmail.com)
87h7h5p2gt.fsf@nicolasgoaziou.fr
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (5 lines)
> For my personal understanding because I am not familiar with Emacs
> packages and package propagation. The package ’emacs-magit’ has ’git’
> as inputs and AFAIK it does not work without Git installed in the
> profile. Why is it different?

It is different because Notmuch is both an external executable and an
Emacs library. Git, OTOH, does not ship with an Elisp library.

However, I think it is a bug if Emacs Magit does not work with git in
profile. We should modify the source so both magit-git-executable and
magit-gitk-executable point to those from inputs.

I suggest to open a new bug report about it, WDYT?

Regards,
--
Nicolas Goaziou
A
A
Andrew Tropin wrote on 8 Jul 2021 12:14
(address . 49457@debbugs.gnu.org)
871r893yet.fsf@trop.in
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (23 lines)
> Hi,
>
> (Sorry for this naive question.)
>
> On Thu, 08 Jul 2021 at 09:41, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>> Andrew Tropin <andrew@trop.in> writes:
>>> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>>
>>>> Thank you. However, notmuch should be an input, there's no reason to
>>>> propagate it into user's profile.
>>>
>>> There is a (require 'notmuch) in consult-notmuch code, so we need
>>> notmuch.el on the load-path, sadly, but we don't have a separate
>>> emacs-notmuch package for it and therefore we have to propagate the
>>> whole notmuch package here :(
>>
>> Duh! You're right, of course.
>
> For my personal understanding because I am not familiar with Emacs
> packages and package propagation. The package ’emacs-magit’ has ’git’
> as inputs and AFAIK it does not work without Git installed in the
> profile. Why is it different?

The magit package itself will be loaded correctly, because its emacs
package requirements are satisfied and even some functions will work,
for example magit-dispatch will show a transient interface. Other
functions that rely on git binary will throw an error and there are two
solutions for that: make a git a propagated input or set
`magit-git-executable` to a path to the git binary inside store, which
will make magit work with git as a regular input.

notmuch in contrast to git provides not only notmuch binary, but also
notmuch.el. consult-notmuch requires only notmuch.el, which have to be
propagated and doesn't depend on notmuch binary, but because notmuch.el
is a part of notmuch package the binary will be propagated too. The
possible solution here is to split notmuch into two packages: notmuch and
emacs-notmuch, so we will be able to set `notmuch-command` variable for
notmuch.el and have notmuch as an input, but not installed in the profile.
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDm0AoPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w85EP/04IAKbb1Q7ENk1nZqXXIHLlfeMs0MrcanRS
VPqE2h3H8KBI7evHd+0bEfoq/dUqmTsYgAHcVTlv0giHFUccP9cD0E+YHHgIj8TS
uzFRhV4d3KocXdX0a3wNRFWXZhjG2RdkhXHEE16CFToJECpq+ZzW1U87WrKCSsv+
F6AhH1gZKH8JFjySZV+jodgdoA82N1OEceDZMzAoNAf3QoLmM3N02z8lI/UShjEp
vd41bquvJawAQFpxYKTf/hCkQCi5LCEJI4yzbLQA6Sov8Yv4wI4+txnqAUXtTjUS
1WDG+wbFL2JZCQIRHDL1V28WvTkw8zcWXXT6xens2r8tYlmLqHacc7vqmO59Wpxk
G1A8sLIMXHyQLRDCKBOOiaf8GancdjFanHx+7VwkIYluNonI9z8BI6gPvzUuIXZC
68AWcj46+wV90yAIXfxHaCLCvpuhL0O5BMvLNc/7TtW0ahdtgljnJiOoidSdabOi
hDZv8VNWt9sVLi8vVjLC3+5UvdlAa5QrOaYa64AoS/NK+zJQ/b4UR+Is7Pq7VmmZ
njX4ucamj1ru4ODq1Bhxb4dMb4Tuqh0LTWi803Mto1wo4NC167cRV1k0ab5nVcXx
Z2WhgvwlVGk/7voMja9tDpmUbbniwxyUtDgLXbkQZLf3a4AMgPH1j2SbAR8S/QLU
IkuA5RhY
=2F/J
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 8 Jul 2021 12:22
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 49457-done@debbugs.gnu.org)
87y2ah2jhw.fsf@trop.in
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (32 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> v2 uses propagated-inputs instead of inputs, because using
>> consult-notmuch without consult and notmuch doesn't make much sense.
>
> I applied this patch with the following changes:
>
>> + (uri (git-reference
>> + (url "https://codeberg.org/jao/consult-notmuch.git")
>
> I removed the ".git" suffix.
>
>> + (license license:gpl3+)
>> + (home-page "https://codeberg.org/jao/consult-notmuch")
>> + (synopsis "Search and preview notmuch emails using consult")
>
> I properly capitalized synopsis (Notmuch, Consult).
>
>> + (description "\
>> +This package provides two commands using consult to query notmuch
>> +emails and present results either as single emails @code{consult-notmuch}
>> +or full trees @code{consult-notmuch-tree}.
>> +
>> +The package also defines a narrowing source for @code{consult-buffer}, which
>> +can be activated with @code{(add-to-list 'consult-buffer-sources
>> +'consult-notmuch-buffer-source)}.")))
>
> I shortened the description as it looked like an introduction part of
> the manual instead.

It was complete) but shorter version is also fine.

Toggle quote (5 lines)
>
> I also reordered licence, home-page, synopsis and description parts.
>
> Thank you!

Thank you!)
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDm0csPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wWj4P/jwzmqEWibQLWRMxzRM3Eh+ECQMkhyOVPhAe
bZBGUdNGgVuK6TljRxv0a8MjTd667WwvKK8doKwppzJfldbgbKOWh8m8awKkOV15
i8XLHprgmSaeywnJih0FBdIXaZ8OKIdiL3maA9I1Fe5xCtDPO6kmtdaPZke4zBe2
Jt+xHtHQMACxPFQHdQbZ6ZVdgQYDNujq00x9StuQvALov60qdkkbNPG74MQxq70B
mO41iT9kH9i2ZnxPihlel96aJZ/UU6lSgVI6WfP+4E9nXEvsMAZRzHvV/a2KXUov
dDfxc0eVckREmH4W1D642snpUiRN/PrWTYHsLlnPfYeyxFJWXZfljmj3/np8dFCB
YKdonOykjdEUKrwP2PxwP+qoBbdtmH0NceewOYX84akw6vlgZgcjni4sfijtft9t
LRkT/PHhZC7r+QBNcQjG9pY4JduXy9hzmvDSA+tTbSoE9cRMADI2I5qX9MTNV7dM
0VjqxghPmCpaDAcfkemZIDPhuzo4jA5rZ49aqaVRSMJgz0Qb4FKS/Jh6d7M9O0Vs
M/z+zZARbetvae/Zm5mGsFJ5TGY5nXKXxEutRxQ9WP/TKLLucbF9pJY8b6NQ7ink
DQQ3855ogG/1wFxFs58xcDnnZHtcbFrzmElqCQsWnIXoCpk9IsbxP8Zi3G9mgvdm
SN4QDovJ
=Myfp
-----END PGP SIGNATURE-----

Closed
N
N
Nicolas Goaziou wrote on 8 Jul 2021 12:32
(name . Andrew Tropin)(address . andrew@trop.in)(address . 49457-done@debbugs.gnu.org)
87v95lnljq.fsf@nicolasgoaziou.fr
Andrew Tropin <andrew@trop.in> writes:

Toggle quote (7 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> I shortened the description as it looked like an introduction part of
>> the manual instead.
>
> It was complete) but shorter version is also fine.

Yes, it was complete.

What I meant is the following: when I look at a description, I try to
see what kind of question it answers. If it answers the question: "Do
I want to install this package?", that's good. But if it answers: "How
can I start using this?", then the description belongs to a manual
instead.

For example,

which can be activated with @code{(add-to-list
'consult-buffer-sources 'consult-notmuch-buffer-source)}.

clearly belongs to the second question. So does the name of functions,
in general.
Closed
K
K
Kyle Meyer wrote on 8 Jul 2021 13:28
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87mtqx82or.fsf@kyleam.com
Nicolas Goaziou writes:

Toggle quote (6 lines)
> However, I think it is a bug if Emacs Magit does not work with git in
> profile. We should modify the source so both magit-git-executable and
> magit-gitk-executable point to those from inputs.
>
> I suggest to open a new bug report about it, WDYT?

Rewriting magit-git-executable to an absolute file name will break Magit
for those that use it over TRAMP.
N
N
Nicolas Goaziou wrote on 8 Jul 2021 13:38
(name . Kyle Meyer)(address . kyle@kyleam.com)
87k0m1nihl.fsf@nicolasgoaziou.fr
Hello,

Kyle Meyer <kyle@kyleam.com> writes:

Toggle quote (11 lines)
> Nicolas Goaziou writes:
>
>> However, I think it is a bug if Emacs Magit does not work with git in
>> profile. We should modify the source so both magit-git-executable and
>> magit-gitk-executable point to those from inputs.
>>
>> I suggest to open a new bug report about it, WDYT?
>
> Rewriting magit-git-executable to an absolute file name will break Magit
> for those that use it over TRAMP.

Point taken. However, such users can fix it by modifying the
`magit-git-executable' defcustom again, can't they?

So, the situation would arguably not be worse that what it is currently,
since it simply doesn't work for users relying on a local installation
of git, and those are probably more common.

Also, a third option: since we're not making use of git input at
runtime, why should it be an input at all? If it is needed at build
time, a native-input should suffice.

Regards,
--
Nicolas Goaziou
K
K
Kyle Meyer wrote on 9 Jul 2021 02:13
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87im1k8hv7.fsf@kyleam.com
Nicolas Goaziou writes:

Toggle quote (16 lines)
> Kyle Meyer <kyle@kyleam.com> writes:
>
>> Nicolas Goaziou writes:
>>
>>> However, I think it is a bug if Emacs Magit does not work with git in
>>> profile. We should modify the source so both magit-git-executable and
>>> magit-gitk-executable point to those from inputs.
>>>
>>> I suggest to open a new bug report about it, WDYT?
>>
>> Rewriting magit-git-executable to an absolute file name will break Magit
>> for those that use it over TRAMP.
>
> Point taken. However, such users can fix it by modifying the
> `magit-git-executable' defcustom again, can't they?

Sure.

Given the number of "oops, some change didn't consider tramp
compatibility" bugs that crop up in Magit, my guess is that Magit is
widely used over TRAMP. So, potentially many users are affected, but I
agree it's an easy fix once they spend time to debug what the issue is.
(That collectively could amount to a lot of wasted time, so in my eyes
it depends on what the practical problem being fixed is.)

Toggle quote (4 lines)
> So, the situation would arguably not be worse that what it is currently,
> since it simply doesn't work for users relying on a local installation
> of git, and those are probably more common.

Hmm, I'm not clear on what the current problem is; a user will typically
have "git" on their path one way or the other. Given Magit's heavily
used, I would have expected to see many Guix bug reports about about it
if it were a problem in practice.

But 1) perhaps I'm missing something or 2) perhaps for philosophical
reasons or to promote best practices rewriting magit-git-executable is
worth the breakage. My drive-by comment was just to mention the
possible breakage [*]. (I don't have a personal stake in what's done
because I don't install Magit from Guix.)

Toggle quote (4 lines)
> Also, a third option: since we're not making use of git input at
> runtime, why should it be an input at all? If it is needed at build
> time, a native-input should suffice.

Yeah, that sounds right (though I haven't tested it).


[*] And it might not break things for much longer. On Magit's end,
Jonas recently floated the idea of not using magit-git-executable
when using TRAMP.

?