(address . bug-guix@gnu.org)
On a x86_64 computer when I run `guix build --no-substitutes
offlineimap` the build fails because the "test_ipv6_available" test
fails.
In the system configuration ipv6 is disabled:
```
(kernel-arguments
(append
(list "nomodeset" "ipv6.disable=1")
%default-kernel-arguments))
```
Taking the failing test's name "test_ipv6_available" literally I would
like to ask if having this test required to build this offlineimap
dependency is necessary? Could this test be allowed to fail or be
skipped without failing the build? This would accommodate Guix users
who have disabled ipv6.
`guix describe` outputs:
```
Generation 18 May 03 2021 13:15:55 (current)
guix 065d2cd
repository URL: https://git.savannah.gnu.org/git/guix.git
commit: 065d2cd6ced96ddb38c15a46f798488f61660a33
```
Build error:
```
starting phase `check'
============================= test session starts ==============================
platform linux2 -- Python 2.7.17, pytest-4.6.11, py-1.8.1, pluggy-0.13.1
rootdir: /tmp/guix-build-python2-rfc6555-0.0.0-1.1a181b4.drv-0/source
plugins: hypothesis-4.57.1
collected 5 items
tests/test_ipv6.py F.... [100%]
=================================== FAILURES ===================================
_____________________________ test_ipv6_available ______________________________
def test_ipv6_available():
Toggle quote (1 lines)
> assert rfc6555._detect_ipv6()
E assert False
E + where False = <function _detect_ipv6 at 0xf6c2887c>()
E + where <function _detect_ipv6 at 0xf6c2887c> = rfc6555._detect_ipv6
tests/test_ipv6.py:11: AssertionError
====================== 1 failed, 4 passed in 0.19 seconds ======================
command "pytest" "tests/test_ipv6.py" failed with status 1
builder for `/gnu/store/4clr8jgvlbhp9qvyx2izdl5dmb8b0xsd-python2-rfc6555-0.0.0-1.1a181b4.drv' failed with exit code 1
build of /gnu/store/4clr8jgvlbhp9qvyx2izdl5dmb8b0xsd-python2-rfc6555-0.0.0-1.1a181b4.drv failed
View build log at '/var/log/guix/drvs/4c/lr8jgvlbhp9qvyx2izdl5dmb8b0xsd-python2-rfc6555-0.0.0-1.1a181b4.drv.bz2'.
cannot build derivation `/gnu/store/pxqzkh8b6266qdrrxhfc74j6bjnb1567-offlineimap-7.3.3.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/pxqzkh8b6266qdrrxhfc74j6bjnb1567-offlineimap-7.3.3.drv' failed
```