[PATCH] gnu: sequoia: Update to 1.1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 2 May 2021 09:41
(address . guix-patches@gnu.org)
2de6a8e0ec4d2b6121ff58155fc530d76fbd550f.1619941234.git.h.goebel@crazy-compilers.com
* gnu/packages/sequoia.scm (sequoia): Update to 1.1.0. [arguments]: Remove
phase "package", add phases "fix-rand-dependency" and "fix-permissions".
---
gnu/packages/sequoia.scm | 19 ++++++++++++++++---
1 file changed, 16 insertions(+), 3 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index b75a622c64..b1d78dad0a 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -42,15 +42,15 @@
(define-public sequoia
(package
(name "sequoia")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit (string-append "v" version))))
+ (commit (string-append "openpgp/v" version))))
(sha256
- (base32 "0y80bl786m29ww3272qsl1ql0xc3pwd6iiqlkv3nmhnjsmygbn0d"))
+ (base32 "0knkm0nw1h4ww51vks4jnnp1yc45llfi7j0i70f6vf2bcknnbmci"))
(file-name (git-file-name name version))))
(build-system cargo-build-system)
(outputs '("out" "python"))
@@ -140,12 +140,25 @@
;; Run make instead of using the rust build system, as
;; suggested by the installation instructions
(replace 'build (lambda _ (invoke "make" "build-release") #t))
+ (delete 'package) ;; cargo can't package a multi-crate workspace
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
(invoke "make" "check")
#t)))
(replace 'install (lambda _ (invoke "make" "install") #t))
+ (add-after 'unpack 'fix-rand-dependency
+ (lambda _
+ (substitute* "ipc/Cargo.toml"
+ ;; required: enable rand::rngs::OsRng in rand >= 0.8
+ (("(^rand =.*,) default-features = false(.*)" _ a b)
+ (string-append a " features = [\"getrandom\"]" b)))
+ #t))
+ (add-after 'unpack 'fix-permissions
+ (lambda _
+ (chmod "sq/src/sq-usage.rs" #o644)
+ (chmod "sqv/src/sqv-usage.rs" #o644)
+ #t))
(add-after 'unpack 'fix-environment
(lambda* (#:key outputs #:allow-other-keys)
;; adjust prefix
--
2.21.4
E
E
Efraim Flashner wrote on 3 May 2021 16:03
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 48154@debbugs.gnu.org)
YJACsO/gNJZNvwPl@3900XT
I'm assuming the inputs haven't changed. Does sequoia4pEp build with
these changes?

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCQAqwACgkQQarn3Mo9
g1EhYA//ZhXm72oByvm2KxhaRx1nz/A9e1QfOuzypqnl3dGk2UovFY1oQB1EqhcA
tNIa7b0sBsZ7x0gSWjiDoFLFSc/U5uQmLg6TadmLvsvt8R8AnOcbHgTxjVhs+VYf
ofHVtiyLLGtdAyRKe/qVv4VIyZkMJhPCYXYhppmBKhVSEJdDRJnn+1dEjhc24/gW
t/lIytiEWZB1TmQoQUuT8yvfU1FBtIFjVOddsYymsRzMIvU3fav14iKwpsYXDftS
+278lwNzTZPpfdBu98aMWW9XEkLkm0YhU96sRD4bNuI1oM2ITFPl0hvhZHHqYFHu
kEqBuJvbu9rJ4QoQmh3QGTYLQ6aN6rZrwsjcmcKRDjFsYcmAZtjNI1jS4stQBtHn
ReA5YSUz+Mm0YhECvV5VeGjHAcSFtCdVowYKgB9viJs71Vr3ZdBxgp7HB1maOuaS
gfLJdvlDZEac5uZK2UtmOCgbjJEl7G8xynfP5baofUspVtCwvgd/s6SQpamrHIXM
np09aoovdY121V/ZMcpF4ay36FmmX0A0oEjadQKfiu6eMOJNdmc5GMycKgRZgHhB
b23lcpBz78chaHZmnyqEI235I+mgFPXbA0l1gzqpcV3jjbihK/OAlCm4UGbXasEp
0JK6kFAFsdklO6dyN3YnM1O2uoaZbR7qqdvhBCLcoTQnVMT+TrQ=
=TmSO
-----END PGP SIGNATURE-----


H
H
Hartmut Goebel wrote on 3 May 2021 21:03
cbc863e7-5abb-cc29-d0c8-2bb2781942a1@crazy-compilers.com
Am 03.05.21 um 16:03 schrieb Efraim Flashner:
Toggle quote (3 lines)
> I'm assuming the inputs haven't changed. Does sequoia4pEp build with
> these changes?

sequoia4pEp is completely unchanged and still builds (more precisely: still the old version from store is used)

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
E
E
Efraim Flashner wrote on 4 May 2021 08:27
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 48154@debbugs.gnu.org)
YJDpYmEa3iAPDrbU@3900XT
On Mon, May 03, 2021 at 09:03:57PM +0200, Hartmut Goebel wrote:
Toggle quote (7 lines)
> Am 03.05.21 um 16:03 schrieb Efraim Flashner:
> > I'm assuming the inputs haven't changed. Does sequoia4pEp build with
> > these changes?
>
> sequoia4pEp is completely unchanged and still builds (more precisely: still the old version from store is used)
>

Looks good to me then!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCQ6WIACgkQQarn3Mo9
g1HcDhAAlg/pcmutV67qEbjUCLonc2E8VHGARlbbyWnICZN6nKPXD+iW04Fz/L6v
v8Lc/Co6gGKfEg/GBHfgdvdBWVLtUsV2LF9BcTFo73GJYo5oVyZAh8qmOtcscZmZ
YwvPlozbgaYnLUHexRfsOLwKi/SR2llPue2bQIHS31OwgTbvSQJjMVtxO493nq3D
jyjbeXpCM64oeDeVW4d3fG+wqiaKi48v7X2LBaLY4qDuJKv4IXUNOnz6fhGE7OmV
UkeJ8CUcZP8bjAD2jR88vh+UmMuJjMLfPo/FLSHZbvVf7Px5atb7PkeyVH0XGhuT
zO/RRRPhRfi+Kdb7g+gZUC3JlY0ASnp8V6RMjf4mEulsMG382fN/88M4bgmI1+bH
nIEGDRxBKkAFycLJEC1qOHYUq05ebo+48Bv7IblsitkJxnn0hAi5D+5+AHPTV3Eq
c0xjgMyuqAHkazMaMUzoRlqj2R4yakscG1fBsykvtPfo68uaz+Gur3cd/UTJsXxF
0Hq+ENjbUGdvIrRF/eQJYU6IfqQaUpOoUkgA8BUFtfK1eiak2w1F+EodPEouAnpH
VHq5o9jqCa7A8Hr7CH/hmsc8AQmcZmcAjmVOUZux0xrkqdVAlA+K136N0BBOWKoZ
yCpccL6TcYW4PARgms2i3g/FV97UTFOl+PfGJ3tCkpDyInNtQiw=
=DERw
-----END PGP SIGNATURE-----


H
H
Hartmut Goebel wrote on 4 May 2021 10:13
b3a832c8-14d2-f76d-f2dc-5a4315eb67a7@crazy-compilers.com
Pushed as ec4012c5820fb139d07dee492f8b0d492ec1c042

Thanks for reviewing.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?