[PATCH] gnu: vim-full: Remove duplicate 'make-flags'.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 5 Mar 2021 20:24
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210305192423.50766-1-zimon.toutoune@gmail.com

* gnu/packages/vim.scm (vim-full): [arguments]: Remove duplicate 'make-flags'.
---
gnu/packages/vim.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 372d470e09..2202788ee3 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -216,11 +217,14 @@ with the editor vim.")))
"--enable-xim"
"--disable-selinux"
"--enable-gui")
- ;; This flag fixes the following error:
- ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
- ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
- #:make-flags '("LDFLAGS=-lexpat")
,@(substitute-keyword-arguments (package-arguments vim)
+ ;; This flag fixes the following error:
+ ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
+ ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
+ ((#:make-flags flags)
+ `(append
+ (list "LDFLAGS=-lexpat")
+ (delete "CFLAGS=-D_REENTRANT" ,flags))) ; Fix <https://bugs.gnu.org/46580>.
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'start-xserver

base-commit: b2a94e59b8fba2f43fbefc45c2f1c4caeabdedb1
--
2.30.1
T
T
Tobias Geerinckx-Rice wrote on 6 Mar 2021 01:30
(address . 46950-done@debbugs.gnu.org)
87a6rh86oy.fsf@nckx
Pushed as c8cbd369eb512b0bc5cc0d5dfc2b5d35da50aa4f with minor ‘[’
tweak and removed out-of-place comment.

Thanks for the swift fix!

T G-R
Closed
?