Extending package transformation options
(address . bug-guix@gnu.org)
Hi Guix!
TL;DR Shall we add a `--without-tests` option (or something similar) for `guix time-machine`?
Our release workflow in Bitcoin is planned to shift over to Guix for the next release, and as such we have a lot more testers who are running Guix as we speak on their machines! Exciting!
Our build workflow basically boils down to something like:
Toggle snippet (5 lines)
$ guix time-machine --commit=<pinned-guix> … \
-- environment --manifest=manifest.scm … \
-- <build-command>
The fact that this is even possible (and allows reproducibility across time) speaks to the awesomeness of Guix! :-)
One of the main reasons for switching over to Guix is for its bootstrappbility and the ability to perform `--bootstrap --no-substitutes` builds. As mentioned in the gnutls ticket, performing these source-based builds can sometimes reveal problems with tests suites:
1. Spurious tests
2. “Expiring” tests (like the gnutls one)
3. Foreign distro problems (0zmcam9sdiag9s1qx3xvlf8a3jnm53x2-sed-4.8.drv fails to build on SELinux-based distros because of a test failure in testsuite/inplace-selinux)
I think that the package transformation options are the perfect “hack-around” solution for this, namely `--without-tests`. In fact, since those who experience these problems are building from source, it makes no difference that the store item would be change: they would need to build everything anyway!
However, in the case of our workflow above, there is no way to specify `--without-tests=` to `guix time-machine`, which insists on building the broken `gnutls` package and running its tests. I’ve tried isolating the command to just:
Toggle snippet (4 lines)
$ guix time-machine --commit=<pinned-guix> … \
-- --help
To make sure that it’s `guix time-machine` which is trying to build gnutls and not the time-machine’d `guix environment`.
I’m not too familiar with how package transformation options work internally, but I’m guessing all we need here is a `--without-tests` option (or something similar) for `guix time-machine`? Is there anything else that’s necessary to successfully skip tests for my workflow?
Cheers,
Carl Dong
contact@carldong.me
"I fight for the users"