[PATCH 0/2] Add r-samr and r-gsa.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Tim Howes
Owner
unassigned
Submitted by
Tim Howes
Severity
normal
T
T
Tim Howes wrote on 15 Feb 2021 06:40
(address . guix-patches@gnu.org)
20210215054029.47677-1-timhowes@lavabit.com
Hello,

This adds the packages samr and GSA for gene expression analysis in R.

Tim Howes (2):
gnu: Add r-gsa.
gnu: Add r-samr.

gnu/packages/cran.scm | 52 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

--
2.30.1
T
T
Tim Howes wrote on 15 Feb 2021 06:44
[PATCH 1/2] gnu: Add r-gsa.
(address . 46524@debbugs.gnu.org)
20210215054437.47745-1-timhowes@lavabit.com
* gnu/packages/cran.scm (r-gsa): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1fe90619cd..86b2df0a9f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
+;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26851,3 +26852,23 @@ from a source package. @code{pkgdown} converts your documentation, vignettes,
README file, and more to HTML making it easy to share information about your
package online.")
(license license:expat)))
+
+(define-public r-gsa
+ (package
+ (name "r-gsa")
+ (version "1.03.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GSA" version))
+ (sha256
+ (base32
+ "05x9wspah1cdznjpncqam1iawsxdiigyl8v2anyhss2k7wwd94p1"))))
+ (properties `((upstream-name . "GSA")))
+ (build-system r-build-system)
+ (home-page
+ "https://statweb.stanford.edu/~tibs/GSA/")
+ (synopsis "Gene Set Analysis")
+ (description "Inference on gene sets in microarray studies.")
+ ;; Any version of the LGPL
+ (license license:lgpl3+)))
--
2.30.1
T
T
Tim Howes wrote on 15 Feb 2021 06:44
[PATCH 2/2] gnu: Add r-samr.
(address . 46524@debbugs.gnu.org)
20210215054437.47745-2-timhowes@lavabit.com
* gnu/packages/cran.scm (r-samr): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 86b2df0a9f..d151f1cb50 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26872,3 +26872,34 @@ package online.")
(description "Inference on gene sets in microarray studies.")
;; Any version of the LGPL
(license license:lgpl3+)))
+
+(define-public r-samr
+ (package
+ (name "r-samr")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "samr" version))
+ (sha256
+ (base32
+ "01km0f7qgm73x19vbvsxl083hs1dq4dj8qm5h64cxbf20b08my15"))))
+ (properties `((upstream-name . "samr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gsa" ,r-gsa)
+ ("r-impute" ,r-impute)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-openxlsx" ,r-openxlsx)
+ ("r-shiny" ,r-shiny)
+ ("r-shinyfiles" ,r-shinyfiles)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page
+ "https://statweb.stanford.edu/~tibs/SAM/")
+ (synopsis
+ "Significance Analysis of Microarrays")
+ (description
+ "Significance Analysis of Microarrays for differential expression
+analysis, RNAseq data and related problems.")
+ ;; Any version of the LGPL
+ (license license:lgpl3+)))
--
2.30.1
R
R
Ricardo Wurmus wrote on 26 Mar 2021 10:14
Re: [bug#46524] [PATCH 0/2] Add r-samr and r-gsa.
(name . Tim Howes)(address . timhowes@lavabit.com)(address . 46524-done@debbugs.gnu.org)
87lfaatgxk.fsf@elephly.net
Hi Tim,

I’m sorry for the delay!

Toggle quote (9 lines)
> This adds the packages samr and GSA for gene expression analysis in R.
>
> Tim Howes (2):
> gnu: Add r-gsa.
> gnu: Add r-samr.
>
> gnu/packages/cran.scm | 52 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 52 insertions(+)

I applied these with minor changes with commit e9741ad623.

Thank you!

--
Ricardo
Closed
?