[bug] build of /gnu/store/~-python2-setuptools-52.0.0.drv failed

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Howard
  • K I
  • Leo Famulari
  • zimoun
Owner
unassigned
Submitted by
K I
Severity
normal
Merged with
K
(name . bug-guix)(address . bug-guix@gnu.org)
E1l4n2Z-0001bf-G0@rmmprod05.runbox
starting phase `patch-source-shebangs'
patch-shebang: ./docs/conf.py: warning: no binary for interpreter `python3' found in $PATH
patch-shebang: ./pkg_resources/_vendor/appdirs.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./setup.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
phase `patch-source-shebangs' succeeded after 0.0 seconds
starting phase `patch-generated-file-shebangs'
phase `patch-generated-file-shebangs' succeeded after 0.0 seconds
starting phase `build'
running "python setup.py" with command "build" and parameters ()
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "setuptools/__init__.py", line 16, in <module>
import setuptools.version
File "setuptools/version.py", line 1, in <module>
import pkg_resources
File "pkg_resources/__init__.py", line 1367
raise SyntaxError(e) from e
^
SyntaxError: invalid syntax
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1
Z
Z
zimoun wrote on 28 Jan 2021 02:09
86zh0thnp9.fsf@gmail.com
Hi,

On Wed, 27 Jan 2021 at 08:47, "K I" <gitlabcanada@runbox.com> wrote:

Toggle quote (6 lines)
> File "pkg_resources/__init__.py", line 1367
> raise SyntaxError(e) from e
> ^
> SyntaxError: invalid syntax
> command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1

It is expected because Setuptools removed the compatibility with Python 2,
see the ChangeLog:

Toggle snippet (8 lines)
v47.0.0

28 May 2020
Breaking Changes

#2094: Setuptools now actively crashes under Python 2. Python 3.5 or later is required. Users of Python 2 should use setuptools<45.



The question is: do we remove ’python2-setuptools’ since it is defined
by the usual ’package-with-python2’?

Toggle snippet (4 lines)
(define-public python2-setuptools
(package-with-python2 python-setuptools))

Or do we define python2-setuptools with the version v46.4.0? Which,
IMHO does not make sense since Python 2 is end of life since one year.


All the best,
simon
L
L
Leo Famulari wrote on 28 Jan 2021 23:06
(no subject)
(address . control@debbugs.gnu.org)
YBM1VQogfyVOOuUB@jasmine.lan
merge 46158 46132
Z
Z
zimoun wrote on 11 Mar 2021 01:22
Re: bug#46132: [bug] build of /gnu/store/~-python2-setuptools-52.0.0.drv failed
(name . K I)(address . gitlabcanada@runbox.com)(address . 46132@debbugs.gnu.org)
8635x2bku9.fsf@gmail.com
Hi,

On Thu, 28 Jan 2021 at 02:09, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (32 lines)
> On Wed, 27 Jan 2021 at 08:47, "K I" <gitlabcanada@runbox.com> wrote:
>
>> File "pkg_resources/__init__.py", line 1367
>> raise SyntaxError(e) from e
>> ^
>> SyntaxError: invalid syntax
>> command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1
>
> It is expected because Setuptools removed the compatibility with Python 2,
> see the ChangeLog:
>
> v47.0.0
>
> 28 May 2020
> Breaking Changes
>
> #2094: Setuptools now actively crashes under Python 2. Python 3.5 or later is required. Users of Python 2 should use setuptools<45.
>
>
> <https://setuptools.readthedocs.io/en/latest/history.html>
> <https://github.com/pypa/setuptools/issues/2094>
>
>
> The question is: do we remove ’python2-setuptools’ since it is defined
> by the usual ’package-with-python2’?
>
> (define-public python2-setuptools
> (package-with-python2 python-setuptools))
>
> Or do we define python2-setuptools with the version v46.4.0? Which,
> IMHO does not make sense since Python 2 is end of life since one year.

Currently, python-setuptools is at version 52.0 and python2-setuptools
at version 41.0.1. Both build fine. The comment says:

Toggle snippet (7 lines)
;; Newer versions of setuptools no longer support Python 2.
(define-public python2-setuptools
(package
(name "python2-setuptools")
(version "41.0.1")

therefore, this part of the bug is done. Let check the other part.


Cheers,
simon
Z
Z
zimoun wrote on 11 Mar 2021 01:27
Re: bug#46158: qucs-s build failure: cairocffi python2 issue
(name . Christopher Howard)(address . christopher@librehacker.com)
86zgzaa60l.fsf@gmail.com
Hi,

On Thu, 28 Jan 2021 at 09:17, Christopher Howard <christopher@librehacker.com> wrote:
Toggle quote (3 lines)
> When I try to install qucs-s, installation ultimately fails due to build failure of dependency
> python2-cairocffi-1.2.0. Apparently python2 is no longer allowed by cairocffi:

Indeed, python2-cairocffi is failing. However qucs-s is available and
build fine with commit 6bed29b.

/gnu/store/2hl8gvma4hzq07m0xdrrncmr46nqwlpy-qucs-s-0.0.21

If it is fine with you, I inclined to close this bug. WDYT?


All the best,
simon
C
C
Christopher Howard wrote on 11 Mar 2021 01:48
(name . zimoun)(address . zimon.toutoune@gmail.com)
9924570c0c4a91edd97e58f7d499671504b6d1c0.camel@librehacker.com
I was able to build qucs a week or two ago, but didn't report it. I
think you can close this bug report. Thank you.

On Thu, 2021-03-11 at 01:27 +0100, zimoun wrote:
Toggle quote (20 lines)
> Hi,
>
> On Thu, 28 Jan 2021 at 09:17, Christopher Howard <
> christopher@librehacker.com> wrote:
> > When I try to install qucs-s, installation ultimately fails due to
> > build failure of dependency
> > python2-cairocffi-1.2.0. Apparently python2 is no longer allowed by
> > cairocffi:
>
> Indeed, python2-cairocffi is failing. However qucs-s is available
> and
> build fine with commit 6bed29b.
>
> /gnu/store/2hl8gvma4hzq07m0xdrrncmr46nqwlpy-qucs-s-0.0.21
>
> If it is fine with you, I inclined to close this bug. WDYT?
>
>
> All the best,
> simon
--
Christopher Howard
phone: (907) 374-0257 (landline)
Z
Z
zimoun wrote on 11 Mar 2021 02:03
(name . Christopher Howard)(address . christopher@librehacker.com)
86sg52a4dt.fsf@gmail.com
On Wed, 10 Mar 2021 at 15:48, Christopher Howard <christopher@librehacker.com> wrote:
Toggle quote (3 lines)
> I was able to build qucs a week or two ago, but didn't report it. I
> think you can close this bug report. Thank you.

Thanks, so closing.
Closed
?