[PATCH 0/1] Fix libnode and r-v8

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 14 Jan 2021 15:30
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210114143054.33683-1-zimon.toutoune@gmail.com
Hi,

Commit 1d77141f6d introduces a regression about libnode. See:

Toggle snippet (14 lines)
$ for ci in $(git -C ~/src/guix/guix log --format="%H" 1d77141f6d^^..1d77141f6d) ;\
do echo "# Commit: $ci" ;\
guix time-machine --commit=$ci -- build libnode --no-grafts -v 0 ;\
done

# Commit: 1d77141f6d5004cf10d1f9ead53855f25a973847
Mise à jour du canal « guix » depuis le dépôt Git « https://git.savannah.gnu.org/git/guix.git »...
guix build: error: build of `/gnu/store/yzpk9vr4ipa58vhfqcb66jpwjs808y3n-libnode-10.20.0.drv' failed

# Commit: ac80cbfab69b59d17fcf38ef9f4ce0acc0e5f9e6
Mise à jour du canal « guix » depuis le dépôt Git « https://git.savannah.gnu.org/git/guix.git »...
/gnu/store/7m6nkxcaky1423078mnxa9zkrxyz2c30-libnode-10.20.0

The patch fixes it. The test is done against r-v8 which uses libnode.
Everything builds fine now.


All the best,
simon

zimoun (1):
gnu: libnode: Fix regression in unused phases.

gnu/packages/node.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)


base-commit: 88eb5370ec155902ed5fe7636e91e932079b338a
--
2.29.2
Z
Z
zimoun wrote on 14 Jan 2021 15:34
[PATCH 1/1] gnu: libnode: Fix regression in unused phases.
(address . 45862@debbugs.gnu.org)
20210114143429.33740-1-zimon.toutoune@gmail.com
Regression introduced in 1d77141f6d5004cf10d1f9ead53855f25a973847.
Reported by Pierre-Antoine Bouttier
<pierre-antoine.bouttier@univ-grenoble-alpes.fr>.

* gnu/packages/node.scm (libnode)[arguments]: Delete phase
"patch-node-shebang".
---
gnu/packages/node.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 9e07cd906e..a495f6d763 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,4 +239,5 @@ devices.")
`(cons* "--shared" "--without-npm" ,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- (delete 'patch-npm-shebang)))))))
+ (delete 'patch-npm-shebang)
+ (delete 'patch-node-shebang)))))))
--
2.29.2
R
R
Ricardo Wurmus wrote on 20 Jan 2021 22:35
Re: [bug#45862] [PATCH 0/1] Fix libnode and r-v8
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 45862-done@debbugs.gnu.org)
87mtx3l2bf.fsf@elephly.net
Hi,

Toggle quote (2 lines)
> Commit 1d77141f6d introduces a regression about libnode. See: […]

Sorry about that!

Toggle quote (3 lines)
> The patch fixes it. The test is done against r-v8 which uses libnode.
> Everything builds fine now.

Indeed! Applied and pushed with commit 41134f915f.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45862@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45862
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch