[PATCH] weather: Fix '--substitute-urls'.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 16 Nov 2020 17:51
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20201116165151.6022-1-zimon.toutoune@gmail.com
Reported by Efraim Flashner <efraim@flashner.co.il>.

* guix/scripts/weather.scm (guix-weather): Fix when substitute-urls
is a list.
---
guix/scripts/weather.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/guix/scripts/weather.scm b/guix/scripts/weather.scm
index 6a2582c997..c6ae4212de 100644
--- a/guix/scripts/weather.scm
+++ b/guix/scripts/weather.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,6 +31,7 @@
#:use-module (guix grafts)
#:use-module (guix gexp)
#:use-module ((guix build syscalls) #:select (terminal-columns))
+ #:use-module ((guix build utils) #:select (every*))
#:use-module (guix scripts substitute)
#:use-module (guix http-client)
#:use-module (guix ci)
@@ -540,7 +542,7 @@ SERVER. Display information for packages with at least THRESHOLD dependents."
(package-outputs packages system))
systems))))))
(exit
- (every (lambda (server)
+ (every* (lambda (server)
(define coverage
(report-server-coverage server items
#:display-missing?

base-commit: 243512d984e1b870d3b77b2759698a64ed723fea
--
2.28.0
M
M
Mathieu Othacehe wrote on 25 Nov 2020 11:56
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 44688-done@debbugs.gnu.org)
87a6v5n1qu.fsf@gnu.org
Hello zimoun,

Toggle quote (3 lines)
> * guix/scripts/weather.scm (guix-weather): Fix when substitute-urls
> is a list.

I fixed indentation and pushed as
c2cc5f0a006fd7797039dae24274833118ea7b47.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44688@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44688
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch