(address . guix-patches@gnu.org)(name . Aniket Patil)(address . aniket112.patil@gmail.com)
* gnu/packages/cran.scm (r-deconstructsigs): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82caaf54f6..75d9ae7de2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24715,3 +24715,33 @@ modal regression and conditional density estimation in the
presence/absence of measurement error. Bandwidth selection is
also provided for each method.")
(license license:gpl2+)))
+
+(define-public r-deconstructsigs
+ (package
+ (name "r-deconstructsigs")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "deconstructSigs" version))
+ (sha256
+ (base32
+ "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+ (properties
+ `((upstream-name . "deconstructSigs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19"
+ ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page
+ "https://github.com/raerose01/deconstructSigs")
+ (synopsis "Identifies Signatures Present in a Tumor Sample")
+ (description
+ "Takes sample information in the form of the fraction of
+mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed,
+most closely reconstructs the mutational profile.")
+ (license license:gpl2+)))
--
2.28.0