"guix weather" : 504 error

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Christopher Baines
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 4 Jun 2020 16:34
(address . bug-guix@gnu.org)
CAJ3okZ23kcBv8UirLSkziVT5N=sm2yt5rNCFx9rjr+LPDT1Y1w@mail.gmail.com
Dear,

By default, "guix weather" returns:

Toggle snippet (3 lines)
'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")

which is not fatal but annoying. Especially, it takes time.

As discussed on IRC [1], it seems that it is a bug server side.

In addition, something appears similar with Bayfront, well the 4
substitutes servers that I know returns:

Toggle snippet (8 lines)
'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
'https://bayfront.guix.gnu.org/api/queue?nr=1000' returned 504
("Gateway Time-out")
(continuous integration information unavailable)
'https://guix.tobias.gr/api/queue?nr=1000' returned 410 ("Gone")


C
C
Christopher Baines wrote on 9 Jun 2020 23:12
87wo4g7xkv.fsf@cbaines.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (21 lines)
> By default, "guix weather" returns:
>
> --8<---------------cut here---------------start------------->8---
> 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
> --8<---------------cut here---------------end--------------->8---
>
> which is not fatal but annoying. Especially, it takes time.
>
> As discussed on IRC [1], it seems that it is a bug server side.
>
> In addition, something appears similar with Bayfront, well the 4
> substitutes servers that I know returns:
>
> --8<---------------cut here---------------start------------->8---
> 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
> 'https://bayfront.guix.gnu.org/api/queue?nr=1000' returned 504
> ("Gateway Time-out")
> (continuous integration information unavailable)
> 'https://guix.tobias.gr/api/queue?nr=1000' returned 410 ("Gone")
> --8<---------------cut here---------------end--------------->8---

Hey,

So I think I've got a patch [1] to Cuirass to "fix" this.


I expected this was due to the complicated part of the db-get-builds
query, but I think it's actually down to the simple part that fetches
all the outputs for all the builds. Fetching the outputs for a build is
slow, because at the moment, there's no index on the Outputs field, so
looking up the outputs requires reading through the whole table, and the
Outputs table can be quite large.

The performance should improve with the additional query. To see why,
you can use EXPLAIN QUERY PLAN to see what SQLite plans to do when
processing the query:

sqlite> EXPLAIN QUERY PLAN SELECT name, path FROM Outputs WHERE derivation = 'foo';
QUERY PLAN
`--SCAN TABLE Outputs

sqlite> CREATE INDEX Outputs_derivation_index ON Outputs (derivation);

sqlite> EXPLAIN QUERY PLAN SELECT name, path FROM Outputs WHERE derivation = 'foo';
QUERY PLAN
`--SEARCH TABLE Outputs USING INDEX Outputs_derivation_index (derivation=?)


I believe that searching the table using an index is going to be faster
than scanning the table, and testing locally and on bayfront suggests
this will resolve the performance issue.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7f+0BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd2dQ//YdwAPpTVYDwXD8pXQUOul6q4hYeg7KkPwcmwNZsDb0/XCbVoExBEMTFN
t+HlE4QFJL6k26m/v4JpTu/WmI0vwK+NkKR2Uew5chAOYPkNRkrEiqkbdNuCxjET
eJAYA9BPcbi2cs6yzc18eOPz1T0K4wv75dIb0nUZB6eaH9RAtPSpC5G3BF/2jb2t
eKnYIqQw6m8LgI4/wrqceDDIGTsu405Zmk++XTUDtSC35Y2vnuKOS9N3NuGdIy0v
Fcb+71cKuBvSK354mDKzXG8fLMoXyhgomjn65BTwNoi2RJxNMZpZNNhlSW/DDLdI
KpMzxRzattgf66Sdhwd6PWpdUNUgTksjnRw5gUz3ID8NyUWk6btUMEZtJYhkttYu
COKL2e/iXW+IdNHnKf0rRHJ4Zp2oaz4/CAyGGzdXa3dRX+vczahWB1eps9zjOI0w
afNsZ2hLS/RgqcmoP9gILSXwPD6xi4KfjsutTjA2sm0P+gpQB1kJc7tf5DTwZI0r
yYQnGm99eEbP0N8nQLleZ01r8UMTJY1D4p2fkRNDKacCsZ/xyani/Q6WihE5NEEd
EBZMxR+lEMipZRpCcruKLEvFZl3Fwl8a2lv4hpRLJZvaVrkrNgkDTxGjpLBU28sj
IxVzfujmzP5OxIHcjlJdYYh1aNtYoGsFncC5c7cbhVRKSwSS46c=
=4XjJ
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 13 Jun 2020 15:18
868sgrje8c.fsf@gmail.com
Hi Chris,

On Tue, 09 Jun 2020 at 22:12, Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (4 lines)
> So I think I've got a patch [1] to Cuirass to "fix" this.
>
> 1: https://lists.gnu.org/archive/html/guix-devel/2020-06/msg00117.html

[...]

Toggle quote (4 lines)
> I believe that searching the table using an index is going to be faster
> than scanning the table, and testing locally and on bayfront suggests
> this will resolve the performance issue.

Is the patch installed on Bayfront?
If yes, I still see 'returned 504 ("Gateway Time-out")' when quering
Bayfront as '--substitute-urls'.
If no, is it possible to install it? for testing it in "real life".


Cheers,
simon

ps:
It is an old request because I complained [1] about it one year ago.
Maybe something related to the summer coming. ;-)

C
C
Christopher Baines wrote on 13 Jun 2020 18:23
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 41708@debbugs.gnu.org)
87o8pn7x4d.fsf@cbaines.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (27 lines)
> On Tue, 09 Jun 2020 at 22:12, Christopher Baines <mail@cbaines.net> wrote:
>
>> So I think I've got a patch [1] to Cuirass to "fix" this.
>>
>> 1: https://lists.gnu.org/archive/html/guix-devel/2020-06/msg00117.html
>
> [...]
>
>> I believe that searching the table using an index is going to be faster
>> than scanning the table, and testing locally and on bayfront suggests
>> this will resolve the performance issue.
>
> Is the patch installed on Bayfront?
> If yes, I still see 'returned 504 ("Gateway Time-out")' when quering
> Bayfront as '--substitute-urls'.
> If no, is it possible to install it? for testing it in "real life".
>
>
> Cheers,
> simon
>
> ps:
> It is an old request because I complained [1] about it one year ago.
> Maybe something related to the summer coming. ;-)
>
> 1: https://lists.gnu.org/archive/html/help-guix/2019-05/msg00355.html

I've now deployed the change to Bayfront, let me know if you see a
difference? :)

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7k/ZJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfUrw//SYMmbzU5Ma7PcVcSphEUBoqQ+2seWTFV7u55oBvmbMaAixFoHtDsGNSc
Ztc2tLIQFDimqIjq9ZrArQCT+AVqhxKr43zMHKPiElJ9uQIfzL79QSXtHeh4kWbP
gakeKbZ+lvviGx7Sd8yxoZUQqIqaLojgY53FypspXZQmQFyIKM3xQQTVKt9lKdg+
2zg+vFi42YnS3pNm5lW8OKgjCsvAzum/Ei0n95p4lcQmBwYLd+ni7j+Pqnd+tuEp
5ZmHFke/GtdxsY0ffP+LBnd3JM0MOknaCLLJ5sw7QpZ7fu8i7aZA6TElVVd3GU+l
pi8QpWxAhSyzjDfA/WLg/hiUG3jJfoD5XdEGSsmreNTw3BOQEIcI/VNcYf2F8Bl5
31QZ8uxydYqIzPgPvPc5MjAAndu2Xy7Y8D18mb0Xcl53nMfApdErl53oGCWz0TMV
qBB6N8hFw3yrNg2hih7aplY+c3XU6rNGk8GjKWurD9gqjz64+mlz9l4bWlD650zQ
7uSBmOrbiLQaRsPhYpVG4HnCjqoaSr59h5LExdhc/iXE3WVv6HUkEL7UnrmVhgkp
uW0JBChbrO1QqYqAnxXgXl5mXMTPrGc8RVDKOTzFJEnnAtbs9hzew/puqo2RnLoh
fsAjB6u4huU9x7oNWCjcj8Gnl3taBolmo3t+pIdNT4D/Udzm0Xs=
=KzX7
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 13 Jun 2020 19:55
(name . Christopher Baines)(address . mail@cbaines.net)(address . 41708@debbugs.gnu.org)
86a716alzo.fsf@gmail.com
Hi Chris,

On Sat, 13 Jun 2020 at 17:23, Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (3 lines)
> I've now deployed the change to Bayfront, let me know if you see a
> difference? :)

Yes! :-)

Toggle snippet (26 lines)
$ guix weather guix --substitute-urls='https://ci.guix.gnu.org https://bayfront.guix.gnu.org'
computing 1 package derivations for x86_64-linux...

looking for 1 store items on https://ci.guix.gnu.org...
https://ci.guix.gnu.org
100.0% substitutes available (1 out of 1)
at least 106.4 MiB of nars (compressed)
278.7 MiB on disk (uncompressed)
0.002 seconds per request (0.0 seconds in total)
543.8 requests per second
'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")

looking for 1 store items on https://bayfront.guix.gnu.org...
https://bayfront.guix.gnu.org
100.0% substitutes available (1 out of 1)
at least 106.3 MiB of nars (compressed)
278.6 MiB on disk (uncompressed)
0.001 seconds per request (0.0 seconds in total)
791.8 requests per second

at least 1,000 queued builds
x86_64-linux: 1000 (100.0%)
build rate: 9.22 builds per hour
x86_64-linux: 9.22 builds per hour

I will try a couple more of queries. But I propose to push the patch on
Berlin too. WDYT?


Cheers,
simon
C
C
Christopher Baines wrote on 15 Jun 2020 20:43
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 41708@debbugs.gnu.org)
87v9jsp3tt.fsf@cbaines.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (39 lines)
> Hi Chris,
>
> On Sat, 13 Jun 2020 at 17:23, Christopher Baines <mail@cbaines.net> wrote:
>
>> I've now deployed the change to Bayfront, let me know if you see a
>> difference? :)
>
> Yes! :-)
>
> --8<---------------cut here---------------start------------->8---
> $ guix weather guix --substitute-urls='https://ci.guix.gnu.org https://bayfront.guix.gnu.org'
> computing 1 package derivations for x86_64-linux...
>
> looking for 1 store items on https://ci.guix.gnu.org...
> https://ci.guix.gnu.org
> 100.0% substitutes available (1 out of 1)
> at least 106.4 MiB of nars (compressed)
> 278.7 MiB on disk (uncompressed)
> 0.002 seconds per request (0.0 seconds in total)
> 543.8 requests per second
> 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
>
> looking for 1 store items on https://bayfront.guix.gnu.org...
> https://bayfront.guix.gnu.org
> 100.0% substitutes available (1 out of 1)
> at least 106.3 MiB of nars (compressed)
> 278.6 MiB on disk (uncompressed)
> 0.001 seconds per request (0.0 seconds in total)
> 791.8 requests per second
>
> at least 1,000 queued builds
> x86_64-linux: 1000 (100.0%)
> build rate: 9.22 builds per hour
> x86_64-linux: 9.22 builds per hour
> --8<---------------cut here---------------end--------------->8---
>
> I will try a couple more of queries. But I propose to push the patch on
> Berlin too. WDYT?

I believe it's been deployed now. It was working earlier today at least,
however all of Cuirass seems to be stuck now.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7nwV5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcqRA/+PXQ+JxJHsS3svH06eR9tKw3vo4A1cRWFq0ZCPdnmD1/6oL87XNkYKyjD
EpRMNypHR3RW3a7k6hJ5xvxFfpBc2cNVRPMDi+HraFeezhYr1noDAfPg+tWs32FN
aY1szaYXCqS0EhEV7+7BjTUNPXRkV/AIASqwGgC1OhnRhXMB8gReg0nQ6Fpexvsr
l+AfT3VbpH1VnhuojU9QOD2ys1COMjh5RH0exN/XSZHvHOqV5aF6oEKsbrs3cY9E
0Z29Lql7ounjWBwDHAk0yzcqpSt9HHgfEz/42MNedY+2iRLyPzjb4stYg+mXUzHA
AE6uONGdA9b/leq8L5UpXCtpJ18X9OezqcTBzMjebjXihrOiJzdEvjfuHeF+9bPf
0dN56YjFzMr4zSzwVvo/SW8KhigFlkFEvb97n697Zo2zGIkC0hXEDs4Kz0w4rQxb
sP1gNYQq3gJs0qXbs5um0mO7NLLdbVhgEf6yrlnTn7dW80/9S2ujDyAKuRKPYw4P
ypS4v+qMlZvOloWeU1zdHprFTbgAQi57IuwifgQlZAQyKrLiPfUYdsfvbCMYc0R5
HUkl0IbKk+SKFRkXRYuSOch/fuDDOHBNABfro2CFQluWIBpiDueA2UZLfO5aipnD
dzjVuaK36yd1ulVGxz+RwLl8cOVsQENeKF+EC8e/MoaGD8qUHD8=
=drb2
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 15 Jun 2020 22:02
(name . Christopher Baines)(address . mail@cbaines.net)(address . 41708@debbugs.gnu.org)
86ftaww0zy.fsf@gmail.com
On Mon, 15 Jun 2020 at 19:43, Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (3 lines)
> I believe it's been deployed now. It was working earlier today at least,
> however all of Cuirass seems to be stuck now.

Well, it seems working. Feel free to close the bug.

Toggle snippet (25 lines)
$ guix weather
computing 13,814 package derivations for x86_64-linux...
looking for 14,354 store items on https://ci.guix.gnu.org...
updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
https://ci.guix.gnu.org
88.2% substitutes available (12,661 out of 14,354)
at least 72,495.6 MiB of nars (compressed)
118,865.0 MiB on disk (uncompressed)
0.021 seconds per request (303.4 seconds in total)
47.3 requests per second

0.0% (0 out of 1,693) of the missing items are queued
at least 1,000 queued builds
i686-linux: 310 (31.0%)
aarch64-linux: 230 (23.0%)
armhf-linux: 313 (31.3%)
x86_64-linux: 147 (14.7%)
build rate: 39.53 builds per hour
x86_64-linux: 9.53 builds per hour
aarch64-linux: 9.57 builds per hour
armhf-linux: 8.54 builds per hour
i686-linux: 11.90 builds per hour


Cheers,
simon
C
C
Christopher Baines wrote on 15 Jun 2020 22:23
(address . 41708-done@debbugs.gnu.org)
87tuzcoz87.fsf@cbaines.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (7 lines)
> On Mon, 15 Jun 2020 at 19:43, Christopher Baines <mail@cbaines.net> wrote:
>
>> I believe it's been deployed now. It was working earlier today at least,
>> however all of Cuirass seems to be stuck now.
>
> Well, it seems working. Feel free to close the bug.

Great, closing :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7n2KhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd6VA//etd3D1onDc734LOqG0g3B//iGTABLuSV7HACokPar0UEQlbvkFAHg+Eq
avD+hRlJiEvrbIhsZ7IECCFBCrWOr7fhfboNySy9xLwqmoXMMLurKf+TmtuKp5EW
QtOPgm8tOPDhLAWdUzeRWwyEXxTM+Um7SYE0RFFafN7QWky/FrCcmeYRWDlBWM0/
1zOH7tVmKzsCeCP86FfjkFgSNBr1E76JzuXn1vRZg9o3Va61VXctK1kegYFlZTH2
0FVadRZdwDmhoR+A8ZK3PX3QYVVYqrCP6FO1dLw1qngsG7cV8CdsnhRHy2l+FQJx
NGcFlDlMe2FvKPFbkQ9dFLmH6edCEqFsUwhcbuOzDq6PnQy+zCXikftdM576P+ob
3bIPEcV+NQRMFCrtTKX1MrJC8YLilAN8OyZ4NH4urWW0VnzpPLufJtXolMZMzI+x
ta/ez1xm3hTcd6cmJ3mFWg1NuQI4aH4vS1g4evReHc88eLOb8IY81bNi33XvIPa/
iopXY/0yrW5ZcnYy8yfcK4kCMigSUQ/xgL27SpV3Al3AAg5NZTPv9MgFm1r0Cf4r
/ul5JKcECLlmhvn4x4vyjPzTM5rnnkOeJBNHchxIXmmRaDpXd1+HhKJUbIioSWsK
k+ZQg0on3bt1vkuYfJZT6LAX+ior51+bY+t17T5TJGmEw1iumWQ=
=HV8i
-----END PGP SIGNATURE-----

Closed
L
L
Ludovic Courtès wrote on 16 Jun 2020 12:15
(name . zimoun)(address . zimon.toutoune@gmail.com)
87o8pjtiyq.fsf@gnu.org
zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (30 lines)
> On Mon, 15 Jun 2020 at 19:43, Christopher Baines <mail@cbaines.net> wrote:
>
>> I believe it's been deployed now. It was working earlier today at least,
>> however all of Cuirass seems to be stuck now.
>
> Well, it seems working. Feel free to close the bug.
>
> $ guix weather
> computing 13,814 package derivations for x86_64-linux...
> looking for 14,354 store items on https://ci.guix.gnu.org...
> updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> https://ci.guix.gnu.org
> 88.2% substitutes available (12,661 out of 14,354)
> at least 72,495.6 MiB of nars (compressed)
> 118,865.0 MiB on disk (uncompressed)
> 0.021 seconds per request (303.4 seconds in total)
> 47.3 requests per second
>
> 0.0% (0 out of 1,693) of the missing items are queued
> at least 1,000 queued builds
> i686-linux: 310 (31.0%)
> aarch64-linux: 230 (23.0%)
> armhf-linux: 313 (31.3%)
> x86_64-linux: 147 (14.7%)
> build rate: 39.53 builds per hour
> x86_64-linux: 9.53 builds per hour
> aarch64-linux: 9.57 builds per hour
> armhf-linux: 8.54 builds per hour
> i686-linux: 11.90 builds per hour

Awesome, thank you Chris!

Ludo’.
Z
Z
zimoun wrote on 20 Jun 2020 02:03
86v9jmsivo.fsf@gmail.com
Dear Chris,

On Mon, 15 Jun 2020 at 21:23, Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (10 lines)
> zimoun <zimon.toutoune@gmail.com> writes:
>> On Mon, 15 Jun 2020 at 19:43, Christopher Baines <mail@cbaines.net> wrote:

>>> I believe it's been deployed now. It was working earlier today at least,
>>> however all of Cuirass seems to be stuck now.
>>
>> Well, it seems working. Feel free to close the bug.
>
> Great, closing :)

I do not know if it is only this evening, but something appears wrong:

Toggle snippet (13 lines)
$ guix weather
computing 13,814 package derivations for x86_64-linux...
looking for 14,354 store items on https://ci.guix.gnu.org...
updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
https://ci.guix.gnu.org
88.3% substitutes available (12,672 out of 14,354)
at least 72,508.1 MiB of nars (compressed)
118,880.3 MiB on disk (uncompressed)
0.001 seconds per request (12.8 seconds in total)
1,123.2 requests per second
'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")

For the record:

Toggle snippet (9 lines)
$ guix describe
Generation 36 Jun 08 2020 00:18:47 (current)
guix e782756
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: e78275608065ef073775fabb9f1a757da65851f2


Cheers,
simon
C
C
Christopher Baines wrote on 20 Jun 2020 10:22
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 41708@debbugs.gnu.org)
871rmam9ih.fsf@cbaines.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (29 lines)
> Dear Chris,
>
> On Mon, 15 Jun 2020 at 21:23, Christopher Baines <mail@cbaines.net> wrote:
>> zimoun <zimon.toutoune@gmail.com> writes:
>>> On Mon, 15 Jun 2020 at 19:43, Christopher Baines <mail@cbaines.net> wrote:
>
>>>> I believe it's been deployed now. It was working earlier today at least,
>>>> however all of Cuirass seems to be stuck now.
>>>
>>> Well, it seems working. Feel free to close the bug.
>>
>> Great, closing :)
>
> I do not know if it is only this evening, but something appears wrong:
>
> --8<---------------cut here---------------start------------->8---
> $ guix weather
> computing 13,814 package derivations for x86_64-linux...
> looking for 14,354 store items on https://ci.guix.gnu.org...
> updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> https://ci.guix.gnu.org
> 88.3% substitutes available (12,672 out of 14,354)
> at least 72,508.1 MiB of nars (compressed)
> 118,880.3 MiB on disk (uncompressed)
> 0.001 seconds per request (12.8 seconds in total)
> 1,123.2 requests per second
> 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
> --8<---------------cut here---------------end--------------->8---

Did you check if any pages loaded for Cuirass, or was it just this API
endpoint that was timing out?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7tx1ZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdUug//TynA3gNAhQDVhLXmpab5ByTiSB7FzVQ8rpAizTFBn/yAxVZCRb9rqbcL
KDJvp3C1/8iudxLGHrbKCphxAjB/4PJUaf+/D06QgJKOoV02NFNFyHGW5Eq9bBDx
4WWnlqQ0rMd1S4DgYnU/+3OpLmxM9zjpWWjbefEl6ovAsgD6AWuLmP7yE4aaiHP/
LDxrvw0RaxFTthHwJOO38nz3Z9gLxRu8m+l6Xbgbi4+yovpWZQ09HGDG0nsL5ROw
QyzKeVutj/BCqpKk7x+sVPHyUkNcbgXAYA8c4croxGY8CAP3TZrLOb8B0qZRFl8Z
7ec3VZSGhCwfIQIxpVNrXZnwjbNdmdotSvVCNsYZfd3HlsBac7Ct8CF70L7zZYYL
57DTt21IEpK2fih2cEU7gLbW1f6+jpGWOPp/6xioTe1OG1endYbWTiz+XRapK/s/
8PxXbIFUdqMuD3KCI7n83QV8iuAt83qpsFQO+pHoDJ2/vH0ZSwcQQUVk6lalHDyv
Q+qejggem7f39VoJemFtYfu8wilvP+HSEhpEUnh8VSuDc4L7jVKc6JBDZ01zJyar
6dd79tO+UdE9Mv7CA+/RD53XTYtuYIdnXTTzxCvamJ3kab4ob08oC8W8cCLucCB8
tB7cTtEmE8GDoIvcb7PM7Y3osAtJdKsnNeVyjLXvXbg6rp5Iepw=
=ZVpp
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jun 2020 12:10
(name . Christopher Baines)(address . mail@cbaines.net)(address . 41708@debbugs.gnu.org)
CAJ3okZ0eHTt58oSVwSPgF-iGN94QHYB9rsrkin-YjrFSOZCz5Q@mail.gmail.com
Hi Chris,

On Sat, 20 Jun 2020 at 10:22, Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (17 lines)
> > --8<---------------cut here---------------start------------->8---
> > $ guix weather
> > computing 13,814 package derivations for x86_64-linux...
> > looking for 14,354 store items on https://ci.guix.gnu.org...
> > updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> > https://ci.guix.gnu.org
> > 88.3% substitutes available (12,672 out of 14,354)
> > at least 72,508.1 MiB of nars (compressed)
> > 118,880.3 MiB on disk (uncompressed)
> > 0.001 seconds per request (12.8 seconds in total)
> > 1,123.2 requests per second
> > 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
> > --8<---------------cut here---------------end--------------->8---
>
> Did you check if any pages loaded for Cuirass, or was it just this API
> endpoint that was timing out?

I am not sure to understand your both questions.
What I see as an end-user is again "returned 504 ("Gateway
Time-out")". And I do not know if something has changed on
ci.guix.gnu.org or if there is another problem.
Tell me if I can do something for helping.

Cheers,
simon
R
R
Ricardo Wurmus wrote on 24 Jun 2020 14:58
(name . zimoun)(address . zimon.toutoune@gmail.com)
87o8p8r57a.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (27 lines)
> Hi Chris,
>
> On Sat, 20 Jun 2020 at 10:22, Christopher Baines <mail@cbaines.net> wrote:
>
>> > --8<---------------cut here---------------start------------->8---
>> > $ guix weather
>> > computing 13,814 package derivations for x86_64-linux...
>> > looking for 14,354 store items on https://ci.guix.gnu.org...
>> > updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
>> > https://ci.guix.gnu.org
>> > 88.3% substitutes available (12,672 out of 14,354)
>> > at least 72,508.1 MiB of nars (compressed)
>> > 118,880.3 MiB on disk (uncompressed)
>> > 0.001 seconds per request (12.8 seconds in total)
>> > 1,123.2 requests per second
>> > 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
>> > --8<---------------cut here---------------end--------------->8---
>>
>> Did you check if any pages loaded for Cuirass, or was it just this API
>> endpoint that was timing out?
>
> I am not sure to understand your both questions.
> What I see as an end-user is again "returned 504 ("Gateway
> Time-out")". And I do not know if something has changed on
> ci.guix.gnu.org or if there is another problem.
> Tell me if I can do something for helping.

Right now I see a response when I visit that URL.
But recently the web interface has been a bit flakey and I had to
restart it not long ago.
Z
Z
zimoun wrote on 24 Jun 2020 15:06
(name . Ricardo Wurmus)(address . rekado@elephly.net)
CAJ3okZ3AMrWMnh32AAD_jV2fYbD3SZvKHSBDr7kECkiUUc3FDA@mail.gmail.com
Hi Ricardo,

On Wed, 24 Jun 2020 at 14:58, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (4 lines)
> Right now I see a response when I visit that URL.
> But recently the web interface has been a bit flakey and I had to
> restart it not long ago.

Thank you for the notification.
Now it works again as expected for me. I have read on #guix that Ludo
restarted the Web Interface at 14:32 and just after the 504
disappeared.

Let say that now this bug is close. :-)

Cheers,
simon
?