Dear Marius,
I do not know if it is a bug or if I misconfigured something but some
images under 'share/info/images' are "broken" for some commits, as if
the font is missing. Because it is 'png' files, it is not related on
the presence or absence of such fonts on my machine, I guess. Or do I
misunderstand something? And if it is, why for some commits it
displays nicely and other not.
When I run:
guix pull --commit=2c8305d -p /tmp/good
then 'display /tmp/good/share/info/images/bootstrap-graph.png'
displays nicely. However, when I run:
guix pull --commit=afc46f2 -p /tmp/bad
'display /tmp/bad/share/info/images/bootstrap-graph.png' is not nice,
as if the font is missing.
Well, I suspect it comes from something related to the recent
'core-updates'. To underline my point, I run this script:
Toggle snippet (29 lines)
SRC=/tmp/guix/
MERGE=/tmp/check/merge
LEFT=/tmp/check/left
RIGHT=/tmp/check/right
mkdir -p $MERGE
mkdir -p $LEFT
mkdir -p $RIGHT
for merge in $(git -C $SRC \
log 2c8305d..afc46f2 \
--ancestry-path --merges \
--format="%h")
do
left=$(git -C $SRC log $merge --format="%p" -n1 | cut -f1 -d' ')
right=$(git -C $SRC log $merge --format="%p" -n1 | cut -f2 -d' ')
echo $merge
guix pull --commit=$merge -p${MERGE}/$merge
echo $left
guix pull --commit=$left -p${LEFT}/$left
echo $right
guix pull --commit=$right -p${RIGHT}/$right
done
which basically pull all the commits corresponding to merges between
the "working" commit and the "broken" commit. And pull the two parent
commits too.
Based on that, all the merged commits are "broken". The image
'share/info/images/bootstrap-graph.png' displays uglily for the
commits:
4bdf4182fe
50e6c1bf2e
87a40d7203
8bf8cd9b85
c263cfdcde
f589cbc4dc
Then the "left" are all broken too, except the commit c81457a588.
All the "right" are ok, except the commit 23a59b180b.
Note that these two corresponds to the last core-updates merge:
git log 4bdf4182fe --format="%h %p %n %s" -n1
as if they were switched.
Last, I have checked the commits:
35c43fcdbb
4ba425060a
45c137e30f
7b07852ddb
2676579dc8
which are the ones just next after the core-updates merge ones and
they appear displaying ugly.
If I misunderstand or misconfigure something, please tell me and I
could correct why I am seeing good images and bad images.
Otherwise, I do not have an idea why it should come from.
Best regards,
simon