[PATCH 00/13] Update Pandoc.

  • Done
  • quality assurance status badge
Details
3 participants
  • Pierre Neidhardt
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:34
(address . guix-patches@gnu.org)
20200226113442.9798-1-mail@ambrevar.xyz
Update ghc-pandoc to 2.92 and rename it to pandoc.
This closes bug 33844.

Questions:

- Should this go on staging? It rebuilds a few hundred packages, maybe less
than 300.
- I'm not 100% sure that updating the Haskell libraries didn't break
anything. I guess the continuous integration will tell us.
- 3-4 libraries seemed to have many dependents and updating them would break
stuff, so instead I created a versioned package, e.g. ghc-regex-base-0.94.
Is this OK? Is there a best practice here?

Pierre Neidhardt (13):
gnu: ghc-hsyaml: Update to 0.2.1.0.
gnu: ghc-doctemplates: Update to 0.8.1.
gnu: Add ghc-regex-base-0.94.
gnu: ghc-regex-pcre-builtin: Update to 0.95.1.1.8.43.
gnu: ghc-skylighting-core: Update to 0.8.3.2.
gnu: ghc-skylighting: Update to 0.8.3.2.
gnu: ghc-pandoc-types: Update to 1.20.
gnu: ghc-texmath: Update to 0.12.0.1.
gnu: Add ghc-base-compat-0.11.
gnu: Add ghc-optparse-applicative-0.15.
gnu: ghc-haddock-library: Update to 1.8.0.
gnu: ghc-pandoc: Update to 2.9.2.
gnu: ghc-pandoc: Rename to pandoc.

gnu/local.mk | 2 -
gnu/packages/haskell-xyz.scm | 130 ++++++++++++------
.../patches/ghc-pandoc-fix-html-tests.patch | 92 -------------
.../patches/ghc-pandoc-fix-latex-test.patch | 31 -----
4 files changed, 89 insertions(+), 166 deletions(-)
delete mode 100644 gnu/packages/patches/ghc-pandoc-fix-html-tests.patch
delete mode 100644 gnu/packages/patches/ghc-pandoc-fix-latex-test.patch

--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 01/13] gnu: ghc-hsyaml: Update to 0.2.1.0.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-1-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-hsyaml): Update to 0.2.1.0.
---
gnu/packages/haskell-xyz.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e368082c03..03adfdb062 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5679,7 +5679,7 @@ for Haskell. The functions provided by this module are @code{upper},
(define-public ghc-hsyaml
(package
(name "ghc-hsyaml")
- (version "0.1.2.0")
+ (version "0.2.1.0")
(source
(origin
(method url-fetch)
@@ -5687,11 +5687,13 @@ for Haskell. The functions provided by this module are @code{upper},
"HsYAML/HsYAML-" version ".tar.gz"))
(sha256
(base32
- "1pajfhj16559v64ixm8j7bvxdqmxg6c3c0z3wz7in8ckswgzfp54"))))
+ "10qzhsg789h37q22hm9p27dx4rhbykcbxp7p3pvkws8fr7ajgxv0"))))
(build-system haskell-build-system)
- (arguments
- `(#:cabal-revision
- ("1" "0j6qmmcz5yqh89hs2cq453maix50q61vl2h0ahj5lg02bygn42cf")))
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://github.com/haskell-hvr/HsYAML")
(synopsis "Pure Haskell YAML 1.2 parser")
(description "This library provides a
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 02/13] gnu: ghc-doctemplates: Update to 0.8.1.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-2-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-doctemplates): Update to 0.8.1.
---
gnu/packages/haskell-xyz.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 03adfdb062..147254c6a9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3115,7 +3115,7 @@ Writer monad), where list append quickly becomes too expensive.")
(define-public ghc-doctemplates
(package
(name "ghc-doctemplates")
- (version "0.2.2.1")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
@@ -3124,17 +3124,25 @@ Writer monad), where list append quickly becomes too expensive.")
version ".tar.gz"))
(sha256
(base32
- "1gyckfg3kgvzhxw14i7iwrw0crygvsp86sy53bbr1yn7bxbgn33b"))))
+ "02xysm510m3hbifwb7ngx39wj1ycxjrws4ngnm0d7ywqm9cv1hbb"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-doclayout" ,ghc-doclayout)
+ ("ghc-glob" ,ghc-glob)
+ ("ghc-hsyaml" ,ghc-hsyaml)
("ghc-vector" ,ghc-vector)
("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-scientific" ,ghc-scientific)))
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-text-conversions" ,ghc-text-conversions)))
(native-inputs
- `(("ghc-hspec" ,ghc-hspec)))
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/jgm/doctemplates#readme")
(synopsis "Pandoc-style document templates")
(description
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 03/13] gnu: Add ghc-regex-base-0.94.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-3-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-regex-base-0.94): New variable.
---
gnu/packages/haskell-xyz.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 147254c6a9..d1e90b79d3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9453,6 +9453,21 @@ regular expressions. Parsers can be built using Applicative interface.")
regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
(license license:bsd-3)))
+(define-public ghc-regex-base-0.94
+ (package
+ (inherit ghc-regex-base)
+ (version "0.94.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/regex-base/regex-base-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "055rlq67xnbqv43fgrlw6d7s8nhyavahrp6blihwjmqizksq47y4"))))))
+
(define-public ghc-regex-compat
(package
(name "ghc-regex-compat")
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 05/13] gnu: ghc-skylighting-core: Update to 0.8.3.2.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-5-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-skylighting-core): Update to 0.8.3.2.
---
gnu/packages/haskell-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index aa915ddd98..875ea37ccc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10539,7 +10539,7 @@ enumerations.")
(define-public ghc-skylighting-core
(package
(name "ghc-skylighting-core")
- (version "0.8.2.1")
+ (version "0.8.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -10547,7 +10547,7 @@ enumerations.")
version ".tar.gz"))
(sha256
(base32
- "0hdchivb4af9w7v5v7lrwfwawd3kcwmpzk69m1vkkm3pis8lcr1s"))))
+ "04l1qcfqkvi7c4hv5nra4nl2zk5r6l6jkj95wvq466anls8x35rj"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 08/13] gnu: ghc-texmath: Update to 0.12.0.1.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-8-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-texmath): Update to 0.12.0.1.
---
gnu/packages/haskell-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 40c8b4293d..b0ea9192e3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11563,14 +11563,14 @@ dependency.")
(define-public ghc-texmath
(package
(name "ghc-texmath")
- (version "0.11.3")
+ (version "0.12.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"texmath/texmath-" version ".tar.gz"))
(sha256
(base32
- "03rpxbp43bjs62mmw4hv4785n6f6nbf8kj2y9mma5nzk6i2xs09f"))))
+ "1halp1vn2334ym3j3fxfbrpkr15nc201c7vfwmzimya6vnyknsxs"))))
(build-system haskell-build-system)
(inputs
`(("ghc-syb" ,ghc-syb)
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 06/13] gnu: ghc-skylighting: Update to 0.8.3.2.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-6-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-skylighting): Update to 0.8.3.2.
---
gnu/packages/haskell-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 875ea37ccc..b6c82322f2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10583,14 +10583,14 @@ provided. Skylighting is intended to be the successor to highlighting-kate.")
(package
(inherit ghc-skylighting-core)
(name "ghc-skylighting")
- (version "0.8.2.1")
+ (version "0.8.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/skylighting-"
version "/skylighting-" version ".tar.gz"))
(sha256
(base32
- "1xls8ycad77m55ax4hp55k60h3pi5sm3m32hycbc8baixbgfx5xz"))))
+ "03kbvz66r4fp1zq09c6arnhi2s81iwsmv8lv2kz0g7a8dr0hpaq2"))))
(inputs
`(("ghc-skylighting-core" ,ghc-skylighting-core)
,@(package-inputs ghc-skylighting-core)))))
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 10/13] gnu: Add ghc-optparse-applicative-0.15.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-10-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-optparse-applicative-0.15): New variable.
---
gnu/packages/haskell-xyz.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9e85f89248..0d766ebe75 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8191,6 +8191,21 @@ easily work with command-line options.")
command line options in Haskell.")
(license license:bsd-3)))
+(define-public ghc-optparse-applicative-0.15
+ (package
+ (inherit ghc-optparse-applicative)
+ (version "0.15.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/optparse-applicative"
+ "/optparse-applicative-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ws6y3b3f6hsgv0ff0yp6lw4hba1rps4dnvry3yllng0s5gngcsd"))))
+ (arguments '())))
+
(define-public ghc-jira-wiki-markup
(package
(name "ghc-jira-wiki-markup")
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 11/13] gnu: ghc-haddock-library: Update to 1.8.0.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-11-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-haddock-library): Update to 1.8.0.
---
gnu/packages/haskell-xyz.scm | 19 ++++---------------
1 file changed, 4 insertions(+), 15 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0d766ebe75..b80e19deef 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4841,7 +4841,7 @@ documentation-generation tool for Haskell libraries.")
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")
- (version "1.7.0")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
@@ -4851,23 +4851,12 @@ documentation-generation tool for Haskell libraries.")
".tar.gz"))
(sha256
(base32
- "04fhcjk0pvsaqvsgp2w06cv2qvshq1xs1bwc157q4lmkgr57khp7"))))
+ "15xpv29yh3kb9qq9gmws2l8m64i7phvf47y08vxc2j55101sg4vh"))))
(build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Since there is no revised Cabal file upstream, we have to
- ;; patch it manually.
- (add-before 'configure 'relax-test-suite-dependencies
- (lambda _
- (substitute* "haddock-library.cabal"
- (("hspec\\s*>= 2.4.4 && < 2.6") "hspec")
- (("QuickCheck\\s*\\^>= 2.11") "QuickCheck"))
- #t)))))
(native-inputs
- `(("ghc-base-compat" ,ghc-base-compat)
+ `(("ghc-base-compat" ,ghc-base-compat-0.11)
("ghc-hspec" ,ghc-hspec)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative-0.15)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-tree-diff" ,ghc-tree-diff)
("hspec-discover" ,hspec-discover)))
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 13/13] gnu: ghc-pandoc: Rename to pandoc.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-13-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-pandoc): Deprecate.
(pandoc): New variable.
---
gnu/packages/haskell-xyz.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d5084d6aa0..a7ba7c5fb2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8303,9 +8303,9 @@ with several features not present in pretty-printing libraries designed for
code. It was designed for use in @code{Pandoc}.")
(license license:bsd-3)))
-(define-public ghc-pandoc
+(define-public pandoc
(package
- (name "ghc-pandoc")
+ (name "pandoc")
(version "2.9.2")
(source
(origin
@@ -8381,6 +8381,9 @@ definition lists, tables, and other features. A compatibility mode is
provided for those who need a drop-in replacement for Markdown.pl.")
(license license:gpl2+)))
+(define-public ghc-pandoc
+ (deprecated-package "ghc-pandoc" pandoc))
+
(define-public ghc-pandoc-citeproc
(package
(name "ghc-pandoc-citeproc")
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:45
[PATCH 07/13] gnu: ghc-pandoc-types: Update to 1.20.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-7-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-pandoc-types): Update to 1.20.
---
gnu/packages/haskell-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b6c82322f2..40c8b4293d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8423,7 +8423,7 @@ suitable for inclusion in pandoc YAML metadata.")
(define-public ghc-pandoc-types
(package
(name "ghc-pandoc-types")
- (version "1.17.6.1")
+ (version "1.20")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -8431,7 +8431,7 @@ suitable for inclusion in pandoc YAML metadata.")
version ".tar.gz"))
(sha256
(base32
- "1d6ygq991ddria71l7hg9yd7lq94sjy4m71rdws1v8hq943c4d0q"))))
+ "0wz89ywyhvxz8daw4ia132kg6ynx5y4wva4g899wvq4kyjy1dixa"))))
(build-system haskell-build-system)
(inputs
`(("ghc-syb" ,ghc-syb)
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 09/13] gnu: Add ghc-base-compat-0.11.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-9-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-base-compat-0.11): New variable.
---
gnu/packages/haskell-xyz.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b0ea9192e3..9e85f89248 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -767,6 +767,21 @@ of base to a wider range of compilers, without requiring the use of CPP
pragmas in your code.")
(license license:bsd-3)))
+(define-public ghc-base-compat-0.11
+ (package
+ (inherit ghc-base-compat)
+ (version "0.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/base-compat/base-compat-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dkdmyxg8hfjn1zyrp4mahkr90g4y672mlvkj0m1krwkxi11avrm"))))))
+
(define-public ghc-base-compat-batteries
(package
(name "ghc-base-compat-batteries")
--
2.25.0
P
P
Pierre Neidhardt wrote on 26 Feb 2020 12:46
[PATCH 12/13] gnu: ghc-pandoc: Update to 2.9.2.
(address . 39798@debbugs.gnu.org)
20200226114605.15106-12-mail@ambrevar.xyz
* gnu/packages/haskell-xyz.scm (ghc-pandoc): Update to 2.9.2.
* gnu/local.mk: Remove obsolete ghc-pandoc patches.
* gnu/packages/patches/ghc-pandoc-fix-html-tests.patch: Remove file.
* gnu/packages/patches/ghc-pandoc-fix-latex-test.patch: Remove file.
---
gnu/local.mk | 2 -
gnu/packages/haskell-xyz.scm | 9 +-
.../patches/ghc-pandoc-fix-html-tests.patch | 92 -------------------
.../patches/ghc-pandoc-fix-latex-test.patch | 31 -------
4 files changed, 5 insertions(+), 129 deletions(-)
delete mode 100644 gnu/packages/patches/ghc-pandoc-fix-html-tests.patch
delete mode 100644 gnu/packages/patches/ghc-pandoc-fix-latex-test.patch

Toggle diff (192 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 857345cfad..edf1d18537 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -917,8 +917,6 @@ dist_patch_DATA = \
%D%/packages/patches/ghc-hpack-fix-tests.patch \
%D%/packages/patches/ghc-microlens-aeson-fix-tests.patch \
%D%/packages/patches/ghc-monad-par-fix-tests.patch \
- %D%/packages/patches/ghc-pandoc-fix-html-tests.patch \
- %D%/packages/patches/ghc-pandoc-fix-latex-test.patch \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b80e19deef..d5084d6aa0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8306,17 +8306,15 @@ code. It was designed for use in @code{Pandoc}.")
(define-public ghc-pandoc
(package
(name "ghc-pandoc")
- (version "2.7.3")
+ (version "2.9.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/pandoc/pandoc-"
version ".tar.gz"))
- (patches (search-patches "ghc-pandoc-fix-html-tests.patch"
- "ghc-pandoc-fix-latex-test.patch"))
(sha256
(base32
- "0dpjrr40h54cljzhvixyym07z792a9izg6b9dmqpjlgcg4rj0xx8"))))
+ "1f9wbwzv6c3dlsn15iydh921icjqj7kjgrb726kqmj5gmaypc39j"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
@@ -8327,7 +8325,9 @@ code. It was designed for use in @code{Pandoc}.")
("ghc-cmark-gfm" ,ghc-cmark-gfm)
("ghc-data-default" ,ghc-data-default)
("ghc-diff" ,ghc-diff)
+ ("ghc-doclayout" ,ghc-doclayout)
("ghc-doctemplates" ,ghc-doctemplates)
+ ("ghc-emojis" ,ghc-emojis)
("ghc-executable-path" ,ghc-executable-path)
("ghc-glob" ,ghc-glob)
("ghc-haddock-library" ,ghc-haddock-library)
@@ -8340,6 +8340,7 @@ code. It was designed for use in @code{Pandoc}.")
("ghc-http-client-tls" ,ghc-http-client-tls)
("ghc-http-types" ,ghc-http-types)
("ghc-ipynb" ,ghc-ipynb)
+ ("ghc-jira-wiki-markup" ,ghc-jira-wiki-markup)
("ghc-juicypixels" ,ghc-juicypixels)
("ghc-network" ,ghc-network)
("ghc-network-uri" ,ghc-network-uri)
diff --git a/gnu/packages/patches/ghc-pandoc-fix-html-tests.patch b/gnu/packages/patches/ghc-pandoc-fix-html-tests.patch
deleted file mode 100644
index b624ff9e9e..0000000000
--- a/gnu/packages/patches/ghc-pandoc-fix-html-tests.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-This patch is taken from upstream. It fixes two HTML tests that are broken
-due to using a Skylighting version greater than or equal to 0.8.2.
-
-From 968d2046a3cb6db661673be580660ac402753c34 Mon Sep 17 00:00:00 2001
-From: John MacFarlane <jgm@berkeley.edu>
-Date: Sun, 14 Jul 2019 10:48:14 -0700
-Subject: [PATCH] Update test for new skylighting.
-
----
- test/lhs-test.html | 13 ++++++-------
- test/lhs-test.html+lhs | 13 ++++++-------
- 2 files changed, 12 insertions(+), 14 deletions(-)
-
-diff --git a/test/lhs-test.html b/test/lhs-test.html
-index 6685555f4..446dd3d95 100644
---- a/test/lhs-test.html
-+++ b/test/lhs-test.html
-@@ -12,19 +12,18 @@
- div.column{display: inline-block; vertical-align: top; width: 50%;}
- </style>
- <style>
--code.sourceCode > span { display: inline-block; line-height: 1.25; }
-+pre > code.sourceCode { white-space: pre; position: relative; }
-+pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
-+pre > code.sourceCode > span:empty { height: 1.2em; }
- code.sourceCode > span { color: inherit; text-decoration: inherit; }
--code.sourceCode > span:empty { height: 1.2em; }
--.sourceCode { overflow: visible; }
--code.sourceCode { white-space: pre; position: relative; }
- div.sourceCode { margin: 1em 0; }
- pre.sourceCode { margin: 0; }
- @media screen {
- div.sourceCode { overflow: auto; }
- }
- @media print {
--code.sourceCode { white-space: pre-wrap; }
--code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
-+pre > code.sourceCode { white-space: pre-wrap; }
-+pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
- }
- pre.numberSource code
- { counter-reset: source-line 0; }
-@@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
- div.sourceCode
- { }
- @media screen {
--code.sourceCode > span > a:first-child::before { text-decoration: underline; }
-+pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
- }
- code span.al { color: #ff0000; font-weight: bold; } /* Alert */
- code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
-diff --git a/test/lhs-test.html+lhs b/test/lhs-test.html+lhs
-index e57dfc105..a5cdb0245 100644
---- a/test/lhs-test.html+lhs
-+++ b/test/lhs-test.html+lhs
-@@ -12,19 +12,18 @@
- div.column{display: inline-block; vertical-align: top; width: 50%;}
- </style>
- <style>
--code.sourceCode > span { display: inline-block; line-height: 1.25; }
-+pre > code.sourceCode { white-space: pre; position: relative; }
-+pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
-+pre > code.sourceCode > span:empty { height: 1.2em; }
- code.sourceCode > span { color: inherit; text-decoration: inherit; }
--code.sourceCode > span:empty { height: 1.2em; }
--.sourceCode { overflow: visible; }
--code.sourceCode { white-space: pre; position: relative; }
- div.sourceCode { margin: 1em 0; }
- pre.sourceCode { margin: 0; }
- @media screen {
- div.sourceCode { overflow: auto; }
- }
- @media print {
--code.sourceCode { white-space: pre-wrap; }
--code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
-+pre > code.sourceCode { white-space: pre-wrap; }
-+pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
- }
- pre.numberSource code
- { counter-reset: source-line 0; }
-@@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
- div.sourceCode
- { }
- @media screen {
--code.sourceCode > span > a:first-child::before { text-decoration: underline; }
-+pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
- }
- code span.al { color: #ff0000; font-weight: bold; } /* Alert */
- code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
---
-2.23.0
-
diff --git a/gnu/packages/patches/ghc-pandoc-fix-latex-test.patch b/gnu/packages/patches/ghc-pandoc-fix-latex-test.patch
deleted file mode 100644
index b38476882d..0000000000
--- a/gnu/packages/patches/ghc-pandoc-fix-latex-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-This patch is taken from upstream. It fixes a LaTeX test that is broken due
-to using a Skylighting version greater than or equal to 0.8.1.1.
-
-From 2cd1c7b30f200d18f1f1bdef1671369e1ad303ed Mon Sep 17 00:00:00 2001
-From: John MacFarlane <jgm@berkeley.edu>
-Date: Thu, 13 Jun 2019 19:33:52 -0700
-Subject: [PATCH] Update test for skylighting 0.8.1.1.
-
----
- test/lhs-test.latex | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/test/lhs-test.latex b/test/lhs-test.latex
-index 0442db5ca..a456995a3 100644
---- a/test/lhs-test.latex
-+++ b/test/lhs-test.latex
-@@ -94,9 +94,9 @@ return a single value:
-
- \begin{Shaded}
- \begin{Highlighting}[]
--\OtherTok{unsplit ::}\NormalTok{ (}\DataTypeTok{Arrow}\NormalTok{ a) }\OtherTok{=>}\NormalTok{ (b }\OtherTok{->}\NormalTok{ c }\OtherTok{->}\NormalTok{ d) }\OtherTok{->}\NormalTok{ a (b, c) d}
-+\OtherTok{unsplit ::}\NormalTok{ (}\DataTypeTok{Arrow}\NormalTok{ a) }\OtherTok{=>}\NormalTok{ (b }\OtherTok{{-}>}\NormalTok{ c }\OtherTok{{-}>}\NormalTok{ d) }\OtherTok{{-}>}\NormalTok{ a (b, c) d}
- \NormalTok{unsplit }\OtherTok{=}\NormalTok{ arr }\OperatorTok{.} \FunctionTok{uncurry}
-- \CommentTok{-- arr (\textbackslash{}op (x,y) -> x `op` y)}
-+ \CommentTok{{-}{-} arr (\textbackslash{}op (x,y) {-}> x \textasciigrave{}op\textasciigrave{} y)}
- \end{Highlighting}
- \end{Shaded}
-
---
-2.23.0
-
--
2.25.0
R
R
Ricardo Wurmus wrote on 26 Feb 2020 19:04
Re: [bug#39798] [PATCH 00/13] Update Pandoc.
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 39798@debbugs.gnu.org)
87r1yhi5t6.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (13 lines)
> Update ghc-pandoc to 2.92 and rename it to pandoc.
> This closes bug 33844.
>
> Questions:
>
> - Should this go on staging? It rebuilds a few hundred packages, maybe less
> than 300.
> - I'm not 100% sure that updating the Haskell libraries didn't break
> anything. I guess the continuous integration will tell us.
> - 3-4 libraries seemed to have many dependents and updating them would break
> stuff, so instead I created a versioned package, e.g. ghc-regex-base-0.94.
> Is this OK? Is there a best practice here?

I would prefer to untangle upgrading any packages from renaming
ghc-pandoc to pandoc.

Haskell package upgrades need to be consistent according to the current
LTS. We can’t just upgrade some Haskell packages without upgrading them
all. They also cannot be upgraded to the latest version as that may be
higher than the LTS version.

--
Ricardo
P
P
Pierre Neidhardt wrote on 27 Feb 2020 08:51
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 39798@debbugs.gnu.org)
87d0a08o34.fsf@ambrevar.xyz
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (11 lines)
>> - Should this go on staging? It rebuilds a few hundred packages, maybe less
>> than 300.
>> - I'm not 100% sure that updating the Haskell libraries didn't break
>> anything. I guess the continuous integration will tell us.
>> - 3-4 libraries seemed to have many dependents and updating them would break
>> stuff, so instead I created a versioned package, e.g. ghc-regex-base-0.94.
>> Is this OK? Is there a best practice here?
>
> I would prefer to untangle upgrading any packages from renaming
> ghc-pandoc to pandoc.

No problem.

Toggle quote (5 lines)
> Haskell package upgrades need to be consistent according to the current
> LTS. We can’t just upgrade some Haskell packages without upgrading them
> all. They also cannot be upgraded to the latest version as that may be
> higher than the LTS version.

I'm new to Haskell packaging. Where do I find the LTS versions?
Can we update pandoc then?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl5XdQ8ACgkQm9z0l6S7
zH/b/Af/ULvH8/7qQKoP6lfjI3S30Dc7tn9DWBLk0eGhw1tHhCtrpeyQrTsD1dTJ
EE2UISo6cDgIEmJd8iKo2dnw7c2H9CJ5BNRrfaI4wftK4E1xMxVqycGTu+RRsHYj
SSCxzK37S/blEDxg3r+CSlbKxIfIurmBSB4mivAgYJsOzfJYdQfhAVJQcUfxh9mF
wNanV4I9gD2N12ymYiDSGYi6D+j1XoDmjrZCE+5l1pxZ5St3A2BohxgROPXrjjTn
M4dGh6HqDI4zc6kmuf8MyDUBUkzLzWYk8arM7BwY+giEpe14HqM7Y5KOK3moHgDf
AUFMDPOJGnfAYZOzv0e1lYyCA5IayA==
=GGTN
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 2 Mar 2020 09:45
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
CAJ3okZ3p+JWyZEhTdJRGBPeWWOKwcYX5wdP0pS7UAHK-+30FUA@mail.gmail.com
Hi Pierre,

On Thu, 27 Feb 2020 at 08:52, Pierre Neidhardt <mail@ambrevar.xyz> wrote:
Toggle quote (10 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:

> > Haskell package upgrades need to be consistent according to the current
> > LTS. We can’t just upgrade some Haskell packages without upgrading them
> > all. They also cannot be upgraded to the latest version as that may be
> > higher than the LTS version.
>
> I'm new to Haskell packaging. Where do I find the LTS versions?
> Can we update pandoc then?

I am not closely following the Haskell packaging in Guix, but you
should find the LTS versions there:
It is better to upgrade all the Haskell packages (compiler included)
to stay compliant with the LTS, otherwise it should become a mess
falling in the Cabal Hell.



Hope that helps.
simon
P
P
Pierre Neidhardt wrote on 2 Mar 2020 09:56
(name . zimoun)(address . zimon.toutoune@gmail.com)
87tv372kzt.fsf@ambrevar.xyz
Makes sense, thanks!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl5cyjYACgkQm9z0l6S7
zH/8kgf8CPf68J7DzUZUi+mVSVdxXLNxvHHPkhjnZNtuKTH1WpBAjPjsqXG+l0Cp
T5NYgyYDYSh4S/Srzdhp7Ku1xxkpGbJufiz/UldJeyH9fW4w8hyp9VAJENEChgtq
rH9WNV0Egnm/8QXfVdzemZ0RnjP7ErQ+e7JasxQEBLQl4UCY4/QRoRqomEvbCAtQ
9YAFBRJK3l+Flsuxa9OZQNTDyqpy8k+YIw1FgwnhzryutoQqCSV+3Py/JmVgIRb3
H8MPL4L/l2GnNozJk6tZwHSlg0vMZjsosNOmtuEiP2mr2IzJwUduj9R5YWQasR7S
td1ZF40OhNb4uQ9FklwBF2mwq33zZg==
=Cg0H
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 27 May 2020 16:24
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 39798@debbugs.gnu.org)
87wo4xihfs.fsf@elephly.net
Hi Pierre,

Toggle quote (3 lines)
> Update ghc-pandoc to 2.92 and rename it to pandoc.
> This closes bug 33844.

We have a stackage importer that can help here. We should update to the
latest LTS Haskell release of 15.14.

The version of Pandoc in that LTS Haskell release is 2.9.1.1.

We will also need a new GHC (8.8.3), and all other Haskell packages need
to upgraded together.

This could then go to a new branch that we can have ci.guix.gnu.org
build for us.

I’m about to finish a few changes to the haskell-build-system and our
current GHC package to reduce the closure size; that could also go to
the same branch.

Would you like to help with the update or should we close this issue?

--
Ricardo
P
P
Pierre Neidhardt wrote on 27 May 2020 16:38
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 39798@debbugs.gnu.org)
87o8q9cuja.fsf@ambrevar.xyz
Hi Ricardo,

Thanks for the update, looks great!

I originally sent this patch because I needed pandoc 2.9.* at some
point, but I no longer use it (at least for now) and I'm no Haskeller so
my motivation is a bit low to be honest :D

If no one else gets to it, I may give this a shot in a while (don't hold
your breat) :p

I suggest you let know guix-devel, hopefully someone will chime in!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl7Oe2kACgkQm9z0l6S7
zH/AgwgAj/H5/HIBlQyfe8iiaGTU9pj9w7eo3hqjOUS/Q2K6zUkS8OloNQUl8uRU
v/Cn0jfevTvKoiXWL+V4e+to5U+sQEeuM2ySv39JK12do5ItBvlqQLPRDN2bYs9+
sMOnX/SLtJMSFTsWIIWdJ/xbHhjpjD4d8Zds8BTQKc+skEYoclI3o2lvC9rqhCxI
TYupSUZZ4Y1yqeq6Tc9OWmMOR7FTF/GpJ6iUuaAMycN3yhtxokpyBfqQXd5tipbc
1xlFDdmR+2p6h+ReuaHeL4UZoS3TzHGXYpjS0HAqbeaehIWkrtUZlsTFsA0lYkgj
CLHrNnquRj8ruczCnx/84dUuHWGcTg==
=Q4DE
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 9 Sep 2020 18:39
(address . 39798@debbugs.gnu.org)
87y2liuco8.fsf@gmail.com
Dear,

On Wed, 26 Feb 2020 at 12:34, Pierre Neidhardt <mail@ambrevar.xyz> wrote:

Toggle quote (2 lines)
> Update ghc-pandoc to 2.92 and rename it to pandoc.

Does this patch set [1] still make sense?
Especially after the merge [2] of wip-haskell and since the patches are
not consistent with LTS, AFAICT.

Toggle quote (2 lines)
> This closes bug 33844.

Almost close by commit d4e4a3824d380e576b56a74aa714db205fcc59a4.



All the best,
simon
R
R
Ricardo Wurmus wrote on 9 Sep 2020 19:02
(name . zimoun)(address . zimon.toutoune@gmail.com)
87sgbq6fzi.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:
Toggle quote (9 lines)
>
> On Wed, 26 Feb 2020 at 12:34, Pierre Neidhardt <mail@ambrevar.xyz> wrote:
>
>> Update ghc-pandoc to 2.92 and rename it to pandoc.
>
> Does this patch set [1] still make sense?
> Especially after the merge [2] of wip-haskell and since the patches are
> not consistent with LTS, AFAICT.

The lack of consistency is the biggest problem. Since Pierre has no
motivation to continue working on these patches I’d say we should close
this issue.

--
Ricardo
Z
Z
zimoun wrote on 14 Sep 2020 19:49
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87d02oqmdq.fsf@gmail.com
Dear,

Toggle quote (2 lines)
>>> Update ghc-pandoc to 2.92 and rename it to pandoc.

Commit d4e4a3824d380e576b56a74aa714db205fcc59a4 adds the package
pandoc. Then couples of commits rename all the dependencies.

Moreover, updating to 2.92 without consistency with Haskell LTS packages
is a problem.

Therefore, I am closing. Feel free to reopen if there is motivation to
continue working on these patches.

All the best,
simon
Z
Closed
?