gnu: Add chatty.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Jonathan Brielmaier
  • Jakub K?dzio?ka
  • Leo Famulari
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 27 Jan 2020 19:25
(address . guix-patches@gnu.org)
77f67f99-44e6-6464-cf96-62eec29493d6@web.de
Hi,

attached is a patch for Chatty. A GUI program for SMS and XMPP optimized
for mobile interfaces. XMPP works nicely already. SMS not yet: I have
the required package "purple-mm-sms" already in my local git, but
couldn't test it yet, because I lack the hardware. I'll submit it
separately as soon it's ready and tested :)

~Jonathan
From d746b3b01acdec8a4ce6a508a063f951dd9e74f6 Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Mon, 27 Jan 2020 19:10:10 +0100
Subject: [PATCH] gnu: Add chatty.

* gnu/packages/messaging.scm (chatty): New variable.
---
gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 839f718134..e66d10b0e9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -1995,4 +1997,40 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))

+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+ ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("folks" ,folks)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("pkg-config" ,pkg-config)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.25.0
J
J
Jonathan Brielmaier wrote on 31 Jan 2020 17:04
Re: [bug#39312] gnu: Add chatty.[v2]
(address . 39312@debbugs.gnu.org)
a2485300-0a7b-0f10-2c6e-5118421871cb@web.de
This time patch v2 without purple-mm-sms, as it's not included yet.

On 27.01.20 19:25, Jonathan Brielmaier wrote:
Toggle quote (9 lines)
> Hi,
>
> attached is a patch for Chatty. A GUI program for SMS and XMPP optimized
> for mobile interfaces. XMPP works nicely already. SMS not yet: I have
> the required package "purple-mm-sms" already in my local git, but
> couldn't test it yet, because I lack the hardware. I'll submit it
> separately as soon it's ready and tested :)
>
> ~Jonathan
From 87e4b48eae543d53c7d80bf031dd93671186e45f Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Thu, 23 Jan 2020 21:32:39 +0100
Subject: [PATCH] gnu: Add chatty.

* gnu/packages/messaging.scm (chatty): New variable.
---
gnu/packages/messaging.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5754c7ce08..1dba50d55c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2041,4 +2041,39 @@ support for high performance Telegram Bot creation.")
(home-page "https://source.puri.sm/Librem5/purple-mm-sms")
(license license:gpl2+)))

+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("folks" ,folks)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("pkg-config" ,pkg-config)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.24.1
L
L
Leo Famulari wrote on 2 Feb 2020 20:37
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 39312@debbugs.gnu.org)
20200202193736.GA24535@jasmine.lan
On Fri, Jan 31, 2020 at 05:04:52PM +0100, Jonathan Brielmaier wrote:
Toggle quote (2 lines)
> This time patch v2 without purple-mm-sms, as it's not included yet.

Okay!

Toggle quote (20 lines)
> From 87e4b48eae543d53c7d80bf031dd93671186e45f Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Thu, 23 Jan 2020 21:32:39 +0100
> Subject: [PATCH] gnu: Add chatty.
>
> * gnu/packages/messaging.scm (chatty): New variable.
> ---
> gnu/packages/messaging.scm | 35 +++++++++++++++++++++++++++++++++++
> 1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 5754c7ce08..1dba50d55c 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -2041,4 +2041,39 @@ support for high performance Telegram Bot creation.")
> (home-page "https://source.puri.sm/Librem5/purple-mm-sms")
> (license license:gpl2+)))
>
> +(define-public chatty

Except that it's still part of the context of this patch (the first two
lines) and so the patch doesn't apply. Can you send a v3?
J
J
jonathan.brielmaier wrote on 3 Feb 2020 11:55
[PATCH] gnu: Add chatty.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200203105506.17445-1-jonathan.brielmaier@web.de
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>

* gnu/packages/messaging.scm (chatty): New variable.
---
gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 839f718134..0a45711ee6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -1995,4 +1997,39 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))

+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+ ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("folks" ,folks)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("pkg-config" ,pkg-config)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.25.0
J
J
Jakub K?dzio?ka wrote on 15 Feb 2020 14:17
(address . jonathan.brielmaier@web.de)(address . 39312@debbugs.gnu.org)
20200215131725.2zireckx3qkxymwv@gravity
On Mon, Feb 03, 2020 at 11:55:06AM +0100, jonathan.brielmaier@web.de wrote:
Toggle quote (7 lines)
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
>
> * gnu/packages/messaging.scm (chatty): New variable.
> ---
> gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)

Hi, I installed the package into my user profile, and all the icons had
the "image not found" icon. After I installed adwaita-icon-theme
separately, the icons showed up properly. Maybe you need
adwaita-icon-theme in the propagated-inputs? But, if so, I'm confused as
to why hicolor-icon-theme is being propagated. Maybe both are needed,
but that seems weird.

Toggle quote (13 lines)
> + (native-inputs
> + `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
> + ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
> + ("folks" ,folks)
> + ("gettext" ,gettext-minimal)
> + ("glib:bin" ,glib "bin")
> + ("gtk+:bin" ,gtk+ "bin")
> + ("libgcrypt" ,libgcrypt)
> + ("libgee" ,libgee)
> + ("libhandy" ,libhandy)
> + ("pidgin" ,pidgin)
> + ("pkg-config" ,pkg-config)
> + ("sqlite" ,sqlite)))
Most of these should not be in native-inputs, but normal inputs.
See '(guix)package Reference':

| The distinction between ‘native-inputs’ and ‘inputs’ is
| necessary when considering cross-compilation. When
| cross-compiling, dependencies listed in ‘inputs’ are built for
| the _target_ architecture; conversely, dependencies listed in
| ‘native-inputs’ are built for the architecture of the _build_
| machine.
|
| ‘native-inputs’ is typically used to list tools needed at
| build time, but not at run time, such as Autoconf, Automake,
| pkg-config, Gettext, or Bison.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5H72QACgkQ4xWnWEYT
FWQSNA//SClZ0VyUiX0mItSa5Cbks8dlMmpgrzgOTUKvLx5d3k5ejfpD/qz/wunY
czJt90g4nVhkSRQfC7YA5oickNjXPlqnrS8aC8m0NMZvK4Bmetwb/Lt8LlEXL6aY
we5FueKYdX+Fwi4vAnKyGvuHz/EriwIUYcCo696IL1kUT666Olzu4f1OyXEEypgO
AQx/Hf0Ioq+RrAuECBTiVPDa1fvjZ6AikOkAEjXH9CFfViuwICE82IYvDD72u08k
bL9X0sRZ4it9TM4pFKPSXsfjiKPnvUAHftvY0dwmavO88S/Y2+yxM5cPLpflEJPv
MTazipjo31gXSccI8qCTUB7iezt1QfkfvrszrEW2LUdL0CFIfw9inqAckhYdRVTn
Vc8PZtUQto2QodoAwgvrN7+NYXcVt6CB/MRb+3C5RKRqbRfHuq1lxZtlVDk8SKbP
P0kVzBLBL2hpid031zI1OBmzBdKKNubisv7+89p4+vjzFalsPxoYwwOdVA6kl68J
DDrYhU96eOZnH3mgtnnJpl3BAvmuIlQcen3bjSyfLCcbicewMue9EhHI4Y9vLf7q
A5vWfPH3RWM5WDUJUU5xIBm8ENoq70eyY5nGXy+UkGQcG9i/WBlsxlG3daJLALvB
ECjtiFIhSk99kUMRRMbbJgIqJ3nLpUutyqf805uizdWf0uNevpM=
=+ybR
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 24 Mar 2020 16:48
(address . 39312@debbugs.gnu.org)
20200324154839.udf7l76nhgdvyoyg@gravity
tags 39312 moreinfo
thanks

Hi there,

what is the status of this patch? Could you fix the issues mentioned in
[0] and send an updated patch, or is that something you don't feel like
pursuing?

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl56K9cACgkQ4xWnWEYT
FWRUzQ/+IjSIMjobWt+eFOKqwSaaaokrSZ++ONPQAQKl5IldLtf3NbHtnWIwH+9O
+EY8q3+8N36ImP54ktfuJoklWngdA0bZpnUpKIBBG9wzgTES92aE67znwoheNtNR
mFZAqTnUBdjtDDxVa/LxR/6LF1FNMVe8vSShJ42eQmH2dOeVQ9AOb+7WU+bR2A+E
N4M6C468mwvsnJ6mpsul9OgDmBoO2HxamPMziL5VFazfr+xNt8yzNpcMfNFambok
I1xvijr0tZQA8xiidLdQw3Q+pXrVUdNlRIGHN5pFp+fItZOdpgS/SpM+wKatdo8h
P5OytHX/cjbXNdQSooOukru541Bd48yOz/6DW7T1HFr7suPhQIZA/ldR2jVavoni
SusRkrH0CS5/iBv+usWhUAiYLOAKsDVRIIW6jxdmL9K9ExAoPEgF/q8YUdWk4jvf
Ygc/CQeKxbT/9M4bACOaQDnao9wXJXOj/esHUkWXPc0Xoiw0OSFeaooHUym1INfz
3XzebGKb9sGZtJ56/3rzSoP+fpzl3S54XzCW0B/V3y3PBoV6y/MLOsPfcllUuv4Z
bgBtJrSV4nFbcWZUK5KDPw5VoXRlFYcjQe25fesHkIl8fklWIEJaQQCOX+sAcohd
/REgG/h4WSdCJmWIXK1BtsLfnFVQBq1/ZYSmQ+B3v3dVw64WGPw=
=Zmvr
-----END PGP SIGNATURE-----


J
J
Jonathan Brielmaier wrote on 24 Mar 2020 18:40
(address . control@debbugs.gnu.org)
6f414220-0e2d-68b2-20a9-3eda94509cde@web.de
Hi Jakub,

thanks for the heads up. I continued some work but in the mean-time
chatty got a new dependency which has still failing tests. I'll post a
new patch series in the coming days...

All in all, this patch suite is not really urgent :P

On 24.03.20 16:48, Jakub K?dzio?ka wrote:
Toggle quote (11 lines)
> tags 39312 moreinfo
> thanks
>
> Hi there,
>
> what is the status of this patch? Could you fix the issues mentioned in
> [0] and send an updated patch, or is that something you don't feel like
> pursuing?
>
> [0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=39312#17
>
J
J
Jonathan Brielmaier wrote on 13 Apr 2020 19:25
[PATCH 0/3] [v2] Add chatty.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200413172508.13532-1-jonathan.brielmaier@web.de
Hi Jakub,

I finally got the new dependency (feedbackd) building.

The status of the patch series:
* compared to the previous version I moved several inputs around
* chatty runs and XMPP functionality is fine, SMS is still unknown as I
don't have a proper device for testing
* feedbackd builds but I don't know if its really working for the same
reason as above
* feedbackd could maybe go to another module, but audio.scm doesn't
really fit as it also provides haptic feedback...

All in all I think it should be in a state to be merged into master.
Further improvements can be done in master. Should be easier.

Jonathan Brielmaier (3):
gnu: Add feedbackd.
gnu: Add purple-mm-sms.
gnu: Add chatty.

gnu/packages/gnome.scm | 36 +++++++++++++++++-
gnu/packages/messaging.scm | 76 ++++++++++++++++++++++++++++++++++++++
2 files changed, 111 insertions(+), 1 deletion(-)

--
2.26.0
J
J
Jonathan Brielmaier wrote on 13 Apr 2020 19:25
[PATCH 1/3] gnu: Add feedbackd.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200413172508.13532-2-jonathan.brielmaier@web.de
* gnu/packages/gnome.scm (feedbackd): New variable.
---
gnu/packages/gnome.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 820811f8fa..a2d77700e7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -10042,3 +10042,37 @@ communicating using the GVariant serialization format instead of JSON when
both peers support it. You might want that when communicating on a single
host to avoid parser overhead and memory-allocator fragmentation.")
(license license:lgpl2.1+)))
+
+(define-public feedbackd
+ (package
+ (name "feedbackd")
+ (version "0.0.0+git20200304")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/feedbackd.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a1pg3gckcdfd0scpv7pi4pp8i4fcikdy2nqj5fv1nfmhnzlhq3q"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("dbus" ,dbus)
+ ("gsound" ,gsound)
+ ("json-glib" ,json-glib)
+ ("libgudev" ,libgudev)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; in Requires of libfeedback-0.0.pc
+ (synopsis "Haptic/visual/audio feedback via DBus")
+ (description "Feedbackd provides a DBus daemon to act on events to provide
+haptic, visual and audio feedback. It offers the libfeedbackd library and
+GObject introspection bindings.")
+ (home-page "https://source.puri.sm/Librem5/feedbackd")
+ (license (list license:lgpl2.1+ ; libfeedbackd
+ license:lgpl3+)))) ; the rest
--
2.26.0
J
J
Jonathan Brielmaier wrote on 13 Apr 2020 19:25
[PATCH 2/3] gnu: Add purple-mm-sms.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200413172508.13532-3-jonathan.brielmaier@web.de
* gnu/packages/messaging.scm (purple-mm-sms): New variable.
---
gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c6217a95de..98b8fb2637 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -2108,4 +2110,40 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))

+(define-public purple-mm-sms
+ (package
+ (name "purple-mm-sms")
+ (version "0.1.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/purple-mm-sms.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1daf7zl8bhhm1szkgxflpqql69f2w9i9nlgf1n4p1nynxifz1bim"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ ;; Fix hardcoded paths
+ (list (string-append "DESTDIR=" out)
+ (string-append "PLUGIN_DIR_PURPLE=" out "/lib/purple-2")
+ (string-append "DATA_ROOT_DIR_PURPLE=" out "/usr/share")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)))) ; no tests
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("modem-manager" ,modem-manager)
+ ("pidgin" ,pidgin)))
+ (synopsis "Libpurple plugin for SMS via ModemManager")
+ (description "Plugin for libpurple to allow sending SMS using ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/purple-mm-sms")
+ (license license:gpl2+)))
+
;;; messaging.scm ends here
--
2.26.0
J
J
Jonathan Brielmaier wrote on 13 Apr 2020 19:25
[PATCH 3/3] gnu: Add chatty.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200413172508.13532-4-jonathan.brielmaier@web.de
* gnu/packages/messaging.scm (chatty): New variable.
---
gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 98b8fb2637..075d69ed81 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2146,4 +2146,42 @@ support for high performance Telegram Bot creation.")
(home-page "https://source.puri.sm/Librem5/purple-mm-sms")
(license license:gpl2+)))

+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18cjm24sj3sm9n2888id9dmzqn3fp5yrwvfkxfbjmvhvv1hyckj8"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("feedbackd" ,feedbackd)
+ ("folks" ,folks)
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.26.0
J
J
Jonathan Brielmaier wrote on 22 Apr 2020 17:08
(address . 39312@debbugs.gnu.org)
560281ad-d4ce-814c-3099-985a2aaa7417@web.de
Ping...
J
J
Jonathan Brielmaier wrote on 11 May 2020 18:16
[v3 PATCH 0/3] Add chatty
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200511161653.22046-1-jonathan.brielmaier@web.de
Changes compared to v2:
* rebased on current master
* updated feedbackd to most current release
* updated chatty to 1.10.0 and propagated evolution-data-service as it otherwise would not start

Jonathan Brielmaier (3):
gnu: Add feedbackd.
gnu: Add purple-mm-sms.
gnu: Add chatty.

gnu/packages/gnome.scm | 36 +++++++++++++++++-
gnu/packages/messaging.scm | 76 ++++++++++++++++++++++++++++++++++++++
2 files changed, 111 insertions(+), 1 deletion(-)

--
2.26.2
J
J
Jonathan Brielmaier wrote on 11 May 2020 18:16
[PATCH 1/3] gnu: Add feedbackd.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200511161653.22046-2-jonathan.brielmaier@web.de
* gnu/packages/gnome.scm (feedbackd): New variable.
---
gnu/packages/gnome.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5a2032ccf..f99a41adae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -10216,3 +10216,37 @@ communicating using the GVariant serialization format instead of JSON when
both peers support it. You might want that when communicating on a single
host to avoid parser overhead and memory-allocator fragmentation.")
(license license:lgpl2.1+)))
+
+(define-public feedbackd
+ (package
+ (name "feedbackd")
+ (version "0.0.0+git20200420")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/feedbackd.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0glzc284wbvwvax52lp6sqr4whhpbqrkn8isidlqz1yrag3phfv9"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("dbus" ,dbus)
+ ("gsound" ,gsound)
+ ("json-glib" ,json-glib)
+ ("libgudev" ,libgudev)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; in Requires of libfeedback-0.0.pc
+ (synopsis "Haptic/visual/audio feedback via DBus")
+ (description "Feedbackd provides a DBus daemon to act on events to provide
+haptic, visual and audio feedback. It offers the libfeedbackd library and
+GObject introspection bindings.")
+ (home-page "https://source.puri.sm/Librem5/feedbackd")
+ (license (list license:lgpl2.1+ ; libfeedbackd
+ license:lgpl3+)))) ; the rest
--
2.26.2
J
J
Jonathan Brielmaier wrote on 11 May 2020 18:16
[PATCH 2/3] gnu: Add purple-mm-sms.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200511161653.22046-3-jonathan.brielmaier@web.de
* gnu/packages/messaging.scm (purple-mm-sms): New variable.
---
gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 46242f20e9..25bd239d8f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,6 +60,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -2160,4 +2162,40 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))

+(define-public purple-mm-sms
+ (package
+ (name "purple-mm-sms")
+ (version "0.1.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/purple-mm-sms.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1daf7zl8bhhm1szkgxflpqql69f2w9i9nlgf1n4p1nynxifz1bim"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ ;; Fix hardcoded paths
+ (list (string-append "DESTDIR=" out)
+ (string-append "PLUGIN_DIR_PURPLE=" out "/lib/purple-2")
+ (string-append "DATA_ROOT_DIR_PURPLE=" out "/usr/share")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)))) ; no tests
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("modem-manager" ,modem-manager)
+ ("pidgin" ,pidgin)))
+ (synopsis "Libpurple plugin for SMS via ModemManager")
+ (description "Plugin for libpurple to allow sending SMS using ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/purple-mm-sms")
+ (license license:gpl2+)))
+
;;; messaging.scm ends here
--
2.26.2
J
J
Jonathan Brielmaier wrote on 11 May 2020 18:16
[PATCH 3/3] gnu: Add chatty.
(address . 39312@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200511161653.22046-4-jonathan.brielmaier@web.de
* gnu/packages/messaging.scm (chatty): New variable.
---
gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 25bd239d8f..331287fc04 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2198,4 +2198,42 @@ support for high performance Telegram Bot creation.")
(home-page "https://source.puri.sm/Librem5/purple-mm-sms")
(license license:gpl2+)))

+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0czvqwjzsb0rvmgrmbh97m1b35rnwl41j7q32z4fcqb7bschibql"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("feedbackd" ,feedbackd)
+ ("folks" ,folks)
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("purple-mm-sms" ,purple-mm-sms)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("evolution-data-server" ,evolution-data-server)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.26.2
J
J
Jonathan Brielmaier wrote on 15 May 2020 10:36
gnu: Add chatty.
(address . control@debbugs.gnu.org)
d328c3d2-5878-5966-42d8-55e63c7f3a76@web.de
tags 39312 - moreinfo

Infos are in.
E
E
Efraim Flashner wrote on 16 Jun 2020 22:57
Re: [bug#39312] [v3 PATCH 0/3] Add chatty
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 39312-done@debbugs.gnu.org)
20200616205735.GK1990@E5400
On Mon, May 11, 2020 at 06:16:50PM +0200, Jonathan Brielmaier wrote:
Toggle quote (15 lines)
> Changes compared to v2:
> * rebased on current master
> * updated feedbackd to most current release
> * updated chatty to 1.10.0 and propagated evolution-data-service as it otherwise would not start
>
> Jonathan Brielmaier (3):
> gnu: Add feedbackd.
> gnu: Add purple-mm-sms.
> gnu: Add chatty.
>
> gnu/packages/gnome.scm | 36 +++++++++++++++++-
> gnu/packages/messaging.scm | 76 ++++++++++++++++++++++++++++++++++++++
> 2 files changed, 111 insertions(+), 1 deletion(-)
>

Patches pushed with some minor changes.
feedbackd: Bumped it to 0.0.0+git20200527
purple-mm-sms: replaced (delete 'tests) with #:tests? #f. Also changed
the output directories in the make-flags
chatty: Tried to skip the post-install update-desktop-database phase
and remove the extra native-inputs but was only partly successful.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7pMj8ACgkQQarn3Mo9
g1H3oQ/+I1CwSre6z+MLBj6PcGOMKCpNVWI2LHW7gzbGc9kvdHW0/8E2zuVy7VQg
MYy33wmA6gJZLPjsK9pQr+1I+4ism4WIpros24EaV8IOCkPwtM+dmU0N5CtJZtXZ
+b/E0slkvKaIBwhvbjynPGpQORk6Qh45q2pZsh8xC6nYC/RW7bvK192dgRsXPa7e
3kcpytTYWcLulcK4EAmUTilXly2slQKJRCXiYzxJze3CTIhNmV9hV+7rEAxMInYR
NNysMMS8jGvx5tBErx5f2uGK1sbPjgF/+gEplEJLpDxb/XhdOi/R6WZ0otbg6wlt
ArhRWQIlThz/E0TEJzuEicUNNZFOCnRpr1BDLcr+b+utVWK532x50Cr7wKnuTkEA
o11CsqA1PJ9qDfBCCOvWc/RmwvrsjhOyfqLwZlg2Yn2LcLwfuafCJxf5Zy062feI
yDXFv4ES3NNQrYEheQAnst24tmLtejNVmAoP3MnrVw9M/lVUqM9GuHP4fmUWt2p3
BJyS+y1cErl9wpQjmN9cgqpL1OM2DeOkeZDJQA5gIirpXo3J3iH3W6i0v6o421wo
EW8FHm7qxbtAdW91xJPiFlPPhp92+bO0o34924jQ/j4214AxlG0dGFlvBWHoJbNu
bMKd5q4T5mJ/+Hs4otYqH2v9tw4u1hXqnpmOfxAbbnUBl4Vrnoc=
=1vcH
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 39312@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39312
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch