(address . bug-gnu-emacs@gnu.org)
The issue only happen wen running Emacs without graphics (i.e. inside
terminal)
emacs -Q -nw --eval="(require 'table)"
;; Notice the option '-nw'
;; Insert following text in *scratch* buffer:
+-------------------------------+----------------------------------+
|`table-insert' |Insert a table consisting of grid |
| |of cells by specifying the number |
| |of COLUMNS, number of ROWS, cell |
| |WIDTH and cell HEIGHT. |
+-------------------------------+----------------------------------+
|`table-insert-row' |Insert row(s) of cells before the |
| |current row that matches the |
| |current row structure. |
+-------------------------------+----------------------------------+
|`table-insert-column' |Insert column(s) of cells before |
| |the current column that matches |
| |the current column structure. |
+-------------------------------+----------------------------------+
M-x table-recognize RET
;; Shift + TAB shows error:
;; <backtab> is undefined
;; When running Emacs with graphics the binding already exists.
In GNU Emacs 25.0.93.9 (x86_64-pc-linux-gnu, GTK+ Version 2.24.30)
of 2016-05-05 built on calancha-pc
Repository revision: 1a4127dbd625ea64f535b3bd09844a99161290a6
Windowing system distributor 'The X.Org Foundation', version 11.0.11803000
System Description: Debian GNU/Linux unstable (sid)
;; Suggested patch:
Toggle diff (12 lines)
diff --git a/lisp/textmodes/table.el b/lisp/textmodes/table.el
index 653db83..49411f4 100644
--- a/lisp/textmodes/table.el
+++ b/lisp/textmodes/table.el
@@ -936,6 +936,7 @@ table-cell-bindings
([(shift backtab)] . table-backward-cell) ; for HPUX console keyboard
([(shift iso-lefttab)] . table-backward-cell) ; shift-tab on a microsoft natural keyboard and redhat linux
([(shift tab)] . table-backward-cell)
+ ([backtab] . table-backward-cell) ; for terminals (e.g. xterm)
([return] . *table--cell-newline)
([(control m)] . *table--cell-newline)
([(control j)] . *table--cell-newline-and-indent)