[PATCH] gnu: bx: New variable.

  • Done
  • quality assurance status badge
Details
One participant
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 19 Apr 11:14 +0200
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
8122f04004dbd1ad197642942533c6a28ed6815b.1713518043.git.atai@atai.org
* gnu/packages/graphics.scm: Add bx.

Change-Id: Idb60e1e73d7c35a9d42cc634eab642abcc991001
---
gnu/packages/graphics.scm | 57 +++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3571a45b84..661df61be6 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2884,6 +2884,63 @@ (define-public f3d
options.")
(license license:bsd-3)))
+(define-public bx
+ (let ((commit "d3434707384f6d62229a4476b10b6dc22fee7c9a")
+ (revision "1"))
+ (package
+ (name "bx")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bkaradzic/bx")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11jii8dfb0nzxamkffa6ij3p6r4w7csfbxw7wpxsmqhirv5i8rns"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+
+ (replace 'build
+ (lambda _
+ (invoke "make" "linux-release64"
+ (string-append "GENIE="
+ #$(this-package-native-input
+ "genie") "/bin/genie") "-j"
+ (number->string (parallel-job-count)))))
+
+ (replace 'check
+ (lambda _
+ (invoke "make" "test")))
+ (replace 'install
+ (lambda _
+ (install-file
+ ".build/linux64_gcc/obj/x64/Release/bin2c/tools/bin2c"
+ (string-append #$output "/bin"))
+ (install-file
+ ".build/linux64_gcc/obj/x64/Release/lemon/tools/lemon"
+ (string-append #$output "/bin"))
+ (for-each (lambda (f)
+ (install-file f
+ (string-append #$output
+ "/lib")))
+ (find-files ".build/linux64_gcc" "\\.a$"))
+ (copy-recursively "include/bx"
+ (string-append #$output
+ "/include/bx")))))))
+ (native-inputs (list genie))
+ (home-page "https://github.com/bkaradzic/bx")
+ (synopsis "Base library used across multiple projects ")
+ (description
+ "Bx is an base library that implements low level functions of the
+Bgfx graphics library.")
+ (license license:bsd-2))))
+
+
(define-public gpaint
(package
(name "gpaint")

base-commit: e0d920b7db3f71c02627d698676339218e03ad63
--
2.34.1
A
A
Andy Tai wrote on 20 Apr 20:32 +0200
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_Esr6+GnV-jK29uKG1-kVhXK5Za65R4UEbW=EPEsO5Lw@mail.gmail.com
close 70471
thanks
patch needs revision, not ready for merge
?