[PATCH] gnu: Add stb-image-resize.

  • Done
  • quality assurance status badge
Details
2 participants
  • aurtzy
  • John Kehayias
Owner
unassigned
Submitted by
aurtzy
Severity
normal
A
A
aurtzy wrote on 19 Apr 03:14 +0200
(address . guix-patches@gnu.org)
f2ae89ce0c6d31f5803bc0c80f80cd3bcb68b51a.1713489293.git.aurtzy@gmail.com
* gnu/packages/stb.scm (stb-image-resize): New variable.

Change-Id: Ia9d654277b26f1bce0f32d064a5d2ae6c434b677
---
gnu/packages/stb.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index 4ee1b4ebd2..9286bcd87d 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -97,6 +97,12 @@ (define-public stb-image
"stb-image is a small and self-contained library for image loading or
decoding from file or memory. A variety of formats are supported."))
+(define-public stb-image-resize
+ (make-stb-header-package
+ "stb-image-resize" "0.96"
+ "stb-image-resize is a library that supports scaling and translation of
+images."))
+
(define-public stb-image-write
(make-stb-header-package
"stb-image-write" "1.15"

base-commit: 49f82fca4130ffcfb16aa0cf89750ab56fb99ad7
prerequisite-patch-id: f5e8f0d0088ee3f75f25a0a5c8516d21ff9f4ea1
--
2.41.0
J
J
John Kehayias wrote on 19 Apr 18:15 +0200
(name . aurtzy)(address . aurtzy@gmail.com)(address . 70463-done@debbugs.gnu.org)
87frvhjplj.fsf@protonmail.com
Hello,

On Thu, Apr 18, 2024 at 09:14 PM, aurtzy wrote:

Toggle quote (28 lines)
> * gnu/packages/stb.scm (stb-image-resize): New variable.
>
> Change-Id: Ia9d654277b26f1bce0f32d064a5d2ae6c434b677
> ---
> gnu/packages/stb.scm | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
> index 4ee1b4ebd2..9286bcd87d 100644
> --- a/gnu/packages/stb.scm
> +++ b/gnu/packages/stb.scm
> @@ -97,6 +97,12 @@ (define-public stb-image
> "stb-image is a small and self-contained library for image loading or
> decoding from file or memory. A variety of formats are supported."))
>
> +(define-public stb-image-resize
> + (make-stb-header-package
> + "stb-image-resize" "0.96"
> + "stb-image-resize is a library that supports scaling and translation of
> +images."))
> +
> (define-public stb-image-write
> (make-stb-header-package
> "stb-image-write" "1.15"
>
> base-commit: 49f82fca4130ffcfb16aa0cf89750ab56fb99ad7
> prerequisite-patch-id: f5e8f0d0088ee3f75f25a0a5c8516d21ff9f4ea1

Thanks, pushed as ff692ed4cf!

John
Closed
?