[PATCH 0/2] Correct some Python dependencies.

  • Open
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 17 Apr 07:36 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240417053807.11358-1-ngraves@ngraves.fr
Test dependencies for python should go into native-inputs rather than propagated-inputs.

Nicolas Graves (2):
gnu: contourpy: Correct dependencies.
gnu: python-seaborn: Correct dependencies.

gnu/packages/python-xyz.scm | 38 +++++++++++++++++++------------------
1 file changed, 20 insertions(+), 18 deletions(-)

--
2.41.0
N
N
Nicolas Graves wrote on 17 Apr 07:40 +0200
[PATCH 1/2] gnu: contourpy: Correct dependencies.
(address . 70431@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240417054040.15563-1-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (contourpy): Correct dependencies.
[propagated-inputs]: Move all except python-numpy from here...
[native-inputs]: ...to here.

Change-Id: I99048270570689ed9ceab6e0ff6db9561193425e
---
gnu/packages/python-xyz.scm | 24 +++++++++++++-----------
1 file changed, 13 insertions(+), 11 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44c709a880..643c427392 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1144,17 +1144,19 @@ (define-public python-contourpy
"--ignore=tests/test_filled.py"
"--ignore=tests/test_lines.py"
"--ignore=tests/test_renderer.py")))
- (propagated-inputs (list python-mypy
- python-numpy
- python-pillow
- python-pytest
- python-pytest-cov
- python-pytest-xdist
- python-selenium
- python-sphinx
- python-sphinx-copybutton
- python-wurlitzer))
- (native-inputs (list meson-python pybind11-2.10 pkg-config))
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list meson-python
+ pybind11-2.10
+ pkg-config
+ python-mypy
+ python-pillow
+ python-pytest
+ python-pytest-cov
+ python-pytest-xdist
+ python-selenium
+ python-sphinx
+ python-sphinx-copybutton
+ python-wurlitzer))
(home-page "https://contourpy.readthedocs.io/")
(synopsis
"Python library for calculating contours of 2D quadrilateral grids")
--
2.41.0
N
N
Nicolas Graves wrote on 17 Apr 07:40 +0200
[PATCH 2/2] gnu: python-seaborn: Correct dependencies.
(address . 70431@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240417054040.15563-2-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-seaborn): Correct dependencies.
[propagated-inputs]: Move python-ipykernel, python-mypy,
python-nbconvert, python-numpydoc, python-pyyaml from here...
[native-inputs]: ... to here.

Change-Id: I94a28f0cb8ec7c2171007f2b635dc10d7a8fcc8c
---
gnu/packages/python-xyz.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 643c427392..f6f90d9c7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13262,23 +13262,23 @@ (define-public python-seaborn
"0ycibcs6kvd3xi4zsxna81claqifyb9dn6z6jwc5x7lqqplnbbdz"))))
(build-system pyproject-build-system)
(propagated-inputs
- (list python-ipykernel
- python-matplotlib
- python-mypy
- python-nbconvert
+ (list python-matplotlib
python-numpy
- python-numpydoc
python-pandas
- python-pyyaml
python-scipy
python-statsmodels))
(native-inputs
(list python-flake8
python-flit-core
python-pre-commit
+ python-ipykernel
+ python-nbconvert
+ python-numpydoc
+ python-mypy
python-pytest
python-pytest-cov
- python-pytest-xdist))
+ python-pytest-xdist
+ python-pyyaml))
(home-page "https://seaborn.pydata.org/")
(synopsis "Statistical data visualization")
(description
--
2.41.0
?