[PATCH] add emacs-smudge package

  • Open
  • quality assurance status badge
Details
One participant
  • Noé Lopez
Owner
unassigned
Submitted by
Noé Lopez
Severity
normal
N
N
Noé Lopez wrote on 14 Apr 00:57 +0200
(address . guix-patches@gnu.org)
87o7acub00.fsf@xn--no-cja.eu
Hi, this is a patch for the smudge emacs package. It allows users to
control any Spotify Connect device or local Spotify instances like
spotifyd.

Have a nice day,
Noé Lopez
From 778f68b7b0926880301a46712e64c0a20a13a7d6 Mon Sep 17 00:00:00 2001
Message-ID: <778f68b7b0926880301a46712e64c0a20a13a7d6.1713048827.git.noelopez@free.fr>
From: =?UTF-8?q?No=C3=A9=20Lopez?= <noelopez@free.fr>
Date: Sun, 14 Apr 2024 00:42:56 +0200
Subject: [PATCH] gnu: Add emacs-smudge.

Change-Id: I152b1cb0127a30aa49e9edd26e8ad3e8d728cd29
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2b622f92..d55ed2b1bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24257,6 +24258,30 @@ (define-public emacs-pulseaudio-control
"This package allows controlling Pulseaudio from Emacs.")
(license license:gpl3+))))
+(define-public emacs-smudge
+ (let ((commit "4a9c5b34e9bc0a694d0faf8c2f83dc244b8b6a2f")
+ (revision "4"))
+ (package
+ (name "emacs-smudge")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danielfm/smudge.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xiqxw87sdk9mgy7fdbmzqaf58dc1grhkigirg1bd0b2q5kbnbwx"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-simple-httpd emacs-request emacs-oauth2))
+ (home-page "https://github.com/danielfm/smudge")
+ (synopsis "Control the Spotify app from within Emacs")
+ (description "Smudge allows you to control the Spotify application
+from Emacs. Either via D-BUS or Spotify Connect if you have a Spotify
+premium subscription.")
+ (license license:gpl3))))
+
(define-public emacs-pulsar
(package
(name "emacs-pulsar")

base-commit: ef9a2f9e91d37c0d93e689eb26ebeb6483655968
--
2.41.0
?