Increase verbosity of diffoscope test suite

  • Open
  • quality assurance status badge
Details
One participant
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 11 Apr 21:50 +0200
(address . guix-patches@gnu.org)
87r0fb3cgx.fsf@wireframe
The attached patch increases the verbosity of the test suite, showing
each test on it's own line and provides a useful summary, often
including a reason why skipped tests were skipped.

This can be useful to help find additional packages to add for broader
test coverage, inspired by discussion in

This also reveals that the conditional to add "enjarify" to
native-inputs on x86_64 is not working correctly... and plausibly could
reveal other similar issues with other missing native-inputs.

live well,
vagrant
From b1475226dc655986e97445dca889d4b0c362215c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Thu, 11 Apr 2024 12:40:19 -0700
Subject: [PATCH] gnu: diffoscope: Increase test verbosity.

* gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check.
---
gnu/packages/diffoscope.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3db52e5008..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -139,6 +139,11 @@ (define (bin command)
(lambda _
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Increase verbosity of tests and provide a summary
+ (invoke "pytest" "-vv" "-r" "sxX"))))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.39.2
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZhg/HgAKCRDcUY/If5cW
qgW5AQDzQ7f7cJAMcFuWYQn+QzKZ232WSPuBPZYNO174a61EwAEA1OKOc9dj92dJ
gosZBACXOiuHDyy99tk3SlkjZve9Bg4=
=hxq0
-----END PGP SIGNATURE-----

?