[PATCH] Fix unitentional creation of greeter's home directory

  • Open
  • quality assurance status badge
Details
One participant
  • lgcoelho
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 10 Apr 01:58 +0200
(address . guix-patches@gnu.org)
c45600de103d560b3487772b103d7e4b@disroot.org
This patch adresses the unintentional creation of the greeter's home
directory when using the greetd-service.
Attachment: file
From 4be55c2b63c050ae837e9afa7969cfb3ee8df1e5 Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Tue, 9 Apr 2024 20:38:33 -0300
Subject: [PATCH] services: base: Fix unintentional creation of greeter's home
directory

* gnu/services/base.scm (greetd-account) [create-home-directory?]: Set to false.
---
gnu/services/base.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 3f912225a0..b39b8418ed 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2024 Luis Guilherme Coelho <lgcoelho@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3481,6 +3482,7 @@ (define (greetd-accounts config)
(name "greeter")
(group "greeter")
(supplementary-groups (greetd-greeter-supplementary-groups config))
+ (create-home-directory? #f)
(system? #t))))
(define (make-greetd-pam-mount-conf-file config)
--
2.41.0
?