[PATCH 00/12] gnu: clipman: Update to 1.6.2.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 24 Mar 01:35 +0100
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1711239854.git.sharlatanus@gmail.com
Hi Guix!

I expected this series would not be so long when I thought just to move
go-github-com-kballard-go-shellquote to golang-xyz while preparing
go-github-com-gin-gonic-gin for review ^.^

Here we go!

- module xdisorg completely relays on golang-xyz, syncthing and golang excluded
- clipman: package is heavenly refactored and updated to the latest version

I even forked go-github-com-kballard-go-shellquote (!) and made the first
release as the current project maintainer was no longer interested in it. I
might propagate it to clipman.

Live galactically,
Oleg

Sharlatan Hellseher (12):
gnu: go-github-com-kballard-go-shellquote: Move to golang-xyz.
gnu: go-github-com-alecthomas-kingpin: Move to golang-xyz.
gnu: go-github-com-alecthomas-template: Move to golang-xyz.
gnu: go-github-com-alecthomas-units: Move to golang-xyz.
gnu: clipman: Fix source and home-page URL.
gnu: clipman: Update to 1.6.2.
gnu: Add go-github-com-xhit-go-str2duration-v2.
gnu: Add go-github-com-alecthomas-kingpin-v2.
gnu: Add go-gopkg-in-alecthomas-kingpin-v2.
gnu: go-github-com-alecthomas-kingpin: Adjust inputs.
gnu: clipman: Simplify package.
gnu: clipman: Refresh package style.

gnu/packages/golang-xyz.scm | 169 +++++++++++++++++++++++++++++++++++-
gnu/packages/golang.scm | 83 ------------------
gnu/packages/syncthing.scm | 24 -----
gnu/packages/xdisorg.scm | 56 ++++++------
4 files changed, 195 insertions(+), 137 deletions(-)


base-commit: d5f857a3cfd1d7523b4051b94bd67b5cf5636219
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 08/12] gnu: Add go-github-com-alecthomas-kingpin-v2.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
41cef86f4abbdb49364af199411f60ae32edfb72.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-kingpin-v2): New variable.
* gnu/packages/golang-xyz.scm (go-github-com-kingpin): Delete variable.

Change-Id: If40f318b960e29fd601602d26fd36dcc8fce9583
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++--
1 file changed, 22 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e3c2d86062..f79fdda696 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -169,8 +169,28 @@ (define-public go-github-com-alecthomas-kingpin
"Go library provides utilities for building command line interfaces.")
(license license:expat)))
-(define-public go-github-com-kingpin
- (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
+(define-public go-github-com-alecthomas-kingpin-v2
+ (package
+ (inherit go-github-com-alecthomas-kingpin)
+ (name "go-github-com-alecthomas-kingpin-v2")
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/kingpin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12xl62xzwq2h71hp1i0133403zhyqwsh95sr870fx18wmpqh8shf"))))
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/kingpin/v2"))
+ (propagated-inputs
+ (list go-github-com-alecthomas-units
+ go-github-com-xhit-go-str2duration-v2))
+ (native-inputs
+ (list go-github-com-stretchr-testify))))
(define-public go-github-com-alecthomas-participle-v2
(package
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 09/12] gnu: Add go-gopkg-in-alecthomas-kingpin-v2.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
73b5585fd6d6a7c2d3ce62d060ede2ee1fd96a92.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang-xyz.scm (go-gopkg-in-alecthomas-kingpin-v2): New variable.

Change-Id: I35a0919b30a191000e922882619e778187b5a0da
---
gnu/packages/golang-xyz.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f79fdda696..3e20061223 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2138,6 +2138,13 @@ (define-public go-go-uber-org-zap
Go.")
(license license:expat)))
+(define-public go-gopkg-in-alecthomas-kingpin-v2
+ (package
+ (inherit go-github-com-alecthomas-kingpin)
+ (arguments
+ (list
+ #:import-path "gopkg.in/alecthomas/kingpin.v2"))))
+
(define-public go-gopkg-in-op-go-logging-v1
(package
(inherit go-github-com-op-go-logging)
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 10/12] gnu: go-github-com-alecthomas-kingpin: Adjust inputs.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e9ecccf8273f3e53b82553fa6e5f3e4bd9b0a92f.1711239854.git.sharlatanus@gmail.com
gnu/packages/golang-xyz.scm (go-github-com-alecthomas-kingpin)
[native-inputs]: Move go-github-com-alecthomas-units and
go-github-com-alecthomas-template from here ...
[propagated-inputs]: ... to here.

Change-Id: I841ea8cf29ef49008d7a725c9db96b963f263f7f
---
gnu/packages/golang-xyz.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3e20061223..9a586fcf37 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -160,9 +160,10 @@ (define-public go-github-com-alecthomas-kingpin
(list
#:import-path "github.com/alecthomas/kingpin"))
(native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
(list go-github-com-alecthomas-template
- go-github-com-alecthomas-units
- go-github-com-stretchr-testify))
+ go-github-com-alecthomas-units))
(home-page "https://github.com/alecthomas/kingpin")
(synopsis "Go library provides utilities for building command line interfaces")
(description
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 11/12] gnu: clipman: Simplify package.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
5ffb8bff4b95061fc047f6322f3b24e90e966e86.1711239854.git.sharlatanus@gmail.com
* gnu/packages/xdisorg.scm (clipman):
[phases] <#:phases>: Adjust 'patch phase to relay on provided module
import path.
[inputs]: Remove go-github-com-alecthomas-kingpin; add
go-gopkg-in-alecthomas-kingpin-v2.

Change-Id: I3d9d82af29672ff94cdbd39b18ec4ed61b8e485f
---
gnu/packages/xdisorg.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7a2395b49d..025f1c5939 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3240,15 +3240,13 @@ (define-public clipman
(add-before 'build 'patch
(lambda _
(substitute* "src/github.com/yory8/clipman/main.go"
- (("gopkg.in/alecthomas/kingpin.v2")
- "github.com/alecthomas/kingpin")
(("\"wl-copy\"")
(string-append "\"" (which "wl-copy") "\"")))))
(delete 'install-license-files))))
(native-inputs (list go-github-com-alecthomas-template
go-github-com-alecthomas-units))
(inputs (list go-github-com-kballard-go-shellquote
- go-github-com-alecthomas-kingpin
+ go-gopkg-in-alecthomas-kingpin-v2
libnotify
wl-clipboard))
(synopsis "Basic clipboard manager with support for persisting copy buffers")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 12/12] gnu: clipman: Refresh package style.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
0618ca4340787ea5b4124e8cd6576548156c7ba5.1711239854.git.sharlatanus@gmail.com
* gnu/packages/xdisorg.scm (clipman): Adjust indentation.
[arguments] <#:phases>: Rename 'patch to 'patch-wl-copy-path phase to
reflect the purpose.
Revert default 'install-license-files phase.
[native-inputs]: Remove go-github-com-alecthomas-template and
go-github-com-alecthomas-units, they are propagated from
go-gopkg-in-alecthomas-kingpin-v2.

Change-Id: I5332906c126904ced595aa322be5f933c305c5f7
---
gnu/packages/xdisorg.scm | 47 ++++++++++++++++++++--------------------
1 file changed, 24 insertions(+), 23 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 025f1c5939..17a24f792d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3224,31 +3224,32 @@ (define-public clipman
(package
(name "clipman")
(version "1.6.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/chmouel/clipman")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32
- "033l2hy46r2zjy8dllcmkjxidhnqac9kfh4wkq9hfvim9imp5a4m"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chmouel/clipman")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "033l2hy46r2zjy8dllcmkjxidhnqac9kfh4wkq9hfvim9imp5a4m"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/yory8/clipman"
- #:install-source? #f
- #:phases #~(modify-phases %standard-phases
- (add-before 'build 'patch
- (lambda _
- (substitute* "src/github.com/yory8/clipman/main.go"
- (("\"wl-copy\"")
- (string-append "\"" (which "wl-copy") "\"")))))
- (delete 'install-license-files))))
- (native-inputs (list go-github-com-alecthomas-template
- go-github-com-alecthomas-units))
- (inputs (list go-github-com-kballard-go-shellquote
- go-gopkg-in-alecthomas-kingpin-v2
- libnotify
- wl-clipboard))
+ (list
+ #:import-path "github.com/yory8/clipman"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'patch-wl-copy-path
+ (lambda _
+ (substitute* "src/github.com/yory8/clipman/main.go"
+ (("\"wl-copy\"")
+ (string-append "\"" (which "wl-copy") "\""))))))))
+ (inputs
+ (list go-github-com-kballard-go-shellquote
+ go-gopkg-in-alecthomas-kingpin-v2
+ libnotify
+ wl-clipboard))
(synopsis "Basic clipboard manager with support for persisting copy buffers")
(description
"A clipboard manager for Wayland that relies on an external selector,
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 04/12] gnu: go-github-com-alecthomas-units: Move to golang-xyz.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
a319ad9ef3496cf1846e3e03b58d090dd2cd9f04.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang.scm (go-github-com-alecthomas-units): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.
* gnu/packages/xdisorg.scm: Remove (gnu packages golang).

Change-Id: I9a4d7da82c9ca1b3c4e0d07d97d8fcde30590e33
---
gnu/packages/golang-xyz.scm | 29 +++++++++++++++++++++++++++++
gnu/packages/golang.scm | 27 ---------------------------
gnu/packages/xdisorg.scm | 1 -
3 files changed, 29 insertions(+), 28 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bd808d44c3..e012beabaf 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -201,6 +201,7 @@ (define-public go-github-com-alecthomas-participle-v2
(license license:expat)))
(define-public go-github-com-alecthomas-template
+ ;; No release, see <https://github.com/alecthomas/template/issues/7>.
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
(revision "0"))
(package
@@ -227,6 +228,34 @@ (define-public go-github-com-alecthomas-template
newlines until a non-newline.")
(license license:bsd-3))))
+(define-public go-github-com-alecthomas-units
+ ;; No release, see <https://github.com/alecthomas/units/issues/9>.
+ (let ((commit "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a")
+ (revision "0"))
+ (package
+ (name "go-github-com-alecthomas-units")
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/units")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j65b91qb9sbrml9cpabfrcf07wmgzzghrl7809hjjhrmbzri5bl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/units"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/units")
+ (synopsis "Helpful unit multipliers and functions for Go")
+ (description
+ "This library provides unit multipliers and functions for Go.")
+ (license license:expat))))
+
(define-public go-github-com-anmitsu-go-shlex
(package
(name "go-github-com-anmitsu-go-shlex")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 18f0e6f7ac..d2f8874de6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,33 +9609,6 @@ (define-public go-github-com-skratchdot-open-golang
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-units
- (let ((commit "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a")
- (revision "0"))
- (package
- (name "go-github-com-alecthomas-units")
- (version "0.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/units")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1j65b91qb9sbrml9cpabfrcf07wmgzzghrl7809hjjhrmbzri5bl"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-stretchr-testify))
- (arguments
- '(#:import-path "github.com/alecthomas/units"
- #:phases %standard-phases))
- (synopsis "Helpful unit multipliers and functions for Go")
- (description
- "This library provides unit multipliers and functions for Go.")
- (home-page "https://github.com/alecthomas/units")
- (license license:expat))))
-
(define-public go-github-com-dreamacro-go-shadowsocks2
(package
(name "go-github-com-dreamacro-go-shadowsocks2")
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b3b305a352..46c9305e65 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -114,7 +114,6 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages gl)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
- #:use-module (gnu packages golang)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 02/12] gnu: go-github-com-alecthomas-kingpin: Move to golang-xyz.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e92d7b979c11477e01c79bd62d35d857d7717132.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang.scm (go-github-com-alecthomas-kingpin): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: Ib7609a82c96683809f81479f4eb13f43d85d4a2f
---
gnu/packages/golang-xyz.scm | 33 ++++++++++++++++++++++++++++++++-
gnu/packages/golang.scm | 29 -----------------------------
2 files changed, 32 insertions(+), 30 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 77608457f2..fb3c31a38e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4,10 +4,11 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
+;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -141,6 +142,36 @@ (define-public go-github-com-alecthomas-chroma-v2
(list go-github-com-alecthomas-assert-v2
go-github-com-alecthomas-repr))))
+(define-public go-github-com-alecthomas-kingpin
+ (package
+ (name "go-github-com-alecthomas-kingpin")
+ (version "2.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/kingpin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/kingpin"))
+ (native-inputs
+ (list go-github-com-alecthomas-template
+ go-github-com-alecthomas-units
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/kingpin")
+ (synopsis "Go library provides utilities for building command line interfaces")
+ (description
+ "Go library provides utilities for building command line interfaces.")
+ (license license:expat)))
+
+(define-public go-github-com-kingpin
+ (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
+
(define-public go-github-com-alecthomas-participle-v2
(package
(name "go-github-com-alecthomas-participle-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6533914f80..062985c0ce 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,35 +9609,6 @@ (define-public go-github-com-skratchdot-open-golang
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-kingpin
- (package
- (name "go-github-com-alecthomas-kingpin")
- (version "2.2.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/kingpin")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-alecthomas-template go-github-com-alecthomas-units
- go-github-com-stretchr-testify))
- (arguments
- '(#:import-path "github.com/alecthomas/kingpin"
- #:phases %standard-phases))
- (synopsis "Go library provides utilities for building command line interfaces")
- (description
- "Go library provides utilities for building command line interfaces.")
- (home-page "https://github.com/alecthomas/kingpin")
- (license license:expat)))
-
-(define-public go-github-com-kingpin
- (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
-
(define-public go-github-com-alecthomas-template
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
(revision "0"))
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 01/12] gnu: go-github-com-kballard-go-shellquote: Move to golang-xyz.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
aeae278611ba1eb27ad4e29b6d053cb9e4112560.1711239854.git.sharlatanus@gmail.com
* gnu/packages/syncthing.scm (go-github-com-kballard-go-shellquote):
Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/xdisorg.scm: Remove (gnu packages syncthing).
Add (gnu packages golang-xyz).

Change-Id: I3ab4cbc55d8ca0ad8b7fec0130bdb935039f2841
---
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
gnu/packages/syncthing.scm | 24 ------------------------
gnu/packages/xdisorg.scm | 2 +-
3 files changed, 28 insertions(+), 25 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cf0b52a043..77608457f2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1221,6 +1221,33 @@ (define-public go-github-com-k0kubun-pp
customized globally.")
(license license:expat)))
+(define-public go-github-com-kballard-go-shellquote
+ ;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
+ (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
+ (revision "1"))
+ (package
+ (name "go-github-com-kballard-go-shellquote")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kballard/go-shellquote")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kballard/go-shellquote"))
+ (synopsis "Shell-style string joins and splits")
+ (description
+ "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+ (home-page "https://github.com/kballard/go-shellquote")
+ (license license:expat))))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ebbf8b82bb..c8eb64b69e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -658,30 +658,6 @@ (define-public go-github-com-petermattis-goid
(home-page "https://github.com/petermattis/goid")
(license asl2.0))))
-(define-public go-github-com-kballard-go-shellquote
- (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
- (revision "1"))
- (package
- (name "go-github-com-kballard-go-shellquote")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kballard/go-shellquote")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/kballard/go-shellquote"))
- (synopsis "Shell-style string joins and splits")
- (description "Shellquote provides utilities for joining/splitting strings
-using sh's word-splitting rules.")
- (home-page "https://github.com/kballard/go-shellquote")
- (license expat))))
-
(define-public go-github-com-syncthing-notify
(let ((commit "69c7a957d3e261f9744f46b3dd4d608d8480ad90")
(revision "5"))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index be8623666f..b3b305a352 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,6 +115,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -140,7 +141,6 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages python-check)
#:use-module (gnu packages qt)
#:use-module (gnu packages sphinx)
- #:use-module (gnu packages syncthing)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tcl)
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 03/12] gnu: go-github-com-alecthomas-template: Move to golang-xyz.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
29e0aafc23624a2fc8dfc114f1ca52cf46484f86.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang.scm (go-github-com-alecthomas-template): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: Iffdd88439819c526cd6dd940192bf48995bf76bc
---
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
gnu/packages/golang.scm | 27 ---------------------------
2 files changed, 27 insertions(+), 27 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fb3c31a38e..bd808d44c3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -200,6 +200,33 @@ (define-public go-github-com-alecthomas-participle-v2
\"unmarshalling\" an instance of a grammar into a struct.")
(license license:expat)))
+(define-public go-github-com-alecthomas-template
+ (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
+ (revision "0"))
+ (package
+ (name "go-github-com-alecthomas-template")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/template")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/template"))
+ (home-page "https://github.com/alecthomas/template")
+ (synopsis "Fork of Go's text/template adding newline elision")
+ (description
+ "This is a fork of Go 1.4's text/template package with one addition: a
+backslash immediately after a closing delimiter will delete all subsequent
+newlines until a non-newline.")
+ (license license:bsd-3))))
+
(define-public go-github-com-anmitsu-go-shlex
(package
(name "go-github-com-anmitsu-go-shlex")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 062985c0ce..18f0e6f7ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,33 +9609,6 @@ (define-public go-github-com-skratchdot-open-golang
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-template
- (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
- (revision "0"))
- (package
- (name "go-github-com-alecthomas-template")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/template")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/alecthomas/template"
- #:phases %standard-phases))
- (synopsis "Fork of Go's text/template adding newline elision")
- (description
- "This is a fork of Go 1.4's text/template package with one addition: a
-backslash immediately after a closing delimiter will delete all subsequent
-newlines until a non-newline.")
- (home-page "https://github.com/alecthomas/template")
- (license license:bsd-3))))
-
(define-public go-github-com-alecthomas-units
(let ((commit "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a")
(revision "0"))
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 06/12] gnu: clipman: Update to 1.6.2.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
4eda9a4cdef4cb5e91270767072f7bedfc81ed84.1711239854.git.sharlatanus@gmail.com
* gnu/packages/xdisorg.scm (clipman): Update to 1.6.2.

Change-Id: I389f93f2d43f1675f2b33694ba84711e42df4eaf
---
gnu/packages/xdisorg.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ba7c5b942e..7a2395b49d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3223,7 +3223,7 @@ (define-public clipmenu
(define-public clipman
(package
(name "clipman")
- (version "1.6.1")
+ (version "1.6.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3231,7 +3231,7 @@ (define-public clipman
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256 (base32
- "0b9kvj0dif4221dy6c1npknhhjxvbc4kygzhwxjirpwjws0yv6v9"))))
+ "033l2hy46r2zjy8dllcmkjxidhnqac9kfh4wkq9hfvim9imp5a4m"))))
(build-system go-build-system)
(arguments
(list #:import-path "github.com/yory8/clipman"
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 05/12] gnu: clipman: Fix source and home-page URL.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
58dcb1ebb77a50ed0220947d0d67d246383a9204.1711239854.git.sharlatanus@gmail.com
The URI https://github.com/yory8/clipman/no longer exists. The new
project's URL was obtained from the Nix package.

* gnu/packages/xdisorg.scm (clipman) [source]: Fix URL.
[home-page]: As above.

Change-Id: I20e9f22780586ce14d925d5cf106e70de8209e1e
---
gnu/packages/xdisorg.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 46c9305e65..ba7c5b942e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3227,7 +3227,7 @@ (define-public clipman
(source (origin
(method git-fetch)
(uri (git-reference
- (url (string-append "https://github.com/yory8/" name "/"))
+ (url "https://github.com/chmouel/clipman")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256 (base32
@@ -3260,7 +3260,7 @@ (define-public clipman
clipman store} (or @command{exec wl-paste -t text --watch clipman store 1>>
PATH/TO/LOGFILE 2>&1 &} to log errors) at the beginning of wherever you
initialize programs.")
- (home-page "https://github.com/yory8/clipman")
+ (home-page "https://github.com/chmouel/clipman")
(license license:gpl3)))
(define-public kbdd
--
2.41.0
S
S
Sharlatan Hellseher wrote on 24 Mar 01:37 +0100
[PATCH 07/12] gnu: Add go-github-com-xhit-go-str2duration-v2.
(address . 69969@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
6a04f228d63724949db9f4767f7092e430e039e5.1711239854.git.sharlatanus@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-xhit-go-str2duration-v2): New variable.

Change-Id: I30425e498db6dd8cb736eedffe006346973628ed
---
gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e012beabaf..e3c2d86062 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2035,6 +2035,31 @@ (define-public go-github-com-whyrusleeping-go-sysinfo
@code{MemoryInfo}.")
(license license:expat)))
+(define-public go-github-com-xhit-go-str2duration-v2
+ (package
+ (name "go-github-com-xhit-go-str2duration-v2")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xhit/go-str2duration")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c9zi9mfy5ww413y1jpfh1rdis43lvd5v6gvajqzh4q1km9lyxjj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xhit/go-str2duration/v2"))
+ (home-page "https://github.com/xhit/go-str2duration")
+ (synopsis "Convert string to duration in golang")
+ (description
+ "This package allows to get a @code{time.Duration} from a string. The
+string can be a string retorned for @code{time.Duration} or a similar string
+with weeks or days too.")
+ (license license:bsd-3)))
+
(define-public go-go-uber-org-automaxprocs
(package
(name "go-go-uber-org-automaxprocs")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 28 Mar 00:11 +0100
[PATCH 00/12] gnu: clipman: Update to 1.6.2.
(address . 69969-done@debbugs.gnu.org)
87plvfe0cl.fsf@gmail.com
Pushed as f427ec7026..2173e4a12e to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYEp7oACgkQdtcnv/Ys
0rUdrw//Znr5NurkijRsCRjhJLCdt/UngNCod+7m97hLs5WdmtnP/d6Pu2xN1GP2
UxPMiSjUhNzokM49NHIcZ963uCaKCzN0JfqCVZ/Yt8Q5Xogg0kCOy/ZHbEt+hN65
9WposHMLgYP+ifdJVI6ImdQ5vfycoPHd+btVyBvWO0TJLNA73T7BYt1Uh+8D6jcj
A1xq3/6xxO7BEKquNN9X9pINYMOyFMClD58cCpAYAxez+o84TFzWQM/VFQ+UWyZg
hgwlMqoNzI0pb+jP+3WgM8qimp6oJ70BP1eYaJzCoZu3mLtJb2X6R++CWV3gCQxq
VImiW0msE0AIiHPc09dd+0FPPZyBGHDoE4OcIqwuFE/0oZf3Mp347KSMLfXQGVvW
6Cf+yQGS78hoUU7o2meSTXFTVSXDkpNf9HtawKTNXpN/Tg0VTVYj5WVSckhAEwsD
Mih9W7V+oSXNgzIfLXnOns1C+IOpvLFrMfQwiLLblCyGbz0OWrLGUJNHDUo8rYOp
7Pe0t+wveuoJzuFYB1XS3+sFAWNrz7Jj9RC8/fKBS3KpQyNIdSNj3UVusFLjK7DN
+kgiIwRSDKZ46wpzJExrIo/8efypjN+D7vjiDq/BkZ+Ff9Xw8dWX32pLHwucdP4r
u2ZgFYOoz5TLNYcR3bMOkot+wnjMgLREpgELhCtMlxeSZE7Wrfk=
=x0fg
-----END PGP SIGNATURE-----

Closed
?