[PATCH] gnu: go-github-com-shirou-gopsutil: Update to 3.24.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 17 Feb 11:50 +0100
(address . guix-patches@gnu.org)
87cysvbby7.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-shirou-gopsutil): Update to 3.24.1.
---
gnu/packages/golang.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 527b63d160..5305137287 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6309,20 +6309,18 @@ (define-public go-github-com-robfig-cron
(license license:expat)))
(define-public go-github-com-shirou-gopsutil
- (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
- (revision "0"))
(package
(name "go-github-com-shirou-gopsutil")
- (version (git-version "v2.19.7" revision commit))
+ (version "3.24.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/shirou/gopsutil")
- (commit commit))) ; XXX
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
+ "0mnlxfmssd15la95c64rsfds92fwp5yx4b2kb8madbj21qi813jf"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/shirou/gopsutil"))
@@ -6331,7 +6329,7 @@ (define-public go-github-com-shirou-gopsutil
on running processes and system utilization (CPU, memory, disks, network,
sensors).")
(home-page "https://github.com/shirou/gopsutil")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-github-com-danwakefield-fnmatch
(let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")

base-commit: 91d80460296e2d5a01704d0f34fb966a45a165ae
--
2.42.0
S
S
Sharlatan Hellseher wrote on 18 Feb 23:42 +0100
(address . 69234@debbugs.gnu.org)
87le7hjsxz.fsf@gmail.com
Hi Troy,

The version 3.24.1 of gopsutil introduces new module name
github.com/shirou/gopsutil/v3 and requires some more inputs which are
not available in Guix.

Toggle snippet (18 lines)
module github.com/shirou/gopsutil/v3

go 1.15

require (
github.com/google/go-cmp v0.6.0
github.com/lufia/plan9stats v0.0.0-20211012122336-39d0f177ccd0
github.com/power-devops/perfstat v0.0.0-20210106213030-5aafc221ea8c
github.com/shoenig/go-m1cpu v0.1.6
github.com/stretchr/testify v1.8.4
github.com/tklauser/go-sysconf v0.3.12
github.com/yusufpapurcu/wmi v1.2.3
golang.org/x/sys v0.16.0
)

retract v3.22.11

Present:
+ golang.org/x/sys
+ github.com/stretchr/testify
+ github.com/google/go-cmp

Missing:
- github.com/yusufpapurcu/wmi
- github.com/tklauser/go-sysconf
- github.com/shoenig/go-m1cpu
- github.com/power-devops/perfstat
- github.com/lufia/plan9stats

I see the package is not in use by any others, but maybe it's planned for
the update you planned. Would like to pack missing inputs for the
v3.24.1 and rename it to go-github-com-shirou-gopsutil-v3?

Status: WAIT

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXSh7gACgkQdtcnv/Ys
0rUaERAAsVTeS0BThpI7pbZf/XlIc1cIMIvXdIi3FfSCn0MJF8zrm9hDmXwEB9/W
4c0s0muCDtx3QbTIqOjBRf77zY5RYfME6Fo1ft5HPdzErLZQNGFdBV4LEHQPay6V
x6H8f8N02h+TJOxlFeyrJv4SN1rH7HXjKRSvIEMDoaschLVCcwx8qlA7FmElb10u
WjiHq6AX9xDs6+VtYOtS+xuXV/T3XT7JRgYX6y3aFsIFvJYAFqzApzlJJp9bey58
g35TWkS1M4raHKJfTG8MTLihFH8ODGKBnYEP2amNFiQmLTTdI3uAf7RkOPaCjUsx
i8ckPA0BgMxuLkRMyXUBp74Wu/p1zMAYfq4kzZr/alp1QjGSX3MurZbFVA0grIBd
ZxmVtWJxpF5+Y1ZP+i52suTkHK7eNdEjg8ewEEAuiVYwtUC0Z7SnyHYJllc5jGUC
+XqWBvbMHyhRJh7M0TpSHs4VyYFKjG/E/zys5YUNlEgABmVdq942lCcS2M51X9YU
XJmNhNePBIkC4esvokGDBe7l8NboUiBguVR8SlYqce8nroeacVY3nk1XHSfPvstC
HYU+N9fGwOQxt/jCVR6iGpsbtfVUc6i2vS9Q6FwW/OCgII7+jjTldt6Ur2LAAjVM
4aN7WMnndczNOrZhYNpuLGPwjtVKnwkNRB8eablF43UfGguVYmQ=
=iWAu
-----END PGP SIGNATURE-----

T
T
Troy Figiel wrote on 19 Feb 09:35 +0100
1b1a6ec1-cab9-45dd-8663-4510cbc799bb@troyfigiel.com
Hi Oleg,

On 2024-02-18 23:42, Sharlatan Hellseher wrote:
Toggle quote (14 lines)
> go 1.15
>
> require (
> github.com/google/go-cmp v0.6.0
> github.com/lufia/plan9stats v0.0.0-20211012122336-39d0f177ccd0
> github.com/power-devops/perfstat v0.0.0-20210106213030-5aafc221ea8c
> github.com/shoenig/go-m1cpu v0.1.6
> github.com/stretchr/testify v1.8.4
> github.com/tklauser/go-sysconf v0.3.12
> github.com/yusufpapurcu/wmi v1.2.3
> golang.org/x/sys v0.16.0
> )
>

Currently the following modules are included in the propagated inputs:
- github.com/tklauser/go-sysconf
- golang.org/x/sys

And only one module is included in the native inputs:
- github.com/stretchr/testify

These are in fact all the modules we need, because the others are hidden
behind build tags that are unsupported by Guix:

//go:build plan9
- github.com/google/go-cmp/cmp
- github.com/lufia/plan9stats

//go:build aix && cgo
- github.com/power-devops/perfstat

//go:build darwin
- github.com/shoenig/go-m1cpu

//go:build windows
- github.com/yusufpapurcu/wmi

Toggle quote (5 lines)
> I see the package is not in use by any others, but maybe it's planned for
> the update you planned. Would like to pack missing inputs for the
> v3.24.1 and rename it to go-github-com-shirou-gopsutil-v3?
>

I can rename it to v3 if that would be preferable. I still need to fix
v2 of gopsutil since it failed to build with the "/..." fix. I will
split the fix and the addition of v3 into, and add both of them to this
issue as a second version of the patch series.

Best wishes,

Troy
S
S
Sharlatan Hellseher wrote on 19 Feb 14:13 +0100
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 69234@debbugs.gnu.org)
CAO+9K5roF_ijqB-NpA283yX_jHSWyNHupHiConE7L46XUJfS6g@mail.gmail.com
Hi Troy,

Naming to *-v3 would follow rest of the golang packages.

Thanks,
Oleg
Attachment: file
T
T
Troy Figiel wrote on 24 Feb 09:10 +0100
[PATCH v2 0/5] gnu: Add go-github-com-shirou-gopsutil-v3.
(address . 69234@debbugs.gnu.org)
87v86e9t3f.fsf@troyfigiel.com
This updated patch series moves and updates go-github-com-shirou-gopsutil, renames it to go-github-com-shirou-gopsutil-v2 and adds go-github-com-shirou-gopsutil-v3.

Troy Figiel (5):
gnu: go-github-com-shirou-gopsutil: Move to golang-xyz.
gnu: go-github-com-shirou-gopsutil: Update to 2.21.11.
gnu: go-github-com-shirou-gopsutil: Reformat with guix style.
gnu: Deprecate go-github-com-shirou-gopsutil.
gnu: Add go-github-com-shirou-gopsutil-v3.

gnu/packages/golang-xyz.scm | 77 ++++++++++++++++++++++++++++++++++++-
gnu/packages/golang.scm | 25 ------------
2 files changed, 76 insertions(+), 26 deletions(-)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.42.0
T
T
Troy Figiel wrote on 24 Feb 09:25 +0100
[PATCH v3 0/5] gnu: Add go-github-com-shirou-gopsutil-v3.
(address . 69234@debbugs.gnu.org)
87ttly9sdt.fsf@troyfigiel.com
I accidentally sent the incorrect cover letter previously.

This updated patch series moves and updates go-github-com-shirou-gopsutil, renames it to go-github-com-shirou-gopsutil-v2 and adds go-github-com-shirou-gopsutil-v3.

Troy Figiel (5):
gnu: go-github-com-shirou-gopsutil: Move to golang-xyz.
gnu: go-github-com-shirou-gopsutil: Update to 2.21.11.
gnu: go-github-com-shirou-gopsutil: Reformat with guix style.
gnu: Deprecate go-github-com-shirou-gopsutil.
gnu: Add go-github-com-shirou-gopsutil-v3.

gnu/packages/golang-xyz.scm | 79 ++++++++++++++++++++++++++++++++++++-
gnu/packages/golang.scm | 25 ------------
2 files changed, 78 insertions(+), 26 deletions(-)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.42.0
T
T
Troy Figiel wrote on 23 Feb 00:14 +0100
[PATCH v3 1/5] gnu: go-github-com-shirou-gopsutil: Move to golang-xyz.
(address . 69234@debbugs.gnu.org)
87sf1i9rxb.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-shirou-gopsutil): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.
---
gnu/packages/golang-xyz.scm | 28 +++++++++++++++++++++++++++-
gnu/packages/golang.scm | 25 -------------------------
2 files changed, 27 insertions(+), 26 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..401c769da5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2,7 +2,8 @@
;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
-;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
@@ -1092,6 +1093,31 @@ (define-public go-github-com-rcrowley-go-metrics
(home-page "https://github.com/rcrowley/go-metrics")
(license license:bsd-2))))
+(define-public go-github-com-shirou-gopsutil
+ (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
+ (revision "0"))
+ (package
+ (name "go-github-com-shirou-gopsutil")
+ (version (git-version "v2.19.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit commit))) ; XXX
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/shirou/gopsutil"))
+ (synopsis "Process and system monitoring in Go")
+ (description "This package provides a library for retrieving information
+on running processes and system utilization (CPU, memory, disks, network,
+sensors).")
+ (home-page "https://github.com/shirou/gopsutil")
+ (license license:bsd-3))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e8abaffb56..15613efbb9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6331,31 +6331,6 @@ (define-public go-github-com-robfig-cron
a cron spec parser and job runner.")
(license license:expat)))
-(define-public go-github-com-shirou-gopsutil
- (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
- (revision "0"))
- (package
- (name "go-github-com-shirou-gopsutil")
- (version (git-version "v2.19.7" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/shirou/gopsutil")
- (commit commit))) ; XXX
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/shirou/gopsutil"))
- (synopsis "Process and system monitoring in Go")
- (description "This package provides a library for retrieving information
-on running processes and system utilization (CPU, memory, disks, network,
-sensors).")
- (home-page "https://github.com/shirou/gopsutil")
- (license license:bsd-3))))
-
(define-public go-github-com-danwakefield-fnmatch
(let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
(revision "0"))
--
2.42.0
T
T
Troy Figiel wrote on 24 Feb 08:59 +0100
[PATCH v3 4/5] gnu: Deprecate go-github-com-shirou-gopsutil.
(address . 69234@debbugs.gnu.org)
87o7c69rwv.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-shirou-gopsutil): Rename to ...
(go-github-com-shirou-gopsutil-v2): ... this.
(go-github-com-shirou-gopsutil): Define as deprecated.
---
gnu/packages/golang-xyz.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d09b837fa9..6eb5770c0f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1094,9 +1094,9 @@ (define-public go-github-com-rcrowley-go-metrics
(home-page "https://github.com/rcrowley/go-metrics")
(license license:bsd-2))))
-(define-public go-github-com-shirou-gopsutil
+(define-public go-github-com-shirou-gopsutil-v2
(package
- (name "go-github-com-shirou-gopsutil")
+ (name "go-github-com-shirou-gopsutil-v2")
(version "2.21.11")
(source
(origin
@@ -1138,6 +1138,9 @@ (define-public go-github-com-shirou-gopsutil
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3)))
+(define-public go-github-com-shirou-gopsutil
+ (deprecated-package "go-github-com-shirou-gopsutil" go-github-com-shirou-gopsutil-v2))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")
--
2.42.0
T
T
Troy Figiel wrote on 24 Feb 09:19 +0100
[PATCH v3 2/5] gnu: go-github-com-shirou-gopsutil: Update to 2.21.11.
(address . 69234@debbugs.gnu.org)
87r0h29rx4.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-shirou-gopsutil): Update to
2.21.11.
[arguments]: Fix tests.
<#:go>: Update to go-1.18.
<#:phases>: Add 'remove-v3 and 'remove-failing-tests phases.
[propagated-inputs]: Add go-golang-org-x-sys.
[native-inputs]: Add go-github-com-stretchr-testify and procps.

* gnu/packages/golang-xyz.scm: Add (gnu packages linux) module.
---
gnu/packages/golang-xyz.scm | 63 ++++++++++++++++++++++++-------------
1 file changed, 41 insertions(+), 22 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 401c769da5..bcf46992e0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -45,7 +45,8 @@ (define-module (gnu packages golang-xyz)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-compression)
- #:use-module (gnu packages golang-crypto))
+ #:use-module (gnu packages golang-crypto)
+ #:use-module (gnu packages linux))
;;; Commentary:
;;;
@@ -1094,29 +1095,47 @@ (define-public go-github-com-rcrowley-go-metrics
(license license:bsd-2))))
(define-public go-github-com-shirou-gopsutil
- (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
- (revision "0"))
- (package
- (name "go-github-com-shirou-gopsutil")
- (version (git-version "v2.19.7" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/shirou/gopsutil")
- (commit commit))) ; XXX
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/shirou/gopsutil"))
- (synopsis "Process and system monitoring in Go")
- (description "This package provides a library for retrieving information
+ (package
+ (name "go-github-com-shirou-gopsutil")
+ (version "2.21.11")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gpb10xkdwfimn1sp4jhrvzz4p3zgmdb78q8v23nap3yi6v4bff5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/shirou/gopsutil"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-v3
+ (lambda* (#:key import-path #:allow-other-keys)
+ ;; We remove the separately included v3 module.
+ (delete-file-recursively (string-append "src/"
+ import-path
+ "/v3"))))
+ (add-before 'check 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ ;; host_test.go tries to access files such as
+ ;; /var/run/utmp that do not exist in the build
+ ;; environment.
+ (string-append "src/" import-path "/host/host_test.go")))))))
+ ;; TODO: Add go-github-com-tklauser-go-sysconf to propagated-inputs once
+ ;; it is packaged.
+ (propagated-inputs (list go-golang-org-x-sys))
+ (native-inputs (list go-github-com-stretchr-testify procps))
+ (synopsis "Process and system monitoring in Go")
+ (description "This package provides a library for retrieving information
on running processes and system utilization (CPU, memory, disks, network,
sensors).")
- (home-page "https://github.com/shirou/gopsutil")
- (license license:bsd-3))))
+ (home-page "https://github.com/shirou/gopsutil")
+ (license license:bsd-3)))
(define-public go-github-com-skip2-go-qrcode
(package
--
2.42.0
T
T
Troy Figiel wrote on 24 Feb 09:05 +0100
[PATCH v3 5/5] gnu: Add go-github-com-shirou-gopsutil-v3.
(address . 69234@debbugs.gnu.org)
87msrq9rwo.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-shirou-gopsutil-v3): New variable.
---
gnu/packages/golang-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6eb5770c0f..2c154dd11c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1141,6 +1142,33 @@ (define-public go-github-com-shirou-gopsutil-v2
(define-public go-github-com-shirou-gopsutil
(deprecated-package "go-github-com-shirou-gopsutil" go-github-com-shirou-gopsutil-v2))
+(define-public go-github-com-shirou-gopsutil-v3
+ (package
+ (inherit go-github-com-shirou-gopsutil-v2)
+ (name "go-github-com-shirou-gopsutil-v3")
+ (version "3.24.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mnlxfmssd15la95c64rsfds92fwp5yx4b2kb8madbj21qi813jf"))))
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/shirou/gopsutil"
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ ;; host_test.go tries to access files such as
+ ;; /var/run/utmp that do not exist in the build
+ ;; environment.
+ (string-append "src/" import-path "/host/host_test.go")))))))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")
--
2.42.0
T
T
Troy Figiel wrote on 24 Feb 08:53 +0100
[PATCH v3 3/5] gnu: go-github-com-shirou-gopsutil: Reformat with guix style.
(address . 69234@debbugs.gnu.org)
87plwm9rwz.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-shirou-gopsutil): Reformat with
guix style.
---
gnu/packages/golang-xyz.scm | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bcf46992e0..d09b837fa9 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1098,15 +1098,15 @@ (define-public go-github-com-shirou-gopsutil
(package
(name "go-github-com-shirou-gopsutil")
(version "2.21.11")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/shirou/gopsutil")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0gpb10xkdwfimn1sp4jhrvzz4p3zgmdb78q8v23nap3yi6v4bff5"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gpb10xkdwfimn1sp4jhrvzz4p3zgmdb78q8v23nap3yi6v4bff5"))))
(build-system go-build-system)
(arguments
(list
@@ -1131,7 +1131,8 @@ (define-public go-github-com-shirou-gopsutil
(propagated-inputs (list go-golang-org-x-sys))
(native-inputs (list go-github-com-stretchr-testify procps))
(synopsis "Process and system monitoring in Go")
- (description "This package provides a library for retrieving information
+ (description
+ "This package provides a library for retrieving information
on running processes and system utilization (CPU, memory, disks, network,
sensors).")
(home-page "https://github.com/shirou/gopsutil")
--
2.42.0
T
T
Troy Figiel wrote on 25 Feb 12:35 +0100
Re: [bug#69234] [PATCH] gnu: go-github-com-shirou-gopsutil: Update to 3.24.1.
(address . guix-patches@gnu.org)
46f7fe28-a9ad-4328-b4eb-d70738c264c5@troyfigiel.com
Hi Oleg,

When I first created this issue, I wrongly assumed
go-github-com-tklauser-go-sysconf was already part of master. It turns
out I had already written a half-finished local package definition,
which is why I needed to add go-github-com-tklauser-go-sysconf as a TODO
in the propagated-inputs of go-github-com-shirou-gopsutil-v2 in patch
series v3.

However, I just sent a patch series for
go-github-com-tklauser-go-sysconf (see issue #69379), so we could also
wait to commit that series first and then I can immediately resolve the
TODO in another patch series. It would reduce the number of unnecessary
commits on master.

What do you think?

Best wishes,

Troy
S
S
Sharlatan Hellseher wrote on 7 Mar 00:56 +0100
[PATCH] gnu: go-github-com-shirou-gopsutil: Update to 3.24.1.
(address . 69234-done@debbugs.gnu.org)
87cys66hk2.fsf@gmail.com
Hi Troy,

I've kept name of 2.21.11 on go-github-com-shirou-gopsutil as there is
no such module for "github.com/shirou/gopsutil/v2" like for v3

Pushed as 8468c55565..12b8b129b3 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXpAp0ACgkQdtcnv/Ys
0rW2WBAArdkdOBc7vonLTlD2Ho40p03HkCj+Fg/6RumLdEBkm2NHg+tcK+Uol4q/
RE6qrOmWKIey9CpuJ1nf2EqEQuYGLVfPq9vA88M0nmT6ZftBUXYycBWDzXbSdjcS
6kPYKdcQwh67EPX1xXvx0AfOQlcWqUS5TpiydtG3c4XpIwRIRk4fPYetzuqnn1GL
FsIgBYe6j/ZK+s6BgjBEK/UmagHAB3/6YcFBMhhTvkuoYOvqiOkqyBNtNCQJDik3
puH5pYWe8MFgakPkL2TMFSn7XlaebirOqKL+F8nFAK59R9/6cp7aHlg4fgHTTT2G
2YZPmR3Bu+aXP8EebQWrhRrYoPX4/v7jlj0FQtAt7dx2VRbl0PsS53q/1GDXRnW4
u/zgq57uK0eKHp5wym9u3scg52QPiFE0WbUOfNpHi76qJicU7ZOFS6WUFjZs1YJ9
MOgZiJTAVuGZltDQ/kGZ54VyaHNrv+b4fkHabONh5zLHDcwAjYe4mRE2N2HoCNyN
EjXPafTwKEXN0Bw7W8nakFYYB/AcQds3O341NWXTR1NUTIKgnICAm856OzJwVQ+A
C/eD47kGAtOMT0iBdlnRXAAMTtyt6HiEg83/ayoRKMrdA8NR6f8I8u7qNHas8XLU
U0+O6hFVTnCBDKQH+BHgw+dKZ8qbzd2Fdeph1al7eQ8Xr29iLOQ=
=n5ed
-----END PGP SIGNATURE-----

Closed
?