[PATCH 0/6] gnu: chezmoi: Update to 1.8.10, fix build.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 14 Feb 22:05 +0100
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1707944340.git.sharlatanus@gmail.com
Hi Guix!

This patch services fixes build of Chezmoi the only package in
configuration-management module :-) with gentle version bump which does not
require brand new world of golang packages!

Hopefully, we have more enthusiastic contributor(s) willing to update it to
the latest version.

Sharlatan Hellseher (6):
gnu: go-github-go-git: Remove labels.
gnu: go-github-go-git: Adjust imports.
gnu: Add go-github-com-bmatcuk-doublestar-v2.
gnu: Add go-github-com-google-go-github-v33.
gnu: chezmoi: Sort inputs alphabetically.
gnu: chezmoi: Update to 1.8.10.

gnu/packages/configuration-management.scm | 86 +++++++++++++++--------
gnu/packages/golang-web.scm | 23 ++++++
gnu/packages/golang.scm | 21 ++++++
gnu/packages/version-control.scm | 36 +++++-----
4 files changed, 119 insertions(+), 47 deletions(-)


base-commit: f21a4f492e03065737d002a786da51db501048ab
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:09 +0100
[PATCH 1/6] gnu: go-github-go-git: Remove labels.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
531675b328b3dab3347d3d08203000f1625456a5.1707944340.git.sharlatanus@gmail.com
* gnu/packages/version-control.scm (go-github-go-git) [native-inputs]:
Remove labels.

Change-Id: Icf5eb3902a520e8f1306d72c7cbc533ff45d8cf4
---
gnu/packages/version-control.scm | 34 ++++++++++++++++----------------
1 file changed, 17 insertions(+), 17 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 51754245d3..0092d932f2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3621,23 +3621,23 @@ (define-public go-github-go-git
#t)
#t)))))
(native-inputs
- `(("go-github-com-emirpasic-gods" ,go-github-com-emirpasic-gods)
- ("go-github-com-go-git-gcfg" ,go-github-com-go-git-gcfg)
- ("go-github-com-go-git-go-billy" ,go-github-com-go-git-go-billy)
- ("go-github-com-imdario-mergo" ,go-github-com-imdario-mergo)
- ("go-github-com-jbenet-go-context" ,go-github-com-jbenet-go-context)
- ("go-github-com-kevinburke-ssh-config" ,go-github-com-kevinburke-ssh-config)
- ("go-github-com-mitchellh-go-homedir" ,go-github-com-mitchellh-go-homedir)
- ("go-github-com-sergi-go-diff" ,go-github-com-sergi-go-diff)
- ("go-github-com-xanzy-ssh-agentf" ,go-github-com-xanzy-ssh-agent)
- ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
- ("go-golang-org-x-net" ,go-golang-org-x-net)
- ("go-gopkg-in-warnings" ,go-gopkg-in-warnings)
- ("go-github-com-go-git-go-git-fixtures" ,go-github-com-go-git-go-git-fixtures)
- ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
- ("go-github-com-alcortesm-tgz" ,go-github-com-alcortesm-tgz)
- ("go-golang-org-x-text" ,go-golang-org-x-text)
- ("git" ,git)))
+ (list go-github-com-emirpasic-gods
+ go-github-com-go-git-gcfg
+ go-github-com-go-git-go-billy
+ go-github-com-imdario-mergo
+ go-github-com-jbenet-go-context
+ go-github-com-kevinburke-ssh-config
+ go-github-com-mitchellh-go-homedir
+ go-github-com-sergi-go-diff
+ go-github-com-xanzy-ssh-agent
+ go-golang-org-x-crypto
+ go-golang-org-x-net
+ go-gopkg-in-warnings
+ go-github-com-go-git-go-git-fixtures
+ go-gopkg-in-check-v1
+ go-github-com-alcortesm-tgz
+ go-golang-org-x-text
+ git))
(home-page "https://github.com/go-git/")
(synopsis "Git implementation library")
(description "This package provides a Git implementation library.")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:09 +0100
[PATCH 2/6] gnu: go-github-go-git: Adjust imports.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
551acbb0f78a177b4a2e0a415ddf8254cb782b67.1707944340.git.sharlatanus@gmail.com
* gnu/packages/version-control.scm (go-github-go-git) [native-inputs]:
Move go-github-com-alcortesm-tgz, go-github-com-emirpasic-gods,
go-github-com-go-git-gcfg, go-github-com-go-git-go-billy,
go-github-com-go-git-go-git-fixtures, go-github-com-imdario-mergo,
go-github-com-jbenet-go-context, go-github-com-kevinburke-ssh-config,
go-github-com-mitchellh-go-homedir, go-github-com-sergi-go-diff,
go-github-com-xanzy-ssh-agent, go-golang-org-x-crypto,
go-golang-org-x-net, go-golang-org-x-text, go-gopkg-in-check-v1 and
go-gopkg-in-warnings from here ...
[propagated-inputs]: ... to here.

Change-Id: I9c16fe28dcbbaf7c53e201625f56a04bceb21fcb
---
gnu/packages/version-control.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0092d932f2..715a2cfd7b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3620,10 +3620,12 @@ (define-public go-github-go-git
(invoke git-exe "config" "--global" "user.name" "GitHub Actions")
#t)
#t)))))
- (native-inputs
- (list go-github-com-emirpasic-gods
+ (propagated-inputs
+ (list go-github-com-alcortesm-tgz
+ go-github-com-emirpasic-gods
go-github-com-go-git-gcfg
go-github-com-go-git-go-billy
+ go-github-com-go-git-go-git-fixtures
go-github-com-imdario-mergo
go-github-com-jbenet-go-context
go-github-com-kevinburke-ssh-config
@@ -3632,12 +3634,10 @@ (define-public go-github-go-git
go-github-com-xanzy-ssh-agent
go-golang-org-x-crypto
go-golang-org-x-net
- go-gopkg-in-warnings
- go-github-com-go-git-go-git-fixtures
- go-gopkg-in-check-v1
- go-github-com-alcortesm-tgz
go-golang-org-x-text
- git))
+ go-gopkg-in-check-v1
+ go-gopkg-in-warnings))
+ (native-inputs (list git))
(home-page "https://github.com/go-git/")
(synopsis "Git implementation library")
(description "This package provides a Git implementation library.")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:10 +0100
[PATCH 3/6] gnu: Add go-github-com-bmatcuk-doublestar-v2.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
f9084deed250c40f6d64e489441995c8b388dfe1.1707944340.git.sharlatanus@gmail.com
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar-v2): New variable.

Change-Id: I56d5588a1741a8e6c86320ec07bc86805f34fc91
---
gnu/packages/golang.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 25e9715c79..87ee0d21d2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7545,6 +7545,27 @@ (define-public go-github-com-bmatcuk-doublestar
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
+;; For chezmoi-1.8.10
+(define-public go-github-com-bmatcuk-doublestar-v2
+ (package
+ (inherit go-github-com-bmatcuk-doublestar)
+ (name "go-github-com-bmatcuk-doublestar-v2")
+ (version "2.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmatcuk/doublestar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09ma8a9rhs8dg527vjhdf3lsb6lajaq193m6ksssm2k3qajhpi94"))))
+ (arguments
+ (list
+ #:tests? #f ; tests have more broken parts
+ #:unpack-path "github.com/bmatcuk/doublestar/v2"
+ #:import-path "github.com/bmatcuk/doublestar/v2"))))
+
(define-public go-github-com-dlclark-regexp2
(package
(name "go-github-com-dlclark-regexp2")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:10 +0100
[PATCH 4/6] gnu: Add go-github-com-google-go-github-v33.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
6d0fcc8748354399581cb5d616df5969c24b4f29.1707944340.git.sharlatanus@gmail.com
* gnu/packages/golang-web.scm (go-github-com-google-go-github-v33): New variable.

Change-Id: Ifafa71ea78b2b430f5f907912038bb03333126cf
---
gnu/packages/golang-web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 673d2c2587..11c7f3179b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -692,6 +692,29 @@ (define-public go-github-com-google-go-github
GitHub API v3.")
(license license:bsd-3)))
+;; For chezmoi-1.8.10
+(define-public go-github-com-google-go-github-v33
+ (package
+ (inherit go-github-com-google-go-github)
+ (name "go-github-com-google-go-github-v33")
+ (version "33.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-github")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nzwgvaa9k1ky3sfynib6nhalam9dx66h5lxff334m9kk3rf5nn0"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-google-go-github)
+ ((#:unpack-path _ "github.com/google/go-github/v26")
+ "github.com/google/go-github/v33")
+ ((#:import-path _ "github.com/google/go-github/v26/github")
+ "github.com/google/go-github/v33/github")))))
+
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:10 +0100
[PATCH 5/6] gnu: chezmoi: Sort inputs alphabetically.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
0e781dafb98ed1510fe22c3e97ade26ca53846ae.1707944340.git.sharlatanus@gmail.com
* gnu/packages/configuration-management.scm (chezmoi) [native-inputs]:
Sort alphabetically to ease maintenance.

Change-Id: I22b82ce7163db696c4d9e8484fbe72da086a4139
---
gnu/packages/configuration-management.scm | 42 +++++++++++------------
1 file changed, 21 insertions(+), 21 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 6632f429e2..c1874fef2d 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -50,40 +50,42 @@ (define-public chezmoi
;; We don't need to install the source code for end-user applications.
#:install-source? #f))
(native-inputs
- (list go-github-com-masterminds-sprig
- go-github-com-masterminds-goutils
- go-github-com-masterminds-semver
- go-github-com-google-uuid
- go-github-com-huandu-xstrings
- go-github-com-imdario-mergo
- go-github-com-mitchellh-reflectwalk
- go-github-com-mitchellh-copystructure
+ (list go-etcd-io-bbolt
+ go-github-com-alecthomas-chroma
+ go-github-com-aymerick-douceur
go-github-com-bmatcuk-doublestar
go-github-com-charmbracelet-glamour
- go-github-com-alecthomas-chroma
+ go-github-com-chris-ramon-douceur
go-github-com-coreos-go-semver
go-github-com-danwakefield-fnmatch
go-github-com-dlclark-regexp2
- go-github-go-git
+ go-github-com-godbus-dbus
go-github-com-google-go-github
go-github-com-google-go-querystring
+ go-github-com-google-goterm
go-github-com-google-renameio
- go-github-com-microcosm-cc-bluemonday
- go-github-com-aymerick-douceur
- go-github-com-chris-ramon-douceur
+ go-github-com-google-uuid
go-github-com-gorilla-css
+ go-github-com-huandu-xstrings
+ go-github-com-imdario-mergo
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-masterminds-goutils
+ go-github-com-masterminds-semver
+ go-github-com-masterminds-sprig
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-github-com-microcosm-cc-bluemonday
+ go-github-com-mitchellh-copystructure
+ go-github-com-mitchellh-reflectwalk
go-github-com-muesli-reflow-ansi
- go-github-com-muesli-reflow-wordwrap
go-github-com-muesli-reflow-indent
go-github-com-muesli-reflow-padding
+ go-github-com-muesli-reflow-wordwrap
go-github-com-muesli-termenv
- go-github-com-google-goterm
- go-github-com-lucasb-eyer-go-colorful
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-runewidth
go-github-com-olekukonko-tablewriter
go-github-com-pelletier-go-toml
go-github-com-pkg-diff
+ go-github-com-rogpeppe-go-internal
go-github-com-sergi-go-diff
go-github-com-spf13-cobra
go-github-com-spf13-viper
@@ -93,12 +95,10 @@ (define-public chezmoi
go-github-com-twpayne-go-xdg
go-github-com-yuin-goldmark
go-github-com-zalando-go-keyring
- go-github-com-godbus-dbus
- go-etcd-io-bbolt
+ go-github-go-git
go-golang-org-x-crypto
go-golang-org-x-net
go-golang-org-x-oauth2
- go-github-com-rogpeppe-go-internal
go-gopkg-in-errgo-fmt-errors))
(home-page "https://www.chezmoi.io/")
(synopsis "Personal configuration files manager")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Feb 22:10 +0100
[PATCH 6/6] gnu: chezmoi: Update to 1.8.10.
(address . 69136@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
81918de85fa99cb5da4b4602f6410e6039b5458e.1707944340.git.sharlatanus@gmail.com
* gnu/packages/configuration-management.scm (chezmoi): Update to 1.8.10.
[arguments] <#:phases>: Add 'remove-failing-test-scripts phase, deleting
testdata scripts requiring additional programs.
[native-inputs]: Remove go-github-com-bmatcuk-doublestar and
go-github-com-google-go-github; add
go-github-com-bmatcuk-doublestar-v2,
go-github-com-google-go-github-v33, and go-golang-org-x-term.

Change-Id: Ia0b9b7e4dd00e99bc8150816c46b456cc272b25c
---
gnu/packages/configuration-management.scm | 44 ++++++++++++++++++-----
1 file changed, 36 insertions(+), 8 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index c1874fef2d..34b7876138 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -32,9 +32,7 @@ (define-module (gnu packages configuration-management)
(define-public chezmoi
(package
(name "chezmoi")
- ;; XXX: Make sure 7f238faa61e46d79b54d4d0ea8f0b5fc27db84b2 applied before
- ;; version update, which should fix @code{password-store} integration.
- (version "1.8.1")
+ (version "1.8.10")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -43,24 +41,53 @@ (define-public chezmoi
(file-name (git-file-name name version))
(sha256
(base32
- "1b8y0wq3myhvjdnwl0i4x85iil7i7kmsjajvbw1a47afm83jkbaw"))))
+ "0ildvlq7v8vnw74y4fgnv3hpq49bpl6zh1wmakfh46crwg7ffmjb"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/twpayne/chezmoi"
- ;; We don't need to install the source code for end-user applications.
- #:install-source? #f))
+ #:install-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Remove test script which expect additional user's programs available
+ ;; in the PATH. The testdata directory is removed in the latest version
+ ;; (2.46.1) of the program.
+ (add-after 'unpack 'remove-failing-test-scripts
+ (lambda* (#:key import-path #:allow-other-keys)
+ (for-each (lambda (f)
+ (delete-file (string-append "src/" import-path "/testdata/scripts/" f)))
+ '("bitwarden.txt"
+ "cd.txt"
+ "cd_unix.txt"
+ "completion.txt"
+ "diff.txt"
+ "edit.txt"
+ "editconfig.txt"
+ "git.txt"
+ "gopass.txt"
+ "keepassxc.txt"
+ "lastpass.txt"
+ "onepassword.txt"
+ "pass.txt"
+ "runscriptdir_unix.txt"
+ "script_unix.txt"
+ "secretgeneric.txt"
+ "secretgopass.txt"
+ "secretkeepassxc.txt"
+ "secretlastpass.txt"
+ "secretonepassword.txt"
+ "secretpass.txt")))))))
(native-inputs
(list go-etcd-io-bbolt
go-github-com-alecthomas-chroma
go-github-com-aymerick-douceur
- go-github-com-bmatcuk-doublestar
+ go-github-com-bmatcuk-doublestar-v2
go-github-com-charmbracelet-glamour
go-github-com-chris-ramon-douceur
go-github-com-coreos-go-semver
go-github-com-danwakefield-fnmatch
go-github-com-dlclark-regexp2
go-github-com-godbus-dbus
- go-github-com-google-go-github
+ go-github-com-google-go-github-v33
go-github-com-google-go-querystring
go-github-com-google-goterm
go-github-com-google-renameio
@@ -99,6 +126,7 @@ (define-public chezmoi
go-golang-org-x-crypto
go-golang-org-x-net
go-golang-org-x-oauth2
+ go-golang-org-x-term
go-gopkg-in-errgo-fmt-errors))
(home-page "https://www.chezmoi.io/")
(synopsis "Personal configuration files manager")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 20 Feb 01:10 +0100
[PATCH 0/6] gnu: chezmoi: Update to 1.8.10, fix build.
(address . 69136-done@debbugs.gnu.org)
877cj0hu73.fsf@gmail.com
Pushed as d3d87b93d2..193a01d73f to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXT7eAACgkQdtcnv/Ys
0rXQmRAAtTHqLxcKe060tlb3jIrkz81M25ok5vbaJ51L6jKcYlL47FuOJ6AfEUSf
9BFFbRx8/NwBOaA+wwQ3d+USTK4LXmUYIEKlt7CdyaVwUwmpbC4Vxkhmn7dgw9hH
Ea16wWUod6BWEgaqQCHueu5j0KMCunCi/gUxZO/ecMnbJ6eW7GwNpDbUHd7wzg+D
9nFN8umnSjN1ke74kLLvFZIDaEkKpA5yOmV0wR0htFuTn1sMo/NDJ58/lyRqVIEb
hFgQqK8bKBwCsjX6OIC1N24LXKd2T0jxWDYEI7HVNZW9m5k1TxcZv0h3nN536hNI
/IU8Wczw/Nw78zqUYK7j74+iuECkKFMpVgti8Yjsng/tu7Sp7jDEBGKYDYfF+tJt
ygPMzbqtXRCV9lX2raNBx8p4k6Cv9m54PqzNGPZj5Ex5hICp33pDxYFzEQU4upPQ
epYkE/IRWMScaRIlOz2ET/Puwp8rC3KXoU+RyahvA4pr0GiYL5VZ0NicbZpgIIoK
UvPXebuC6o55ZwVtx6vk11ihv5zw4KZf8dNwys+F/5CVZdKW9fbyHINbilwM0MTM
kQF91EcajGP23Rt240wdR5hal1mH5sJ0DXo76hvK2toRaH/E3nNuamhWkkOD1Cea
2vH6wL/isOHMLuXOeQ59OdWD3froICVBEK3WZR6Q9HhVhfkcMTQ=
=joDx
-----END PGP SIGNATURE-----

Closed
?