[PATCH] gnu: go-github-com-oneofone-xxhash: Remove benchmarks.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 11 Feb 12:17 +0100
(address . guix-patches@gnu.org)
87o7cn9rde.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash)[source]: Remove benchmarks.
---
gnu/packages/golang.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..ccbd9bf8f4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10225,7 +10225,9 @@ (define-public go-github-com-oneofone-xxhash
(file-name (git-file-name name version))
(sha256
(base32
- "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
+ "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "benchmarks"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/OneOfOne/xxhash"))

base-commit: b6439fc5f800b5d22d48192bc347be794f050329
--
2.42.0
T
T
Troy Figiel wrote on 11 Feb 12:17 +0100
[PATCH v2] gnu: go-github-com-oneofone-xxhash: Remove benchmarks.
(address . 69047@debbugs.gnu.org)
87zfw5bcco.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash): Remove benchmarks.
[arguments]<#:phases>: Add remove-benchmarks phase.
---
gnu/packages/golang.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..2d52dbaa19 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10228,7 +10228,13 @@ (define-public go-github-com-oneofone-xxhash
"0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/OneOfOne/xxhash"))
+ (list
+ #:import-path "github.com/OneOfOne/xxhash"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmarks")))))))
(home-page "https://github.com/OneOfOne/xxhash")
(synopsis "Go implementation of xxHash")
(description "This is a native Go implementation of the

base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
--
2.42.0
S
S
Sharlatan Hellseher wrote on 13 Feb 22:37 +0100
[PATCH] gnu: go-github-com-oneofone-xxhash: Remove benchmarks.
(address . 69047-done@debbugs.gnu.org)
87eddgoxjv.fsf@gmail.com
Hi,

Pushed as 73867181830f5cb8d885a5404147ef675b1db707 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXL4SQACgkQdtcnv/Ys
0rVtSA//Zi6FgVZ6j/nlfnfXkSx/I4+Qy2NF/ySozg1Ck+AtKKnBBtuk3W+rD2nX
DRXdPndecNRmDV88CHFxrPYp/xlxLFWsqeP+tI1JNbCbPaXGaDc8olC9R15wxI6Z
V7vR4ozYhdnRm5+3nZ9QoEAJAeeEYEa5LywW42aZx4eU/o/GH0ObtsfbKqZoQPeq
K9mB+XDiBKf9m3IeUvrJsDjrmawBekkSVTY7N+KtWg/X7Rc87YTUX72i+3GZLx4h
ZB7WVvstW094T0xbjuSkab5cKwXzBVKV3sCq6NCRf5i2ju6nU2OIikijY/Dscg+w
pX0/amnd/vr1HpvQxu+V8CyxSY19wdWi2fKMjNjgL5bm8qpioACAeh8MI7uJkuc/
HDBRytZa9GdTB+d1mngSpdx1ij0IORkj7wpU+8ajtGG6Yue4aiA2yWmdM1Q/BkK3
rZBn8UtydEzXSMGMN4Bfnk+32pJZfvUfSPdzJUhAINAC5IZMx1ARB7pDjOvdCh8R
foBO0XbElMhAkLRhdan+O24eDKWFN41PlnjmsIBb52ytFmcSCKtrtM0aiSU/xRsM
zH7l9YaJW05qOYPhyK6tmgPCfr2CYOzWrB+i2Idfg4UOFOoX0EejlSdWAA0yo/Rn
RvJmoM5tOF7Qva5kZ0jg+ehbb2hKK6fMqb5vTMdoJ1MDNceOM6E=
=VQUD
-----END PGP SIGNATURE-----

Closed
?