[PATCH 0/2] Deprecate the go-etcd-io-bbolt variable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 10 Feb 17:57 +0100
(address . guix-patches@gnu.org)
87bk8ob6cd.fsf@troyfigiel.com
This patch series removes a duplicate variable. We move go-go-etcd-io-bbolt to
gnu/packages/golang.scm and deprecate go-etcd-io-bbolt. Copyright did not need
to be updated.

I decided to keep go-go-etcd-io-bbolt, because this name follows the
conventions set by the Go importer.

Troy Figiel (2):
gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang).
gnu: Deprecate the go-etcd-io-bbolt variable.

gnu/packages/configuration-management.scm | 2 +-
gnu/packages/databases.scm | 28 -----------------
gnu/packages/golang.scm | 38 ++++++++++++++---------
3 files changed, 24 insertions(+), 44 deletions(-)


base-commit: e257de4365b24a84f39813aea2e8b4ab6259f283
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 17:40 +0100
[PATCH 1/2] gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang).
(address . 69015@debbugs.gnu.org)
878r3sb4x7.fsf@troyfigiel.com
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang.scm: ... to here.
---
gnu/packages/databases.scm | 28 ----------------------------
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
2 files changed, 28 insertions(+), 28 deletions(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 903088ed4b..0345505ec1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2946,34 +2946,6 @@ (define-public libpqxx
(home-page "https://pqxx.org/")
(license license:bsd-3)))
-(define-public go-go-etcd-io-bbolt
- (package
- (name "go-go-etcd-io-bbolt")
- (version "1.3.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"
- ;; Extending the test timeout to 30 minutes still times out on aarch64.
- #:tests? ,(not target-arm?)))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://go.etcd.io/bbolt")
- (synopsis "Embedded key/value database for Go")
- (description "Bolt is a pure Go key/value store inspired by Howard Chu's
-LMDB project. The goal of the project is to provide a simple, fast, and
-reliable database for projects that don't require a full database server such as
-Postgres or MySQL.")
- (license license:expat)))
-
(define-public python-peewee
(package
(name "python-peewee")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..2b5a447c5d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9328,6 +9328,34 @@ (define-public go-github-com-zclconf-go-cty
configuration languages, but other uses may be possible too.")
(license license:expat)))
+(define-public go-go-etcd-io-bbolt
+ (package
+ (name "go-go-etcd-io-bbolt")
+ (version "1.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/bbolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "go.etcd.io/bbolt"
+ ;; Extending the test timeout to 30 minutes still times out on aarch64.
+ #:tests? ,(not target-arm?)))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://go.etcd.io/bbolt")
+ (synopsis "Embedded key/value database for Go")
+ (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project. The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server such as
+Postgres or MySQL.")
+ (license license:expat)))
+
(define-public go-etcd-io-bbolt
(package
(name "go-etcd-io-bbolt")
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 17:56 +0100
[PATCH 2/2] gnu: Deprecate the go-etcd-io-bbolt variable.
(address . 69015@debbugs.gnu.org)
877cjcb4ws.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-etcd-io-bbolt): Rename to "go-go-etcd-io-bbolt".
(go-etcd-io-bbolt): Define as deprecated by "go-go-etcd-io-bbolt".
* gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Add
"go-go-etcd-io-bbolt". Remove "go-etcd-io-bbolt".
---
gnu/packages/configuration-management.scm | 2 +-
gnu/packages/golang.scm | 22 +---------------------
2 files changed, 2 insertions(+), 22 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 296f48dcd5..52c85dddeb 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -93,7 +93,7 @@ (define-public chezmoi
go-github-com-yuin-goldmark
go-github-com-zalando-go-keyring
go-github-com-godbus-dbus
- go-etcd-io-bbolt
+ go-go-etcd-io-bbolt
go-golang-org-x-crypto
go-golang-org-x-net
go-golang-org-x-oauth2
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b5a447c5d..019bf4dad2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9357,27 +9357,7 @@ (define-public go-go-etcd-io-bbolt
(license license:expat)))
(define-public go-etcd-io-bbolt
- (package
- (name "go-etcd-io-bbolt")
- (version "1.3.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
- (synopsis "Low-level key/value store in Go")
- (description "This package implements a low-level key/value store in Go.")
- (license license:expat)))
+ (deprecated-package "go-etcd-io-bbolt" go-go-etcd-io-bbolt))
(define-public go-github-com-bwesterb-go-ristretto
(package
--
2.42.0
S
S
Sharlatan Hellseher wrote on 10 Feb 21:57 +0100
[PATCH 0/2] Deprecate the go-etcd-io-bbolt variable.
(address . 69015@debbugs.gnu.org)
CAO+9K5rPnZRdPq5koYvv95fUdY=+kwh6sk0qEORgSzjxg_Y+KA@mail.gmail.com
Hi Troy,

Thank you for the patch.

I'm in process of splitting monolithic golang.scm into logical
modules e.g. golang-web golang-crypto golang-xyz.

May you use one of them and try to avoid to add to golang.scm
as it eventually will remain just versions of go.

Thanks,
Oleg
Attachment: file
T
T
Troy Figiel wrote on 10 Feb 22:16 +0100
(address . guix-patches@gnu.org)
7c2dffe6-534c-4dd0-9e7b-52a79610ac07@troyfigiel.com
Hi Oleg,

I missed golang-xyz. I will move it to there.

Best wishes,

Troy

On 2024-02-10 21:57, Sharlatan Hellseher wrote:
Toggle quote (12 lines)
> Hi Troy,
>
> Thank you for the patch.
>
> I'm in process of splitting monolithic golang.scm into logical
> modules e.g. golang-web golang-crypto golang-xyz.
>
> May you use one of them and try to avoid to add to golang.scm
> as it eventually will remain just versions of go. 
>
> Thanks,
> Oleg
T
T
Troy Figiel wrote on 10 Feb 22:55 +0100
[PATCH v2 0/3] Deprecate the go-etcd-io-bbolt variable.
(address . 69015@debbugs.gnu.org)
871q9kaso8.fsf@troyfigiel.com
Second set of patches. Oleg Pykhalov actually did not have a copyright in
golang.scm although he originally added the go-etcd-io-bbolt package. I added
his copyright to golang-xyz.scm.

Troy Figiel (3):
gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
gnu: go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
gnu: Deprecate the go-etcd-io-bbolt variable.

gnu/packages/configuration-management.scm | 3 +-
gnu/packages/databases.scm | 28 ------------------
gnu/packages/golang-xyz.scm | 35 +++++++++++++++++++++++
gnu/packages/golang.scm | 23 ---------------
4 files changed, 37 insertions(+), 52 deletions(-)


base-commit: e257de4365b24a84f39813aea2e8b4ab6259f283
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 22:28 +0100
[PATCH 1/3] gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
(address . 69015@debbugs.gnu.org)
87zfw89e17.fsf@troyfigiel.com
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.
---
gnu/packages/databases.scm | 28 ----------------------------
gnu/packages/golang-xyz.scm | 29 +++++++++++++++++++++++++++++
2 files changed, 29 insertions(+), 28 deletions(-)

Toggle diff (86 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 903088ed4b..0345505ec1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2946,34 +2946,6 @@ (define-public libpqxx
(home-page "https://pqxx.org/")
(license license:bsd-3)))
-(define-public go-go-etcd-io-bbolt
- (package
- (name "go-go-etcd-io-bbolt")
- (version "1.3.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"
- ;; Extending the test timeout to 30 minutes still times out on aarch64.
- #:tests? ,(not target-arm?)))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://go.etcd.io/bbolt")
- (synopsis "Embedded key/value database for Go")
- (description "Bolt is a pure Go key/value store inspired by Howard Chu's
-LMDB project. The goal of the project is to provide a simple, fast, and
-reliable database for projects that don't require a full database server such as
-Postgres or MySQL.")
- (license license:expat)))
-
(define-public python-peewee
(package
(name "python-peewee")
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8823ae21c6..d52cbedd9c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -196,6 +197,34 @@ (define-public go-github-com-nats-io-nuid
very fast, and tries to be entropy pool friendly.")
(license license:asl2.0)))
+(define-public go-go-etcd-io-bbolt
+ (package
+ (name "go-go-etcd-io-bbolt")
+ (version "1.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/bbolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "go.etcd.io/bbolt"
+ ;; Extending the test timeout to 30 minutes still times out on aarch64.
+ #:tests? ,(not target-arm?)))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://go.etcd.io/bbolt")
+ (synopsis "Embedded key/value database for Go")
+ (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project. The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server such as
+Postgres or MySQL.")
+ (license license:expat)))
+
(define-public go-go-uber-org-automaxprocs
(package
(name "go-go-uber-org-automaxprocs")
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 22:29 +0100
[PATCH 2/3] gnu: go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
(address . 69015@debbugs.gnu.org)
87y1bs9dzy.fsf@troyfigiel.com
* gnu/packages/configuration-management.scm: Add (gnu packages golang-xyz) to used modules.
* gnu/packages/databases.scm (go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.
---
gnu/packages/configuration-management.scm | 1 +
gnu/packages/golang-xyz.scm | 26 +++++++++++++++++++++++
gnu/packages/golang.scm | 23 --------------------
3 files changed, 27 insertions(+), 23 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 296f48dcd5..aedf4f38e4 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -22,6 +22,7 @@ (define-module (gnu packages configuration-management)
#:use-module (guix git-download)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages version-control)
#:use-module (gnu packages textutils)
#:use-module ((guix licenses) #:prefix license:)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d52cbedd9c..fe46a87093 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -39,6 +42,29 @@ (define-module (gnu packages golang-xyz)
;;;
;;; Code:
+(define-public go-etcd-io-bbolt
+ (package
+ (name "go-etcd-io-bbolt")
+ (version "1.3.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/bbolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "go.etcd.io/bbolt"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
+ (synopsis "Low-level key/value store in Go")
+ (description "This package implements a low-level key/value store in Go.")
+ (license license:expat)))
+
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..5d3b39d1a9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9328,29 +9328,6 @@ (define-public go-github-com-zclconf-go-cty
configuration languages, but other uses may be possible too.")
(license license:expat)))
-(define-public go-etcd-io-bbolt
- (package
- (name "go-etcd-io-bbolt")
- (version "1.3.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
- (synopsis "Low-level key/value store in Go")
- (description "This package implements a low-level key/value store in Go.")
- (license license:expat)))
-
(define-public go-github-com-bwesterb-go-ristretto
(package
(name "go-github-com-bwesterb-go-ristretto")
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 22:31 +0100
[PATCH 3/3] gnu: Deprecate the go-etcd-io-bbolt variable.
(address . 69015@debbugs.gnu.org)
87wmrc9dju.fsf@troyfigiel.com
* gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Add
"go-go-etcd-io-bbolt". Remove "go-etcd-io-bbolt".
* gnu/packages/golang-xyz.scm (go-etcd-io-bbolt): Rename to "go-go-etcd-io-bbolt".
(go-etcd-io-bbolt): Define as deprecated by "go-go-etcd-io-bbolt".
---
gnu/packages/configuration-management.scm | 2 +-
gnu/packages/golang-xyz.scm | 26 +++--------------------
2 files changed, 4 insertions(+), 24 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index aedf4f38e4..532aafd3ac 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -94,7 +94,7 @@ (define-public chezmoi
go-github-com-yuin-goldmark
go-github-com-zalando-go-keyring
go-github-com-godbus-dbus
- go-etcd-io-bbolt
+ go-go-etcd-io-bbolt
go-golang-org-x-crypto
go-golang-org-x-net
go-golang-org-x-oauth2
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fe46a87093..ffa9ad9024 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -42,29 +42,6 @@ (define-module (gnu packages golang-xyz)
;;;
;;; Code:
-(define-public go-etcd-io-bbolt
- (package
- (name "go-etcd-io-bbolt")
- (version "1.3.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
- (synopsis "Low-level key/value store in Go")
- (description "This package implements a low-level key/value store in Go.")
- (license license:expat)))
-
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")
@@ -251,6 +228,9 @@ (define-public go-go-etcd-io-bbolt
Postgres or MySQL.")
(license license:expat)))
+(define-public go-etcd-io-bbolt
+ (deprecated-package "go-etcd-io-bbolt" go-go-etcd-io-bbolt))
+
(define-public go-go-uber-org-automaxprocs
(package
(name "go-go-uber-org-automaxprocs")
--
2.42.0
T
T
Troy Figiel wrote on 10 Feb 23:30 +0100
Re: [bug#69015] [PATCH 0/2] Deprecate the go-etcd-io-bbolt variable.
(address . guix-patches@gnu.org)
b44a37c5-7a3d-4fe4-a677-3988064374fb@troyfigiel.com
Hi Oleg,

Because I am deprecating go-etcd-io-bbolt in favour of
go-go-etcd-io-bbolt, its definition has to appear after
go-go-etcd-io-bbolt. I am aware alphabetical order is preferred, but in
this case that was not possible.

And of course I forgot to add my own copyright again...

Best wishes,

Troy
S
S
Sharlatan Hellseher wrote on 23 Feb 09:06 +0100
[PATCH 0/2] Deprecate the go-etcd-io-bbolt variable.
(address . 69015-done@debbugs.gnu.org)
8734tj8v07.fsf@gmail.com
Hi Troy,

go-team branch is initiated!


I completely removed go-etcd-io-bbolt as it was only used by Chezmoi,
and it had been broken for a while without any reports in the bug
tracker to fix it. This lack of activity gave me confidence that it was
not being used much.

2 patches are squashed and amended:
- [PATCH 3/3] gnu: Deprecate the go-etcd-io-bbolt variable.
- [PATCH 2/3] gnu: go-etcd-io-bbolt: Move to (gnu packages golang-xyz).

Toggle snippet (11 lines)
gnu: Remove go-etcd-io-bbolt.

go-go-etcd-io-bbolt and go-etcd-io-bbolt are the same version and source
packages. This change removes go-etcd-io-bbolt and keeps
go-go-etcd-io-bbolt.

* gnu/packages/configuration-management.scm (chezmoi) [native-inputs]:
Add go-go-etcd-io-bbolt. Remove go-etcd-io-bbolt.
* gnu/packages/golang.scm (go-etcd-io-bbolt): Remove variable.

Pushed as d5d87a4e1d..b482b25d00 to go-team.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXYUggACgkQdtcnv/Ys
0rWaHg/9GqoQP5RqB9p/SR4CIH8+1hy3ldtvBN9O8nlgwBBWA2mwRpEPy976W2a4
ra0Fm/92xsVKEZYFeZWKpKiyQXfq22ybfRJAnMd+6V39Ak9eHRfxBUm9Lg21Hgtb
Iiv8y9T7eALczAtSYp6XdrnNcSKfoHa5Dyyi8zY7Yk6m9LxiGA4TkU12d9hK1C/v
cTcJA7iOVGkMX9MsPPrgtZYuNCt0devkTSHXVjoYkvKX3U+ls6r6HcpY4awuUHJs
i+dzqNyOAfq3SJBuYNg3B2dS3VFc7j7uhBtUqo/oFo0YWBdOGMhQXxIEjE5fRV+S
EUDwJG0ajLtIcn9dziRWpJZ5mrGeKdlvun5XIXAPiPd+Y+O27CSr1YxdG46BeC8Q
vC/xCY7Bomy0xCze3cdt7HmvLvQeRrdlyGFR6Ji8ZgNHWaNn0HBtFURlD+ESy4Ba
8NqNGqtUkI2Vn3zGhqag2rWdW1qq3m59Ow2M4WePFER5Tkj+mt6oy4gSD+t4eO9w
8HGEAgX2a5p2b0VenIQZlgKKqGU02hKp5Pva1ojaBci0+4AdM9KxhT0UnXZZ2GtI
DqmdFu9ixoHlMZ/FMHqo7r+paqeVapya4Ub5bIUsUrhOjBG5xCpbJsFl+OvxiOAk
JdMMwZwuAXNZ2EN52cUttJz0TIzKUsMU8K7mrx9i3DNJnwVtjto=
=jJiv
-----END PGP SIGNATURE-----

Closed
?