[PATCH] gnu: ghc-9.2: Make Cabal respect GHC_PACKAGE_PATH

  • Open
  • quality assurance status badge
Details
3 participants
  • Lars-Dominik Braun
  • Saku Laesvuori
  • soeren
Owner
unassigned
Submitted by
soeren
Severity
normal
S
S
soeren wrote on 19 Dec 2023 11:05
(address . guix-patches@gnu.org)
6fccf7c2e9095cb27cb93644f3bd4a92f4687d13.1702980332.git.soeren@soeren-tempel.net
From: Sören Tempel <soeren@soeren-tempel.net>

**tl;dr** Applying this patch makes Cabal work in Guix environments
and ensures that Cabal picks up Haskell packages installed via Guix.

Guix makes heavy use of GHC_PACKAGE_PATH to make GHC pickup Haskell
packages installed via the Guix package manager. The environment
variable is set using native-search-paths from the GHC packages.

Unfortunately, upstream Cabal does presently not respect
GHC_PACKAGE_PATH. If this environment variable is set, `cabal build`
and other commands will terminate. For building packages, Guix does
not make much use of cabal-install hence this is not as big of an
issue. However, cabal-install does therefore presently not work
out-of-the-box in environments created by Guix. For example,
in `guix shell` environments. This makes it essentially impossible
to use Guix for setting up development environments for Haskell software.

Cabal upstream is aware of this issue and a patch exists to workaround
this problem. The patch is currently not merged upstream due to issues
related to reconfiguration (changing GHC_PACKAGE_PATH between `cabal
configure` and `cabal build`). However, I would argue that this edge
case is not that relevant for Guix and therefore propose including
this patch with the Cabal Guix package. As outlined above, cabal-install
is not usable by default presently, and I would therefore argue that
this is a major improvement over the current situation. I am willing to
work with Cabal upstream to have this issue fixed upstream eventually.

Note that this requires patching the GHC package instead of the
cabal-install package as Guix uses the version of the Cabal package


* gnu/packages/haskell-apps.scm (cabal-install): Include patch
to support the GHC_PACKAGE_PATH environment variable.

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
gnu/packages/haskell.scm | 3 +-
.../ghc-9.2-cabal-support-package-path.patch | 67 +++++++++++++++++++
2 files changed, 69 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch

Toggle diff (89 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 62815efbb1..0cd0734d6d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1348,7 +1348,8 @@ (define-public ghc-9.2
(sha256
(base32
"07028i0hm74svvq9b3jpkczaj6lsdgn3hgr4wa7diqiq3dypj1h6"))
- (patches (search-patches "ghc-9.2-glibc-2.33-link-order.patch"))))
+ (patches (search-patches "ghc-9.2-glibc-2.33-link-order.patch"
+ "ghc-9.2-cabal-support-package-path.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:phases phases '%standard-phases)
diff --git a/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch b/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch
new file mode 100644
index 0000000000..9e4c405c50
--- /dev/null
+++ b/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch
@@ -0,0 +1,67 @@
+Without this patch, Cabal terminates if GHC_PACKAGE_PATH is set. This is
+an annoyance with Guix as it makes heavy use of GHC_PACKAGE_PATH to have
+GHC pickup Haskell package installed via Guix. Therefore, Cabal does
+presently not work by default in environments created by Guix. This is
+a workaround which makes Cabal respect GHC_PACKAGE_PATH.
+
+Taken from https://github.com/haskell/cabal/issues/3728
+
+diff -upr a/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs b/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs
+--- a/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs 2022-11-06 20:41:17.000000000 +0100
++++ b/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs 2023-12-18 14:34:15.148911717 +0100
+@@ -71,6 +71,7 @@ module Distribution.Simple.GHC (
+ ) where
+
+ import Prelude ()
++import Distribution.Compat.Environment (lookupEnv)
+ import Distribution.Compat.Prelude
+
+ import qualified Distribution.Simple.GHC.Internal as Internal
+@@ -117,7 +118,7 @@ import System.Directory
+ , canonicalizePath, removeFile, renameFile, getDirectoryContents )
+ import System.FilePath ( (</>), (<.>), takeExtension
+ , takeDirectory, replaceExtension
+- ,isRelative )
++ , isRelative, searchPathSeparator )
+ import qualified System.Info
+ #ifndef mingw32_HOST_OS
+ import System.Posix (createSymbolicLink)
+@@ -333,9 +334,11 @@ getInstalledPackages :: Verbosity -> Com
+ -> ProgramDb
+ -> IO InstalledPackageIndex
+ getInstalledPackages verbosity comp packagedbs progdb = do
+- checkPackageDbEnvVar verbosity
+ checkPackageDbStack verbosity comp packagedbs
+- pkgss <- getInstalledPackages' verbosity packagedbs progdb
++ envPackageDBs <-
++ maybe [] (map SpecificPackageDB . unintersperse searchPathSeparator)
++ <$> lookupEnv "GHC_PACKAGE_PATH"
++ pkgss <- getInstalledPackages' verbosity (envPackageDBs ++ packagedbs) progdb
+ index <- toPackageIndex verbosity pkgss progdb
+ return $! hackRtsPackage index
+
+@@ -405,10 +408,6 @@ getUserPackageDB _verbosity ghcProg plat
+ packageConfFileName = "package.conf.d"
+ ghcVersion = fromMaybe (error "GHC.getUserPackageDB: no ghc version") $ programVersion ghcProg
+
+-checkPackageDbEnvVar :: Verbosity -> IO ()
+-checkPackageDbEnvVar verbosity =
+- Internal.checkPackageDbEnvVar verbosity "GHC" "GHC_PACKAGE_PATH"
+-
+ checkPackageDbStack :: Verbosity -> Compiler -> PackageDBStack -> IO ()
+ checkPackageDbStack verbosity comp =
+ if flagPackageConf implInfo
+@@ -461,8 +460,11 @@ getInstalledPackagesMonitorFiles :: Verb
+ -> ProgramDb
+ -> [PackageDB]
+ -> IO [FilePath]
+-getInstalledPackagesMonitorFiles verbosity platform progdb =
+- traverse getPackageDBPath
++getInstalledPackagesMonitorFiles verbosity platform progdb packageDBs = do
++ envPackageDBs <-
++ maybe [] (map SpecificPackageDB . unintersperse searchPathSeparator)
++ <$> lookupEnv "GHC_PACKAGE_PATH"
++ traverse getPackageDBPath (envPackageDBs ++ packageDBs)
+ where
+ getPackageDBPath :: PackageDB -> IO FilePath
+ getPackageDBPath GlobalPackageDB =

base-commit: 29c94dd522833b2603a651c14a5b06120bcf1829
S
S
Sören Tempel wrote on 6 Jan 10:09 +0100
(address . 67896@debbugs.gnu.org)(address . lars@6xq.net)
3K6E1L1WLK573.223FCVRGQCGWL@8pit.net
If we don't want to patch the vendored Cabal version shipped by GHC
itself, we could also explore packaging Cabal separately and making
cabal-install depend on that. However, given that Setup.hs also uses
Distribution.Simple and that there are several places in Guix itself
where we need to unset GHC_PACKAGE_PATH atm, I personally believe it
to be preferable to fix the vendored version.

Lars, what do you think?

Greetings
Sören
L
L
Lars-Dominik Braun wrote on 6 Jan 15:49 +0100
(name . Sören Tempel)(address . soeren@soeren-tempel.net)(address . 67896@debbugs.gnu.org)
ZZloY0SubqGqVa_O@noor.fritz.box
Hi,

sorry for the delay, I just tried your patch and it works well combining
a local cabal project and libraries/GHC from Guix. I’d say this is a
massive improvement, so I’d like to ship it with Guix. However this
is a world rebuilding change, so I’ll push it to the haskell-team
branch and probably wait for #67921 to be ready before it can hit master.

One minor issue: If you add a patch file, also add it to gnu/local.mk.

Toggle quote (5 lines)
> However, given that Setup.hs also uses
> Distribution.Simple and that there are several places in Guix itself
> where we need to unset GHC_PACKAGE_PATH atm, I personally believe it
> to be preferable to fix the vendored version.

Which locations are you referring to?

Cheers,
Lars
S
S
Sören Tempel wrote on 6 Jan 16:07 +0100
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 67896@debbugs.gnu.org)
3ELNY2F2SV7KX.2JFO7970OJNKU@8pit.net
Hi,

Lars-Dominik Braun <lars@6xq.net> wrote:
Toggle quote (6 lines)
> sorry for the delay, I just tried your patch and it works well combining
> a local cabal project and libraries/GHC from Guix. I’d say this is a
> massive improvement, so I’d like to ship it with Guix. However this
> is a world rebuilding change, so I’ll push it to the haskell-team
> branch and probably wait for #67921 to be ready before it can hit master.

Yea, glad to hear that. Waiting for #67921 is fine by me. Should I also
prepare a patch for the GHC 9.4 package then? Currently this is only GHC
9.2.

Toggle quote (2 lines)
> One minor issue: If you add a patch file, also add it to gnu/local.mk.

Oh, I wasn't aware. Thanks for pointing that out, will keep it in mind
for future patches!

Toggle quote (7 lines)
> > However, given that Setup.hs also uses
> > Distribution.Simple and that there are several places in Guix itself
> > where we need to unset GHC_PACKAGE_PATH atm, I personally believe it
> > to be preferable to fix the vendored version.
>
> Which locations are you referring to?

L
L
Lars-Dominik Braun wrote on 6 Jan 16:51 +0100
(name . Sören Tempel)(address . soeren@soeren-tempel.net)(address . 67896@debbugs.gnu.org)
ZZl2_OMTbD9bovN1@noor.fritz.box
Hi,

Toggle quote (4 lines)
> Yea, glad to hear that. Waiting for #67921 is fine by me. Should I also
> prepare a patch for the GHC 9.4 package then? Currently this is only GHC
> 9.2.

as far as I see 9.4 inherits from 9.2 and thus this patch should be
applied automatically.

Toggle quote (6 lines)
> I just grep'ed for GHC_PACKAGE_PATH, e.g.:
>
> * https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/virtualization.scm#n784
> * https://git.savannah.gnu.org/cgit/guix.git/tree/guix/build/haskell-build-system.scm#n111
> * https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/haskell.scm#n963

Ah, I see. I’ll check whether this is still necessary.

Cheers,
Lars
S
S
Saku Laesvuori wrote on 6 Jan 22:16 +0100
Re: [bug#67896] [PATCH] gnu: ghc-9.2: Make Cabal respect GHC_PACKAGE_PATH
(name . Sören Tempel)(address . soeren@soeren-tempel.net)
w5b6g7spkrevdxpb6m6ugrecumgjwaf6myrh5ig4g6pgep4htj@h4vgj6if5zkj
Toggle quote (13 lines)
> Hi,
>
> Lars-Dominik Braun <lars@6xq.net> wrote:
> > sorry for the delay, I just tried your patch and it works well combining
> > a local cabal project and libraries/GHC from Guix. I’d say this is a
> > massive improvement, so I’d like to ship it with Guix. However this
> > is a world rebuilding change, so I’ll push it to the haskell-team
> > branch and probably wait for #67921 to be ready before it can hit master.
>
> Yea, glad to hear that. Waiting for #67921 is fine by me. Should I also
> prepare a patch for the GHC 9.4 package then? Currently this is only GHC
> 9.2.

I'm currently trying to update GHC to 9.6 in that series (there are some
weird issues when running the test suite). If the same cabal patch works
with GHC 9.6 I can add the reference to it in the package definition
(same with 9.4). Otherwise a patch for those versions would be nice.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmWZwysACgkQJX0oSiod
OjLRBRAAwIm+OVdfsjEVmZGGygim1vjjFIq0GUXIXGyQ7qArsIhHQ+Uy1CD9nuRf
HnjbF+6LCqcF8WFTmnCiHuHUo6v0Af8iXUhbO6iGpuQ+bnj9YYLubI+l81QyN83f
yf9ON60AVy0X0Mlb1TDA4IO02idbftr+9VKMpUbyO1jZVm76T+w1M7B0YscXhHXN
dnZM/naUxcOvHEdL8qBSPz+357oRXOdYZYGe3FpeP8oVygB9VXQwfXeJej7QE71H
H+0LSlv2/7rqbBolMJRGX/I1LbE5RsBbprBaaSrbSLBQSgVL3btbarziQWlFUdsq
HViIyyVk9HquIkWee6vqXmPsh/AJBMjZWQtrAlPhiMkblQgnoqNOlSovYRHzBE0D
WCH3pR3PdNqlzmmwUqkQ48VVN1geklk1pStxbBcSRt+ReoX+wWptlzz6lyU687Ia
RUSXnWMSksO3+Ghy/rjxETAsy0OLELepPfDuvUocvQMVE7S6znNi+hRyL4TnOQDV
K7VnprCzh7tAAP+6Gyw4Yh9Ee0WVta7gjLsLm9USBtNo/TPf9bWQwu3rpjwgzzAD
zEKfNfWkBYPthIBdZouJGPbkDfVsg66Stn4zMmReRKOU9awUogx7qmKO0usRPHKb
Qvero3/bfeAknXaEWXgXpJeO5540jLpAIH3OsDLYeytCBvyZXq4=
=vwJz
-----END PGP SIGNATURE-----


S
S
Sören Tempel wrote on 7 Jan 10:37 +0100
(name . Saku Laesvuori)(address . saku@laesvuori.fi)
270O1QKCL3GA8.2UGLUU9CUOGAL@8pit.net
I just tested this, the patch applies cleanly for both GHC 9.4.8 and 9.6.3.

Saku Laesvuori <saku@laesvuori.fi> wrote:
Toggle quote (17 lines)
> > Hi,
> >
> > Lars-Dominik Braun <lars@6xq.net> wrote:
> > > sorry for the delay, I just tried your patch and it works well combining
> > > a local cabal project and libraries/GHC from Guix. I’d say this is a
> > > massive improvement, so I’d like to ship it with Guix. However this
> > > is a world rebuilding change, so I’ll push it to the haskell-team
> > > branch and probably wait for #67921 to be ready before it can hit master.
> >
> > Yea, glad to hear that. Waiting for #67921 is fine by me. Should I also
> > prepare a patch for the GHC 9.4 package then? Currently this is only GHC
> > 9.2.
>
> I'm currently trying to update GHC to 9.6 in that series (there are some
> weird issues when running the test suite). If the same cabal patch works
> with GHC 9.6 I can add the reference to it in the package definition
> (same with 9.4). Otherwise a patch for those versions would be nice.
?