[PATCH] gnu: d-tools: Update to 2.105.3

  • Done
  • quality assurance status badge
Details
2 participants
  • Hugo Nobrega
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hugo Nobrega
Severity
normal
H
H
Hugo Nobrega wrote on 10 Nov 2023 23:44
(address . guix-patches@gnu.org)(name . Hugo Nobrega)(address . hugonobrega@gmail.com)
7815811a22c4555f21cc4737b82f49ba718ad134.1699656270.git.hugonobrega@gmail.com
The previous version 2.100 was failing in `check` due to changes to the Phobos stdlib

Change-Id: Id9e4580d555c735fb0eebe880928ef2f558f959e
---
gnu/packages/dlang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 2b5b123..f6b5f12 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -57,7 +57,7 @@ (define-module (gnu packages dlang)
(define-public d-tools
(package
(name "d-tools")
- (version "2.100.0")
+ (version "2.105.3")
(source
(origin
(method git-fetch)
@@ -66,7 +66,7 @@ (define-public d-tools
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jbn0hyskv4ykcckw0iganpyrm0bq2lggswspw21r4hgnxkmjbyw"))))
+ (base32 "0hvz786k0pi8697x1vk9x5bx52jiy7pvi13wmfkx15ddvv0x5j33"))))
(build-system gnu-build-system)
(arguments
(list #:phases

base-commit: 00fd6895322d0b1fd774e79494cfcad721b50b8d
--
2.41.0
L
L
Ludovic Courtès wrote on 2 Dec 2023 12:24
(name . Hugo Nobrega)(address . hugonobrega@gmail.com)(address . 67056-done@debbugs.gnu.org)
871qc4hmnx.fsf@gnu.org
Hi,

Hugo Nobrega <hugonobrega@gmail.com> skribis:

Toggle quote (4 lines)
> The previous version 2.100 was failing in `check` due to changes to the Phobos stdlib
>
> Change-Id: Id9e4580d555c735fb0eebe880928ef2f558f959e

Applied!

‘dub’ now fails to build like so:

Toggle snippet (21 lines)
starting phase `build'
Using pre-existing version file. To force a rebuild, provide an explicit version (first argument) or remove: /tmp/guix-build-dub-1.23.0.drv-0/source/./source/dub/version_.d
Building dub using ldmd2 (dflags: ["-g", "-O", "-w"]), this may take a while...
Command `["ldmd2", "-of/tmp/guix-build-dub-1.23.0.drv-0/source/./bin/dub", "-I/tmp/guix-build-dub-1.23.0.drv-0/source/./source", "-version=DubUseCurl", "-version=DubApplication", "-g", "-O", "-w", "@build-files.txt"]` failed, output was:
source/dub/dependency.d(782): Deprecation: usage of the `body` keyword is deprecated. Use `do` instead.
source/dub/packagemanager.d(275): Deprecation: usage of the `body` keyword is deprecated. Use `do` instead.
source/dub/semver.d(107): Deprecation: usage of the `body` keyword is deprecated. Use `do` instead.
source/dub/internal/sdlang/parser.d(121): Deprecation: module std.variant is not accessible here, perhaps add 'static import std.variant;'
source/dub/internal/sdlang/parser.d(121): Deprecation: module std.variant is not accessible here, perhaps add 'static import std.variant;'
Serializing composite type BuildRequirements which has no serializable fields
Serializing composite type BuildOptions which has no serializable fields
source/dub/packagesuppliers/maven.d(82): Error: unable to read module `xml`
source/dub/packagesuppliers/maven.d(82): Expected 'std/xml.d' or 'std/xml/package.d' in one of the following import paths:
import path[0] = /tmp/guix-build-dub-1.23.0.drv-0/source/./source
import path[1] = /gnu/store/wwjmq2wpa50xjj7irai5ln838krh7cgk-ldc-1.32.2/include/d

error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "./build.d" arguments: () exit-status: 1 term-signal: #f stop-signal: #f>
phase `build' failed after 4.8 seconds

Next task I guess? :-)

Thanks,
Ludo’.
Closed
H
H
Hugo Nobrega wrote on 6 Dec 2023 22:13
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 67056-done@debbugs.gnu.org)
CA+hgWQNp-jChRQ6BPwgV6GUTcDyTZN7rJXD30HgVyZnX=2Tq0Q@mail.gmail.com
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (7 lines)
> ‘dub’ now fails to build like so:
>
> [..]
>
> Next task I guess? :-)
>

Done! o7
It was another very simple version bump.

Best wishes,
Hugo

On Sat, Dec 2, 2023 at 8:24?AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (55 lines)
> Hi,
>
> Hugo Nobrega <hugonobrega@gmail.com> skribis:
>
> > The previous version 2.100 was failing in `check` due to changes to the
> Phobos stdlib
> >
> > Change-Id: Id9e4580d555c735fb0eebe880928ef2f558f959e
>
> Applied!
>
> ‘dub’ now fails to build like so:
>
> --8<---------------cut here---------------start------------->8---
> starting phase `build'
> Using pre-existing version file. To force a rebuild, provide an explicit
> version (first argument) or remove:
> /tmp/guix-build-dub-1.23.0.drv-0/source/./source/dub/version_.d
> Building dub using ldmd2 (dflags: ["-g", "-O", "-w"]), this may take a
> while...
> Command `["ldmd2", "-of/tmp/guix-build-dub-1.23.0.drv-0/source/./bin/dub",
> "-I/tmp/guix-build-dub-1.23.0.drv-0/source/./source",
> "-version=DubUseCurl", "-version=DubApplication", "-g", "-O", "-w",
> "@build-files.txt"]` failed, output was:
> source/dub/dependency.d(782): Deprecation: usage of the `body` keyword is
> deprecated. Use `do` instead.
> source/dub/packagemanager.d(275): Deprecation: usage of the `body` keyword
> is deprecated. Use `do` instead.
> source/dub/semver.d(107): Deprecation: usage of the `body` keyword is
> deprecated. Use `do` instead.
> source/dub/internal/sdlang/parser.d(121): Deprecation: module std.variant
> is not accessible here, perhaps add 'static import std.variant;'
> source/dub/internal/sdlang/parser.d(121): Deprecation: module std.variant
> is not accessible here, perhaps add 'static import std.variant;'
> Serializing composite type BuildRequirements which has no serializable
> fields
> Serializing composite type BuildOptions which has no serializable fields
> source/dub/packagesuppliers/maven.d(82): Error: unable to read module `xml`
> source/dub/packagesuppliers/maven.d(82): Expected 'std/xml.d' or
> 'std/xml/package.d' in one of the following import paths:
> import path[0] = /tmp/guix-build-dub-1.23.0.drv-0/source/./source
> import path[1] =
> /gnu/store/wwjmq2wpa50xjj7irai5ln838krh7cgk-ldc-1.32.2/include/d
>
> error: in phase 'build': uncaught exception:
> %exception #<&invoke-error program: "./build.d" arguments: () exit-status:
> 1 term-signal: #f stop-signal: #f>
> phase `build' failed after 4.8 seconds
> --8<---------------cut here---------------end--------------->8---
>
> Next task I guess? :-)
>
> Thanks,
> Ludo’.
>
Attachment: file
Closed
?