[PATCH] gnu: Update go-github-com-mattn-go-runewidth to 0.0.14

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nguy?n Gia Phong
Owner
unassigned
Submitted by
Nguy?n Gia Phong
Severity
normal
N
N
Nguy?n Gia Phong wrote on 13 Jun 2023 07:58
(address . guix-patches@gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
1c3151223a5fd4ffe63d7949a0f7834ad841dbfa.1686635881.git.mcsinyx@disroot.org
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Update to 0.0.14
* gnu/packages/golang.scm: Fix input typoes

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/golang.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d51c023808cf..b99659966dda 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2755,7 +2755,7 @@ (define-public go-github-com-gizak-termui
'(#:unpack-path "github.com/gizak/termui"
#:import-path "github.com/gizak/termui/v3"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-mitchellh-go-wordwrap go-github.com-nsf-termbox-go))
(home-page "https://github.com/gizak/termui")
(synopsis "Terminal dashboard widget Go library")
@@ -7105,7 +7105,7 @@ (define-public go-github-com-gdamore-tcell
(arguments
`(#:import-path "github.com/gdamore/tcell"))
(inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-lucasb-eyer-go-colorful
go-golang-org-x-text
go-github-com-gdamore-encoding))
@@ -9128,7 +9128,7 @@ (define-public go-github-com-muesli-reflow-wordwrap
`(#:import-path "github.com/muesli/reflow/wordwrap"
#:unpack-path "github.com/muesli/reflow"))
(native-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/reflow/")
(synopsis "Collection of methods helping to transform blocks of text")
(description "This package provides a collection of ANSI-aware methods and
@@ -9187,7 +9187,7 @@ (define-public go-github-com-muesli-termenv
(list go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
- go-github.com-mattn-go-runewidth))
+ go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/termenv/")
(synopsis "Advanced styling options on the terminal")
(description "termenv lets you safely use advanced styling options on the
@@ -9241,7 +9241,7 @@ (define-public go-github-com-olekukonko-tablewriter
(arguments
`(#:import-path "github.com/olekukonko/tablewriter"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/olekukonko/tablewriter/")
(synopsis "Generate ASCII table")
(description "This package generates ASCII tables. Features:
@@ -9338,7 +9338,7 @@ (define-public go-github-com-charmbracelet-glamour
go-github-com-muesli-reflow-wordwrap
go-github-com-muesli-reflow-indent
go-github-com-muesli-reflow-padding
- go-github.com-mattn-go-runewidth
+ go-github-com-mattn-go-runewidth
go-github-com-muesli-termenv
go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
@@ -11521,7 +11521,7 @@ (define-public go-github-com-rivo-uniseg
(define-public go-github-com-mattn-go-runewidth
(package
(name "go-github-com-mattn-go-runewidth")
- (version "0.0.13")
+ (version "0.0.14")
(source
(origin
(method git-fetch)
@@ -11530,7 +11530,7 @@ (define-public go-github-com-mattn-go-runewidth
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1yir0f3wc5z5hnkwhvx5qb6nmpfb05zp2gvfjvna63s8kmla1rrn"))))
+ (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
(build-system go-build-system)
(arguments '(#:import-path "github.com/mattn/go-runewidth"))
(propagated-inputs
@@ -11563,7 +11563,7 @@ (define-public go-github-com-charmbracelet-bubbletea
(propagated-inputs
`(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
- ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
("go-github-com-lucasb-eyer-go-colorful" ,go-github-com-lucasb-eyer-go-colorful)

base-commit: 3c390111146a41c8b35a5384a0262987b34e0ef2
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 18 Jun 2023 05:43
[PATCH v2 2/2] gnu: go-github-com-gdamore-tcell-v2: Update to 2.6.0
(address . 64033@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
35cd3c1a8a57768cc8e8d20f9bae3eb3be3624b1.1687059530.git.mcsinyx@disroot.org
gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2): Update to 2.6.0.

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b99659966dda..e4c4cb299b48 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7121,7 +7121,7 @@ (define-public go-github-com-gdamore-tcell-v2
(package
(inherit go-github-com-gdamore-tcell)
(name "go-github-com-gdamore-tcell")
- (version "2.5.3")
+ (version "2.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7130,7 +7130,7 @@ (define-public go-github-com-gdamore-tcell-v2
(file-name (git-file-name name version))
(sha256
(base32
- "0pvs0gigqxpifc7y7cx82cg95pgqmy8qzxynja3zidplrx2075j3"))))
+ "0126hi8glnfqdx4l9zlh6dhd5f5c8bws7arv9pp4n2kqcnhdc6g2"))))
(arguments
(list #:import-path "github.com/gdamore/tcell/v2"
#:phases
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 18 Jun 2023 05:43
[PATCH v2 0/2] Update go libraries runewidth and tcell
(address . 64033@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
cover.1687059530.git.mcsinyx@disroot.org
I'm working on updating aerc and adding senpai,
both share the following patches.

Nguy?n Gia Phong (2):
gnu: Update go-github-com-mattn-go-runewidth to 0.0.14
gnu: go-github-com-gdamore-tcell-v2: Update to 2.6.0

gnu/packages/configuration-management.scm | 2 +-
gnu/packages/databases.scm | 2 +-
gnu/packages/disk.scm | 2 +-
gnu/packages/golang.scm | 22 +++++++++---------
gnu/packages/terminals.scm | 4 ++--
gnu/packages/textutils.scm | 28 -----------------------
gnu/packages/time.scm | 2 +-
7 files changed, 17 insertions(+), 45 deletions(-)


base-commit: 428b810ca23fa1c1c565da15c0e95273f6487384
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 18 Jun 2023 05:43
[PATCH v2 1/2] gnu: Update go-github-com-mattn-go-runewidth to 0.0.14
(address . 64033@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
f6e016ae4d2f2c4bcca09a6b9c26f3ba335cab40.1687059530.git.mcsinyx@disroot.org
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Update to 0.0.14.
* gnu/packages/golang.scm: Fix input typoes

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
Note that this is not a rename:
the package in golang.scm was named with all hyphens.
gnu/packages/configuration-management.scm | 2 +-
gnu/packages/databases.scm | 2 +-
gnu/packages/disk.scm | 2 +-
gnu/packages/golang.scm | 18 +++++++--------
gnu/packages/terminals.scm | 4 ++--
gnu/packages/textutils.scm | 28 -----------------------
gnu/packages/time.scm | 2 +-
7 files changed, 15 insertions(+), 43 deletions(-)

Toggle diff (200 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index b66f70545ab3..95a7e8615fc9 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -78,7 +78,7 @@ (define-public chezmoi
go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
- go-github.com-mattn-go-runewidth
+ go-github-com-mattn-go-runewidth
go-github-com-olekukonko-tablewriter
go-github-com-pelletier-go-toml
go-github-com-pkg-diff
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 74483d27f781..937958b60031 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5075,7 +5075,7 @@ (define-public sqls
go-github-com-pkg-errors
go-github-com-sourcegraph-jsonrpc2
go-golang-org-x-crypto
- go-github.com-mattn-go-runewidth
+ go-github-com-mattn-go-runewidth
go-golang-org-x-xerrors
go-gopkg-in-yaml-v2))
(synopsis "SQL language server written in Go")
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index abbc87a95ab4..b878614dc290 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1161,7 +1161,7 @@ (define-public lf
"1piym8za0iw2s8yryh39y072f90mzisv89ffvn1jzb71f71mbfqa"))))
(build-system go-build-system)
(native-inputs
- (list go-github.com-mattn-go-runewidth go-golang-org-x-term
+ (list go-github-com-mattn-go-runewidth go-golang-org-x-term
go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2-2.3))
(arguments
`(#:import-path "github.com/gokcehan/lf"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d51c023808cf..b99659966dda 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2755,7 +2755,7 @@ (define-public go-github-com-gizak-termui
'(#:unpack-path "github.com/gizak/termui"
#:import-path "github.com/gizak/termui/v3"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-mitchellh-go-wordwrap go-github.com-nsf-termbox-go))
(home-page "https://github.com/gizak/termui")
(synopsis "Terminal dashboard widget Go library")
@@ -7105,7 +7105,7 @@ (define-public go-github-com-gdamore-tcell
(arguments
`(#:import-path "github.com/gdamore/tcell"))
(inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-lucasb-eyer-go-colorful
go-golang-org-x-text
go-github-com-gdamore-encoding))
@@ -9128,7 +9128,7 @@ (define-public go-github-com-muesli-reflow-wordwrap
`(#:import-path "github.com/muesli/reflow/wordwrap"
#:unpack-path "github.com/muesli/reflow"))
(native-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/reflow/")
(synopsis "Collection of methods helping to transform blocks of text")
(description "This package provides a collection of ANSI-aware methods and
@@ -9187,7 +9187,7 @@ (define-public go-github-com-muesli-termenv
(list go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
- go-github.com-mattn-go-runewidth))
+ go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/termenv/")
(synopsis "Advanced styling options on the terminal")
(description "termenv lets you safely use advanced styling options on the
@@ -9241,7 +9241,7 @@ (define-public go-github-com-olekukonko-tablewriter
(arguments
`(#:import-path "github.com/olekukonko/tablewriter"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/olekukonko/tablewriter/")
(synopsis "Generate ASCII table")
(description "This package generates ASCII tables. Features:
@@ -9338,7 +9338,7 @@ (define-public go-github-com-charmbracelet-glamour
go-github-com-muesli-reflow-wordwrap
go-github-com-muesli-reflow-indent
go-github-com-muesli-reflow-padding
- go-github.com-mattn-go-runewidth
+ go-github-com-mattn-go-runewidth
go-github-com-muesli-termenv
go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
@@ -11521,7 +11521,7 @@ (define-public go-github-com-rivo-uniseg
(define-public go-github-com-mattn-go-runewidth
(package
(name "go-github-com-mattn-go-runewidth")
- (version "0.0.13")
+ (version "0.0.14")
(source
(origin
(method git-fetch)
@@ -11530,7 +11530,7 @@ (define-public go-github-com-mattn-go-runewidth
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1yir0f3wc5z5hnkwhvx5qb6nmpfb05zp2gvfjvna63s8kmla1rrn"))))
+ (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
(build-system go-build-system)
(arguments '(#:import-path "github.com/mattn/go-runewidth"))
(propagated-inputs
@@ -11563,7 +11563,7 @@ (define-public go-github-com-charmbracelet-bubbletea
(propagated-inputs
`(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
- ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
("go-github-com-lucasb-eyer-go-colorful" ,go-github-com-lucasb-eyer-go-colorful)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7579d2e7bfb8..d1cfbeab1732 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -957,7 +957,7 @@ (define-public go-github.com-nsf-termbox-go
(arguments
'(#:import-path "github.com/nsf/termbox-go"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(synopsis "@code{termbox} provides a minimal API for text-based user
interfaces")
(description
@@ -984,7 +984,7 @@ (define-public go-github-com-junegunn-fzf
(arguments
`(#:import-path "github.com/junegunn/fzf"))
(inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-mattn-go-shellwords
go-github-com-mattn-go-isatty
go-github-com-gdamore-tcell
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 026264dc27ce..2252bb7c16fa 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1008,34 +1008,6 @@ (define-public txt2tags
markup and converts it to multiple formats.")
(license license:gpl2)))
-(define-public go-github.com-mattn-go-runewidth
- (let ((commit "703b5e6b11ae25aeb2af9ebb5d5fdf8fa2575211")
- (version "0.0.4")
- (revision "1"))
- (package
- (name "go-github.com-mattn-go-runewidth")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/runewidth")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0znpyz71gajx3g0j2zp63nhjj2c07g16885vxv4ykwnrfmzbgk4w"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/mattn/go-runewidth"))
- (synopsis "@code{runewidth} provides Go functions to work with string widths")
- (description
- "The @code{runewidth} library provides Go functions for padding,
-measuring and checking the width of strings, with support for East Asian
-text.")
- (home-page "https://github.com/mattn/runewidth")
- (license license:expat))))
-
(define-public docx2txt
(package
(name "docx2txt")
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 38b51583da27..5c8f65a1e67b 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -623,7 +623,7 @@ (define-public countdown
(arguments
'(#:import-path "github.com/antonmedv/countdown"))
(native-inputs
- `(("runewidth" ,go-github.com-mattn-go-runewidth)
+ `(("runewidth" ,go-github-com-mattn-go-runewidth)
("termbox" ,go-github.com-nsf-termbox-go)))
(home-page "https://github.com/antonmedv/countdown")
(synopsis "Counts to zero with a text user interface")
--
2.40.1
L
L
Ludovic Courtès wrote on 20 Jun 2023 23:58
Re: bug#64033: [PATCH] gnu: Update go-github-com-mattn-go-runewidth to 0.0.14
(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)(address . 64033-done@debbugs.gnu.org)
87sfalaj8z.fsf_-_@gnu.org
Hi,

Nguy?n Gia Phong <mcsinyx@disroot.org> skribis:

Toggle quote (3 lines)
> gnu: Update go-github-com-mattn-go-runewidth to 0.0.14
> gnu: go-github-com-gdamore-tcell-v2: Update to 2.6.0

Applied, thanks!

Ludo’.
Closed
?