[PATCH 06/25] gnu: Add go-github-com-jba-templatecheck.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Tobias Geerinckx-Rice
  • (
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
Merged with
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 02:44
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20230118014510.19320-7-cox.katherine.e@gmail.com
* gnu/packages/golang.scm (go-github-com-jba-templatecheck): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f7a8160de..aabaa6336c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8541,6 +8541,33 @@ (define-public go-github-com-jba-printsrc
;; MIT
(license license:expat)))
+(define-public go-github-com-jba-templatecheck
+ (package
+ (name "go-github-com-jba-templatecheck")
+ (version "0.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jba/templatecheck")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12iwkidz4p6wdl65jfddqxls80mv879k2rpb42dj7y4dja5advlc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jba/templatecheck"))
+ (propagated-inputs (list go-github-com-google-safehtml))
+ (home-page "https://github.com/jba/templatecheck")
+ (synopsis "Checks Go templates for problems")
+ (description
+ "Package templatecheck checks Go templates for problems. It can detect
+many errors that are normally caught only during execution. Use templatecheck
+in tests to find template errors early, and along template execution paths
+that might only rarely be reached.")
+ ;; MIT
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-context
(let ((commit "d14ea06fba99483203c19d92cfcd13ebe73135f4")
(revision "1"))
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 11:56
(no subject)
(address . control@debbugs.gnu.org)
542e82bcc0f385c117ba662c7dcf1dbf@tobias.gr
merge 60898 60899 60900 60901 60902
merge 60898 60903 60904 60905 60906
merge 60898 60907 60908 60909 60910
merge 60898 60911 60912 60913 60914
merge 60898 60915 60916 60917 60918
merge 60898 60919 60920
T
T
Tobias Geerinckx-Rice wrote on 18 Jan 2023 12:43
(address . control@debbugs.gnu.org)
37de5823441633151229c783f2acfca3@tobias.gr
merge 60898 60921 60922
thanks

Weird: I got ‘Unknown command or malformed arguments to command.’ for
this obviously correct line.

Let's try again.
K
K
Katherine Cox-Buday wrote on 18 Jan 2023 18:07
Merging erroneously opened bugs
(address . control@debbugs.gnu.org)
87zgafrct9.fsf@gmail.com
merge 60899 60904 60907 60908 60917 60920 60921 60919 60910 60903 60915 60914 60922 60909 60918 60913 60900 60899 60905 60901 60912 60898 60906 60902 60916 60911
--
Katherine
(
Re: [bug#60902] [PATCH 06/25] gnu: Add go-github-com-jba-templatecheck.
CQBTM1GFSF6L.2HLV78PQTAAQ8@guix-framework
* gnu/packages/golang.scm (go-github-com-jba-templatecheck): New variable.

Toggle quote (7 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -8541,6 +8541,33 @@ (define-public go-github-com-jba-printsrc

> + (synopsis "Checks Go templates for problems")

s/problems/errors/

Toggle quote (6 lines)
> + (description
> + "Package templatecheck checks Go templates for problems. It can detect
> +many errors that are normally caught only during execution. Use templatecheck
> +in tests to find template errors early, and along template execution paths
> +that might only rarely be reached.")

(description
"This package provides a Go library for checking Go templates for errors,
including many errors normally caught only during execution.")
Toggle quote (2 lines)
> + ;; MIT

Don't bother with the comment here :)

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPhejAACgkQ7ImHg/nq
I23KMAv9EhS4PbV+ROeMyCUa7uEA8mZi5Vz86u+qlIELiC05A2H6ll2wA9EC77qS
LDnfXA8WNKGaIZU6AvcTA4IEjC0eO/05e/WYgJfcWTsTTPxyAcR1CWVrAOOIeY2d
CJCpef1A+oNGX04KxxjW315HR+CcAbCQq4vc6yHyL8IasuiAdsUFuMPV/LX/NODI
7pJdVmjI7pthcq5IOMnlF312GFDHI8Ew9QlLLvhVgRFxtoAvFG7Y/c3L2maKbwct
oOR8Mo39wj1zA+D832NiGyoqRFlujPE+5dYmv0LgC2+7DP58T5xhDcECG44QvyL2
8dchNU9gOnJDzs4YmxzD0f5qeCvjXErN9KEvnPZi6twgOUkHMgbjpjYcjFHbJahy
0yXr4coDI8u96+obua094ayMEQPIgVxfCCxA5ISM1lnDhibB7d8KKVsOo3duropi
Qoa3Gs+t5otgJga47pv3O7/QziecnArMIYdHQBM9PZ/gZAk84eP9jZs11txaW+Td
3DY1VhtW
=Wz7v
-----END PGP SIGNATURE-----


K
K
Katherine Cox-Buday wrote on 7 Feb 2023 18:12
(name . ( via Guix-patches via)(address . guix-patches@gnu.org)
87ilgdxuv4.fsf@gmail.com
"( via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> * gnu/packages/golang.scm (go-github-com-jba-templatecheck): New variable.
>
>> --- a/gnu/packages/golang.scm
>> +++ b/gnu/packages/golang.scm
>
>> @@ -8541,6 +8541,33 @@ (define-public go-github-com-jba-printsrc
>
>> + (synopsis "Checks Go templates for problems")
>
> s/problems/errors/

Upstream's synopsis uses the word "validity". I think I probably pulled
the synopsis from the first sentence of upstream's description, which
uses the word "problems".

For future reference, would something like this really hold up a merge?

Toggle quote (10 lines)
>> + (description
>> + "Package templatecheck checks Go templates for problems. It can detect
>> +many errors that are normally caught only during execution. Use templatecheck
>> +in tests to find template errors early, and along template execution paths
>> +that might only rarely be reached.")
>
> (description
> "This package provides a Go library for checking Go templates for errors,
> including many errors normally caught only during execution.")

Can you give more general guidance on what a description should have? I
can't infer any general rules from the reviews you've given, other than
maybe you are suggesting shorter descriptions. But the manual says:

Descriptions should take between five and ten lines.

So I think my inference is probably not correct.

Toggle quote (4 lines)
>> + ;; MIT
>
> Don't bother with the comment here :)

No? I like knowing what license things are! But if this is a style
thing, I can start leaving them off.

--
Katherine
(
(address . 60902@debbugs.gnu.org)
CQCIKLLD1WJN.1TTDED5IKML3F@guix-framework
On Tue Feb 7, 2023 at 5:12 PM GMT, Katherine Cox-Buday wrote:
Toggle quote (3 lines)
> No? I like knowing what license things are! But if this is a style
> thing, I can start leaving them off.

MIT == Expat or X11; a comment noting that it's MIT is redundant :)

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmPijUAACgkQ7ImHg/nq
I23ePAv/W4TVfXBzJn0HC+ilvy/L/gJ5TUwnDB0vgwnp2mH0gtcJR9T2A8aPolEw
2W+dMHVsoD77Ay80rtt+mkfA8hPxffhEJ0wqcIuzjufVg+0pqXYCeNyHQXUBddt9
rJcwryzhwg5wPhE9LRz/p/sqBkcs7le+YnxOqTQUCIaJdNKzbKVSpSYAf3OVVXQB
T+m7CWW3vjYn7wxCICAUQMVJhRNZ7qoPsHIDFaRxfFlX4Dl+SP2vWbpruNJjKG5d
k/QWITyVEPoUYNZ5wFWt/UEfytVXCsXP3ulHlFCv+dJ18Ew3r4CIAepD/piccMIO
UFUiYBfZhy4zC17T5XViAI+elNkHiThAM3TZjk/iqYlI8y+9z5EglszFcmnuLRNB
JvOknXsdiwzazz1QPCeMUfNGeiBlsJus/iRQweUzS47l7irtLrYur5aVU8awmyhi
ffiTNWnmvN6ilVRf8Ks4+lXY8Rhitj6V9o+8qlK7iPcGuQtviDSCTlhpIXmvZ0Yq
aPUVhPfL
=mztC
-----END PGP SIGNATURE-----


?