[PATCH 1/2] gnu: Add python-rx.

  • Open
  • quality assurance status badge
Details
One participant
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 16 Jan 2023 12:04
(name . Guix Patches)(address . guix-patches@gnu.org)
tGnn-m9_s6RBc1MheYMdfJsNBu5b0GvXQZ8NQIzLuAHY-h5Cs1chRHFEZLs-VRSIvmmFfmHMidLVHWX4FUjeKo72PxGWcWwBReskB_AHTdg=@protonmail.com
Hello,

sorry for this email, the correct recipient should have been guix-patches@gnu.org.


----
Petr

------- Original Message -------
On Monday, January 16th, 2023 at 12:00 PM, phodina via <help-guix@gnu.org> wrote:


Toggle quote (6 lines)
> Hi,
>
> here are two Python modules to upstream.
>
> ----
> Petr
P
P
phodina wrote on 8 Feb 2023 15:37
Include missing patches
(name . 60857@debbugs.gnu.org)(address . 60857@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
ui-Ec9yhOU19T7FYMvzaB6527wuoRNowA9a_C3zNNPn4KzIEkRyvKrYxJO9tcad9UxIaqCyiFKfIyXJMB2AfwP8daVyGRNpaDlXJXe1NtGg=@protonmail.com
Hi,

here are the patches. Unfortunately, they were not included from the original message.

----
Petr
Attachment: file
From 31a313be47093eae5cd211094fa2bea38148f657 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 16 Jan 2023 11:40:34 +0100
Subject: [PATCH 1/2] gnu: Add python-rx.

* gnu/packages/python-xyz.scm (python-rx): New variable.

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d826d3c5..a9e0981e9a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4028,6 +4028,25 @@ (define-public python-roman
to Roman Numerals.")
(license license:psfl)))
+(define-public python-rx
+ (package
+ (name "python-rx")
+ (version "3.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Rx" version))
+ (sha256
+ (base32
+ "076rcgcyqqpr5y7jyg7za6ngfm75qbx0kzfwyyi5sj5a8lmwlmxn"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f)) ;no test suite
+ (native-inputs (list python-pytest))
+ (home-page "https://reactivex.io/")
+ (synopsis "Reactive Extensions for Python")
+ (description "This package provides Reactive Extensions for Python.")
+ (license license:expat)))
+
(define-public python-unidecode
(package
(name "python-unidecode")
--
2.38.1
From a396f110c1111527b6f06839e91ea89d1d1724c6 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 16 Jan 2023 11:41:00 +0100
Subject: [PATCH 2/2] gnu: Add python-injector.

* gnu/packages/python-xyz.scm (python-injector): New variable.

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9e0981e9a..ebada3d15e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20228,6 +20228,31 @@ (define-public python-iniconfig
@end itemize")
(license license:expat)))
+(define-public python-injector
+ (package
+ (name "python-injector")
+ (version "0.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "injector" version))
+ (sha256
+ (base32
+ "0fi2zw6nffl91ihx25wfvr5mq8jyrdx2pa56wdhww2c35ydb8qc6"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-typing-extensions))
+ (native-inputs (list python-black
+ python-check-manifest
+ python-dataclasses
+ python-mypy
+ python-pytest
+ python-pytest-cov))
+ (home-page "https://github.com/python-injector/injector")
+ (synopsis "Python dependency injection framework")
+ (description
+ "This package provides Python dependency injection framework - inspired by
+Guice.")
+ (license license:bsd-3)))
+
(define-public python-mamba
(package
(name "python-mamba")
--
2.38.1
?