[PATCH 0/5] gnu: Add emacs-wanderlust.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Christopher Baines
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 20 Nov 2022 06:42
(address . guix-patches@gnu.org)
y76a64mp4f5.wl-hako@ultrarare.space
*** BLURB HERE ***

Hilton Chain (5):
gnu: Add emacs-bbdb-vcard.
gnu: Add emacs-apel-lb.
gnu: Add emacs-flim-lb.
gnu: Add emacs-semi-epg.
gnu: Add emacs-wanderlust.

gnu/packages/emacs-xyz.scm | 209 +++++++++++++++++++++++++++++++++++++
1 file changed, 209 insertions(+)


base-commit: 8cef05bab6251978018ccab7bb44883676ce8f6c
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 06:44
[PATCH 1/5] gnu: Add emacs-bbdb-vcard.
(address . 59402@debbugs.gnu.org)
y767czqp4c7.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-bbdb-vcard): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c1138e954..7479376018 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2841,6 +2841,34 @@ (define-public emacs-bbdb
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-bbdb-vcard
+ ;; No release since Dec 1, 2013.
+ (let ((version "0.4.1") ;3d79fdb4200a64a043e203a3baac95c936095b52, not tagged
+ (revision "88")
+ (commit "113c66115ce68316e209f51ebce56de8dded3606"))
+ (package
+ (name "emacs-bbdb-vcard")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tohojo/bbdb-vcard")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sr5kd2gvw1b4hl147yb60cgx6j730vdnpyr09p7vmpw65hzwlwm"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-bbdb))
+ (home-page "https://github.com/tohojo/bbdb-vcard")
+ (synopsis
+ "vCard Import and Export for The Insidious Big Brother Database (BBDB)")
+ (description
+ "@code{bbdb-vcard.el} imports and exports vCards (version 3.0) as
+defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
+(BBDB). Version 2.1 vCards are converted into version 3.0 on import.")
+ (license license:gpl2+))))
+
(define-public emacs-beacon
(package
(name "emacs-beacon")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 06:45
[PATCH 2/5] gnu: Add emacs-apel-lb.
(address . 59402@debbugs.gnu.org)
y765yfap4b7.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-apel-lb): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7479376018..dc6899884d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33873,6 +33873,32 @@ (define-public emacs-mpv
process via its IPC interface.")
(license license:gpl3+))))
+(define-public emacs-apel-lb
+ ;; No release since Jun 15, 2010.
+ (let ((version "10.8") ;tag chise-base-0_25
+ (revision "81")
+ (commit "82eb2325bd149dc57b43a9ce9402c6c6183e4052"))
+ (package
+ (name "emacs-apel-lb")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/apel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qiw19pn1cs8y571irw7bjdygkvwan9ch2i1dg139dri4b6q1il6"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Library for making portable Emacs Lisp programs")
+ (description
+ "A Portable Emacs Library (APEL) is a library for making portable Emacs
+Lisp programs. APEL-LB is a variant of APEL, which features supports to
+latest Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 06:45
[PATCH 3/5] gnu: Add emacs-flim-lb.
(address . 59402@debbugs.gnu.org)
y764juup4al.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-flim-lb): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc6899884d..a5621e4fea 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33899,6 +33899,34 @@ (define-public emacs-apel-lb
latest Emacs.")
(license license:gpl2+))))
+(define-public emacs-flim-lb
+ ;; No release since Nov 28, 2007.
+ (let ((version "1.14.9")
+ (revision "133")
+ (commit "57c6b868aa314717f40a520daed7249665e8d992"))
+ (package
+ (name "emacs-flim-lb")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/flim")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mf8r5mf3bd0719fnhifb6lfvl7n4m552crcdhkbkkif8srrl6df"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-apel-lb emacs-oauth2))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis
+ "Library for basic features about message representation or encoding")
+ (description
+ "FLIM is a library to provide basic features about message representation
+or encoding. FLIM-LB is a variant of FLIM, which features supports to latest
+Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 06:46
[PATCH 4/5] gnu: Add emacs-semi-epg.
(address . 59402@debbugs.gnu.org)
y7635aep49z.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-semi-epg): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a5621e4fea..f4b39b90ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33927,6 +33927,33 @@ (define-public emacs-flim-lb
Emacs.")
(license license:gpl2+))))
+(define-public emacs-semi-epg
+ ;; No release since Dec 24, 2003.
+ (let ((version "1.14.6")
+ (revision "241")
+ (commit "ac3e726ca94ed245c25881ec8d7177d0d834ea6a"))
+ (package
+ (name "emacs-semi-epg")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/semi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bg07y6svvg1mmlr455x3j1anjp3wbv27s6b2inp294rbwprm41n"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-bbdb-vcard emacs-flim-lb))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Library to provide MIME feature for GNU Emacs")
+ (description
+ "SEMI is a package for GNU Emacs to provide features related with MIME
+user interface. SEMI-EPG is a variant of SEMI, which features supports to
+EasyPG and latest Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 06:46
[PATCH 5/5] gnu: Add emacs-wanderlust.
(address . 59402@debbugs.gnu.org)
y761qpyp49f.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-wanderlust): New variable.
---
gnu/packages/emacs-xyz.scm | 100 +++++++++++++++++++++++++++++++++++++
1 file changed, 100 insertions(+)

Toggle diff (113 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f4b39b90ef..03c9cec60e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33954,6 +33954,106 @@ (define-public emacs-semi-epg
EasyPG and latest Emacs.")
(license license:gpl2+))))
+(define-public emacs-wanderlust
+ ;; No release since Jan 15, 2010.
+ ;; FIXME: Building with emacs-next-pgtk would yield a void variable related
+ ;; macro-expansion failure at runtime, so don't rewrite emacs input of this
+ ;; package.
+ (let ((version "2.15.9")
+ (revision "779")
+ (commit "f5cb2f0cf5e2c893acf2e669fd549836828dfdfc"))
+ (package
+ (name "emacs-wanderlust")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/wanderlust")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "WL-CFG"
+ ((".*WL_PREFIX.*")
+ (string-append "(setq wl-install-utils t)" "\n"
+ "(setq WL_PREFIX \"\")" "\n"
+ "(setq ELMO_PREFIX \"\")" "\n")))
+ (substitute* "Makefile"
+ (("package-user-dir") "NONE"))))
+ (sha256
+ (base32
+ "1ijs57wv1vrh33vn311hgkp42vlmjyi998nc4qdrqi7yy9j8hl1h"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'expand-load-path 'chdir-elmo
+ (lambda _
+ (chdir "elmo")))
+ (add-after 'chdir-elmo 'expand-load-path-elmo
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-elmo 'chdir-utils
+ (lambda _
+ (chdir "../utils")))
+ (add-after 'chdir-utils 'expand-load-path-utils
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-utils 'chdir-wl
+ (lambda _
+ (chdir "../wl")))
+ (add-after 'chdir-wl 'expand-load-path-wl
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-wl 'change-directory
+ (lambda _
+ (chdir "..")))
+ (add-after 'install 'install-via-makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((emacs (search-input-file inputs "/bin/emacs"))
+ (lispdir (elpa-directory #$output))
+ (infodir (string-append #$output "/share/info")))
+ (for-each mkdir-p (list lispdir infodir))
+ (substitute* "Makefile"
+ (("(EMACS = )emacs" all m)
+ (string-append m emacs))
+ (("(LISPDIR = )NONE" all m)
+ (string-append m lispdir))
+ (("(PIXMAPDIR = )NONE" all m)
+ (string-append m lispdir))
+ (("(INFODIR = )NONE" all m)
+ (string-append m infodir))))
+ (invoke "make" "install")
+ (invoke "make" "install-info"))))))
+ (propagated-inputs (list emacs-semi-epg))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Yet Another Message Interface on Emacsen")
+ (description
+ "Wanderlust is an mail/news management system on Emacsen. It supports
+IMAP4rev1(RFC2060), NNTP, POP and local message files.
+
+The main features of Wanderlust:
+
+@itemize
+@item Pure elisp implementation.
+@item Supports IMAP4rev1, NNTP, POP(POP3/APOP), MH and Maildir format.
+@item Unified access method to messages based on Mew-like Folder Specification.
+@item Mew-like Key-bind and mark handling.
+@item Manages unread messages.
+@item Interactive thread display.
+@item Folder Mode shows the list of subscribed folders.
+@item Message Cache, Disconnected Operation.
+@item MH-like FCC. (Fcc: %Backup and Fcc: $Backup is allowed).
+@item MIME compliant (by SEMI).
+@item Transmission of news and mail are unified by Message transmitting draft.
+@item Graphical list of folders.
+@item View a part of message without retrieving the whole message (IMAP4).
+@item Server-side message look up (IMAP4). Multi-byte characters are allowed.
+@item Virtual Folders.
+@item Supports compressed folder using common archiving utilities.
+@item Old articles in folders are automatically removed/archived (Expiration).
+@item Automatic re-file.
+@item Template function makes it convenient to send fixed form messages.
+@end itemize\n")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 07:04
[PATCH v2 0/5] gnu: Add emacs-wanderlust.
(address . guix-patches@gnu.org)
y76y1s6nov0.wl-hako@ultrarare.space
v1 -> v2: Install icons to a proper path.

Hilton Chain (5):
gnu: Add emacs-bbdb-vcard.
gnu: Add emacs-apel-lb.
gnu: Add emacs-flim-lb.
gnu: Add emacs-semi-epg.
gnu: Add emacs-wanderlust.

gnu/packages/emacs-xyz.scm | 209 +++++++++++++++++++++++++++++++++++++
1 file changed, 209 insertions(+)

base-commit: 8cef05bab6251978018ccab7bb44883676ce8f6c
--
2.38.1

Diff range from v1 to v2:
Toggle diff (13 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 03c9cec60e..d3331f9d52 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34017,7 +34017,7 @@ (define-public emacs-wanderlust
(("(LISPDIR = )NONE" all m)
(string-append m lispdir))
(("(PIXMAPDIR = )NONE" all m)
- (string-append m lispdir))
+ (string-append m lispdir "/icons"))
(("(INFODIR = )NONE" all m)
(string-append m infodir))))
(invoke "make" "install")
H
H
Hilton Chain wrote on 20 Nov 2022 07:04
[PATCH v2 1/5] gnu: Add emacs-bbdb-vcard.
(address . guix-patches@gnu.org)
y76wn7qnoub.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-bbdb-vcard): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c1138e954..7479376018 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2841,6 +2841,34 @@ (define-public emacs-bbdb
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-bbdb-vcard
+ ;; No release since Dec 1, 2013.
+ (let ((version "0.4.1") ;3d79fdb4200a64a043e203a3baac95c936095b52, not tagged
+ (revision "88")
+ (commit "113c66115ce68316e209f51ebce56de8dded3606"))
+ (package
+ (name "emacs-bbdb-vcard")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tohojo/bbdb-vcard")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sr5kd2gvw1b4hl147yb60cgx6j730vdnpyr09p7vmpw65hzwlwm"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-bbdb))
+ (home-page "https://github.com/tohojo/bbdb-vcard")
+ (synopsis
+ "vCard Import and Export for The Insidious Big Brother Database (BBDB)")
+ (description
+ "@code{bbdb-vcard.el} imports and exports vCards (version 3.0) as
+defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
+(BBDB). Version 2.1 vCards are converted into version 3.0 on import.")
+ (license license:gpl2+))))
+
(define-public emacs-beacon
(package
(name "emacs-beacon")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 07:05
[PATCH v2 2/5] gnu: Add emacs-apel-lb.
(address . guix-patches@gnu.org)
y76v8nanotm.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-apel-lb): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7479376018..dc6899884d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33873,6 +33873,32 @@ (define-public emacs-mpv
process via its IPC interface.")
(license license:gpl3+))))
+(define-public emacs-apel-lb
+ ;; No release since Jun 15, 2010.
+ (let ((version "10.8") ;tag chise-base-0_25
+ (revision "81")
+ (commit "82eb2325bd149dc57b43a9ce9402c6c6183e4052"))
+ (package
+ (name "emacs-apel-lb")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/apel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qiw19pn1cs8y571irw7bjdygkvwan9ch2i1dg139dri4b6q1il6"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Library for making portable Emacs Lisp programs")
+ (description
+ "A Portable Emacs Library (APEL) is a library for making portable Emacs
+Lisp programs. APEL-LB is a variant of APEL, which features supports to
+latest Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 07:05
[PATCH v2 3/5] gnu: Add emacs-flim-lb.
(address . guix-patches@gnu.org)
y76tu2unosz.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-flim-lb): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc6899884d..a5621e4fea 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33899,6 +33899,34 @@ (define-public emacs-apel-lb
latest Emacs.")
(license license:gpl2+))))
+(define-public emacs-flim-lb
+ ;; No release since Nov 28, 2007.
+ (let ((version "1.14.9")
+ (revision "133")
+ (commit "57c6b868aa314717f40a520daed7249665e8d992"))
+ (package
+ (name "emacs-flim-lb")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/flim")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mf8r5mf3bd0719fnhifb6lfvl7n4m552crcdhkbkkif8srrl6df"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-apel-lb emacs-oauth2))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis
+ "Library for basic features about message representation or encoding")
+ (description
+ "FLIM is a library to provide basic features about message representation
+or encoding. FLIM-LB is a variant of FLIM, which features supports to latest
+Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 07:05
[PATCH v2 4/5] gnu: Add emacs-semi-epg.
(address . guix-patches@gnu.org)
y76sfienose.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-semi-epg): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a5621e4fea..f4b39b90ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33927,6 +33927,33 @@ (define-public emacs-flim-lb
Emacs.")
(license license:gpl2+))))
+(define-public emacs-semi-epg
+ ;; No release since Dec 24, 2003.
+ (let ((version "1.14.6")
+ (revision "241")
+ (commit "ac3e726ca94ed245c25881ec8d7177d0d834ea6a"))
+ (package
+ (name "emacs-semi-epg")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/semi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bg07y6svvg1mmlr455x3j1anjp3wbv27s6b2inp294rbwprm41n"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-bbdb-vcard emacs-flim-lb))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Library to provide MIME feature for GNU Emacs")
+ (description
+ "SEMI is a package for GNU Emacs to provide features related with MIME
+user interface. SEMI-EPG is a variant of SEMI, which features supports to
+EasyPG and latest Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
H
H
Hilton Chain wrote on 20 Nov 2022 07:06
[PATCH v2 5/5] gnu: Add emacs-wanderlust.
(address . guix-patches@gnu.org)
y76r0xynorq.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-wanderlust): New variable.
---
gnu/packages/emacs-xyz.scm | 100 +++++++++++++++++++++++++++++++++++++
1 file changed, 100 insertions(+)

Toggle diff (113 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f4b39b90ef..d3331f9d52 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33954,6 +33954,106 @@ (define-public emacs-semi-epg
EasyPG and latest Emacs.")
(license license:gpl2+))))
+(define-public emacs-wanderlust
+ ;; No release since Jan 15, 2010.
+ ;; FIXME: Building with emacs-next-pgtk would yield a void variable related
+ ;; macro-expansion failure at runtime, so don't rewrite emacs input of this
+ ;; package.
+ (let ((version "2.15.9")
+ (revision "779")
+ (commit "f5cb2f0cf5e2c893acf2e669fd549836828dfdfc"))
+ (package
+ (name "emacs-wanderlust")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanderlust/wanderlust")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "WL-CFG"
+ ((".*WL_PREFIX.*")
+ (string-append "(setq wl-install-utils t)" "\n"
+ "(setq WL_PREFIX \"\")" "\n"
+ "(setq ELMO_PREFIX \"\")" "\n")))
+ (substitute* "Makefile"
+ (("package-user-dir") "NONE"))))
+ (sha256
+ (base32
+ "1ijs57wv1vrh33vn311hgkp42vlmjyi998nc4qdrqi7yy9j8hl1h"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'expand-load-path 'chdir-elmo
+ (lambda _
+ (chdir "elmo")))
+ (add-after 'chdir-elmo 'expand-load-path-elmo
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-elmo 'chdir-utils
+ (lambda _
+ (chdir "../utils")))
+ (add-after 'chdir-utils 'expand-load-path-utils
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-utils 'chdir-wl
+ (lambda _
+ (chdir "../wl")))
+ (add-after 'chdir-wl 'expand-load-path-wl
+ (assoc-ref %standard-phases 'expand-load-path))
+ (add-after 'expand-load-path-wl 'change-directory
+ (lambda _
+ (chdir "..")))
+ (add-after 'install 'install-via-makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((emacs (search-input-file inputs "/bin/emacs"))
+ (lispdir (elpa-directory #$output))
+ (infodir (string-append #$output "/share/info")))
+ (for-each mkdir-p (list lispdir infodir))
+ (substitute* "Makefile"
+ (("(EMACS = )emacs" all m)
+ (string-append m emacs))
+ (("(LISPDIR = )NONE" all m)
+ (string-append m lispdir))
+ (("(PIXMAPDIR = )NONE" all m)
+ (string-append m lispdir "/icons"))
+ (("(INFODIR = )NONE" all m)
+ (string-append m infodir))))
+ (invoke "make" "install")
+ (invoke "make" "install-info"))))))
+ (propagated-inputs (list emacs-semi-epg))
+ (home-page "https://www.emacswiki.org/emacs/WanderLust")
+ (synopsis "Yet Another Message Interface on Emacsen")
+ (description
+ "Wanderlust is an mail/news management system on Emacsen. It supports
+IMAP4rev1(RFC2060), NNTP, POP and local message files.
+
+The main features of Wanderlust:
+
+@itemize
+@item Pure elisp implementation.
+@item Supports IMAP4rev1, NNTP, POP(POP3/APOP), MH and Maildir format.
+@item Unified access method to messages based on Mew-like Folder Specification.
+@item Mew-like Key-bind and mark handling.
+@item Manages unread messages.
+@item Interactive thread display.
+@item Folder Mode shows the list of subscribed folders.
+@item Message Cache, Disconnected Operation.
+@item MH-like FCC. (Fcc: %Backup and Fcc: $Backup is allowed).
+@item MIME compliant (by SEMI).
+@item Transmission of news and mail are unified by Message transmitting draft.
+@item Graphical list of folders.
+@item View a part of message without retrieving the whole message (IMAP4).
+@item Server-side message look up (IMAP4). Multi-byte characters are allowed.
+@item Virtual Folders.
+@item Supports compressed folder using common archiving utilities.
+@item Old articles in folders are automatically removed/archived (Expiration).
+@item Automatic re-file.
+@item Template function makes it convenient to send fixed form messages.
+@end itemize\n")
+ (license license:gpl2+))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
C
C
Christopher Baines wrote on 21 Nov 2022 15:39
Re: [bug#59402] [PATCH v2 0/5] gnu: Add emacs-wanderlust.
(name . Hilton Chain)(address . hako@ultrarare.space)
87sfictlqd.fsf@cbaines.net
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (14 lines)
> v1 -> v2: Install icons to a proper path.
>
> Hilton Chain (5):
> gnu: Add emacs-bbdb-vcard.
> gnu: Add emacs-apel-lb.
> gnu: Add emacs-flim-lb.
> gnu: Add emacs-semi-epg.
> gnu: Add emacs-wanderlust.
>
> gnu/packages/emacs-xyz.scm | 209 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 209 insertions(+)
>
> base-commit: 8cef05bab6251978018ccab7bb44883676ce8f6c

Thanks! I've made a few tweaks, mostly to address a couple of lint
warnings for emacs-wanderlust and pushed to master as
bb2d7259eed3f00213c3ad66a0de0c94a10f05b2.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN7jbpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfQoRAAjm7fRSegU4Rn24yzF9PlPCb6qJ5TNElp
eZcJqKboEFj5M3R0aWJj1I1UmzZq4bjBmIaNjEvUZZbOuPpT2Wy8LerhscMBlpGk
SouJCBOXt8WKzeM78rCt4lSWmtWTfCNjznBMeD/kCsnIxSMhmIB+ncz7rgeX/yxh
lViEg9Zrdpr0rPdmCHC3fViM3kmMJ+Kyt2BBD9IXxZKUg9vfujGc+rIKsXhguHvG
5Cl5LDs5Zm466jSLBBeBGGRqqYjiqMrKvCKz02c3Jc40ifWSbniW5V+q8+CSO7Ps
XiHvotjuA02ZYcvDeZyQ+4wuvOyVWzhSiNu9wyeKQ3FQXx620dSc6a1MRP7F+j0E
Rz6IAQe6ti+h0GTyVxzUlYK3DN3PcfE6wu5/leckvH0hYhIe+xYM3W0dStHmZ8wZ
79fqXq0PmyhYXpe6oIEZsdbnwO/SgAhJEl1sbU+iKweShvIiSZBWqsWqq5vY7dhD
2IgovupRPxc77cjDAF9BaFq10tb6Q+65TtDZtSpATLBk89qiyeXS+dvzt8PWPEas
u9fo6doPpYO1ml1+wKvrHWs8IyHDQguas1hsBcOUZjFewPKWH/UnjR0ElVUdvX9s
vfN7cXgMC96YC9gAzwIAlWPRNKkZvUtfFJY0sOcYxhPhGOY4sPPd2MXTuWLqI0p7
Jv3CginarBc=
=I0n3
-----END PGP SIGNATURE-----

Closed
?