[PATCH] gnu: go-github-com-zenhack-go-notmuch: Use UNGEXP-NATIVE with NOTMUCH-FIXTURES.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20221108171958.4579-1-paren@disroot.org
* gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch)
[arguments]<#:phases>{'unpack-test-fixtures}: Use UNGEXP-NATIVE with
NOTMUCH-FIXTURES.
---
gnu/packages/golang.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e52161228e..26b5048ed0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10371,7 +10371,7 @@ (define-public go-github-com-zenhack-go-notmuch
(lambda* (#:key inputs import-path
#:allow-other-keys)
(invoke "tar" "xf"
- #$notmuch-fixtures "-C"
+ #+notmuch-fixtures "-C"
(string-append "src/" import-path
"/fixtures")))))))
(inputs (list notmuch))

base-commit: 96ae718c516a289124a0b91ceeef78b20d187825
--
2.38.0
C
C
Christopher Baines wrote on 20 Nov 2022 12:28
(name . ()(address . paren@disroot.org)
87tu2tx3t2.fsf@cbaines.net
"( via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (23 lines)
> * gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch)
> [arguments]<#:phases>{'unpack-test-fixtures}: Use UNGEXP-NATIVE with
> NOTMUCH-FIXTURES.
> ---
> gnu/packages/golang.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index e52161228e..26b5048ed0 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -10371,7 +10371,7 @@ (define-public go-github-com-zenhack-go-notmuch
> (lambda* (#:key inputs import-path
> #:allow-other-keys)
> (invoke "tar" "xf"
> - #$notmuch-fixtures "-C"
> + #+notmuch-fixtures "-C"
> (string-append "src/" import-path
> "/fixtures")))))))
> (inputs (list notmuch))
>
> base-commit: 96ae718c516a289124a0b91ceeef78b20d187825

Hey,

I can guess at why you might be wanting to change this, but I'm
interested in what your actual reasoning is (and it's good if this is in
the commit message to)?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN6D3lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XedOQ//WwX/po4BEUsTq1a2foj4sOpTxAZIDKJV
ATyIX9lt7VLoe6JrVKUZmfwcLdXtMO8Qfeodk9xXNDDRWCwzIwZcmftStLf1BWeq
GWeHOggrbkVtBHIttXQLBQGYLwsF8K1K6X34lld45x+FqO9SPo3ePnp8p1ABXbSE
RyW43vkt4E7ct+I6WlaKqTz9GW2qDdLF2pQvAXtw3gUJQ8CmjnVNYPDP3gcRWYo/
/u117CVwdmw+Wl+Me3RUHY+FQc9M3eTaWowrgGpRv8CsakzrRHzOORFqrG2zjQlZ
mb5BjMfALSfLdi43xmgigmMOsYk4JqA25XkQYG30mJUvHXuagN1yzbYLtYDZpjz9
05K9oJjX4jVr5uTVcVIlJy4ANadXYIi0WkWCZ4Bbpro2y5OSqAiGAnpNP70vccN0
PwDCfnbwKpF/X1jyP0sebnDm3wtNv1so46+zQjMcHiCWs6Nl2v3yb3FMrG4BMKMC
usCqg2nNp2ButR6zkIv/kZsK1PYdugsjkjDLKB4uxO27bKjrEuS/xbTeasKr5PkT
lnhPdq5NEWGAsMg8XX/seyHBdYZI070JxOSgWbprm889Wi2YwnBThp2gN43mO/r5
MJ5SqgfKMMQL0pWGx/k2T8eYXxjXoub8DZHP23rCI7cYJ7YsuAM4ggDI2dY8wJIh
CKi76sOCiJE=
=8RAn
-----END PGP SIGNATURE-----

(
(name . Christopher Baines)(address . mail@cbaines.net)
COH3F0NM9USG.2RHC8U7L45EF5@guix-framework
On Sun Nov 20, 2022 at 11:28 AM GMT, Christopher Baines wrote:
Toggle quote (4 lines)
> I can guess at why you might be wanting to change this, but I'm
> interested in what your actual reasoning is (and it's good if this is in
> the commit message to)?

Well, since NOTMUCH-FIXTURES is just an origin, it won't differ on
different systems. So, we don't need to cross-compile it, because a
non-cross-compiled version will work just as well. But Guix has no
way of knowing this, so if we use UNGEXP, it'll re-build the origin
unnecessarily. If we use UNGEXP-NATIVE, it'll just use the host's
NOTMUCH-FIXTURES.

-- (
C
C
Christopher Baines wrote on 20 Nov 2022 13:09
(name . ()(address . paren@disroot.org)
878rk5x1x5.fsf@cbaines.net
"(" <paren@disroot.org> writes:

Toggle quote (12 lines)
> On Sun Nov 20, 2022 at 11:28 AM GMT, Christopher Baines wrote:
>> I can guess at why you might be wanting to change this, but I'm
>> interested in what your actual reasoning is (and it's good if this is in
>> the commit message to)?
>
> Well, since NOTMUCH-FIXTURES is just an origin, it won't differ on
> different systems. So, we don't need to cross-compile it, because a
> non-cross-compiled version will work just as well. But Guix has no
> way of knowing this, so if we use UNGEXP, it'll re-build the origin
> unnecessarily. If we use UNGEXP-NATIVE, it'll just use the host's
> NOTMUCH-FIXTURES.

Thanks. And yeah, given notmuch-fixtures is just an origin, maybe this
just does make sense without any extra explaination.

I've gone ahead and pushed this to master as
cfec9f055272feb6fca8c52ba92c8e7d831052ac.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN6GQZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XciNRAAjqVeFXyO6kBz5vZg/iZQ/eu3xsv2Yhyl
Y17nfEGrB6v3oxf/vvxjt44V5eltCHT7cLTWzZUlQOm8Mb2cB0/fey0NyWQGH8uK
AhkK6W54QiJ2GhS0r8tk4DgRmYY1wtbxq2/QNSzScqdDG9dls17GdcNoP9jRLMAu
2LyME0jlHRwrR3mL73kJK8pgrTAfwjmNpbzivf/TtoIpQlm27NtgU4Jr1qvFYq9c
m7gy6BtIU4Yn8krNM2fIHfGo09Sij7P0icI8vFGiiki1Tyse4R3nL9y6dd2a90S7
y6xakZ7AZe/KGwY50jZDcD4uPn/Nw1vx4nkR3hrXOS9xRZV1oCF3lE4uH20bJxy0
C9tvKhqcFvfUoalPoxPe03QwuECxBmmCoNxPe1vnBQKqHpu8uGbiqyI5KpvsJzYT
j3Ptvd4MrkfcYlcWWeJDNlWhnC8sN8FWbreMU2/sUGZJvA20favDZHqHo52UcmOr
xMtmAKpn39dfHK3N6qnuEHdiJ7wEM0Ao9JmyFGgaxA6LyaVSXj61FuREVF5Ur024
Emnfp9zTltekEEdynjViYbgeL1JcR6ot9rJ/qsDVph8lerwoqdyX6hNhsCqzzcTA
6M0Jc+u8g3/KoAV14U8R9vMufmdqoAYdLEu18Ht9OLCWRJVo56SfIRF5LKx1Cyxk
EOv1ptmfZYo=
=9cMs
-----END PGP SIGNATURE-----

(
(name . Christopher Baines)(address . mail@cbaines.net)
COH43NWF8RIZ.33HS3E7VDKR83@guix-framework
On Sun Nov 20, 2022 at 12:09 PM GMT, Christopher Baines wrote:
Toggle quote (3 lines)
> I've gone ahead and pushed this to master as
> cfec9f055272feb6fca8c52ba92c8e7d831052ac.

Thanks!

-- (
?