[PATCH] build-system: emacs: Use new function for autoloads generation

  • Open
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 10 Aug 2022 19:37
(address . guix-patches@gnu.org)
DM5PR03MB31632CAA1BEDE81708A8AD6FC5659@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* guix/build/emacs-utils.scm (emacs-generate-autoloads): Use
'loaddefs-generate' to create autoloads instead of
'update-directory-autoloads' if we are using a new enough Emacs
---

I'm not sure how long it takes to rebuild all the Emacs packages so I CC'd Liliana since they are going to change the Emacs build system soon anyways.

This change is to allow packages to be built with the latest commits of emacs (guix build emacs-crdt --with-input=emacs-minimal=emacs-next --with-latest=emacs-next)

Just last week the 'update-directory-autoloads' function got deprecated and replaced. Since continuing to use the deprecated function would require changes anyways (adding a '(require 'autoloads)' would do it I think), I decided to just use the newer function.

Is this a bug in upstream Emacs where autoloaded functions like 'update-directory-autoloads' don't get autoloaded when they are in the obsolete directory? Possibly. Is this a bug related to our packaging of Emacs? Possibly. Is this the intended behaviour? Possibly. I'm not the guy to ask :P. I'm really not sure why this stopped working. But we will have to switch to the 'loaddefs-generate' function eventually anyways so I think this patch is probably good to apply.


Thanks,

Morgan


guix/build/emacs-utils.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/guix/build/emacs-utils.scm b/guix/build/emacs-utils.scm
index 8ee547f2b3..180c3ae08c 100644
--- a/guix/build/emacs-utils.scm
+++ b/guix/build/emacs-utils.scm
@@ -105,7 +105,11 @@ (define (emacs-generate-autoloads name directory)
(let* ((file (string-append directory "/" name "-autoloads.el"))
(expr `(let ((backup-inhibited t)
(generated-autoload-file ,file))
- (update-directory-autoloads ,directory))))
+ (if (not (require 'loaddefs-gen nil t))
+ ;; Emacs <= 28
+ (update-directory-autoloads ,directory)
+ ;; Emacs >= 29
+ (loaddefs-generate ,directory ,file)))))
(emacs-batch-eval expr #:dynamic? #t)))
(define* (emacs-byte-compile-directory dir)
--
2.37.1
L
L
Liliana Marie Prikler wrote on 10 Aug 2022 21:57
c31b42a35b0a5d02cf1d0afba88c3d6b1a5fc922.camel@gmail.com
Am Mittwoch, dem 10.08.2022 um 13:37 -0400 schrieb
Morgan.J.Smith@outlook.com:
Toggle quote (10 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * guix/build/emacs-utils.scm (emacs-generate-autoloads): Use
> 'loaddefs-generate' to create autoloads instead of
> 'update-directory-autoloads' if we are using a new enough Emacs
> ---
>
> I'm not sure how long it takes to rebuild all the Emacs packages so I
> CC'd Liliana since they are going to change the Emacs build system
> soon anyways.
I can tack that onto native-comp no problem. I can't recall the time
it took to rebuild everything for the last big upgrade, but it's
definitely something to do for fun and a little heat in winter.

Toggle quote (18 lines)
> This change is to allow packages to be built with the latest commits
> of emacs (guix build emacs-crdt --with-input=emacs-minimal=emacs-next
> --with-latest=emacs-next)
>
> Just last week the 'update-directory-autoloads' function got
> deprecated and replaced.  Since continuing to use the deprecated
> function would require changes anyways (adding a '(require
> 'autoloads)' would do it I think), I decided to just use the newer
> function.
>
> Is this a bug in upstream Emacs where autoloaded functions like
> 'update-directory-autoloads' don't get autoloaded when they are in
> the obsolete directory?  Possibly.  Is this a bug related to our
> packaging of Emacs?  Possibly.  Is this the intended behaviour? 
> Possibly.  I'm not the guy to ask :P. I'm really not sure why this
> stopped working.  But we will have to switch to the 'loaddefs-
> generate' function eventually anyways so I think this patch is
> probably good to apply.
Can we instead use make-directory-autoloads or has that also been
deprecated in 29? make-directory-autoloads exists since Emacs 28.1 and
seems to have the same signature as loaddefs-generate. Any reason to
prefer the latter?


Cheers
M
M
Morgan Smith wrote on 11 Aug 2022 01:12
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 57122@debbugs.gnu.org)
DM5PR03MB31632A11FFB2018EC40F5AB8C5659@DM5PR03MB3163.namprd03.prod.outlook.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (5 lines)
> Can we instead use make-directory-autoloads or has that also been
> deprecated in 29? make-directory-autoloads exists since Emacs 28.1 and
> seems to have the same signature as loaddefs-generate. Any reason to
> prefer the latter?

make-directory-autoloads is in autoloads.el which has been moved to a
directory named "obsolete" but the function itself hasn't been marked
obsolete. I'm not really sure what that means but it looks like all the
autoloads stuff is being deprecated in favor of the newer loaddef stuff
M
M
Morgan Smith wrote on 18 Aug 2022 14:43
Re: bug#57122: [PATCH] build-system: emacs: Use new function for autoloads generation
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 57122@debbugs.gnu.org)
DM5PR03MB3163DC71A53488287BD01A8CC56D9@DM5PR03MB3163.namprd03.prod.outlook.com
So the FreeBSD guys had the same issue but actually bothered to notify
upstream so the issue has been fixed:

That doesn't mean we shouldn't look into using a non-deprecated function
though. Earlier I did try to use 'package-generate-autoloads' as that
seems like the ideal function to use but it adds the following string to
the loaddefs file:

"(add-to-list 'load-path (directory-file-name
(or (file-name-directory #$) (car load-path))))"

This line would probably work fine but for some reason when I tried it,
it didn't properly substitute '#$' with the file name. I'm not really
sure how to fix that.
L
L
Liliana Marie Prikler wrote on 18 Aug 2022 20:37
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 57122@debbugs.gnu.org)
ec7126d4b08d58087dbdd48c458b488af7bcbc74.camel@gmail.com
Am Donnerstag, dem 18.08.2022 um 08:43 -0400 schrieb Morgan Smith:
Toggle quote (16 lines)
>
> So the FreeBSD guys had the same issue but actually bothered to
> notify upstream so the issue has been fixed:
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57200
>
> That doesn't mean we shouldn't look into using a non-deprecated
> function though.  Earlier I did try to use 'package-generate-
> autoloads' as that seems like the ideal function to use but it adds
> the following string to the loaddefs file:
>
> "(add-to-list 'load-path (directory-file-name
>                      (or (file-name-directory #$) (car load-path))))"
>
> This line would probably work fine but for some reason when I tried
> it, it didn't properly substitute '#$' with the file name.  I'm not
> really sure how to fix that.
Is "#$" a literal string? You might want to substitute* the correct
directory in there after running package-generate-autoloads.

As for make-directory-autoloads vs. loaddefs-generate, IIRC both have
the same signature, so you could make this work with both the non-
deprecated function in Emacs 28 and the new one added in Emacs 29.

Cheers
?