[PATCH] gnu: emacs-list-utils: update to latest commit

  • Done
  • quality assurance status badge
Details
2 participants
  • Erik Šabi?
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Erik Šabi?
Severity
normal
E
E
Erik Šabi? wrote on 21 May 2022 12:01
(address . guix-patches@gnu.org)
20220521100117.7776-1-erik.sab@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-list-utils): [version] The latest
commit (0dec8c02962d2591766739e37c5714ba21133093) contains both the
patch-require-cl, which I removed, and calls to define-obsolete-function-alias
are made with 3 arguments instead of 2, which is necessary to compile with
Emacs 28.1
---
gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++----------------------
1 file changed, 19 insertions(+), 25 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae81f4e395..944597139a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18730,31 +18730,25 @@ (define-public emacs-helm-gtags
(license license:gpl3+)))
(define-public emacs-list-utils
- (package
- (name "emacs-list-utils")
- (version "0.4.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rolandwalker/list-utils")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "07hbz2md52ccy95gv4d5n6szrfmpfqf3w4kwqdg2cf54c7kgf7hw"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-require-cl
- (lambda _
- (substitute* "list-utils.el"
- (("\\(require 'cl\\)") "(require 'cl-lib)"))
- #t)))))
- (home-page "https://github.com/rolandwalker/list-utils")
- (synopsis "List-manipulation utility functions")
- (description "This package provides a list manipulation library for Emacs.")
- (license license:gpl3+)))
+ (let ((commit "0dec8c02962d2591766739e37c5714ba21133093") (revision "1"))
+ (package
+ (name "emacs-list-utils")
+ (version (git-version "0.4.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rolandwalker/list-utils")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11nm8649a131bn2kwj4fxkiijdx2d4f1byx7a985zlb3bzdwnaw8"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rolandwalker/list-utils")
+ (synopsis "List-manipulation utility functions")
+ (description
+ "This package provides a list manipulation library for Emacs.")
+ (license license:gpl3+))))
(define-public emacs-parsec
(package

base-commit: 94b28247d1b976e9c01c75794663603b7b81eaeb
--
2.36.1
T
T
Tobias Geerinckx-Rice wrote on 26 May 2022 21:49
(name . Erik Šabi?)(address . erik.sab@gmail.com)
877d686oyv@nckx
Erik,

Thank you!

This build failure was bugging a lot of people, so I pushed your
fix as commit c5d68c6d12e691bceba60bc9537ea499bb50273d, with a
message matching out conventions.
Please take a look.

For example, we use a specific ‘gnu: foo: Update to $VERSION.’
title, and again in the changelog section.

Erik Šabi? ???
Toggle quote (10 lines)
> * gnu/packages/emacs-xyz.scm (emacs-list-utils): [version] The
> latest
> commit (0dec8c02962d2591766739e37c5714ba21133093) contains both
> the
> patch-require-cl, which I removed, and calls to
> define-obsolete-function-alias
> are made with 3 arguments instead of 2, which is necessary to
> compile with
> Emacs 28.1

I moved this comment to the code. Comments like this almost
*never* belong in commit messages. Who reads those — in context —
after a week?

Thanks again!

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYo/dGA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15RtMA/ApdTxdFA0sQlGy8iCfaBYNWyoy18SNsDJ0TZ/KU
dWBhAQD0cuet32KnVspjYmr3wsOp6efw9E2+Se2qNZ+U20pSBw==
=kTVf
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 55558@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55558
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch