[PATCH 0/5] some golang packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Maxime Devos
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 23 Feb 2022 11:24
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
cover.1645611835.git.efraim@flashner.co.il
Just a couple of golang packages I have ready for upstreaming

Efraim Flashner (5):
gnu: Add go-github-com-xdg-go-stringprep.
gnu: Add go-github-com-niemeyer-pretty.
gnu: Add go-github-com-docker-go-units.
gnu: Add go-github-com-xdg-go-pbkdf2.
gnu: Add go-github-com-xdg-go-scram.

gnu/packages/golang.scm | 126 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 126 insertions(+)


base-commit: ec66f84824198f380d20126d3e4b2ea795fd205a
prerequisite-patch-id: 9d30bed3a784f3e68b0c243cfa605ef2c9dbfe23
--
2.34.0
E
E
Efraim Flashner wrote on 23 Feb 2022 11:29
[PATCH 1/5] gnu: Add go-github-com-xdg-go-stringprep.
(address . 54123@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
5dd3dd24a7fb6a1b16dd6898c45b34f6c9205437.1645611835.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-github-com-xdg-go-stringprep): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a093728805..e1d9d1fcde 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7867,6 +7867,31 @@ (define-public go-github-com-twpayne-go-xdg
@uref{freedesktop.org}.")
(license license:expat)))
+(define-public go-github-com-xdg-go-stringprep
+ (package
+ (name "go-github-com-xdg-go-stringprep")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/stringprep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1df0l5n3c520y9filzz83j42wa5c056jcygmfwhjyf1pq8f6jkv9"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/xdg-go/stringprep"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (home-page "https://github.com/xdg-go/stringprep")
+ (synopsis "Go implementation of RFC-3454 stringprep and RFC-4013 SASLprep")
+ (description
+ "Package stringprep provides data tables and algorithms for RFC-3454,
+including errata. It also provides a profile for SASLprep as defined in
+RFC-4013.")
+ (license license:asl2.0)))
+
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")
--
2.34.0
E
E
Efraim Flashner wrote on 23 Feb 2022 11:29
[PATCH 2/5] gnu: Add go-github-com-niemeyer-pretty.
(address . 54123@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
98ccc56c6c203acd07dcb8ec0a81c0a39db622b9.1645611835.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-github-com-niemeyer-pretty): New variable.
---
gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e1d9d1fcde..95ef87385a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5511,6 +5511,36 @@ (define-public go-github-com-kr-pretty
(home-page "https://github.com/kr/pretty")
(license license:expat)))
+(define-public go-github-com-niemeyer-pretty
+ (package
+ (name "go-github-com-niemeyer-pretty")
+ (version "0.0.0-20200227124842-a10e7caefd8e")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/niemeyer/pretty")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jmazh4xzaa3v6g46hz60q2z7nmqs9l9cxdzmmscn3kbcs2znq4v"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/niemeyer/pretty"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; https://github.com/kr/pretty/pull/66
+ (substitute* "src/github.com/niemeyer/pretty/formatter.go"
+ (("string\\(i\\)") "string(rune(i))")))))))
+ (propagated-inputs
+ (list go-github-com-kr-text))
+ (home-page "https://github.com/niemeyer/pretty")
+ (synopsis "Pretty printer for Go values")
+ (description "This package provides a pretty printer for Go values.")
+ (license license:expat)))
+
(define-public go-github-com-kylelemons-godebug
(package
(name "go-github-com-kylelemons-godebug")
--
2.34.0
E
E
Efraim Flashner wrote on 23 Feb 2022 11:29
[PATCH 3/5] gnu: Add go-github-com-docker-go-units.
(address . 54123@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
961b100f8b31cf8c678514ea36acf6d62ec7e85d.1645611835.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-github-com-docker-go-units): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 95ef87385a..bce327a7c1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3892,6 +3892,28 @@ (define-public go-github-com-docker-go-connections
translation (NAT), proxies, sockets, and transport layer security (TLS).")
(license license:asl2.0))))
+(define-public go-github-com-docker-go-units
+ (package
+ (name "go-github-com-docker-go-units")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-units")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k8gja8ql4pqg5rzmqvka42vjfs6rzablak87whcnqba6qxpimvz"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/docker/go-units"))
+ (home-page "https://github.com/docker/go-units")
+ (synopsis "Parse and print size and time units in human-readable format")
+ (description
+ "@code{go-units} is a library to transform human friendly measurements into
+machine friendly values.")
+ (license license:asl2.0)))
+
(define-public go-github-com-docker-machine
(let ((commit "7b7a141da84480342357c51838be142bf183b095")
(revision "0"))
--
2.34.0
E
E
Efraim Flashner wrote on 23 Feb 2022 11:29
[PATCH 4/5] gnu: Add go-github-com-xdg-go-pbkdf2.
(address . 54123@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
31271c6a474dfa21f09b3df5333d1091531999ab.1645611835.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-github-com-xdg-go-pbkdf2): New variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bce327a7c1..08bc1578e3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7944,6 +7944,29 @@ (define-public go-github-com-xdg-go-stringprep
RFC-4013.")
(license license:asl2.0)))
+(define-public go-github-com-xdg-go-pbkdf2
+ (package
+ (name "go-github-com-xdg-go-pbkdf2")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/pbkdf2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nipijy5xkdnfyhkp5ryrjzm14si1i2v2xyfmblf84binwkbr8jh"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/xdg-go/pbkdf2"))
+ (home-page "https://github.com/xdg-go/pbkdf2")
+ (synopsis "Go implementation of PBKDF2")
+ (description
+ "Package pbkdf2 implements password-based key derivation using the PBKDF2
+algorithm described in @url{https://rfc-editor.org/rfc/rfc2898.html,RFC 2898}
+and @url{https://rfc-editor.org/rfc/rfc8018.html,RFC 8018}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")
--
2.34.0
E
E
Efraim Flashner wrote on 23 Feb 2022 11:29
[PATCH 5/5] gnu: Add go-github-com-xdg-go-scram.
(address . 54123@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
6af020863a6bfa7c843f9738f536c605fdde68d8.1645611835.git.efraim@flashner.co.il
* gnu/packages/golang.scm (go-github-com-xdg-go-scram): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 08bc1578e3..9c7f8580ec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7967,6 +7967,32 @@ (define-public go-github-com-xdg-go-pbkdf2
and @url{https://rfc-editor.org/rfc/rfc8018.html,RFC 8018}.")
(license license:asl2.0)))
+(define-public go-github-com-xdg-go-scram
+ (package
+ (name "go-github-com-xdg-go-scram")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/scram")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jyv4qgc1dgh3v96pazmgljpp9ij25k8hwn0v4fck18g16i0nccm"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/xdg-go/scram"))
+ (propagated-inputs
+ (list go-github-com-xdg-go-stringprep
+ go-github-com-xdg-go-pbkdf2))
+ (home-page "https://github.com/xdg-go/scram")
+ (synopsis "Go implementation of RFC-5802")
+ (description
+ "Package scram provides client and server implementations of the
+@acronym{Salted Challenge Response Authentication Mechanism, SCRAM} described in
+RFC-5802 and RFC-7677.")
+ (license license:asl2.0)))
+
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")
--
2.34.0
M
M
Maxime Devos wrote on 23 Feb 2022 13:39
Re: [bug#54123] [PATCH 2/5] gnu: Add go-github-com-niemeyer-pretty.
3e005ac0e0c41ec31ca0b3edb44ce63ef1770e62.camel@telenet.be
Efraim Flashner schreef op wo 23-02-2022 om 12:29 [+0200]:
Toggle quote (10 lines)
> +    (arguments
> +     '(#:import-path "github.com/niemeyer/pretty"
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch-source
> +           (lambda _
> +             ;; https://github.com/kr/pretty/pull/66
> +             (substitute* "src/github.com/niemeyer/pretty/formatter.go"
> +               (("string\\(i\\)") "string(rune(i))")))))))

The 'patches' and 'snippet' fields of 'origin' are for patching
source code. While patching in a phase works, an origin snippet
seems a more natural place to me.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYhYq5BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rpJAQDB9RzZIx84ZwYoLuTXldViP7kh
hMXpOxTwor5w4o5PDQEAvRiat7TcHItPOtfKAaIkdl7xpX+QxT319Gnx61w1Owc=
=nwlk
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 6 Mar 2022 11:26
Re: [PATCH 1/5] gnu: Add go-github-com-xdg-go-stringprep.
(address . 54123-done@debbugs.gnu.org)
YiSMR/5JQ00xMhWl@3900XT
Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmIkjEcACgkQQarn3Mo9
g1E53Q/+NbrqRNo+NpSgbE4zpHZN27r7ne+hN10X3/gbYHBQumlDcfrrJyLCim9F
/5AhPG0hX+d76dHYhgZp0ypAmrTh6TZdT8eakqi/4+AtPXFwj6jU9GNbt3EsU7G5
wzLU8sHIIr21h/aIW95c9huCy4lQ86ZIU3OcSsCwanCpd32A5mXSm+dm1JXYzh3O
kAmazbS7VAYgDWv+VsBHWyY6CH2dCQxGi2g97EL6D7+A6utYjRqJmxE5QU4WZiha
Cts/ddipz1q4dZXyn1DsBjULyFESYD3l8eBAhvCYE2BWccAInVgTNM0zKkFQidDz
/KkzssY+8kyP9Ki1kPaXaCXmrWfL3C1Gf97RDirv2gHllZYf8cz788bkLlX7fHy+
VPv+LBImxBgt7Flzar0c8OvR8Fao9+NByT0/Jy55UrMthe9qutD6/SYPFKHtJZFY
WRpDy0jkvXsJO5XWe9nZEn/IdSGGm3Ussx2IpKtwk+tTsPtySwPsvszpKulu8Cjh
ByuqSuLwgB0SBx32TP6PdZIPSaMlDzwLsO6S+ETBosZGFPaREjIZGcTc6F3RcRmx
6B4PURWAiHWkHm71/4ZKtAHS7RLaBWev5ctES2s3Fsnn5WS1STaxVHH7canMjGaX
Rv9O0cZpt3dyeom5mUmpaQOzNQ2HOPPEkMHbFwOIp7dOVkXssho=
=d14C
-----END PGP SIGNATURE-----


Closed
?