[PATCH 33/42] gnu: Add rust-sequoia-openpgp-1.

H
H
Hartmut Goebel wrote on 18 Dec 2021 21:49
(address . guix-patches@gnu.org)
8946747811780e05e1059b5b55e82d3f707725bc.1639859823.git.h.goebel@crazy-compilers.com
* gnu/packages/sequoia.scm (rust-sequoia-openpgp-1): New variable.
---
gnu/packages/sequoia.scm | 87 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 87 insertions(+)

Toggle diff (100 lines)
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 3757fdd971..dc0e542505 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -39,6 +39,93 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls))
+(define-public rust-sequoia-openpgp-1
+ (package
+ (name "rust-sequoia-openpgp")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sequoia-openpgp" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1mdprsijszkg2j6jk1iq7q1z9yikq598y12m5zbv94fs37xlx3qm"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove dependencies on rust-crypto and win32-cng
+ '(let* ((other-crypto-pkgs
+ (list ;; rust-crypto
+ "aes" "block-modes" "block-padding" "blowfish" "cast5"
+ "cipher" "des" "digest" "eax" "ed25519-dalek"
+ "generic-array" "idea" "md-5" "num-bigint-dig" "rand"
+ "ripemd160" "rsa" "sha-1" "sha2" "twofish" "typenum"
+ "x25519-dalek" "p256" "rand_core" "rand_core" "ecdsa"
+ ;; win32-cng
+ "eax" "winapi" "win-crypto-ng" "ed25519-dalek"
+ "num-bigint-dig"))
+ (pkgs-pattern (pk (string-join
+ (list "^\\[dependencies\\.("
+ (string-join other-crypto-pkgs "|")
+ ")\\]")
+ ""))))
+ (substitute* "Cargo.toml"
+ ((pkgs-pattern line name) (string-append "[off." name "]"))
+ (("^crypto-cng =" line) (string-append "# " line))
+ (("^crypto-rust =" line) (string-append "# " line))
+ (("^\\[(target\\.\"cfg\\(windows\\))" line name)
+ (string-append "[off." name)))))))
+ (build-system cargo-build-system)
+ (native-inputs
+ (list clang pkg-config))
+ (inputs
+ (list gmp nettle))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-buffered-reader" ,rust-buffered-reader-1)
+ ("rust-bzip2" ,rust-bzip2-0.4)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-dyn-clone" ,rust-dyn-clone-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-idna" ,rust-idna-0.2)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-lalrpop" ,rust-lalrpop-0.19)
+ ("rust-lalrpop-util" ,rust-lalrpop-util-0.19)
+ ("rust-lazy-static" ,rust-lazy-static-1) ;; 1.4.0
+ ("rust-libc" ,rust-libc-0.2) ;; 0.2.66
+ ("rust-memsec" ,rust-memsec-0.6)
+ ("rust-nettle" ,rust-nettle-7)
+ ("rust-plotters" ,rust-plotters-0.3)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-regex-syntax" ,rust-regex-syntax-0.6)
+ ("rust-sha1collisiondetection" ,rust-sha1collisiondetection-0.2)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
+ ("rust-xxhash-rust" ,rust-xxhash-rust-0.8))
+ #:cargo-development-inputs
+ ;; keep the development-inputs to allow running tests easily
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-quickcheck" ,rust-quickcheck-0.9)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-rpassword" ,rust-rpassword-5))))
+ (home-page "https://sequoia-pgp.org/")
+ (synopsis "OpenPGP data types and associated machinery")
+ (description "This crate aims to provide a complete implementation of
+OpenPGP as defined by RFC 4880 as well as some extensions (e.g., RFC 6637,
+which describes ECC cryptography) for OpenPGP. This includes support for
+unbuffered message processing.
+
+A few features that the OpenPGP community considers to be deprecated (e.g.,
+version 3 compatibility) have been left out. The developers have also updated
+some OpenPGP defaults to avoid foot guns (e.g., they selected modern algorithm
+defaults).
+
+This Guix package is built to use the nettle cryptographic library.")
+ (license license:lgpl2.0+)))
+
(define-public sequoia
(package
(name "sequoia")
--
2.30.2
Z
Z
zimoun wrote on 21 Dec 2021 09:11
control merge #52610
(address . control@debbugs.gnu.org)
868rwes7g9.fsf@gmail.com
merge 52610 52611
merge 52610 52612
merge 52610 52613
merge 52610 52614
merge 52610 52615
merge 52610 52616
merge 52610 52617
merge 52610 52618
merge 52610 52619
merge 52610 52620
merge 52610 52621
merge 52610 52622
merge 52610 52623
merge 52610 52624
merge 52610 52625
merge 52610 52626
merge 52610 52627
merge 52610 52628
merge 52610 52629
merge 52610 52630
merge 52610 52631
merge 52610 52632
merge 52610 52633
merge 52610 52634
merge 52610 52635
merge 52610 52636
merge 52610 52637
merge 52610 52638
merge 52610 52639
merge 52610 52640
merge 52610 52641
merge 52610 52642
merge 52610 52643
merge 52610 52644
quit
?