(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
Hi,
It is possible to use another OPAM repository when importing, for instance
"guix import opam --repo=https://coq.inria.fr/opam/released"-- although Coq
packages are generally not built using OCaml or Dune build-system, another
story. :-) Or even, a package using OCaml or Dune build system but not
included in Opam repositories supported by Guix.
However, if this package uses OCaml or Dune build system, then 'refresh'
leaves which is annoying. For instance, consider:
Toggle snippet (9 lines)
$ guix lint -L /tmp/pkgs example
/tmp/pkgs/mine.scm:8:2: example@0 : champ de licence invalide
/tmp/pkgs/mine.scm:23:14: example@0 : le synopsis ne devrait pas commencer par un nom de paquet
/tmp/pkgs/mine.scm:22:15: example@0 : Erreur de certificat TLS : X.509 server certificate for 'exmaple.org' does not match: C=US,ST=California,L=test,O=testexample,OU=testexample,CN=testexp
guix lint: erreur : le paquet « example » est introuvable
The trivial patch instead turns this error to a warning which allows to run
all the checkers:
Toggle snippet (12 lines)
$ ./pre-inst-env guix lint -L /tmp/pkgs example
/tmp/pkgs/mine.scm:8:2: example@0: invalid license field
/tmp/pkgs/mine.scm:23:14: example@0: synopsis should not start with the package name
/tmp/pkgs/mine.scm:22:15: example@0: TLS certificate error: X.509 server certificate for 'exmaple.org' does not match: C=US,ST=California,L=test,O=testexample,OU=testexample,CN=testexp
guix lint: warning: opam: package 'example' not found
/tmp/pkgs/mine.scm:12:6: warning: failed to fetch Git repository for example
/tmp/pkgs/mine.scm:12:6: example@0: updater 'opam' failed to find upstream releases
/tmp/pkgs/mine.scm:12:6: example@0: scheduled Software Heritage archival
here 'archival'. Note that the failure is correctly handled by 'lint' when
the early leave skips.
Note that it could be better that 'opam-fetch' raises an error in order to be
catched by caller and thus make all the UI consistent. However, this requires
a revamp of all inporters...
Cheers,
simon
Example of file /tmp/pkgs/mine.scm:
Toggle snippet (27 lines)
(define-module (mine)
#:use-module (guix packages)
#:use-module (guix build-system ocaml)
#:use-module (guix git-download))
(define-public example
(package
(name "example")
(version "0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://example.org")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0m5si9dsv96z92gy4xaqz8mzyz8zp7j1sp542l0wzsp5xgyfpc7i"))))
(build-system ocaml-build-system)
(home-page "https://exmaple.org")
(synopsis "Example")
(description "This is an exmaple.")
(license #f)))
zimoun (1):
import: opam: Warn instead of leave when fetching fails.
guix/import/opam.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
base-commit: 122396075f12b013b6bde56dafb895587b95bc9d
--
2.32.0