[PATCH] gnu: Add emacs-org-vcard

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • pinoaffe
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 9 Nov 2021 10:34
(address . guix-patches@gnu.org)
87wnlhis4h.fsf@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-org-vcard): New variable.
---
gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c2ab1e92e..1ecfe7358a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12367,6 +12367,25 @@ (define-public emacs-org-contacts
in your Org Agenda, and more.")
(license license:gpl3+))))
+(define-public emacs-org-vcard
+ (package
+ (name "emacs-org-vcard")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flexibeast/org-vcard")
+ (commit "v0.2.0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14l3xqahqmnfl3sskqcr33xpcsic8dm9cr9wmbv5la3xv14n10k7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flexibeast/org-vcard")
+ (synopsis "org-mode support for vCard export and import.")
+ (description
+ "Export and import vCard files from within GNU Emacs' Org mode".)
+ (license license:gpl3+)))
+
(define-public emacs-org-pretty-table
;; There is no release yet.
(let ((commit "1331c600b83d95b28730b1bfcb48369ac1cf12ef")
--
2.33.1
P
P
pinoaffe wrote on 9 Nov 2021 10:34
[PATCH v2] gnu: Add emacs-org-vcard
(address . 51714@debbugs.gnu.org)
87tuglbj8p.fsf@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-org-vcard): New variable.
---
gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c2ab1e92e..df3851f65c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12367,6 +12367,25 @@ (define-public emacs-org-contacts
in your Org Agenda, and more.")
(license license:gpl3+))))
+(define-public emacs-org-vcard
+ (package
+ (name "emacs-org-vcard")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flexibeast/org-vcard")
+ (commit "v0.2.0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14l3xqahqmnfl3sskqcr33xpcsic8dm9cr9wmbv5la3xv14n10k7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flexibeast/org-vcard")
+ (synopsis "Org mode support for vCard export and import")
+ (description
+ "Export and import vCard files from within GNU Emacs' Org mode.")
+ (license license:gpl3+)))
+
(define-public emacs-org-pretty-table
;; There is no release yet.
(let ((commit "1331c600b83d95b28730b1bfcb48369ac1cf12ef")
--
2.33.1
N
N
Nicolas Goaziou wrote on 15 Nov 2021 11:33
(name . pinoaffe)(address . pinoaffe@gmail.com)(address . 51714-done@debbugs.gnu.org)
87ee7hiu8s.fsf@nicolasgoaziou.fr
Hello,

pinoaffe <pinoaffe@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-vcard): New variable.

Thank you. Applied, with the modifications below:

Toggle quote (7 lines)
> + (version "0.2.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/flexibeast/org-vcard")
> + (commit "v0.2.0")))

-> (commit (string-append "v" version))

Toggle quote (4 lines)
> + (description
> + "Export and import vCard files from within GNU Emacs' Org
> mode.")

This package exports…

Regards,
--
Nicolas Goaziou
Closed
?