[PATCH 0/4] More julia packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • zimoun
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 20 Oct 2021 14:48
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
cover.1634733947.git.efraim@flashner.co.il
I figured out where earcut is from finally and I'm skipping it for now.
The package providing libearcut.so is from Julia's Yggdrasil itself so
I'm not sure about it. TimeZones.jl is rough, I need to figure out how
to generate portions of it from our tzdata package.

Efraim Flashner (4):
gnu: Add julia-gr-jll.
gnu: Add julia-gr.
gnu: Add julia-geometrybasics.
gnu: Add julia-infinity.

gnu/packages/julia-jll.scm | 50 +++++++++++++++++++
gnu/packages/julia-xyz.scm | 100 +++++++++++++++++++++++++++++++++++++
2 files changed, 150 insertions(+)


base-commit: 19d3cfec72720a4a1339be3d14f4d88ae5bd59f4
--
2.33.1
E
E
Efraim Flashner wrote on 20 Oct 2021 14:51
[PATCH 1/4] gnu: Add julia-gr-jll.
(address . 51305@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
b239a8b691c8cd767382ea367c38fba36332c9c9.1634733947.git.efraim@flashner.co.il
* gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
---
gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index d3677d0a33..51643819ae 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -36,6 +36,7 @@ (define-module (gnu packages julia-jll)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -522,6 +523,55 @@ (define-public julia-glib-jll
(description "This package provides a wrapper for the glib library.")
(license license:expat)))
+(define-public julia-gr-jll
+ (package
+ (name "julia-gr-jll")
+ (version "0.58.1+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+ (commit (string-append "GR-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16m22n0wh86v3lh0im2pc9bg381djbmqji5hjx42j6aaz634gqiq"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"GR\", \""
+ (assoc-ref inputs "gr-framework") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("gr-framework" ,gr-framework)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-cairo-jll" ,julia-cairo-jll)
+ ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
+ ("julia-fontconfig-jll" ,julia-fontconfig-jll)
+ ("julia-glfw-jll" ,julia-glfw-jll)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-libpng-jll" ,julia-libpng-jll)
+ ("julia-libtiff-jll" ,julia-libtiff-jll)
+ ("julia-pixman-jll" ,julia-pixman-jll)
+ ("julia-qt5base-jll" ,julia-qt5base-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+ (synopsis "GR framework library wrappers")
+ (description "This package provides a wrapper for the GR framework.")
+ (license license:expat)))
+
(define-public julia-gumbo-jll
(package
(name "julia-gumbo-jll")
--
2.33.1
E
E
Efraim Flashner wrote on 20 Oct 2021 14:51
[PATCH 2/4] gnu: Add julia-gr.
(address . 51305@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
b39dca394d1948b3e41daa2dacd85ccded220b6a.1634733947.git.efraim@flashner.co.il
* gnu/packages/julia-xyz.scm (julia-gr): New variable.
---
gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 58f58f36ec..1db5a1bc58 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1895,6 +1895,28 @@ (define-public julia-genericschur
matrices the Schur form is often more useful.")
(license license:expat)))
+(define-public julia-gr
+ (package
+ (name "julia-gr")
+ (version "0.58.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jheinen/GR.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18zxa1w2wmrf44c5l10qbh99zjdp7h94gxlymh47cf5kj5fc4xmx"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-gr-jll" ,julia-gr-jll)))
+ (home-page "https://github.com/jheinen/GR.jl")
+ (synopsis "Plotting for Julia based on GR")
+ (description "This module provides a Julia interface to GR, a framework for
+visualisation applications.")
+ (license license:expat)))
+
(define-public julia-graphics
(package
(name "julia-graphics")
--
2.33.1
E
E
Efraim Flashner wrote on 20 Oct 2021 14:51
[PATCH 3/4] gnu: Add julia-geometrybasics.
(address . 51305@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
414e86395ac9f901ca9d4a5250eb1d75ddd26357.1634733947.git.efraim@flashner.co.il
* gnu/packages/julia-xyz.scm (julia-geometrybasics): New variable.
---
gnu/packages/julia-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 1db5a1bc58..74bec305f0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1895,6 +1895,51 @@ (define-public julia-genericschur
matrices the Schur form is often more useful.")
(license license:expat)))
+(define-public julia-geometrybasics
+ (package
+ (name "julia-geometrybasics")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaGeometry/GeometryBasics.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "057j3hjpli3q5b98cqkpi4p10x2k9pyksrz62hjmv1kb5qzdvhsj"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-earcut
+ (lambda _
+ (substitute* '("Project.toml"
+ "src/GeometryBasics.jl")
+ ((".*EarCut.*") ""))
+ #t))
+ (add-after 'unpack 'skip-incompatible-test
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("@testset.*MetaT and heterogeneous data.*" all)
+ (string-append all "return\n")))
+ #t)))))
+ (propagated-inputs
+ `(("julia-itertools" ,julia-itertools)
+ ("julia-staticarrays" ,julia-staticarrays)
+ ("julia-structarrays" ,julia-structarrays)
+ ("julia-tables" ,julia-tables)))
+ (native-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)))
+ (home-page "https://github.com/JuliaGeometry/GeometryBasics.jl")
+ (synopsis "Basic Geometry Types")
+ (description "This package aims to offer a standard set of Geometry types,
+which easily work with metadata, query frameworks on geometries and different
+memory layouts. The aim is to create a solid basis for Graphics/Plotting,
+finite elements analysis, Geo applications, and general geometry manipulations
+- while offering a Julian API, that still allows performant C-interop.")
+ (license license:expat)))
+
(define-public julia-gr
(package
(name "julia-gr")
--
2.33.1
E
E
Efraim Flashner wrote on 20 Oct 2021 14:51
[PATCH 4/4] gnu: Add julia-infinity.
(address . 51305@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
73f77189e867d3146fb299a6ddc2ec5c48113d71.1634733947.git.efraim@flashner.co.il
* gnu/packages/julia-xyz.scm (julia-infinity): New variable.
---
gnu/packages/julia-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 74bec305f0..93fadf318c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2448,6 +2448,39 @@ (define-public julia-indirectarrays
indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
(license license:expat)))
+(define-public julia-infinity
+ (package
+ (name "julia-infinity")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cjdoris/Infinity.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1941lwvrdjnrynigzixxin3chpg1ba6xplvcwc89x0f6z658hwmm"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-timezones.jl
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("using TimeZones.*") "")
+ ((".*infextendedtime.*") ""))
+ #t)))))
+ (propagated-inputs
+ `(("julia-requires" ,julia-requires)))
+ (native-inputs
+ `(("julia-compat" ,julia-compat)))
+ (home-page "https://docs.juliahub.com/Infinity/")
+ (synopsis "Representation of infinity in Julia")
+ (description "This package provides representations for infinity and
+negative infinity in Julia.")
+ (license license:expat)))
+
(define-public julia-inifile
(package
(name "julia-inifile")
--
2.33.1
Z
Z
zimoun wrote on 21 Oct 2021 15:01
Re: bug#51305: [PATCH 0/4] More julia packages
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 51305@debbugs.gnu.org)
86o87ilef0.fsf_-_@gmail.com
Hi,

On mer., 20 oct. 2021 at 15:51, Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (5 lines)
> * gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
> ---
> gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 50 insertions(+)

LGTM, except...

Toggle quote (16 lines)
> + (inputs
> + `(("gr-framework" ,gr-framework)))
> + (propagated-inputs
> + `(("julia-jllwrappers" ,julia-jllwrappers)
> + ("julia-bzip2-jll" ,julia-bzip2-jll)
> + ("julia-cairo-jll" ,julia-cairo-jll)
> + ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
> + ("julia-fontconfig-jll" ,julia-fontconfig-jll)
> + ("julia-glfw-jll" ,julia-glfw-jll)
> + ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
> + ("julia-libpng-jll" ,julia-libpng-jll)
> + ("julia-libtiff-jll" ,julia-libtiff-jll)
> + ("julia-pixman-jll" ,julia-pixman-jll)
> + ("julia-qt5base-jll" ,julia-qt5base-jll)
> + ("julia-zlib-jll" ,julia-zlib-jll)))

...is it possible to alphabetically sort? I find easier for maintenance
later. WDYT?

Cheers,
simon
Z
Z
zimoun wrote on 21 Oct 2021 15:12
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 51305@debbugs.gnu.org)
86lf2mldxl.fsf@gmail.com
Hi Efraim,

On mer., 20 oct. 2021 at 15:48, Efraim Flashner <efraim@flashner.co.il> wrote:

Toggle quote (6 lines)
> Efraim Flashner (4):
> gnu: Add julia-gr-jll.
> gnu: Add julia-gr.
> gnu: Add julia-geometrybasics.
> gnu: Add julia-infinity.

LGTM. Except minor comment about julia-gr-jll.


Thanks,
simon
E
E
Efraim Flashner wrote on 24 Oct 2021 08:16
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51305@debbugs.gnu.org)
YXT6MbTuvZTGONju@3900XT
On Thu, Oct 21, 2021 at 03:01:55PM +0200, zimoun wrote:
Toggle quote (29 lines)
> Hi,
>
> On mer., 20 oct. 2021 at 15:51, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
> > ---
> > gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 50 insertions(+)
>
> LGTM, except...
>
> > + (inputs
> > + `(("gr-framework" ,gr-framework)))
> > + (propagated-inputs
> > + `(("julia-jllwrappers" ,julia-jllwrappers)
> > + ("julia-bzip2-jll" ,julia-bzip2-jll)
> > + ("julia-cairo-jll" ,julia-cairo-jll)
> > + ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
> > + ("julia-fontconfig-jll" ,julia-fontconfig-jll)
> > + ("julia-glfw-jll" ,julia-glfw-jll)
> > + ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
> > + ("julia-libpng-jll" ,julia-libpng-jll)
> > + ("julia-libtiff-jll" ,julia-libtiff-jll)
> > + ("julia-pixman-jll" ,julia-pixman-jll)
> > + ("julia-qt5base-jll" ,julia-qt5base-jll)
> > + ("julia-zlib-jll" ,julia-zlib-jll)))
>
> ...is it possible to alphabetically sort? I find easier for maintenance
> later. WDYT?

the julia-jllwrappers are intentionally at the top of the list because
then all the package jll packages are grouped together.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF0+jEACgkQQarn3Mo9
g1EkyhAAve+mTxRM1nMq/AYm7q1X8KKjUgbHyrzbqfOjrI71NAqTW5Boma6bTwW9
G88fFnoDmFk405qlA896Nk2KzAi7ZnpCroKqLFBfBUtvZBuBwt/RFbgU9S6IEndE
LFQvwGzF8za//1DEKk2rdCL9l24q7nZw0MCtmk/IogyE74/BBFZtISasBC+C7HYE
/FXgD6C1VOJwTLo+gEs6GH7WtgPaecAvPrvv2K3bHV09aqL34oPK1Q5xpZ+MWJQ8
jTSJcH2ID/wLaE5NAZldwoTHMaHWzSXEjaVTjen1KesTxHqiw5XYSl3WNZg5kf+7
qm2qRNzBNJHruQhRBlcElBxh9uh9BZjY+KRbRgWRimzTw1eACXUhMmo+a0BSIZeb
ZCWLSvk4PZOWA/yVDGdGPqGFW/fnay2N+cl+GXaL8AbOmiSZojaZrZiVnHHOJbpG
aogULU+FIkjQTz3d9UlBkWkIY+TLI29A75vPHbqCEe1+Zd+gr0sPJd2Y5xpB3u5S
TOM04B6e2OrM3TE5YgAxN7Gl4k6yRwrv+6qBLphYfKycXaVyLLzg+MGtOFXoCs4M
SF1Qda4CsaOMfM/nZ6F6TVPa5voeg5Sjt7EhRGj5/mWs7hCyK6Q4LhG0A6FPkMfQ
INAat8YvnvHqetpDSlJWRGa1wkkCgyc/AESdYTRySxPxqpnCkrY=
=eLhZ
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 24 Oct 2021 09:54
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 51305@debbugs.gnu.org)
86y26iamdt.fsf@gmail.com
Hi Efraim,

On Sun, 24 Oct 2021 at 09:16, Efraim Flashner <efraim@flashner.co.il> wrote:

Toggle quote (3 lines)
> the julia-jllwrappers are intentionally at the top of the list because
> then all the package jll packages are grouped together.

It makes sense. :-)

Thanks,
simon
E
E
Efraim Flashner wrote on 24 Oct 2021 10:42
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51305-done@debbugs.gnu.org)
YXUce7Ef8cuoG3d7@3900XT
On Sun, Oct 24, 2021 at 09:54:22AM +0200, zimoun wrote:
Toggle quote (12 lines)
> Hi Efraim,
>
> On Sun, 24 Oct 2021 at 09:16, Efraim Flashner <efraim@flashner.co.il> wrote:
>
> > the julia-jllwrappers are intentionally at the top of the list because
> > then all the package jll packages are grouped together.
>
> It makes sense. :-)
>
> Thanks,
> simon

Thanks for the reviews! Patches pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF1HHsACgkQQarn3Mo9
g1EMig/8DkrbXw1O6sXaPO2Pa01p/bWPB2jk6DlEyDmsOWnGa0C5rWyOndnjDW+T
4Oi2tNk+yiyQxjsi7ONgV+QiorDucBl1Jojgqc1QhWtx2Y/fBsoRj4wqSaXFjPa9
ucJW1rymvJbFK7A+UT47dtMCKwrl29dWjlUm/q3DTtQrVsUSRWPxfHBQR9h/3XNg
RpcuyerxAdkYW/22p4TTEb0KnYPaDeJK7uwd0eKcwtX2Tx5qPbGhwaTmsrxGRwwh
wm3Vv7CtKpWZVIMb5gJCgvFRqkDMKP4A2nQDxBzafyR7YTwabi1rjnJhAyAGVFLK
eihKq7CAmlikITtA2wE2wyaZIUeWzCCHzg/4J0eZ1hWXHGR6fjAtMVQw/6abQjkD
YcywTASamDT+pgaSg4LL8IPZh5h74000pcrCIgAGkAZRVZ/quuF3ZWsop9+HVkpW
xEyXsiLbOk4WW7ppCMmRy6dQhKdSlcHmnpRir01MfErc1y0XiWBB/GCy+tFKOOLo
llmdHWqORDp3S6LT77XHDh9NEYenOfxWyk3YAVJXoSBi21hYMYoHtQjI4q4oretc
c3ELLHeh0QMKoeT0zBdF+P1XJX+vZlYtghVsMOfFcI6kj4tSLnKq8i04t2rkW5bX
KIOAmm0V/lk13aAG0AjyIf0SZYQQLO3zBLJkdb8Gx8P/sy93oZI=
=ntb5
-----END PGP SIGNATURE-----


Closed
?