[PATCH 1/2] gnu: waypipe: Simplify 'fix-sleep-path phase.

  • Done
  • quality assurance status badge
Details
2 participants
  • Robby Zambito
  • Ludovic Courtès
Owner
unassigned
Submitted by
Robby Zambito
Severity
normal
R
R
Robby Zambito wrote on 20 Oct 2021 04:19
(address . guix-patches@gnu.org)(name . Robby Zambito)(address . contact@robbyzambito.me)
20211020021936.1629519-1-contact@robbyzambito.me
* gnu/packages/freedesktop.scm (waypipe)
[arguments]: Remove inputs argument.
[native-inputs]: Remove coreutils.
---
gnu/packages/freedesktop.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 086707d51a..eb19552746 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2454,16 +2454,14 @@ compositors.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-sleep-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((coreutils (assoc-ref inputs "coreutils")))
- (substitute* "./test/startup_failure.py"
- (("sleep") (string-append coreutils "/bin/sleep")))))))))
+ (lambda* (#:key #:allow-other-keys)
+ (substitute* "./test/startup_failure.py"
+ (("sleep") (which "sleep"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("scdoc" ,scdoc)
;; For tests
- ("python" ,python)
- ("coreutils" ,coreutils)))
+ ("python" ,python)))
(home-page "https://gitlab.freedesktop.org/mstoeckl/waypipe")
(synopsis "Proxy for Wayland protocol applications")
(description
--
2.33.1
L
L
Ludovic Courtès wrote on 28 Oct 2021 20:47
(name . Robby Zambito)(address . contact@robbyzambito.me)(address . 51300-done@debbugs.gnu.org)
871r4556md.fsf@gnu.org
Hi,

Robby Zambito <contact@robbyzambito.me> skribis:

Toggle quote (4 lines)
> * gnu/packages/freedesktop.scm (waypipe)
> [arguments]: Remove inputs argument.
> [native-inputs]: Remove coreutils.

Applied, thanks!

Ludo’.
Closed
?