[PATCH] gnu: packages: Add python-ijson

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Raphaël Mélotte
Owner
unassigned
Submitted by
Raphaël Mélotte
Severity
normal
R
R
Raphaël Mélotte wrote on 19 Oct 2021 14:08
(address . guix-patches@gnu.org)(name . Raphaël Mélotte)(address . raphael.melotte@mind.be)
20211019120852.1009756-1-raphael.melotte@mind.be
* gnu/packages/python-xyz.scm (python-ijson): New variable.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c335dea277..cc66134fcd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -110,6 +110,7 @@
;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
+;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27604,3 +27605,34 @@ (define-public python-aspectlib
code is desired. It includes tools for debugging and testing:
simple mock/record and a complete capture/replay framework.")
(license license:bsd-2)))
+
+(define-public python-ijson
+ (package
+ (name "python-ijson")
+ (version "3.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ijson" version))
+ (sha256
+ (base32 "1sp463ywj4jv5cp6hsv2qwiima30d09xsabxb2dyq5b17jp0640x"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; the tests run by the default setup.py require yajl 1.x,
+ ;; but we have 2.x. yajl 1.x support is going to be removed
+ ;; anyway, so use pytest to avoid running the yajl1-related
+ ;; tests. See: https://github.com/ICRAR/ijson/issues/55
+ (replace 'check
+ (lambda _ (invoke "pytest" "-vv"))))))
+ (inputs
+ ;; libyajl is optional, but compiling with it makes faster
+ ;; backends available to ijson:
+ `(("libyajl", libyajl)
+ ("python-pytest", python-pytest)))
+ (build-system python-build-system)
+ (home-page "https://github.com/ICRAR/ijson")
+ (synopsis "Iterative JSON parser with standard Python iterator interfaces")
+ (description
+ "Iterative JSON parser with standard Python iterator interfaces")
+ (license license:bsd-3)))
--
2.33.0
L
L
Ludovic Courtès wrote on 30 Oct 2021 17:12
(name . Raphaël Mélotte)(address . raphael.melotte@mind.be)(address . 51287-done@debbugs.gnu.org)
87sfwisg0q.fsf@gnu.org
Hi,

Raphaël Mélotte <raphael.melotte@mind.be> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-ijson): New variable.

Applied with the following changes to placate ‘guix lint’ and improve
synopsis/description.

Thanks,
Ludo’.
Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4edc1e49f..f12cca9757 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27626,15 +27626,19 @@ (define-public python-ijson
;; anyway, so use pytest to avoid running the yajl1-related
;; tests. See: https://github.com/ICRAR/ijson/issues/55
(replace 'check
- (lambda _ (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(inputs
;; libyajl is optional, but compiling with it makes faster
;; backends available to ijson:
- `(("libyajl", libyajl)
- ("python-pytest", python-pytest)))
+ `(("libyajl", libyajl)))
+ (native-inputs
+ `(("python-pytest", python-pytest)))
(build-system python-build-system)
(home-page "https://github.com/ICRAR/ijson")
- (synopsis "Iterative JSON parser with standard Python iterator interfaces")
+ (synopsis "Iterative JSON parser with Python iterator interfaces")
(description
- "Iterative JSON parser with standard Python iterator interfaces")
+ "Ijson is an iterative JSON parser with standard Python iterator
+interfaces.")
(license license:bsd-3)))
Closed
?