[PATCH] gnu: Add neatmail.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211019061358.8705-1-jgart@dismail.de
* gnu/packages/mail.scm (neatmail): New variable.
---
gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 523e6cdce3..6b29463ba3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4494,6 +4494,43 @@ (define-public libpst
databases, and other tools to process Outlook email archives.")
(license license:gpl2+)))
+(define-public neatmail
+ (package
+ (name "neatmail")
+ (version "02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/aligrudi/neatmail")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00d453d57d3v6ja2gpmjd8vch804c72g38pc1nr5shmz3hkgd52d"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install ; There is no install target in the Makefile.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (rename-file "mail" "neatmail")
+ (install-file "neatmail" bin)))))))
+ (home-page "https://litcave.rudi.ir/")
+ (synopsis "Text-mode mail client")
+ (description
+"@command{neatmail} is a noninteractive mail client. It generates a listing
+of the messages in a mailbox in mbox format and executes a list of ex-like
+commands on it.")
+ (license license:isc)))
+
(define-public crm114
(package
(name "crm114")
--
2.33.0
N
N
Nicolas Goaziou wrote on 14 Nov 2021 15:15
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87sfvykelm.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/mail.scm (neatmail): New variable.

Thank you. I applied your patch with the tiny changes below.
Toggle quote (16 lines)
> ---
> gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index 523e6cdce3..6b29463ba3 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -4494,6 +4494,43 @@ (define-public libpst
> databases, and other tools to process Outlook email archives.")
> (license license:gpl2+)))
>
> + #:make-flags
> + (list (string-append "CC=" ,(cc-for-target))
> + (string-append "DESTDIR=" %output))

I removed the "DESTDIR" environment variable.

Toggle quote (5 lines)
> + (description
> +"@command{neatmail} is a noninteractive mail client. It generates a listing
> +of the messages in a mailbox in mbox format and executes a list of ex-like
> +commands on it.")

I removed trailing white spaces in the descrption.

Regards,
--
Nicolas Goaziou
?