ghci missing reference to gcc

  • Open
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Simon Tournier
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 14 Oct 2021 22:00
(address . bug-guix@gnu.org)
alpine.DEB.2.21.2110141553240.4243@marsh.hcoop.net
Hi Guix,

Using Guix 5fafb6e792c1e18ec223f0c7fb350d0c9b962a45, running ghci in an
environment can't find gcc:

$ guix environment --ad-hoc ghc -- ghci
GHCi, version 8.10.7: https://www.haskell.org/ghc/ :? for help
ghc: could not execute: gcc

but if gcc-toolchain is included, it can:

$ guix environment --ad-hoc ghc gcc-toolchain -- ghci
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'...
100.0%
The following derivation will be built:
/gnu/store/dqga43d50f6n1isazmi4cx83l3hyhsz5-profile.drv

60.0 MB will be downloaded
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
gcc-11.2.0-lib 5.0MiB
1.5MiB/s 00:03 [##################] 100.0%
gcc-11.2.0 30.7MiB
2.4MiB/s 00:13 [##################] 100.0%
gcc-toolchain-11.2.0 5KiB
40KiB/s 00:00 [##################] 100.0%
building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building GHC package cache...
building directory of Info manuals...
building database for manual pages...
building profile with 2 packages...
GHCi, version 8.10.7: https://www.haskell.org/ghc/ :? for help
Prelude>

Best,
Jack
J
J
Jack Hill wrote on 17 Oct 2021 06:11
(address . 51213@debbugs.gnu.org)
alpine.DEB.2.21.2110162324520.4243@marsh.hcoop.net
On Thu, 14 Oct 2021, Jack Hill wrote:

Toggle quote (5 lines)
> Hi Guix,
>
> Using Guix 5fafb6e792c1e18ec223f0c7fb350d0c9b962a45, running ghci in an
> environment can't find gcc:

Some more observations about this problem. It only occurs with our two
newest GHC packages (8.10.7 and 8.8.4), previous releases start ghci and
perform light usage fine. However, all releases fail to build executables
without gcc-toolchain in the path:

```
jackhill@alperton /tmp [env]$ ghc hello.hs
[1 of 1] Compiling Main ( hello.hs, hello.o )

<no location info>: error:
Warning: Couldn't figure out C compiler information!
Make sure you're using GNU gcc, or clang
ghc: could not execute: gcc
jackhill@alperton /tmp [env]$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 8.10.7
```

Interestingly, clang-toolchain can be substituted for gcc-toolchain to get
a working ghci, but with 8.10.7, compiling with gcc still doesn't work,
but ghc 7.10.2 find clang-toolchain to be satisfactory.

Best,
Jack
S
S
Simon Tournier wrote on 22 Sep 2023 18:19
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 51213@debbugs.gnu.org)
8734z689ky.fsf@gmail.com
Hi,

On Thu, 14 Oct 2021 at 16:00, Jack Hill <jackhill@jackhill.us> wrote:

Toggle quote (4 lines)
> $ guix environment --ad-hoc ghc -- ghci
> GHCi, version 8.10.7: https://www.haskell.org/ghc/ :? for help
> ghc: could not execute: gcc

This is currently expected.


Toggle quote (2 lines)
> but if gcc-toolchain is included, it can:

One option is to have a package “ghc-toolchain“ which provide ghc and
all the other required packages. I have some patches for that
somewhere. :-)

For now, I propose to close and just add gcc-toolchain.

WDYT?

Cheers,
simon
J
J
Jack Hill wrote on 23 Sep 2023 03:23
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 51213@debbugs.gnu.org)
alpine.DEB.2.21.2309222103170.16303@marsh.hcoop.net
Hi Simon,

Thanks for caring for this old issue.

On Fri, 22 Sep 2023, Simon Tournier wrote:

Toggle quote (21 lines)
> Hi,
>
> On Thu, 14 Oct 2021 at 16:00, Jack Hill <jackhill@jackhill.us> wrote:
>
>> $ guix environment --ad-hoc ghc -- ghci
>> GHCi, version 8.10.7: https://www.haskell.org/ghc/ :? for help
>> ghc: could not execute: gcc
>
> This is currently expected.
>
>
>> but if gcc-toolchain is included, it can:
>
> One option is to have a package “ghc-toolchain“ which provide ghc and
> all the other required packages. I have some patches for that
> somewhere. :-)
>
> For now, I propose to close and just add gcc-toolchain.
>
> WDYT?

Yes, I agree. I think having a ghc-toolchain would match my expectation.
Until then, I think we can close. Let's keep working on improving the
Haskell in Guix experience!

Best,
Jack
?