[PATCH 0/9] More Julia packages toward Flux

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 14 Oct 2021 17:56
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155656.3221423-1-zimon.toutoune@gmail.com
Hi,

Since Documenter.jl is now available, let use it and turn on the missing tests
of some packages.

Then, more trivial packages which are dependencies of Flux (machine learning
framework). The hard part still missing is CUDA.

All the best,
simon


zimoun (9):
gnu: julia-coordinatetransformations: Enable tests.
gnu: julia-colortypes: Enable tests.
gnu: julia-irtools: Enable tests.
gnu: julia-paddedviews: Enable tests.
gnu: julia-stackviews: Enable tests.
gnu: Add julia-functors.
gnu: Add julia-transcodingstreams.
gnu: Add julia-codeczlib.
gnu: Add julia-media.

gnu/packages/julia-xyz.scm | 139 ++++++++++++++++++++++++++++++++-----
1 file changed, 122 insertions(+), 17 deletions(-)


base-commit: e2a021a745d5009f2e8386108840146faa33fd86
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 4/9] gnu: julia-paddedviews: Enable tests.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-4-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz (julia-paddedviews)[arguments]: Remove.
[native-inputs]: Add julia-documenter.
---
gnu/packages/julia-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3dd12b60b8..07b6265473 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3123,10 +3123,10 @@ (define-public julia-paddedviews
(sha256
(base32 "0ran2vj6ahlzib0g77y7g0jhavy3k9s2mqq23ybpgp9z677wf26h"))))
(build-system julia-build-system)
- (arguments
- '(#:tests? #f)) ;require Documenter, not packaged yet
(propagated-inputs
`(("julia-offsetarrays" ,julia-offsetarrays)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)))
(home-page "https://github.com/JuliaArrays/PaddedViews.jl")
(synopsis "Add virtual padding to the edges of an array")
(description "@code{PaddedViews} provides a simple wrapper type,
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:58
[PATCH 1/9] gnu: julia-coordinatetransformations: Enable tests.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-1-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-coordinatetransformations)[arguments]:
Remove.
[native-inputs]: Add julia-documenter, julia-forwarddiff, julia-unitful.
---
gnu/packages/julia-xyz.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c1ebc0fba1..62b6e4edfb 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -806,14 +806,12 @@ (define-public julia-coordinatetransformations
(sha256
(base32 "15zbkn32v7xlz7559s0r5a0vkwmjwsswxaqpzijly4lky4jnp33d"))))
(build-system julia-build-system)
- (arguments
- `(#:tests? #f)) ; Documenter.jl not packaged yet.
(propagated-inputs
`(("julia-staticarrays" ,julia-staticarrays)))
- ;(native-inputs
- ; `(("julia-documenter" ,julia-documenter)
- ; ("julia-forwarddiff" ,julia-forwarddiff)
- ; ("julia-unitful" ,julia-unitful)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)
+ ("julia-forwarddiff" ,julia-forwarddiff)
+ ("julia-unitful" ,julia-unitful)))
(home-page "https://github.com/JuliaGeometry/CoordinateTransformations.jl")
(synopsis "Coordinate transformations in Julia")
(description "@code{CoordinateTransformations} is a Julia package to manage
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 8/9] gnu: Add julia-codeczlib.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-8-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-codeczlib): New variable.
---
gnu/packages/julia-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index cd865db890..da8a3140d5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -561,6 +561,38 @@ (define-public julia-chainrulestestutils
dependencies, while keeping @code{ChainRulesCore.jl} as light-weight as possible.")
(license license:expat)))
+(define-public julia-codeczlib
+ (package
+ (name "julia-codeczlib")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaIO/CodecZlib.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xm603nylkwk4bzx66zv1g3syzrvn3jh9spdx7kvcvgszzyrrgh4"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
+ (propagated-inputs
+ `(("julia-zlib-jll" ,julia-zlib-jll)
+ ("julia-transcodingstreams" ,julia-transcodingstreams)))
+ (home-page "https://github.com/JuliaIO/CodecZlib.jl")
+ (synopsis "Zlib codecs for @code{TranscodingStreams.jl}")
+ (description "This package provides zlib codecs for
+@code{TranscodingStreams.jl}.")
+ (license license:expat)))
+
(define-public julia-colors
(package
(name "julia-colors")
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 6/9] gnu: Add julia-functors.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-6-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-functors): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9604460600..86f3446ba3 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1743,6 +1743,31 @@ (define-public julia-functionwrappers
arbitrary functions.")
(license license:expat)))
+(define-public julia-functors
+ (package
+ (name "julia-functors")
+ (version "0.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FluxML/Functors.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vkyh63v6kj70bqg09z6vsnxm2idz3xwiz7nsr53fgj5c37y2xrj"))))
+ (build-system julia-build-system)
+ (home-page "https://fluxml.ai/Functors")
+ (synopsis "Design pattern for structures as in machine learning")
+ (description "This package provides tools to express a design pattern for
+dealing with large/ nested structures, as in machine learning and
+optimisation. For large machine learning models it can be cumbersome or
+inefficient to work with parameters as one big, flat vector, and structs help
+in managing complexity; but it is also desirable to easily operate over all
+parameters at once, e.g. for changing precision or applying an optimiser
+update step.")
+ (license license:expat)))
+
(define-public julia-fuzzycompletions
(package
(name "julia-fuzzycompletions")
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 9/9] gnu: Add julia-media.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-9-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-media): New variable.
---
gnu/packages/julia-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index da8a3140d5..737e8bb733 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2865,6 +2865,32 @@ (define-public julia-measures
resolving them into absolute units.")
(license license:expat)))
+(define-public julia-media
+ (package
+ (name "julia-media")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JunoLab/Media.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05jq9j3vs8yfj2lwz3sh1vk5rha06xdcikp9s2q3dn316vryy6di"))))
+ (build-system julia-build-system)
+ ;; Package without Project.toml
+ (arguments
+ '(#:julia-package-name "Media"))
+ (propagated-inputs
+ `(("julia-macrotools" ,julia-macrotools)))
+ (home-page "https://github.com/JunoLab/Media.jl")
+ (synopsis "Unified measure and coordinates types")
+ (description "This package provides a display system which enables the
+user handle multiple input/output devices and decide what media types get
+displayed where.")
+ (license license:expat)))
+
(define-public julia-missings
(package
(name "julia-missings")
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:58
[PATCH 2/9] gnu: julia-colortypes: Enable tests.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-2-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz (julia-colortypes)[arguments]: Remove.
[native-inputs]: Add julia-documenter.
---
gnu/packages/julia-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 62b6e4edfb..89bb2c0f92 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -624,11 +624,11 @@ (define-public julia-colortypes
(file-name (git-file-name name version))
(sha256
(base32 "0n7h70caqv7yd0khjhn90iax62r73mcif8qzkwj5b4q46li1r8ih"))))
- (arguments
- '(#:tests? #f)) ;require Documenter, not packaged yet
(build-system julia-build-system)
(propagated-inputs
`(("julia-fixedpointnumbers" ,julia-fixedpointnumbers)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)))
(home-page "https://github.com/JuliaGraphics/ColorTypes.jl")
(synopsis "Basic color types and constructor")
(description "This minimalistic package serves as the foundation for
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 7/9] gnu: Add julia-transcodingstreams.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-7-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-transcodingstreams): New variable.
---
gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 86f3446ba3..cd865db890 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4563,6 +4563,31 @@ (define-public julia-tracker
automatic differentiation for its machine learning platform.")
(license license:expat)))
+(define-public julia-transcodingstreams
+ (package
+ (name "julia-transcodingstreams")
+ (version "0.9.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaIO/TranscodingStreams.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w3klii293caqiclfh28jggv7f53xclm9fr6xmw38brwrn1hjb48"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f)) ;Circular dependency with CodecZlib
+ (home-page "https://github.com/JuliaIO/TranscodingStreams.jl")
+ (synopsis "Fast I/O transcoding data streams")
+ (description "This package provides tools for transcoding data streams
+which are fast: (small overhead and specialized methods; consistent: basic I/O
+operations work as expected; generic: support any I/O objects like files,
+buffers, pipes, etc.; extensible: easy definition for new codec to transcode
+data.")
+ (license license:expat)))
+
(define-public julia-typedtables
(package
(name "julia-typedtables")
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:59
[PATCH 5/9] gnu: julia-stackviews: Enable tests.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-5-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz (julia-stackviews)[arguments]: Remove #:tests?.
[native-inputs]: Add julia-aqua and julia-documenter.
---
gnu/packages/julia-xyz.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 07b6265473..9604460600 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4123,8 +4123,7 @@ (define-public julia-stackviews
(base32 "1fwiaxdpx1z9dli3jr8kyraych0jbdiny3qklynf0r13px25r6i7"))))
(build-system julia-build-system)
(arguments
- `(#:tests? #f ; Documenter.jl not packaged yet
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-doctest
(lambda _
@@ -4133,9 +4132,9 @@ (define-public julia-stackviews
#t)))))
(propagated-inputs
`(("julia-offsetarrays" ,julia-offsetarrays)))
- ;(native-inputs
- ; `(("julia-aqua" ,julia-aqua)
- ; ("julia-documenter" ,julia-documenter)))
+ (native-inputs
+ `(("julia-aqua" ,julia-aqua)
+ ("julia-documenter" ,julia-documenter)))
(home-page "https://github.com/JuliaArrays/StackViews.jl")
(synopsis "No more catcat")
(description "StackViews provides only one array type: @code{StackView}.
--
2.32.0
Z
Z
zimoun wrote on 14 Oct 2021 17:58
[PATCH 3/9] gnu: julia-irtools: Enable tests.
(address . 51207@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211014155905.3221481-3-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz (julia-irtools)[arguements]: Remove.
[native-inputs]: Add julia-documenter.
---
gnu/packages/julia-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 89bb2c0f92..3dd12b60b8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2461,11 +2461,11 @@ (define-public julia-irtools
(file-name (git-file-name name version))
(sha256
(base32 "11334fcg2slpwcj0raxf457brhf7pxglgxc6cy8q58ggrpxqfqql"))))
- (arguments
- '(#:tests? #f)) ;require Documenter, not packaged yet
(build-system julia-build-system)
(propagated-inputs
`(("julia-macrotools" ,julia-macrotools)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)))
(home-page "https://github.com/FluxML/IRTools.jl")
(synopsis "Simple and flexible IR format")
(description "This package provides a simple and flexible IR format,
--
2.32.0
E
E
Efraim Flashner wrote on 19 Oct 2021 09:23
Re: [bug#51207] [PATCH 0/9] More Julia packages toward Flux
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51207-done@debbugs.gnu.org)
YW5yiQR2QWvTavXf@3900XT
On Thu, Oct 14, 2021 at 05:56:56PM +0200, zimoun wrote:
Toggle quote (8 lines)
> Hi,
>
> Since Documenter.jl is now available, let use it and turn on the missing tests
> of some packages.
>
> Then, more trivial packages which are dependencies of Flux (machine learning
> framework). The hard part still missing is CUDA.

I'm not looking forward to trying to get CUDA working.

I fixed up the home-page in julia-functors and changed
julia-transcodingstreams to use an itemized list for the description.

Patches pushed!

Toggle quote (27 lines)
> All the best,
> simon
>
>
> zimoun (9):
> gnu: julia-coordinatetransformations: Enable tests.
> gnu: julia-colortypes: Enable tests.
> gnu: julia-irtools: Enable tests.
> gnu: julia-paddedviews: Enable tests.
> gnu: julia-stackviews: Enable tests.
> gnu: Add julia-functors.
> gnu: Add julia-transcodingstreams.
> gnu: Add julia-codeczlib.
> gnu: Add julia-media.
>
> gnu/packages/julia-xyz.scm | 139 ++++++++++++++++++++++++++++++++-----
> 1 file changed, 122 insertions(+), 17 deletions(-)
>
>
> base-commit: e2a021a745d5009f2e8386108840146faa33fd86
> --
> 2.32.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFucokACgkQQarn3Mo9
g1H4SQ/8CmJYHu4IiG/ynrArwxP+fCeKeuXpLDyZ5jAAZ0w0pzjhuUyGgsnS2+Dn
R4bGdPUcTizHVQGn9ye4rAZRcQ2IluovrwIeW/e5wnDPVb6H5DAk+zmqeO6R0dBh
KCHtbF0jRUpbZccvn4wOm/alpwOizZONpNvcZvUSoCv8ysEJHhzyW1eRYctVc9yh
ksKYZQxS6kTt6zOYHtseovx3eSXlMlfCxHZkUMVvkwwx5ZwBlrrgp23NiMVot7s1
60pS/YoUwBZsZFGrRDhqEKwnj1hUJ2M2inuKVx3j6qzCnGke96OEc+zRTBTkZ5DH
AdyPtXPbw3BCQzDzNGY0cKmq7TJVBtqfISun67L7DbZ0j0YVTF7+HKOU5VUzF4Cl
2XWQaqTBk+KlhTnfEVIpbIfGtRW4uBMXO1LZ5AU+85qZFP+ccraMNy2ULHnTWjJU
ogvgTCnyjifK2cE7uTrpEKzCJ5WN1/6n1VIzmvX7s+72TkNLAlLZyG9L4vd4PXSO
eK0+ZBNc6HzQQGpRREzTP1k+/OaXOZJfj4K77bVw2lbBW2/y4Xo2K2yqSSbUSkGs
IXe67WaxheRnz5CBBTi6n34fOVf5jzr9mGYqqhMIyyNvL0OfWunAkE3wkD+7tCAu
7Kfqgp+oP3IzZk/3V4eqAcZc0jqcUpQ5+EFJaQ4TMNuKRw3gTSU=
=O6fa
-----END PGP SIGNATURE-----


Closed
Z
Z
zimoun wrote on 19 Oct 2021 09:46
CAJ3okZ3dLZH+xBkHo-rHOHm5WBSg8Cpq4WNTJvKQke+Q6ySFXw@mail.gmail.com
Hi Efraim,

On Tue, 19 Oct 2021 at 09:24, Efraim Flashner <efraim@flashner.co.il> wrote:

Toggle quote (2 lines)
> I'm not looking forward to trying to get CUDA working.

Sadly, I do not have any idea to tackle this.


Toggle quote (3 lines)
> I fixed up the home-page in julia-functors and changed
> julia-transcodingstreams to use an itemized list for the description.

Thanks.

Cheers,
simon
Closed
?