[PATCH] gnu: emacs: Find real GVFS processes.

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 13 Oct 2021 21:32
(address . guix-patches@gnu.org)
e2f7cf953c7e899c5d0ce8752c70cfd611e534e3.camel@gmail.com
* gnu/packages/emacs.scm (emacs)[#:phases]<patch-program-file-names>: Expand
calls to “tramp-compat-process-running-p” so that Guix wrappers are also
matched.
---
gnu/packages/emacs.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6d9950d068..a59931ddc4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -136,6 +136,12 @@
"lisp/progmodes/sh-script.el")
(("\"/bin/sh\"")
(format #f "~s" (which "sh"))))
+ ;; match ".gvfs-fuse-daemon-real" and ".gvfsd-fuse-real"
+ ;; respectively when looking for GVFS processes.
+ (substitute* "lisp/net/tramp-gvfs.el"
+ (("\\(tramp-compat-process-running-p \"(.*)\"\\)" all process)
+ (format #f "(or ~a (tramp-compat-process-running-p ~s))"
+ all (string-append "." process "-real"))))
#t))
(add-before 'configure 'fix-/bin/pwd
(lambda _
--
2.33.0
L
L
Liliana Marie Prikler wrote on 3 Dec 2021 21:40
(address . 51188-done@debbugs.gnu.org)
1388ecee07e92e74a13e309c1dfe8a8e6884ab8b.camel@gmail.com
Pushed as f725279cdd66e7739fd756807ef2a1c7b1611d51.
Closed
?