[PATCH] gnu: Add yt-dlp.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Liliana Marie Prikler
  • Robin Templeton
Owner
unassigned
Submitted by
Robin Templeton
Severity
normal
Merged with
R
R
Robin Templeton wrote on 13 Oct 2021 11:44
(address . guix-patches@gnu.org)
87pms9mf7a.fsf@terpri.org
* gnu/packages/video.scm (yt-dlp): New variable.

Suggested-by: bdju <bdju@tilde.team>
---
gnu/packages/video.scm | 71 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 71 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fcac369f60..1aceac25eb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2360,6 +2360,77 @@ YouTube.com and many more sites.")
(home-page "https://yt-dl.org")
(license license:public-domain)))
+(define-public yt-dlp
+ (package
+ (name "yt-dlp")
+ (version "2021.10.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/yt-dlp/yt-dlp/"
+ "releases/download/"
+ version "/yt-dlp.tar.gz"))
+ (sha256
+ (base32
+ "1ywld4qhvsik970gbac1h3kvxb74r7150m5axq9r5nffdw5sz3vd"))
+ (snippet
+ '(begin
+ ;; Delete the pre-generated files, except for the man page
+ ;; which requires 'pandoc' to build.
+ (for-each delete-file '("yt-dlp"
+ ;;pandoc is needed to generate
+ ;;"yt-dlp.1"
+ "completions/bash/yt-dlp"
+ "completions/fish/yt-dlp.fish"
+ "completions/zsh/_yt-dlp"))
+ #t))))
+ (build-system python-build-system)
+ (arguments
+ ;; The problem here is that the directory for the man page and completion
+ ;; files is relative, and for some reason, setup.py uses the
+ ;; auto-detected sys.prefix instead of the user-defined "--prefix=FOO".
+ ;; So, we need pass the prefix directly.
+ `(#:tests? #f ; Many tests fail. The test suite can be run with pytest.
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'default-to-the-ffmpeg-input
+ (lambda _
+ ;; See <https://issues.guix.gnu.org/43418#5>.
+ ;; ffmpeg is big but required to request free formats
+ ;; from, e.g., YouTube so pull it in unconditionally.
+ ;; Continue respecting the --ffmpeg-location argument.
+ (substitute* "yt_dlp/postprocessor/ffmpeg.py"
+ (("\\.get\\('ffmpeg_location'\\)" match)
+ (format #f "~a or '~a'" match (which "ffmpeg"))))
+ #t))
+ (add-before 'build 'build-generated-files
+ (lambda _
+ ;; Avoid the make targets that require pandoc.
+ (invoke "make"
+ "PYTHON=python"
+ "yt-dlp"
+ ;;"youtube-dl.1" ; needs pandoc
+ "completions")))
+ (add-before 'install 'fix-the-data-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prefix (assoc-ref outputs "out")))
+ (substitute* "setup.py"
+ (("'etc/")
+ (string-append "'" prefix "/etc/"))
+ (("'share/")
+ (string-append "'" prefix "/share/")))
+ #t))))))
+ (native-inputs
+ `(("zip" ,zip)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (synopsis "Download videos from YouTube.com and other sites")
+ (description
+ "yt-dlp is a small command-line program to download videos from
+YouTube.com and many more sites. It is a fork of youtube-dl with a
+focus on adding new features while keeping up-to-date with the
+original project.")
+ (home-page "https://github.com/yt-dlp/yt-dlp")
+ (license license:public-domain)))
+
(define-public youtube-dl-gui
(package
(name "youtube-dl-gui")
--
2.33.0
L
L
Liliana Marie Prikler wrote on 13 Oct 2021 12:15
aa296b61dbd63cd5a5b7132cfe641f45ff99dd8a.camel@gmail.com
Hi Robin,

Am Mittwoch, den 13.10.2021, 05:44 -0400 schrieb Robin Templeton:
Toggle quote (20 lines)
> * gnu/packages/video.scm (yt-dlp): New variable.
>
> Suggested-by: bdju <bdju@tilde.team>
> ---
> gnu/packages/video.scm | 71
> ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 71 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index fcac369f60..1aceac25eb 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -2360,6 +2360,77 @@ YouTube.com and many more sites.")
> (home-page "https://yt-dl.org")
> (license license:public-domain)))
>
> +(define-public yt-dlp
> + (package
> + (name "yt-dlp")
> + (version "2021.10.10")
I think yt-dlp can (and ought to) inherit from youtube-dl, which might
simplify some of the below.
Toggle quote (25 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/yt-dlp/yt-dlp/
> "
> + "releases/download/"
> + version "/yt-dlp.tar.gz"))
> + (sha256
> + (base32
> + "1ywld4qhvsik970gbac1h3kvxb74r7150m5axq9r5nffdw5sz3v
> d"))
> + (snippet
> + '(begin
> + ;; Delete the pre-generated files, except for the
> man page
> + ;; which requires 'pandoc' to build.
> + (for-each delete-file '("yt-dlp"
> + ;;pandoc is needed to
> generate
> + ;;"yt-dlp.1"
> + "completions/bash/yt-dlp"
> + "completions/fish/yt-
> dlp.fish"
> + "completions/zsh/_yt-
> dlp"))
> + #t))))
Is this the same as for youtube-dl? If not, we might want to give
pandoc as native-input. That will increase build times, but it ought
not to increase closure size.
Toggle quote (42 lines)
> + (build-system python-build-system)
> + (arguments
> + ;; The problem here is that the directory for the man page and
> completion
> + ;; files is relative, and for some reason, setup.py uses the
> + ;; auto-detected sys.prefix instead of the user-defined "
> --prefix=FOO".
> + ;; So, we need pass the prefix directly.
> + `(#:tests? #f ; Many tests fail. The test suite can be run with
> pytest.
> + #:phases (modify-phases %standard-phases
> + (add-after 'unpack 'default-to-the-ffmpeg-input
> + (lambda _
> + ;; See <https://issues.guix.gnu.org/43418#5>;.
> + ;; ffmpeg is big but required to request free
> formats
> + ;; from, e.g., YouTube so pull it in
> unconditionally.
> + ;; Continue respecting the --ffmpeg-location
> argument.
> + (substitute* "yt_dlp/postprocessor/ffmpeg.py"
> + (("\\.get\\('ffmpeg_location'\\)" match)
> + (format #f "~a or '~a'" match (which
> "ffmpeg"))))
> + #t))
> + (add-before 'build 'build-generated-files
> + (lambda _
> + ;; Avoid the make targets that require pandoc.
> + (invoke "make"
> + "PYTHON=python"
> + "yt-dlp"
> + ;;"youtube-dl.1" ; needs pandoc
> + "completions")))
> + (add-before 'install 'fix-the-data-directories
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((prefix (assoc-ref outputs "out")))
> + (substitute* "setup.py"
> + (("'etc/")
> + (string-append "'" prefix "/etc/"))
> + (("'share/")
> + (string-append "'" prefix "/share/")))
> + #t))))))
Horizontal space is at a premium and you can save some.
Toggle quote (12 lines)
> + (native-inputs
> + `(("zip" ,zip)))
> + (inputs
> + `(("ffmpeg" ,ffmpeg)))
> + (synopsis "Download videos from YouTube.com and other sites")
> + (description
> + "yt-dlp is a small command-line program to download videos from
> +YouTube.com and many more sites. It is a fork of youtube-dl with a
> +focus on adding new features while keeping up-to-date with the
> +original project.")
> + (home-page "https://github.com/yt-dlp/yt-dlp")
> + (license license:public-domain)))
Otherwise LGTM, but haven't tested.

Regards,
Liliana
R
R
Robin Templeton wrote on 13 Oct 2021 14:46
[PATCH v2] Re: bug#51179: [PATCH] gnu: Add yt-dlp.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 51179@debbugs.gnu.org)
87ee8pm6sn.fsf_-_@terpri.org
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (2 lines)
> Am Mittwoch, den 13.10.2021, 05:44 -0400 schrieb Robin Templeton:
>> * gnu/packages/video.scm (yt-dlp): New variable.
[...]
Toggle quote (7 lines)
>> +(define-public yt-dlp
>> + (package
>> + (name "yt-dlp")
>> + (version "2021.10.10")
> I think yt-dlp can (and ought to) inherit from youtube-dl, which might
> simplify some of the below.

Agreed, changed in the revised patch below (yt-dlp can't, e.g., directly
use youtube-dl's extra phases at the moment, but it should be more
maintainable in the future).

[...]
Toggle quote (5 lines)
>> + (snippet
>> + '(begin
>> + ;; Delete the pre-generated files, except for the
>> man page
>> + ;; which requires 'pandoc' to build.
[...]
Toggle quote (4 lines)
> Is this the same as for youtube-dl? If not, we might want to give
> pandoc as native-input. That will increase build times, but it ought
> not to increase closure size.

This is analogous to youtube-dl's pandoc avoidance; IMHO youtube-dl
ought to use pandoc as a native input, but I wanted to keep the
packaging as close to youtube-dl's as possible.

[...]
Toggle quote (19 lines)
>> + (add-before 'build 'build-generated-files
>> + (lambda _
>> + ;; Avoid the make targets that require pandoc.
>> + (invoke "make"
>> + "PYTHON=python"
>> + "yt-dlp"
>> + ;;"youtube-dl.1" ; needs pandoc
>> + "completions")))
>> + (add-before 'install 'fix-the-data-directories
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (let ((prefix (assoc-ref outputs "out")))
>> + (substitute* "setup.py"
>> + (("'etc/")
>> + (string-append "'" prefix "/etc/"))
>> + (("'share/")
>> + (string-append "'" prefix "/share/")))
>> + #t))))))
> Horizontal space is at a premium and you can save some.

I'm not sure where exactly this should use fewer columns, but I squeezed
the make invocation onto a single line.

v2 also adds three inputs needed for the program to run correctly
(updated based on efraim's yt-dlp package, https://bpa.st/FJDA; in
that package, the extra libraries are propagated inputs, but adding them
as regular inputs appears to be sufficient).

[...]
Toggle quote (2 lines)
> Otherwise LGTM, but haven't tested.

Thanks for the quick review! Patch v2 below. (I tested it on a few
YouTube videos and it worked as expected, at least for simple "yt-dlp
$URL"-type usage.)

Toggle snippet (90 lines)
* gnu/packages/video.scm (yt-dlp): New variable.

Suggested-by: bdju <bdju@tilde.team>
---
gnu/packages/video.scm | 61 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fcac369f60..94f5e85e77 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -142,6 +142,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages music)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
@@ -2360,6 +2361,66 @@ YouTube.com and many more sites.")
(home-page "https://yt-dl.org")
(license license:public-domain)))
+(define-public yt-dlp
+ (package/inherit youtube-dl
+ (name "yt-dlp")
+ (version "2021.10.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/yt-dlp/yt-dlp/"
+ "releases/download/"
+ version "/yt-dlp.tar.gz"))
+ (sha256
+ (base32
+ "1ywld4qhvsik970gbac1h3kvxb74r7150m5axq9r5nffdw5sz3vd"))
+ (snippet
+ '(begin
+ ;; Delete the pre-generated files, except for the man page
+ ;; which requires 'pandoc' to build.
+ (for-each delete-file '("yt-dlp"
+ ;;pandoc is needed to generate
+ ;;"yt-dlp.1"
+ "completions/bash/yt-dlp"
+ "completions/fish/yt-dlp.fish"
+ "completions/zsh/_yt-dlp"))
+ #t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments youtube-dl)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; See the comment for the corresponding phase in youtube-dl.
+ (replace 'default-to-the-ffmpeg-input
+ (lambda _
+ (substitute* "yt_dlp/postprocessor/ffmpeg.py"
+ (("\\.get\\('ffmpeg_location'\\)" match)
+ (format #f "~a or '~a'" match (which "ffmpeg"))))
+ #t))
+ (replace 'build-generated-files
+ (lambda _
+ ;; Avoid the yt-dlp.1 target, which requires pandoc.
+ (invoke "make" "PYTHON=python" "yt-dlp" "completions")))
+ (replace 'fix-the-data-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prefix (assoc-ref outputs "out")))
+ (substitute* "setup.py"
+ (("'etc/")
+ (string-append "'" prefix "/etc/"))
+ (("'share/")
+ (string-append "'" prefix "/share/"))))
+ #t))
+ (delete 'install-completion)))))
+ (inputs
+ `(("python-mutagen" ,python-mutagen)
+ ("python-pycryptodomex" ,python-pycryptodomex)
+ ("python-websockets" ,python-websockets)
+ ,@(package-inputs youtube-dl)))
+ (description
+ "yt-dlp is a small command-line program to download videos from
+YouTube.com and many more sites. It is a fork of youtube-dl with a
+focus on adding new features while keeping up-to-date with the
+original project.")
+ (home-page "https://github.com/yt-dlp/yt-dlp")))
+
(define-public youtube-dl-gui
(package
(name "youtube-dl-gui")
--
2.33.0
L
L
Liliana Marie Prikler wrote on 13 Oct 2021 16:53
(name . Robin Templeton)(address . robin@terpri.org)(address . 51179@debbugs.gnu.org)
99268fb747b2278cc0e279c5efc83f5bbbfaccf1.camel@gmail.com
Hi Robin,

when pasting other stuff into a patch, one usually ought to do so after
the "---" line before the summary and the first diff.

Am Mittwoch, den 13.10.2021, 08:46 -0400 schrieb Robin Templeton:
Toggle quote (16 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> [...]
> > > + (snippet
> > > + '(begin
> > > + ;; Delete the pre-generated files, except for
> > > the man page
> > > + ;; which requires 'pandoc' to build.
> [...]
> > Is this the same as for youtube-dl? If not, we might want to give
> > pandoc as native-input. That will increase build times, but it
> > ought not to increase closure size.
>
> This is analogous to youtube-dl's pandoc avoidance; IMHO youtube-dl
> ought to use pandoc as a native input, but I wanted to keep the
> packaging as close to youtube-dl's as possible.
Hence why I asked whether youtube-dl does the same. Making that change
would probably be out of scope for now.

Toggle quote (24 lines)
> [...]
> > > + (add-before 'build 'build-generated-files
> > > + (lambda _
> > > + ;; Avoid the make targets that require
> > > pandoc.
> > > + (invoke "make"
> > > + "PYTHON=python"
> > > + "yt-dlp"
> > > + ;;"youtube-dl.1" ; needs pandoc
> > > + "completions")))
> > > + (add-before 'install 'fix-the-data-directories
> > > + (lambda* (#:key outputs #:allow-other-keys)
> > > + (let ((prefix (assoc-ref outputs "out")))
> > > + (substitute* "setup.py"
> > > + (("'etc/")
> > > + (string-append "'" prefix "/etc/"))
> > > + (("'share/")
> > > + (string-append "'" prefix
> > > "/share/")))
> > > + #t))))))
> > Horizontal space is at a premium and you can save some.
>
> I'm not sure where exactly this should use fewer columns, but I
> squeezed the make invocation onto a single line.
You fixed it by accident, given that you're now required to use
substitute-keyword-arguments*, putting #:phases on an extra line as it
ought to be.

Toggle quote (4 lines)
> v2 also adds three inputs needed for the program to run correctly
> (updated based on efraim's yt-dlp package, <https://bpa.st/FJDA>;; in
> that package, the extra libraries are propagated inputs, but adding
> them as regular inputs appears to be sufficient).
Can we somehow verify that this is indeed the case? Normally we would
wrap PYTHONPATH in such a case.

Toggle quote (89 lines)
> [...]
> > Otherwise LGTM, but haven't tested.
>
> Thanks for the quick review! Patch v2 below. (I tested it on a few
> YouTube videos and it worked as expected, at least for simple "yt-dlp
> $URL"-type usage.)
>
> --8<---------------cut here---------------start------------->8---
>
> * gnu/packages/video.scm (yt-dlp): New variable.
>
> Suggested-by: bdju <bdju@tilde.team>
> ---
> gnu/packages/video.scm | 61
> ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 61 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index fcac369f60..94f5e85e77 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -142,6 +142,7 @@
> #:use-module (gnu packages man)
> #:use-module (gnu packages markup)
> #:use-module (gnu packages maths)
> + #:use-module (gnu packages music)
> #:use-module (gnu packages mp3)
> #:use-module (gnu packages ncurses)
> #:use-module (gnu packages networking)
> @@ -2360,6 +2361,66 @@ YouTube.com and many more sites.")
> (home-page "https://yt-dl.org")
> (license license:public-domain)))
>
> +(define-public yt-dlp
> + (package/inherit youtube-dl
> + (name "yt-dlp")
> + (version "2021.10.10")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/yt-dlp/yt-dlp/
> "
> + "releases/download/"
> + version "/yt-dlp.tar.gz"))
> + (sha256
> + (base32
> + "1ywld4qhvsik970gbac1h3kvxb74r7150m5axq9r5nffdw5sz3v
> d"))
> + (snippet
> + '(begin
> + ;; Delete the pre-generated files, except for the
> man page
> + ;; which requires 'pandoc' to build.
> + (for-each delete-file '("yt-dlp"
> + ;;pandoc is needed to
> generate
> + ;;"yt-dlp.1"
> + "completions/bash/yt-dlp"
> + "completions/fish/yt-
> dlp.fish"
> + "completions/zsh/_yt-
> dlp"))
> + #t))))
> + (arguments
> + (substitute-keyword-arguments (package-arguments youtube-dl)
> + ((#:phases phases)
> + `(modify-phases ,phases
> + ;; See the comment for the corresponding phase in
> youtube-dl.
> + (replace 'default-to-the-ffmpeg-input
> + (lambda _
> + (substitute* "yt_dlp/postprocessor/ffmpeg.py"
> + (("\\.get\\('ffmpeg_location'\\)" match)
> + (format #f "~a or '~a'" match (which "ffmpeg"))))
> + #t))
> + (replace 'build-generated-files
> + (lambda _
> + ;; Avoid the yt-dlp.1 target, which requires pandoc.
> + (invoke "make" "PYTHON=python" "yt-dlp"
> "completions")))
> + (replace 'fix-the-data-directories
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((prefix (assoc-ref outputs "out")))
> + (substitute* "setup.py"
> + (("'etc/")
> + (string-append "'" prefix "/etc/"))
> + (("'share/")
> + (string-append "'" prefix "/share/"))))
> + #t))
> + (delete 'install-completion)))))
Why do we not install completions?
Toggle quote (16 lines)
> + (inputs
> + `(("python-mutagen" ,python-mutagen)
> + ("python-pycryptodomex" ,python-pycryptodomex)
> + ("python-websockets" ,python-websockets)
> + ,@(package-inputs youtube-dl)))
> + (description
> + "yt-dlp is a small command-line program to download videos from
> +YouTube.com and many more sites. It is a fork of youtube-dl with a
> +focus on adding new features while keeping up-to-date with the
> +original project.")
> + (home-page "https://github.com/yt-dlp/yt-dlp")))
> +
> (define-public youtube-dl-gui
> (package
> (name "youtube-dl-gui")

Regards,
Liliana
L
L
Leo Famulari wrote on 23 Oct 2021 22:51
(no subject)
(address . control@debbugs.gnu.org)
YXR10L+4lud8NgzE@jasmine.lan
merge 51363 51179
R
R
Robin Templeton wrote on 25 Oct 2021 05:12
Re: bug#51179: [PATCH] gnu: Add yt-dlp.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 51179@debbugs.gnu.org)
8735opvlvd.fsf@terpri.org
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (5 lines)
> Hi Robin,
>
> when pasting other stuff into a patch, one usually ought to do so after
> the "---" line before the summary and the first diff.

Ah, thanks for the reminder, it's been a minute since I used email for
patch submissions :) So IIUC, it's preferable to write:

Toggle quote (9 lines)
> * gnu/packages/video.scm (yt-dlp): New variable. [...]
> ---
>
> [RANDOM COMMENTS HERE]
>
> gnu/packages/video.scm | 61
> ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 61 insertions(+)

rather than using "cut here" lines and the like.

Toggle quote (20 lines)
> Am Mittwoch, den 13.10.2021, 08:46 -0400 schrieb Robin Templeton:
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> [...]
>> > > + (snippet
>> > > + '(begin
>> > > + ;; Delete the pre-generated files, except for
>> > > the man page
>> > > + ;; which requires 'pandoc' to build.
>> [...]
>> > Is this the same as for youtube-dl? If not, we might want to give
>> > pandoc as native-input. That will increase build times, but it
>> > ought not to increase closure size.
>>
>> This is analogous to youtube-dl's pandoc avoidance; IMHO youtube-dl
>> ought to use pandoc as a native input, but I wanted to keep the
>> packaging as close to youtube-dl's as possible.
> Hence why I asked whether youtube-dl does the same. Making that change
> would probably be out of scope for now.

+1

Toggle quote (28 lines)
>> [...]
>> > > + (add-before 'build 'build-generated-files
>> > > + (lambda _
>> > > + ;; Avoid the make targets that require
>> > > pandoc.
>> > > + (invoke "make"
>> > > + "PYTHON=python"
>> > > + "yt-dlp"
>> > > + ;;"youtube-dl.1" ; needs pandoc
>> > > + "completions")))
>> > > + (add-before 'install 'fix-the-data-directories
>> > > + (lambda* (#:key outputs #:allow-other-keys)
>> > > + (let ((prefix (assoc-ref outputs "out")))
>> > > + (substitute* "setup.py"
>> > > + (("'etc/")
>> > > + (string-append "'" prefix "/etc/"))
>> > > + (("'share/")
>> > > + (string-append "'" prefix
>> > > "/share/")))
>> > > + #t))))))
>> > Horizontal space is at a premium and you can save some.
>>
>> I'm not sure where exactly this should use fewer columns, but I
>> squeezed the make invocation onto a single line.
> You fixed it by accident, given that you're now required to use
> substitute-keyword-arguments*, putting #:phases on an extra line as it
> ought to be.

Oh, I see what you meant now, thanks for clarifying.

Toggle quote (7 lines)
>> v2 also adds three inputs needed for the program to run correctly
>> (updated based on efraim's yt-dlp package, <https://bpa.st/FJDA>;; in
>> that package, the extra libraries are propagated inputs, but adding
>> them as regular inputs appears to be sufficient).
> Can we somehow verify that this is indeed the case? Normally we would
> wrap PYTHONPATH in such a case.

python-build-system wraps the yt-dlc script correctly, although (as
jgart explained to me on IRC) the Python library inputs would need to
become propagated inputs if users or future packages want to use yt-dlc
as a library.

Morgan's patch packages yt-dlc the way I'd package *youtube-dl* (using a
git origin, generating the manpage with pandoc, etc.) but yt-dlc doesn't
inherit from youtube-dl in their patch. The non-downloading-related part
of yt-dlc's test suite (~10% of tests) *does* run without failures,
unlike youtube-dl, so I enabled tests and added the pytest invocation
from Morgan's version; otherwise, no changes in v3 (besides using the
latest yt-dlc release), which I'll post as a follow-up.

I don't have a strong opinion about my patch vs. Morgan's for an initial
version; at some point I think youtube-dl should be packaged similarly
to Morgan's approach, which would allow the yt-dlc definition to be
simplified too, but my patch is written to inherit from youtube-dl as
it's packaged now. IMO the order of the changes doesn't matter much.

Thanks,
Robin

--
Inteligenta persono lernas la lingvon Esperanton rapide kaj facile.
Esperanto estas moderna, kultura lingvo por la mondo. Simpla, fleksebla,
belsona, Esperanto estas la praktika solvo de la problemo de universala
interkompreno. Lernu la interlingvon Esperanton!
R
R
Robin Templeton wrote on 25 Oct 2021 05:36
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 51179@debbugs.gnu.org)
87wnm1u66f.fsf_-_@terpri.org
* gnu/packages/video.scm (yt-dlp): New variable.

Co-authored-by: Morgan Smith <Morgan.J.Smith@outlook.com>
Suggested-by: bdju <bdju@tilde.team>
---
Add check phase from Morgan's package and use latest yt-dlp release

gnu/packages/video.scm | 70 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 70 insertions(+)

Toggle diff (97 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d2a2a08ee3..a2ae26987a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021 Robin Templeton <robin@terpri.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,6 +143,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages music)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
@@ -2360,6 +2362,74 @@ (define-public youtube-dl
(home-page "https://yt-dl.org")
(license license:public-domain)))
+(define-public yt-dlp
+ (package/inherit youtube-dl
+ (name "yt-dlp")
+ (version "2021.10.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/yt-dlp/yt-dlp/"
+ "releases/download/"
+ version "/yt-dlp.tar.gz"))
+ (sha256
+ (base32
+ "0xh4cwmvx49pxn8x07wj2dy8ynj6xg8977l5493vv0l8zc27wp87"))
+ (snippet
+ '(begin
+ ;; Delete the pre-generated files, except for the man page
+ ;; which requires 'pandoc' to build.
+ (for-each delete-file '("yt-dlp"
+ ;;pandoc is needed to generate
+ ;;"yt-dlp.1"
+ "completions/bash/yt-dlp"
+ "completions/fish/yt-dlp.fish"
+ "completions/zsh/_yt-dlp"))
+ #t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments youtube-dl)
+ ((#:tests? _) #t)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; See the comment for the corresponding phase in youtube-dl.
+ (replace 'default-to-the-ffmpeg-input
+ (lambda _
+ (substitute* "yt_dlp/postprocessor/ffmpeg.py"
+ (("\\.get\\('ffmpeg_location'\\)" match)
+ (format #f "~a or '~a'" match (which "ffmpeg"))))
+ #t))
+ (replace 'build-generated-files
+ (lambda _
+ ;; Avoid the yt-dlp.1 target, which requires pandoc.
+ (invoke "make" "PYTHON=python" "yt-dlp" "completions")))
+ (replace 'fix-the-data-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prefix (assoc-ref outputs "out")))
+ (substitute* "setup.py"
+ (("'etc/")
+ (string-append "'" prefix "/etc/"))
+ (("'share/")
+ (string-append "'" prefix "/share/"))))
+ #t))
+ (delete 'install-completion)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-k" "not download"))))))))
+ (inputs
+ `(("python-mutagen" ,python-mutagen)
+ ("python-pycryptodomex" ,python-pycryptodomex)
+ ("python-websockets" ,python-websockets)
+ ,@(package-propagated-inputs youtube-dl)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ,@(package-native-inputs youtube-dl)))
+ (description
+ "yt-dlp is a small command-line program to download videos from
+YouTube.com and many more sites. It is a fork of youtube-dl with a
+focus on adding new features while keeping up-to-date with the
+original project.")
+ (home-page "https://github.com/yt-dlp/yt-dlp")))
+
(define-public youtube-dl-gui
(package
(name "youtube-dl-gui")
--
2.33.0
L
L
Liliana Marie Prikler wrote on 26 Oct 2021 14:54
(name . Robin Templeton)(address . robin@terpri.org)(address . 51179-done@debbugs.gnu.org)
a2cb0be852dabc396389d895e86becd8065af119.camel@gmail.com
Hi,

I've pushed this patch with the following adjustments,

Am Sonntag, den 24.10.2021, 23:36 -0400 schrieb Robin Templeton:
Toggle quote (76 lines)
> * gnu/packages/video.scm (yt-dlp): New variable.
>
> Co-authored-by: Morgan Smith <Morgan.J.Smith@outlook.com>
> Suggested-by: bdju <bdju@tilde.team>
> ---
> Add check phase from Morgan's package and use latest yt-dlp release
>
> gnu/packages/video.scm | 70
> ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 70 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index d2a2a08ee3..a2ae26987a 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -53,6 +53,7 @@
> ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
> ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
> ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
> +;;; Copyright © 2021 Robin Templeton <robin@terpri.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -142,6 +143,7 @@ (define-module (gnu packages video)
> #:use-module (gnu packages man)
> #:use-module (gnu packages markup)
> #:use-module (gnu packages maths)
> + #:use-module (gnu packages music)
> #:use-module (gnu packages mp3)
> #:use-module (gnu packages ncurses)
> #:use-module (gnu packages networking)
> @@ -2360,6 +2362,74 @@ (define-public youtube-dl
> (home-page "https://yt-dl.org")
> (license license:public-domain)))
>
> +(define-public yt-dlp
> + (package/inherit youtube-dl
> + (name "yt-dlp")
> + (version "2021.10.22")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/yt-dlp/yt-dlp/
> "
> + "releases/download/"
> + version "/yt-dlp.tar.gz"))
> + (sha256
> + (base32
> + "0xh4cwmvx49pxn8x07wj2dy8ynj6xg8977l5493vv0l8zc27wp8
> 7"))
> + (snippet
> + '(begin
> + ;; Delete the pre-generated files, except for the
> man page
> + ;; which requires 'pandoc' to build.
> + (for-each delete-file '("yt-dlp"
> + ;;pandoc is needed to
> generate
> + ;;"yt-dlp.1"
> + "completions/bash/yt-dlp"
> + "completions/fish/yt-
> dlp.fish"
> + "completions/zsh/_yt-
> dlp"))
> + #t))))
> + (arguments
> + (substitute-keyword-arguments (package-arguments youtube-dl)
> + ((#:tests? _) #t)
> + ((#:phases phases)
> + `(modify-phases ,phases
> + ;; See the comment for the corresponding phase in
> youtube-dl.
> + (replace 'default-to-the-ffmpeg-input
> + (lambda _
> + (substitute* "yt_dlp/postprocessor/ffmpeg.py"
> + (("\\.get\\('ffmpeg_location'\\)" match)
> + (format #f "~a or '~a'" match (which "ffmpeg"))))
"get" becomes "get_param" in yt-dlp.
Toggle quote (25 lines)
> + #t))
> + (replace 'build-generated-files
> + (lambda _
> + ;; Avoid the yt-dlp.1 target, which requires pandoc.
> + (invoke "make" "PYTHON=python" "yt-dlp"
> "completions")))
> + (replace 'fix-the-data-directories
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((prefix (assoc-ref outputs "out")))
> + (substitute* "setup.py"
> + (("'etc/")
> + (string-append "'" prefix "/etc/"))
> + (("'share/")
> + (string-append "'" prefix "/share/"))))
> + #t))
> + (delete 'install-completion)
> + (replace 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (when tests?
> + (invoke "pytest" "-k" "not download"))))))))
> + (inputs
> + `(("python-mutagen" ,python-mutagen)
> + ("python-pycryptodomex" ,python-pycryptodomex)
> + ("python-websockets" ,python-websockets)
> + ,@(package-propagated-inputs youtube-dl)))
Used (package-inputs) as it should be.
Toggle quote (10 lines)
> + (native-inputs
> + `(("python-pytest" ,python-pytest)
> + ,@(package-native-inputs youtube-dl)))
> + (description
> + "yt-dlp is a small command-line program to download videos from
> +YouTube.com and many more sites. It is a fork of youtube-dl with a
> +focus on adding new features while keeping up-to-date with the
> +original project.")
> + (home-page "https://github.com/yt-dlp/yt-dlp")))

Thanks
Closed
?